Update to upstream version 2.10

Details:
- Update to upstream version 2.10
- Disable the unconditional dependency on SSE-optimized routines
  on i386, as it (1) results in build failures and (2) there are
  non-SSE-capable i386 CPUs in use in the FreeBSD community, thus
  the default package cannot depend on it.

PR:		233491
Submitted by:	lbartoletti@tuxfamily.org (maintainer)
Reviewed by:	riggs
This commit is contained in:
Thomas Zander 2018-12-09 07:39:29 +00:00
parent 5ff7c7f986
commit bd8a2f6074
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=487028
6 changed files with 91 additions and 26 deletions

View File

@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= osgearth
PORTVERSION= 2.9
PORTVERSION= 2.10
DISTVERSIONPREFIX= ${PORTNAME}-
PORTREVISION= 2
CATEGORIES= graphics geography
CATEGORIES= graphics geography
MAINTAINER= lbartoletti@tuxfamily.org
@ -22,7 +22,7 @@ LIB_DEPENDS= libosg.so:graphics/osg \
libprotoc.so:devel/protobuf \
librocksdb.so:databases/rocksdb
USES= cmake compiler:c++11-lang pkgconfig sqlite
USES= cmake compiler:c++11-lang gl pkgconfig sqlite
USE_GITHUB= yes
GH_ACCOUNT= gwaldron
@ -30,10 +30,15 @@ GH_ACCOUNT= gwaldron
USE_CXXSTD= c++11
USE_LDCONFIG= yes
USE_GL+= gl glu
PLIST_SUB= OSGVERSION=3.4.0
CMAKE_ARGS+= -DCMAKE_INCLUDE_PATH:PATH=${LOCALBASE}/include \
-DCMAKE_LIBRARY_PATH:PATH=${LOCALBASE}/lib \
-DLIB_POSTFIX:STRING=""
.include <bsd.port.mk>
.include <bsd.port.pre.mk>
.if ${ARCH} == i386
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-i386
.endif
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1518100553
SHA256 (gwaldron-osgearth-osgearth-2.9_GH0.tar.gz) = 22aeef42bb700c1e669d9ba57ce4155c0668caf86cc738750a6b9d34c1eaf2a4
SIZE (gwaldron-osgearth-osgearth-2.9_GH0.tar.gz) = 85149312
TIMESTAMP = 1542524324
SHA256 (gwaldron-osgearth-osgearth-2.10_GH0.tar.gz) = 986ad26b8e340a40ac6404137aa61f80a030030fa3e8cf5fbdf183c697f2556e
SIZE (gwaldron-osgearth-osgearth-2.10_GH0.tar.gz) = 90196039

View File

@ -0,0 +1,21 @@
--- src/osgEarthDrivers/fastdxt/CMakeLists.txt.orig 2018-11-12 18:17:36 UTC
+++ src/osgEarthDrivers/fastdxt/CMakeLists.txt
@@ -30,7 +30,6 @@ SET(TARGET_SRC
dxt.cpp
util.cpp
libdxt.cpp
- intrinsic.cpp
)
SETUP_PLUGIN(fastdxt)
--- src/osgEarthDrivers/fastdxt/dxt.cpp.orig 2018-11-12 18:17:36 UTC
+++ src/osgEarthDrivers/fastdxt/dxt.cpp
@@ -7,7 +7,7 @@
#include "util.h"
-#define DXT_INTR 1
+#define DXT_INTR 0
void ExtractBlock( const byte *inPtr, int width, byte *colorBlock );
void ExtractBlock_Intrinsics( const byte *inPtr, int width, byte *colorBlock );

View File

@ -0,0 +1,18 @@
--- src/osgEarthDrivers/fastdxt/libdxt.cpp.orig 2018-11-12 18:17:36 UTC
+++ src/osgEarthDrivers/fastdxt/libdxt.cpp
@@ -24,7 +24,7 @@
#include "libdxt.h"
-#if defined(__APPLE__)
+#if defined(__APPLE__) || (__FreeBSD__)
#define memalign(x,y) malloc((y))
#else
#include <malloc.h>
@@ -92,4 +92,4 @@ int CompressDXT(const byte *in, byte *ou
// Join all the threads
nbbytes = job.nbb;
return nbbytes;
-}
\ No newline at end of file
+}

View File

@ -0,0 +1,11 @@
--- src/osgEarthDrivers/fastdxt/util.h.orig 2018-11-18 08:00:00 UTC
+++ src/osgEarthDrivers/fastdxt/util.h
@@ -64,7 +64,7 @@ void aFree(void* const p);
float drand48(void);
#endif
-#if defined(__APPLE__)
+#if defined(__APPLE__) || defined(__FreeBSD__)
#define memalign(x,y) malloc((y))
#else
#include <malloc.h>

View File

@ -4,20 +4,22 @@ bin/osgearth_annotation
bin/osgearth_atlas
bin/osgearth_boundarygen
bin/osgearth_cache
bin/osgearth_cache_test
bin/osgearth_city
bin/osgearth_clipplane
bin/osgearth_cluster
bin/osgearth_colorfilter
bin/osgearth_computerangecallback
bin/osgearth_controls
bin/osgearth_conv
bin/osgearth_datetime
bin/osgearth_drawables
bin/osgearth_eci
bin/osgearth_elevation
bin/osgearth_ephemeris
bin/osgearth_featurefilter
bin/osgearth_featureinfo
bin/osgearth_featurequery
bin/osgearth_features
bin/osgearth_geodetic_graticule
bin/osgearth_graticule
bin/osgearth_horizon
bin/osgearth_htm
@ -26,6 +28,7 @@ bin/osgearth_imageoverlay
bin/osgearth_infinitescroll
bin/osgearth_lights
bin/osgearth_los
bin/osgearth_magnify
bin/osgearth_manip
bin/osgearth_map
bin/osgearth_measure
@ -36,6 +39,7 @@ bin/osgearth_occlusionculling
bin/osgearth_overlayviewer
bin/osgearth_package
bin/osgearth_pick
bin/osgearth_scenegraphcallbacks
bin/osgearth_sequencecontrol
bin/osgearth_server
bin/osgearth_shadercomp
@ -54,6 +58,7 @@ bin/osgearth_version
bin/osgearth_video
bin/osgearth_viewer
bin/osgearth_wfs
bin/osgearth_windows
include/osgEarth/Bounds
include/osgEarth/Cache
include/osgEarth/CacheBin
@ -83,12 +88,14 @@ include/osgEarth/ElevationLOD
include/osgEarth/ElevationLayer
include/osgEarth/ElevationPool
include/osgEarth/ElevationQuery
include/osgEarth/EllipsoidIntersector
include/osgEarth/Endian
include/osgEarth/Export
include/osgEarth/Extension
include/osgEarth/FadeEffect
include/osgEarth/FileUtils
include/osgEarth/GLSLChunker
include/osgEarth/GLUtils
include/osgEarth/GeoCommon
include/osgEarth/GeoData
include/osgEarth/GeoMath
@ -98,6 +105,7 @@ include/osgEarth/GeometryClamper
include/osgEarth/HTTPClient
include/osgEarth/HeightFieldUtils
include/osgEarth/Horizon
include/osgEarth/HorizonClipPlane
include/osgEarth/IOTypes
include/osgEarth/ImageLayer
include/osgEarth/ImageMosaic
@ -110,6 +118,7 @@ include/osgEarth/LandCoverLayer
include/osgEarth/Layer
include/osgEarth/LayerListener
include/osgEarth/Lighting
include/osgEarth/LineDrawable
include/osgEarth/LineFunctor
include/osgEarth/LocalTangentPlane
include/osgEarth/Locators
@ -123,7 +132,6 @@ include/osgEarth/MapNodeObserver
include/osgEarth/MapNodeOptions
include/osgEarth/MapOptions
include/osgEarth/MaskLayer
include/osgEarth/MaskNode
include/osgEarth/MaskSource
include/osgEarth/MemCache
include/osgEarth/Memory
@ -141,9 +149,9 @@ include/osgEarth/PatchLayer
include/osgEarth/PhongLightingEffect
include/osgEarth/Picker
include/osgEarth/PluginLoader
include/osgEarth/PointDrawable
include/osgEarth/PrimitiveIntersector
include/osgEarth/Profile
include/osgEarth/Profiler
include/osgEarth/Progress
include/osgEarth/Random
include/osgEarth/Registry
@ -154,14 +162,13 @@ include/osgEarth/ScreenSpaceLayout
include/osgEarth/ShaderFactory
include/osgEarth/ShaderGenerator
include/osgEarth/ShaderLoader
include/osgEarth/ShaderMerger
include/osgEarth/ShaderUtils
include/osgEarth/Shaders
include/osgEarth/Shadowing
include/osgEarth/SharedSARepo
include/osgEarth/SimplexNoise
include/osgEarth/SpatialReference
include/osgEarth/StateSetCache
include/osgEarth/StateSetLOD
include/osgEarth/Status
include/osgEarth/StringUtils
include/osgEarth/TaskService
@ -176,10 +183,10 @@ include/osgEarth/TerrainTileModel
include/osgEarth/TerrainTileModelFactory
include/osgEarth/TerrainTileNode
include/osgEarth/Tessellator
include/osgEarth/Text
include/osgEarth/ThreadingUtils
include/osgEarth/TileHandler
include/osgEarth/TileKey
include/osgEarth/TileKeyDataStore
include/osgEarth/TileRasterizer
include/osgEarth/TileSource
include/osgEarth/TileVisitor
@ -194,7 +201,6 @@ include/osgEarth/VideoLayer
include/osgEarth/Viewpoint
include/osgEarth/VirtualProgram
include/osgEarth/VisibleLayer
include/osgEarth/WrapperLayer
include/osgEarth/XmlUtils
include/osgEarth/optional
include/osgEarth/tinystr.h
@ -230,6 +236,7 @@ include/osgEarthDrivers/bing/BingOptions
include/osgEarthDrivers/cache_filesystem/FileSystemCache
include/osgEarthDrivers/cache_leveldb/LevelDBCacheOptions
include/osgEarthDrivers/cache_rocksdb/RocksDBCacheOptions
include/osgEarthDrivers/cesiumion/CesiumIonOptions
include/osgEarthDrivers/colorramp/ColorRampOptions
include/osgEarthDrivers/debug/DebugOptions
include/osgEarthDrivers/engine_mp/Common
@ -276,7 +283,6 @@ include/osgEarthDrivers/feature_elevation/FeatureElevationOptions
include/osgEarthDrivers/feature_mapnikvectortiles/MVTFeatureOptions
include/osgEarthDrivers/feature_ogr/FeatureCursorOGR
include/osgEarthDrivers/feature_ogr/OGRFeatureOptions
include/osgEarthDrivers/feature_raster/RasterFeatureOptions
include/osgEarthDrivers/feature_tfs/TFSFeatureOptions
include/osgEarthDrivers/feature_wfs/WFSFeatureOptions
include/osgEarthDrivers/feature_xyz/XYZFeatureOptions
@ -289,7 +295,6 @@ include/osgEarthDrivers/mask_feature/FeatureMaskOptions
include/osgEarthDrivers/mbtiles/MBTilesOptions
include/osgEarthDrivers/model_feature_geom/FeatureGeomModelOptions
include/osgEarthDrivers/model_simple/SimpleModelOptions
include/osgEarthDrivers/ocean_simple/SimpleOceanOptions
include/osgEarthDrivers/osg/OSGOptions
include/osgEarthDrivers/scriptengine_javascript/DuktapeEngine
include/osgEarthDrivers/scriptengine_javascript/JSGeometry
@ -298,7 +303,9 @@ include/osgEarthDrivers/scriptengine_javascript/duktape.h
include/osgEarthDrivers/sky_gl/GLSkyOptions
include/osgEarthDrivers/sky_simple/SimpleSkyOptions
include/osgEarthDrivers/skyview/SkyViewOptions
include/osgEarthDrivers/tilecache/TileCacheOptions
include/osgEarthDrivers/tileindex/TileIndexOptions
include/osgEarthDrivers/tilepackage/TilePackageOptions
include/osgEarthDrivers/tms/TMSOptions
include/osgEarthDrivers/vpb/VPBOptions
include/osgEarthDrivers/wcs/WCSOptions
@ -329,9 +336,9 @@ include/osgEarthFeatures/FeatureSourceLayer
include/osgEarthFeatures/FeatureTileSource
include/osgEarthFeatures/Filter
include/osgEarthFeatures/FilterContext
include/osgEarthFeatures/GPULines
include/osgEarthFeatures/GeometryCompiler
include/osgEarthFeatures/GeometryUtils
include/osgEarthFeatures/ImageToFeatureLayer
include/osgEarthFeatures/LabelSource
include/osgEarthFeatures/MVT
include/osgEarthFeatures/OgrUtils
@ -349,6 +356,7 @@ include/osgEarthFeatures/TessellateOperator
include/osgEarthFeatures/TextSymbolizer
include/osgEarthFeatures/TransformFilter
include/osgEarthFeatures/VirtualFeatureSource
include/osgEarthFeatures/vector_tile.pb.h
include/osgEarthSplat/Coverage
include/osgEarthSplat/Export
include/osgEarthSplat/GroundCover
@ -384,8 +392,6 @@ include/osgEarthSymbology/IconSymbol
include/osgEarthSymbology/InstanceResource
include/osgEarthSymbology/InstanceSymbol
include/osgEarthSymbology/LineSymbol
include/osgEarthSymbology/MarkerResource
include/osgEarthSymbology/MarkerSymbol
include/osgEarthSymbology/MeshConsolidator
include/osgEarthSymbology/MeshFlattener
include/osgEarthSymbology/MeshSubdivider
@ -399,7 +405,6 @@ include/osgEarthSymbology/Resource
include/osgEarthSymbology/ResourceCache
include/osgEarthSymbology/ResourceLibrary
include/osgEarthSymbology/Skins
include/osgEarthSymbology/StencilVolumeNode
include/osgEarthSymbology/Stroke
include/osgEarthSymbology/Style
include/osgEarthSymbology/StyleSelector
@ -408,14 +413,16 @@ include/osgEarthSymbology/Symbol
include/osgEarthSymbology/Tags
include/osgEarthSymbology/TextSymbol
include/osgEarthUtil/ActivityMonitorTool
include/osgEarthUtil/AnnotationEvents
include/osgEarthUtil/ArcGIS
include/osgEarthUtil/AtlasBuilder
include/osgEarthUtil/AutoClipPlaneHandler
include/osgEarthUtil/AutoScaleCallback
include/osgEarthUtil/BrightnessContrastColorFilter
include/osgEarthUtil/CMYKColorFilter
include/osgEarthUtil/ChromaKeyColorFilter
include/osgEarthUtil/ClampCallback
include/osgEarthUtil/ClipSpace
include/osgEarthUtil/ClusterNode
include/osgEarthUtil/Common
include/osgEarthUtil/ContourMap
include/osgEarthUtil/Controls
@ -432,6 +439,8 @@ include/osgEarthUtil/GARSGraticule
include/osgEarthUtil/GLSLColorFilter
include/osgEarthUtil/GammaColorFilter
include/osgEarthUtil/GeodeticGraticule
include/osgEarthUtil/GeodeticLabelingEngine
include/osgEarthUtil/GraticuleLabelingEngine
include/osgEarthUtil/HSLColorFilter
include/osgEarthUtil/HTM
include/osgEarthUtil/LODBlending
@ -446,7 +455,6 @@ include/osgEarthUtil/MouseCoordsTool
include/osgEarthUtil/MultiElevationLayer
include/osgEarthUtil/NightColorFilter
include/osgEarthUtil/Ocean
include/osgEarthUtil/PolyhedralLineOfSight
include/osgEarthUtil/RGBColorFilter
include/osgEarthUtil/RTTPicker
include/osgEarthUtil/RadialLineOfSight
@ -491,6 +499,7 @@ lib/libosgEarthUtil.so
lib/libosgEarthUtil.so.0
lib/libosgEarthUtil.so.2.9.0
lib/osgdb_earth.so
lib/osgdb_fastdxt.so
lib/osgdb_kml.so
lib/osgdb_osgearth_agglite.so
lib/osgdb_osgearth_arcgis.so
@ -499,6 +508,7 @@ lib/osgdb_osgearth_bumpmap.so
lib/osgdb_osgearth_cache_filesystem.so
lib/osgdb_osgearth_cache_leveldb.so
lib/osgdb_osgearth_cache_rocksdb.so
lib/osgdb_osgearth_cesiumion.so
lib/osgdb_osgearth_colorramp.so
lib/osgdb_osgearth_debug.so
lib/osgdb_osgearth_detail.so
@ -507,7 +517,6 @@ lib/osgdb_osgearth_engine_rex.so
lib/osgdb_osgearth_feature_elevation.so
lib/osgdb_osgearth_feature_mapnikvectortiles.so
lib/osgdb_osgearth_feature_ogr.so
lib/osgdb_osgearth_feature_raster.so
lib/osgdb_osgearth_feature_tfs.so
lib/osgdb_osgearth_feature_wfs.so
lib/osgdb_osgearth_feature_xyz.so
@ -521,14 +530,15 @@ lib/osgdb_osgearth_mbtiles.so
lib/osgdb_osgearth_model_feature_geom.so
lib/osgdb_osgearth_model_simple.so
lib/osgdb_osgearth_monitor.so
lib/osgdb_osgearth_ocean_simple.so
lib/osgdb_osgearth_osg.so
lib/osgdb_osgearth_scriptengine_javascript.so
lib/osgdb_osgearth_sky_gl.so
lib/osgdb_osgearth_sky_simple.so
lib/osgdb_osgearth_skyview.so
lib/osgdb_osgearth_terrainshader.so
lib/osgdb_osgearth_tilecache.so
lib/osgdb_osgearth_tileindex.so
lib/osgdb_osgearth_tilepackage.so
lib/osgdb_osgearth_tms.so
lib/osgdb_osgearth_vdatum_egm2008.so
lib/osgdb_osgearth_vdatum_egm84.so