Nuked at maintainer's request now that pam_passwdqc is in the base system.

This commit is contained in:
Dag-Erling Smørgrav 2002-04-04 19:30:49 +00:00
parent a4cecf2e4a
commit bd860384a9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=57326
7 changed files with 0 additions and 66 deletions

View File

@ -167,7 +167,6 @@
SUBDIR += pam_alreadyloggedin
SUBDIR += pam_krb5
SUBDIR += pam_ldap
SUBDIR += pam_passwdqc
SUBDIR += pam_pwdfile
SUBDIR += pam_smb
SUBDIR += pgp

View File

@ -1,18 +0,0 @@
# New ports collection makefile for: pam_passwdqc
# Date created: 01/04/2002
# Whom: Dominic Marks <dominic_marks@btinternet.com>
#
# $FreeBSD$
#
PORTNAME= pam_passwdqc
PORTVERSION= 0.4
CATEGORIES= security
MASTER_SITES= http://www.openwall.com/passwdqc/
MAINTAINER= dominic_marks@btinternet.com
do-install:
@${INSTALL_DATA} ${WRKSRC}/pam_passwdqc.so ${PREFIX}/lib
.include <bsd.port.mk>

View File

@ -1 +0,0 @@
MD5 (pam_passwdqc-0.4.tar.gz) = e19fbb925c7badb7033fe462a7faf205

View File

@ -1,36 +0,0 @@
--- Makefile.orig Fri Oct 12 18:09:30 2001
+++ Makefile Sun Mar 31 22:49:43 2002
@@ -2,13 +2,12 @@
# Copyright (c) 2000,2001 by Solar Designer. See LICENSE.
#
-CC = gcc
LD = ld
RM = rm -f
MKDIR = mkdir -p
INSTALL = install
-CFLAGS = -c -Wall -fPIC -DHAVE_SHADOW -O2
-LDFLAGS = -s -lpam -lcrypt --shared
+CFLAGS += -c -Wall -fPIC
+LDFLAGS = -lpam -lcrypt -shared
LDFLAGS_SUN = -s -lpam -lcrypt -G
TITLE = pam_passwdqc
@@ -20,15 +19,8 @@
PROJ = $(LIBSHARED)
OBJS = pam_passwdqc.o passwdqc_check.o passwdqc_random.o wordset_4k.o
-all:
- if [ "`uname -s`" = "SunOS" ]; then \
- make LDFLAGS="$(LDFLAGS_SUN)" $(PROJ); \
- else \
- make $(PROJ); \
- fi
-
-$(LIBSHARED): $(OBJS)
- $(LD) $(LDFLAGS) $(OBJS) -o $(LIBSHARED)
+all: $(OBJS)
+ $(CC) $(OBJS) -o $(LIBSHARED) $(LDFLAGS)
.c.o:
$(CC) $(CFLAGS) $*.c

View File

@ -1 +0,0 @@
A pam module to validate passwords for quality

View File

@ -1,8 +0,0 @@
This PAM module validates passwords for resistance against password
attacks. It examines passwords in the same way as cracking tools examine
the password hash.
WWW: http://www.openwall.com/passwdqc/
- Dominic
dominic_marks@btinternet.com

View File

@ -1 +0,0 @@
lib/pam_passwdqc.so