Update to 2.1.15.

This commit is contained in:
Hajimu UMEMOTO 2003-07-15 18:32:58 +00:00
parent 034a457bcd
commit bcf750fff8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=84929
8 changed files with 21 additions and 67 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= saslauthd
PORTVERSION= 2.1.14
PORTVERSION= 2.1.15
#PORTREVISION= 0
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/%SUBDIR%/ \
@ -77,7 +77,6 @@ CONFIGURE_ARGS+=--enable-gssapi=${HEIMDAL_HOME}
CONFIGURE_ARGS+=--enable-gssapi
.else
CONFIGURE_ARGS+=--disable-gssapi
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-saslauthd::mechanisms.h
.endif
.include <bsd.port.pre.mk>

View File

@ -1,13 +0,0 @@
Index: saslauthd/mechanisms.h
diff -u saslauthd/mechanisms.h.orig saslauthd/mechanisms.h
--- saslauthd/mechanisms.h.orig Sat Jul 5 15:41:07 2003
+++ saslauthd/mechanisms.h Sat Jul 5 15:41:14 2003
@@ -52,7 +52,7 @@
* Figure out which optional drivers we support.
*/
#ifndef AUTH_KRB5
-# if defined(HAVE_KRB5_H)
+# if defined(HAVE_KRB5_H) && defined(STATIC_GSSAPIV2)
# define AUTH_KRB5
# endif
#endif

View File

@ -6,8 +6,8 @@
#
PORTNAME= cyrus-sasl
PORTVERSION= 2.1.14
PORTREVISION= 1
PORTVERSION= 2.1.15
#PORTREVISION= 0
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/%SUBDIR%/ \
ftp://ftp.westbend.net/pub/cyrus-mail/%SUBDIR%/ \
@ -155,14 +155,15 @@ CYRUS_GROUP?= cyrus
DOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README
DOC2= ONEWS TODO draft-burdis-cat-srp-sasl-06.txt \
draft-ietf-cat-sasl-gssapi-05.txt draft-ietf-sasl-anon-01.txt \
draft-ietf-sasl-crammd5-00.txt draft-ietf-sasl-plain-01.txt \
draft-ietf-sasl-rfc2222bis-00.txt draft-ietf-sasl-rfc2831bis-01.txt \
draft-newman-sasl-c-api-01.txt draft-sasl-login.txt rfc1321.txt \
rfc1939.txt rfc2104.txt rfc2195.txt rfc2222.txt rfc2243.txt \
rfc2245.txt rfc2289.txt rfc2444.txt rfc2595.txt rfc2831.txt \
rfc2945.txt rfc3174.txt server-plugin-flow.fig testing.txt
DOC2= ONEWS TODO draft-burdis-cat-srp-sasl-08.txt \
draft-ietf-cat-sasl-gssapi-05.txt draft-ietf-sasl-anon-02.txt \
draft-ietf-sasl-crammd5-00.txt draft-ietf-sasl-plain-02.txt \
draft-ietf-sasl-rfc2222bis-01.txt draft-ietf-sasl-rfc2831bis-02.txt \
draft-ietf-sasl-saslprep-03.txt draft-newman-sasl-c-api-01.txt \
draft-sasl-login.txt rfc1321.txt rfc1939.txt rfc2104.txt rfc2195.txt \
rfc2222.txt rfc2243.txt rfc2245.txt rfc2289.txt rfc2444.txt \
rfc2595.txt rfc2831.txt rfc2945.txt rfc3174.txt \
server-plugin-flow.fig testing.txt
HTDOCS= advanced appconvert gssapi index install macosx mechanisms \
options plugprog programming readme sysadmin upgrading windows

View File

@ -1 +1 @@
MD5 (cyrus-sasl-2.1.14.tar.gz) = f2c5adf17029fc103903a3c801d95107
MD5 (cyrus-sasl-2.1.15.tar.gz) = 82c7f82a777b7bc10cc1ef68fb8e2a37

View File

@ -1,7 +1,7 @@
Index: config/ltmain.sh
diff -u config/ltmain.sh.orig config/ltmain.sh
--- config/ltmain.sh.orig Thu Jun 12 09:32:43 2003
+++ config/ltmain.sh Wed Jul 2 11:50:04 2003
--- config/ltmain.sh.orig Wed Jul 2 22:29:00 2003
+++ config/ltmain.sh Wed Jul 16 02:57:20 2003
@@ -1901,7 +1901,7 @@
deplib_matches=`eval \\$echo \"$library_names_spec\"`
set dummy $deplib_matches
@ -20,15 +20,6 @@ diff -u config/ltmain.sh.orig config/ltmain.sh
newdeplibs="$newdeplibs $i"
else
droppeddeps=yes
@@ -1959,7 +1959,7 @@
set dummy $deplibs_check_method
file_magic_regex="`expr \"$deplibs_check_method\" : \"$2 \(.*\)\"`"
for a_deplib in $deplibs; do
- name="`expr $a_deplib : '-l\(.*\)'`"
+ name="`expr X$a_deplib : 'X-l\(.*\)'`"
# If $name is empty we are operating on a -L argument.
if test "$name" != "" ; then
libname=`eval \\$echo \"$libname_spec\"`
@@ -3396,8 +3396,8 @@
# Install the pseudo-library for information purposes.
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`

View File

@ -1,12 +0,0 @@
Index: plugins/mysql.c
diff -u plugins/mysql.c.orig plugins/mysql.c
--- plugins/mysql.c.orig Thu May 15 03:46:02 2003
+++ plugins/mysql.c Tue Jul 1 02:00:55 2003
@@ -326,6 +326,7 @@
"mysql plugin try and connect to %s\n",
cur_host);
+ mysql_init(&mysql);
sock = mysql_real_connect(&mysql,cur_host,
settings->mysql_user,
settings->mysql_passwd,

View File

@ -1,13 +0,0 @@
Index: saslauthd/config/ltmain.sh
diff -u saslauthd/config/ltmain.sh.orig saslauthd/config/ltmain.sh
--- saslauthd/config/ltmain.sh.orig Wed Apr 16 07:28:26 2003
+++ saslauthd/config/ltmain.sh Tue Jul 1 01:24:38 2003
@@ -1959,7 +1959,7 @@
set dummy $deplibs_check_method
file_magic_regex="`expr \"$deplibs_check_method\" : \"$2 \(.*\)\"`"
for a_deplib in $deplibs; do
- name="`expr $a_deplib : '-l\(.*\)'`"
+ name="`expr X$a_deplib : 'X-l\(.*\)'`"
# If $name is empty we are operating on a -L argument.
if test "$name" != "" ; then
libname=`eval \\$echo \"$libname_spec\"`

View File

@ -53,13 +53,14 @@ sbin/saslpasswd2
%%PORTDOCS%%%%DOCSDIR%%/ONEWS
%%PORTDOCS%%%%DOCSDIR%%/Sendmail.README
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%PORTDOCS%%%%DOCSDIR%%/draft-burdis-cat-srp-sasl-06.txt
%%PORTDOCS%%%%DOCSDIR%%/draft-burdis-cat-srp-sasl-08.txt
%%PORTDOCS%%%%DOCSDIR%%/draft-ietf-cat-sasl-gssapi-05.txt
%%PORTDOCS%%%%DOCSDIR%%/draft-ietf-sasl-anon-01.txt
%%PORTDOCS%%%%DOCSDIR%%/draft-ietf-sasl-anon-02.txt
%%PORTDOCS%%%%DOCSDIR%%/draft-ietf-sasl-crammd5-00.txt
%%PORTDOCS%%%%DOCSDIR%%/draft-ietf-sasl-plain-01.txt
%%PORTDOCS%%%%DOCSDIR%%/draft-ietf-sasl-rfc2222bis-00.txt
%%PORTDOCS%%%%DOCSDIR%%/draft-ietf-sasl-rfc2831bis-01.txt
%%PORTDOCS%%%%DOCSDIR%%/draft-ietf-sasl-plain-02.txt
%%PORTDOCS%%%%DOCSDIR%%/draft-ietf-sasl-rfc2222bis-01.txt
%%PORTDOCS%%%%DOCSDIR%%/draft-ietf-sasl-rfc2831bis-02.txt
%%PORTDOCS%%%%DOCSDIR%%/draft-ietf-sasl-saslprep-03.txt
%%PORTDOCS%%%%DOCSDIR%%/draft-newman-sasl-c-api-01.txt
%%PORTDOCS%%%%DOCSDIR%%/draft-sasl-login.txt
%%PORTDOCS%%%%DOCSDIR%%/rfc1321.txt