MFH: r466448
Update devel/gitlab-shell to version 6.0.3 which is required fot gitlab 10.5.x. Reviewed by: swills (mentor) Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D14942 Approved by: ports-secteam (eadler)
This commit is contained in:
parent
202cd1ced8
commit
bcf2bd391c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2018Q2/; revision=467717
@ -2,10 +2,8 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= gitlab-shell
|
||||
PORTVERSION= 5.11.0
|
||||
PORTVERSION= 6.0.3
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= https://gitlab.com/gitlab-org/${PORTNAME}/repository/archive.tar.gz?ref=v${PORTVERSION}&dummy=/
|
||||
DISTNAME= ${PORTNAME}-v${PORTVERSION}
|
||||
|
||||
LICENSE= MIT
|
||||
|
||||
@ -15,17 +13,21 @@ COMMENT= GitLab Shell handles git commands for GitLab
|
||||
BUILD_DEPENDS= gem:devel/ruby-gems \
|
||||
go>=1.5.3:lang/go
|
||||
|
||||
USE_GITLAB= yes
|
||||
GL_ACCOUNT= gitlab-org
|
||||
# Find the commit hash here: https://gitlab.com/gitlab-org/gitlab-shell/tags
|
||||
GL_COMMIT= ec2806f1f2ad10b7ec68b1835c54c11915387a6a
|
||||
|
||||
USERS= git
|
||||
GROUPS= git
|
||||
|
||||
post-extract:
|
||||
@${MV} ${WRKDIR}/${DISTNAME}-* ${WRKDIR}/${DISTNAME}
|
||||
|
||||
post-patch:
|
||||
${MV} ${WRKSRC}/config.yml.example ${WRKSRC}/config.yml.sample
|
||||
|
||||
do-build:
|
||||
export GOCACHE=${WRKSRC}/go && ${WRKSRC}/bin/compile
|
||||
|
||||
pre-install:
|
||||
${WRKSRC}/bin/compile
|
||||
${RM} -rf ${WRKSRC}/go
|
||||
${RM} -rf ${WRKSRC}/go_build
|
||||
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1516803476
|
||||
SHA256 (gitlab-shell-v5.11.0.tar.gz) = b63cba3452f82d719ebbc74a3cf95314d38051327dfe38def3fe6a04e56a9929
|
||||
SIZE (gitlab-shell-v5.11.0.tar.gz) = 714049
|
||||
TIMESTAMP = 1522769153
|
||||
SHA256 (gitlab-org-gitlab-shell-ec2806f1f2ad10b7ec68b1835c54c11915387a6a_GL0.tar.gz) = f68d6f6925e2d54e5ff8acac8c0b5f47ab5804492e363bb097fd3b19b7e405c2
|
||||
SIZE (gitlab-org-gitlab-shell-ec2806f1f2ad10b7ec68b1835c54c11915387a6a_GL0.tar.gz) = 782621
|
||||
|
@ -1,6 +1,15 @@
|
||||
--- config.yml.example.orig 2016-07-26 21:04:16 UTC
|
||||
--- config.yml.example.orig 2018-02-06 17:56:45 UTC
|
||||
+++ config.yml.example
|
||||
@@ -43,7 +43,7 @@ redis:
|
||||
@@ -25,7 +25,7 @@ http_settings:
|
||||
self_signed_cert: false
|
||||
|
||||
# File used as authorized_keys for gitlab user
|
||||
-auth_file: "/home/git/.ssh/authorized_keys"
|
||||
+auth_file: "/usr/home/git/.ssh/authorized_keys"
|
||||
|
||||
# File that contains the secret key for verifying access to GitLab.
|
||||
# Default is .gitlab_shell_secret in the gitlab-shell directory.
|
||||
@@ -37,7 +37,7 @@ auth_file: "/home/git/.ssh/authorized_ke
|
||||
|
||||
# Log file.
|
||||
# Default is gitlab-shell.log in the root directory.
|
||||
|
@ -9,7 +9,6 @@
|
||||
%%DATADIR%%/Gemfile.lock
|
||||
%%DATADIR%%/Guardfile
|
||||
%%DATADIR%%/LICENSE
|
||||
%%DATADIR%%/Makefile
|
||||
%%DATADIR%%/README.md
|
||||
%%DATADIR%%/VERSION
|
||||
@(,,555) %%DATADIR%%/bin/authorized_keys
|
||||
@ -19,7 +18,6 @@
|
||||
@(,,555) %%DATADIR%%/bin/gitaly-upload-pack
|
||||
@(,,555) %%DATADIR%%/bin/gitaly-receive-pack
|
||||
@(,,555) %%DATADIR%%/bin/gitlab-keys
|
||||
@(,,555) %%DATADIR%%/bin/gitlab-projects
|
||||
@(,,555) %%DATADIR%%/bin/gitlab-shell
|
||||
@(,,555) %%DATADIR%%/bin/gitlab-shell-authorized-keys-check
|
||||
@(,,555) %%DATADIR%%/bin/install
|
||||
@ -38,28 +36,10 @@
|
||||
%%DATADIR%%/lib/gitlab_metrics.rb
|
||||
%%DATADIR%%/lib/gitlab_net.rb
|
||||
%%DATADIR%%/lib/gitlab_post_receive.rb
|
||||
%%DATADIR%%/lib/gitlab_projects.rb
|
||||
%%DATADIR%%/lib/gitlab_redis.rb
|
||||
%%DATADIR%%/lib/gitlab_reference_counter.rb
|
||||
%%DATADIR%%/lib/gitlab_shell.rb
|
||||
%%DATADIR%%/lib/httpunix.rb
|
||||
%%DATADIR%%/lib/names_helper.rb
|
||||
%%DATADIR%%/lib/object_dirs_helper.rb
|
||||
%%DATADIR%%/lib/vendor/redis/lib/redis.rb
|
||||
%%DATADIR%%/lib/vendor/redis/lib/redis/client.rb
|
||||
%%DATADIR%%/lib/vendor/redis/lib/redis/connection.rb
|
||||
%%DATADIR%%/lib/vendor/redis/lib/redis/connection/command_helper.rb
|
||||
%%DATADIR%%/lib/vendor/redis/lib/redis/connection/hiredis.rb
|
||||
%%DATADIR%%/lib/vendor/redis/lib/redis/connection/registry.rb
|
||||
%%DATADIR%%/lib/vendor/redis/lib/redis/connection/ruby.rb
|
||||
%%DATADIR%%/lib/vendor/redis/lib/redis/connection/synchrony.rb
|
||||
%%DATADIR%%/lib/vendor/redis/lib/redis/distributed.rb
|
||||
%%DATADIR%%/lib/vendor/redis/lib/redis/errors.rb
|
||||
%%DATADIR%%/lib/vendor/redis/lib/redis/hash_ring.rb
|
||||
%%DATADIR%%/lib/vendor/redis/lib/redis/pipeline.rb
|
||||
%%DATADIR%%/lib/vendor/redis/lib/redis/subscribe.rb
|
||||
%%DATADIR%%/lib/vendor/redis/lib/redis/version.rb
|
||||
%%DATADIR%%/spec/fixtures/gitlab_config_redis.yml
|
||||
%%DATADIR%%/spec/gitlab_access_spec.rb
|
||||
%%DATADIR%%/spec/gitlab_config_spec.rb
|
||||
%%DATADIR%%/spec/gitlab_custom_hook_spec.rb
|
||||
@ -69,8 +49,6 @@
|
||||
%%DATADIR%%/spec/gitlab_metrics_spec.rb
|
||||
%%DATADIR%%/spec/gitlab_net_spec.rb
|
||||
%%DATADIR%%/spec/gitlab_post_receive_spec.rb
|
||||
%%DATADIR%%/spec/gitlab_projects_spec.rb
|
||||
%%DATADIR%%/spec/gitlab_reference_counter_spec.rb
|
||||
%%DATADIR%%/spec/gitlab_shell_authorized_keys_check_spec.rb
|
||||
%%DATADIR%%/spec/gitlab_shell_spec.rb
|
||||
%%DATADIR%%/spec/httpunix_spec.rb
|
||||
|
Loading…
Reference in New Issue
Block a user