Add laspack 1.12.2,

package for solving large sparse systems of
linear equations.

PR:		83968
Submitted by:	Pedro F. Giffuni" <giffunip at asme dot org>
This commit is contained in:
Simon Barner 2005-07-25 09:05:50 +00:00
parent a58473d9fc
commit bcd4eab4cb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=140069
6 changed files with 92 additions and 0 deletions

View File

@ -98,6 +98,7 @@
SUBDIR += lapack
SUBDIR += lapack++
SUBDIR += lapack95
SUBDIR += laspack
SUBDIR += ldouble
SUBDIR += libRmath
SUBDIR += libgmp4

33
math/laspack/Makefile Normal file
View File

@ -0,0 +1,33 @@
# New ports collection makefile for: LASPack
# Date created: 27 July 2005
# Whom: giffunip
#
# $FreeBSD$
#
PORTNAME= laspack
PORTVERSION= 1.12.2
CATEGORIES= math
MASTER_SITES= ftp://netlib.bell-labs.com/netlib/linalg/ \
ftp://www.hensa.ac.uk/mirrors/netlib/linalg/ \
http://www.netlib.org/linalg/
DISTNAME= ${PORTNAME}
EXTRACT_SUFX= .tgz
MAINTAINER= giffunip@asme.org
COMMENT= Package for solving large sparse systems of linear equations
USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
MAKEFILE= makefile
post-patch:
@${REINPLACE_CMD} -e 's+/usr/local+${LOCALBASE}+g' ${WRKSRC}/${MAKEFILE}
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/doc/*.ps ${DOCSDIR}
.endif
.include <bsd.port.mk>

2
math/laspack/distinfo Normal file
View File

@ -0,0 +1,2 @@
MD5 (laspack.tgz) = fcfb3c86cc993e29eb477191b1136a8d
SIZE (laspack.tgz) = 195214

View File

@ -0,0 +1,13 @@
--- makefile.orig Mon Jul 25 00:24:08 2005
+++ makefile Mon Jul 25 00:24:30 2005
@@ -21,8 +21,8 @@
#
# set the destination directories for the library and include files
#
-LIBDEST = $(HOME)/lib$(ARCH_EXT)
-INCDEST = $(HOME)/include
+LIBDEST = $(PREFIX)/lib
+INCDEST = $(PREFIX)/include
#
# the following text was created automaticaly. You should change it carefully.

23
math/laspack/pkg-descr Normal file
View File

@ -0,0 +1,23 @@
LASPack (version 1.12.2)
LASPack is a package for solving large sparse systems of linear equations
like those which arise from discretization of partial differential equations.
Main features:
- The primary aim of LASPack is the implementation of efficient iterative
methods for the solution of systems of linear equations.
- Beside the obligatory Jacobi, succesive over-relaxation, Chebyshev, and
conjugate gradient solvers, LASPack contains selected state-of-the-art
algorithms which are commonly used for large sparse systems:
- CG-like methods for non-symmetric systems: CGN, GMRES, BiCG, QMR, CGS, and
BiCGStab,
- multilevel methods such as multigrid and conjugate gradient method
preconditioned by multigrid and BPX preconditioners.
A complete description of the package (including the installation procedure)
you may find in LASPack Reference Manual in the following postscript files:
WWW: http://www.tu-dresden.de/mwism/skalicky/laspack/laspack.html

20
math/laspack/pkg-plist Normal file
View File

@ -0,0 +1,20 @@
include/laspack/copyrght.h
include/laspack/eigenval.h
include/laspack/elcmp.h
include/laspack/errhandl.h
include/laspack/factor.h
include/laspack/itersolv.h
include/laspack/lastypes.h
include/laspack/matrix.h
include/laspack/mlsolv.h
include/laspack/operats.h
include/laspack/precond.h
include/laspack/qmatrix.h
include/laspack/rtc.h
include/laspack/vector.h
include/laspack/version.h
lib/liblaspack.a
%%PORTDOCS%%%%DOCSDIR%%/laspack1.ps
%%PORTDOCS%%%%DOCSDIR%%/laspack2.ps
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/laspack