- Update to 2.0.2

PR:		141819
Submitted by:	Ports Fury
This commit is contained in:
Martin Wilke 2009-12-22 11:25:40 +00:00
parent 1ee9fc2f3d
commit bcd38ad09b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=246438
8 changed files with 66 additions and 36 deletions

View File

@ -6,34 +6,38 @@
#
PORTNAME= qbittorrent
PORTVERSION= 1.5.6
PORTVERSION= 2.0.2
CATEGORIES= net-p2p
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Bittorrent client written in C++ / Qt4 using libtorrent
LIB_DEPENDS= ccext2-1.7.0:${PORTSDIR}/devel/commoncpp \
execinfo.1:${PORTSDIR}/devel/libexecinfo \
zzip.13:${PORTSDIR}/devel/zziplib \
curl.5:${PORTSDIR}/ftp/curl \
BUILD_DEPENDS= ${LOCALBASE}/share/GeoIP/GeoIP.dat:${PORTSDIR}/net/GeoIP
LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo \
torrent-rasterbar.5:${PORTSDIR}/net-p2p/rblibtorrent-devel
RUN_DEPENDS:= ${BUILD_DEPENDS}
OPTIONS= NOTIFY "Enable libnotify support" off
USE_QT_VER= 4
QT_COMPONENTS= corelib gui network xml \
moc_build qmake_build rcc_build uic_build
QT_NONSTANDARD= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --with-libcurl-inc="${LOCALBASE}/include" \
--with-libcurl-lib="${LOCALBASE}/lib" \
--with-libzzip-inc="${LOCALBASE}/include" \
--with-libzzip-lib="${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-libboost-inc="${LOCALBASE}/include"
INSTALLS_ICONS= yes
MAN1= qbittorrent.1
.include <bsd.port.pre.mk>
.if defined(WITH_NOTIFY)
LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
.else
CONFIGURE_ARGS+= --disable-libnotify
.endif
post-patch:
@${REINPLACE_CMD} -e 's|$$$$PREFIX/share/man|${MANPREFIX}/man|' \
${WRKSRC}/src/src.pro

View File

@ -1,3 +1,3 @@
MD5 (qbittorrent-1.5.6.tar.gz) = a1976d71614f4b8cfc22e3289fb16887
SHA256 (qbittorrent-1.5.6.tar.gz) = 786af55c83a1d076a9ec59f2c710dfc36813c5303677e107665c7f245a5855ab
SIZE (qbittorrent-1.5.6.tar.gz) = 1746583
MD5 (qbittorrent-2.0.2.tar.gz) = 94dfa2a217ea3b0829e2366558246563
SHA256 (qbittorrent-2.0.2.tar.gz) = 2f21de941f7a30f882239a3132059faee876e5ea3abb8d053e4b0b64f378b747
SIZE (qbittorrent-2.0.2.tar.gz) = 2115373

View File

@ -0,0 +1,11 @@
--- src/filesystemwatcher.h.orig 2009-12-11 04:39:09.000000000 +0900
+++ src/filesystemwatcher.h 2009-12-17 00:41:29.000000000 +0900
@@ -11,7 +11,7 @@
#include <QSet>
#include <iostream>
#include <errno.h>
-#ifdef Q_WS_MAC
+#if defined(Q_WS_MAC) || defined(__FreeBSD__)
#include <sys/param.h>
#include <sys/mount.h>
#else

View File

@ -1,11 +1,11 @@
--- src/misc.h.orig 2009-10-01 03:44:58.000000000 +0900
+++ src/misc.h 2009-11-27 02:33:54.000000000 +0900
@@ -43,7 +43,7 @@
#include <QThread>
--- src/misc.h.orig 2009-12-13 19:15:50.000000000 +0900
+++ src/misc.h 2009-12-17 00:34:12.000000000 +0900
@@ -47,7 +47,7 @@
#include <boost/date_time/posix_time/conversion.hpp>
#ifndef Q_WS_WIN
-#ifdef Q_WS_MAC
+#if defined(Q_WS_MAC) || defined(__FreeBSD__)
#include <sys/param.h>
#include <sys/mount.h>
#include <sys/param.h>
#include <sys/mount.h>
#else

View File

@ -6,34 +6,38 @@
#
PORTNAME= qbittorrent
PORTVERSION= 1.5.6
PORTVERSION= 2.0.2
CATEGORIES= net-p2p
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Bittorrent client written in C++ / Qt4 using libtorrent
LIB_DEPENDS= ccext2-1.7.0:${PORTSDIR}/devel/commoncpp \
execinfo.1:${PORTSDIR}/devel/libexecinfo \
zzip.13:${PORTSDIR}/devel/zziplib \
curl.5:${PORTSDIR}/ftp/curl \
BUILD_DEPENDS= ${LOCALBASE}/share/GeoIP/GeoIP.dat:${PORTSDIR}/net/GeoIP
LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo \
torrent-rasterbar.5:${PORTSDIR}/net-p2p/rblibtorrent-devel
RUN_DEPENDS:= ${BUILD_DEPENDS}
OPTIONS= NOTIFY "Enable libnotify support" off
USE_QT_VER= 4
QT_COMPONENTS= corelib gui network xml \
moc_build qmake_build rcc_build uic_build
QT_NONSTANDARD= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --with-libcurl-inc="${LOCALBASE}/include" \
--with-libcurl-lib="${LOCALBASE}/lib" \
--with-libzzip-inc="${LOCALBASE}/include" \
--with-libzzip-lib="${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-libboost-inc="${LOCALBASE}/include"
INSTALLS_ICONS= yes
MAN1= qbittorrent.1
.include <bsd.port.pre.mk>
.if defined(WITH_NOTIFY)
LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
.else
CONFIGURE_ARGS+= --disable-libnotify
.endif
post-patch:
@${REINPLACE_CMD} -e 's|$$$$PREFIX/share/man|${MANPREFIX}/man|' \
${WRKSRC}/src/src.pro

View File

@ -1,3 +1,3 @@
MD5 (qbittorrent-1.5.6.tar.gz) = a1976d71614f4b8cfc22e3289fb16887
SHA256 (qbittorrent-1.5.6.tar.gz) = 786af55c83a1d076a9ec59f2c710dfc36813c5303677e107665c7f245a5855ab
SIZE (qbittorrent-1.5.6.tar.gz) = 1746583
MD5 (qbittorrent-2.0.2.tar.gz) = 94dfa2a217ea3b0829e2366558246563
SHA256 (qbittorrent-2.0.2.tar.gz) = 2f21de941f7a30f882239a3132059faee876e5ea3abb8d053e4b0b64f378b747
SIZE (qbittorrent-2.0.2.tar.gz) = 2115373

View File

@ -0,0 +1,11 @@
--- src/filesystemwatcher.h.orig 2009-12-11 04:39:09.000000000 +0900
+++ src/filesystemwatcher.h 2009-12-17 00:41:29.000000000 +0900
@@ -11,7 +11,7 @@
#include <QSet>
#include <iostream>
#include <errno.h>
-#ifdef Q_WS_MAC
+#if defined(Q_WS_MAC) || defined(__FreeBSD__)
#include <sys/param.h>
#include <sys/mount.h>
#else

View File

@ -1,11 +1,11 @@
--- src/misc.h.orig 2009-10-01 03:44:58.000000000 +0900
+++ src/misc.h 2009-11-27 02:33:54.000000000 +0900
@@ -43,7 +43,7 @@
#include <QThread>
--- src/misc.h.orig 2009-12-13 19:15:50.000000000 +0900
+++ src/misc.h 2009-12-17 00:34:12.000000000 +0900
@@ -47,7 +47,7 @@
#include <boost/date_time/posix_time/conversion.hpp>
#ifndef Q_WS_WIN
-#ifdef Q_WS_MAC
+#if defined(Q_WS_MAC) || defined(__FreeBSD__)
#include <sys/param.h>
#include <sys/mount.h>
#include <sys/param.h>
#include <sys/mount.h>
#else