MFH: r457833
Remove ibus-cangjie, new BROKEN port
This commit is contained in:
parent
7d83dbdf08
commit
bcb610d60b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2018Q1/; revision=457834
@ -52,7 +52,6 @@
|
||||
SUBDIR += gydict
|
||||
SUBDIR += hc
|
||||
SUBDIR += ibus-array
|
||||
SUBDIR += ibus-cangjie
|
||||
SUBDIR += ibus-chewing
|
||||
SUBDIR += ibus-libpinyin
|
||||
SUBDIR += ibus-pinyin
|
||||
|
@ -1,50 +0,0 @@
|
||||
# Created by: blubee <hello@blubee.me>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ibus-cangjie
|
||||
PORTVERSION= 2.4
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= chinese
|
||||
|
||||
MAINTAINER= hello@blubee.me
|
||||
COMMENT= IBus engine for users of the Cangjie and Quick
|
||||
|
||||
LICENSE= GPLv3+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
LIB_DEPENDS= libibus-1.0.so:textproc/ibus
|
||||
BUILD_DEPENDS= ${PREFIX}/lib/python3.6/site-packages/cangjie/_core.so:chinese/pycangjie
|
||||
RUN_DEPENDS= ${PREFIX}/lib/python3.6/site-packages/cangjie/_core.so:chinese/pycangjie \
|
||||
${PYTHON_SITELIBDIR}/pycanberra/__init__.py:devel/pycanberra@py36
|
||||
|
||||
USES= autoreconf gmake libtool pkgconfig python:3.6
|
||||
|
||||
OPTIONS_DEFINE= NLS
|
||||
NLS_USES= gettext
|
||||
NLS_CONFIGURE_ENABLE= gettext
|
||||
|
||||
INSTALLS_ICONS= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= PYTHON=${PYTHON_CMD}
|
||||
|
||||
USE_GNOME= introspection:run py3gobject3 intltool
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= Cangjians
|
||||
GH_PROJECT= ibus-cangjie
|
||||
|
||||
# ugly kludge fix for this:
|
||||
# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=224486
|
||||
# We know python3 will be installed so we work around this check
|
||||
do-configure:
|
||||
@(cd ${WRKSRC} && ${REINPLACE_CMD} \
|
||||
-e 's|([3.2.3])|([2.7])|g' ${WRKSRC}/configure.ac && \
|
||||
autopoint --force && \
|
||||
intltoolize --force --copy --automake && \
|
||||
aclocal -I m4 && \
|
||||
autoheader && \
|
||||
automake --add-missing --copy && \
|
||||
autoconf && \
|
||||
./configure ${CONFIGURE_ENV})
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1,3 +0,0 @@
|
||||
TIMESTAMP = 1509798473
|
||||
SHA256 (Cangjians-ibus-cangjie-v2.4_GH0.tar.gz) = 632b38bf8fe979fbbe50fe0cee5322fe2f5c815c3ad0e800c0bdab7e3b814043
|
||||
SIZE (Cangjians-ibus-cangjie-v2.4_GH0.tar.gz) = 38549
|
@ -1,8 +0,0 @@
|
||||
--- autogen.sh.orig 2015-03-29 15:19:21 UTC
|
||||
+++ autogen.sh
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/bin/bash
|
||||
+#!/bin/sh
|
||||
|
||||
set -e
|
||||
set -x
|
@ -1,8 +0,0 @@
|
||||
This is an IBus engine for users of the Cangjie and
|
||||
Quick input methods.
|
||||
|
||||
It is primarily intended to Hong Kong people
|
||||
who want to input Traditional Chinese,
|
||||
as they are (by far) the majority of Cangjie and Quick users.
|
||||
|
||||
WWW: http://cangjians.github.io/projects/ibus-cangjie/
|
@ -1,30 +0,0 @@
|
||||
bin/ibus-setup-cangjie
|
||||
lib/ibus-cangjie/ibus-engine-cangjie
|
||||
lib/python3.6/site-packages/ibus_cangjie/__init__.py
|
||||
lib/python3.6/site-packages/ibus_cangjie/__pycache__/__init__.cpython-36.opt-1.pyc
|
||||
lib/python3.6/site-packages/ibus_cangjie/__pycache__/__init__.cpython-36.pyc
|
||||
lib/python3.6/site-packages/ibus_cangjie/__pycache__/canberra.cpython-36.opt-1.pyc
|
||||
lib/python3.6/site-packages/ibus_cangjie/__pycache__/canberra.cpython-36.pyc
|
||||
lib/python3.6/site-packages/ibus_cangjie/__pycache__/engine.cpython-36.opt-1.pyc
|
||||
lib/python3.6/site-packages/ibus_cangjie/__pycache__/engine.cpython-36.pyc
|
||||
lib/python3.6/site-packages/ibus_cangjie/__pycache__/setup.cpython-36.opt-1.pyc
|
||||
lib/python3.6/site-packages/ibus_cangjie/__pycache__/setup.cpython-36.pyc
|
||||
lib/python3.6/site-packages/ibus_cangjie/canberra.py
|
||||
lib/python3.6/site-packages/ibus_cangjie/engine.py
|
||||
lib/python3.6/site-packages/ibus_cangjie/setup.py
|
||||
share/appdata/cangjie.appdata.xml
|
||||
share/appdata/quick.appdata.xml
|
||||
share/applications/ibus-setup-cangjie.desktop
|
||||
share/applications/ibus-setup-quick.desktop
|
||||
share/glib-2.0/schemas/org.cangjians.ibus.cangjie.gschema.xml
|
||||
share/glib-2.0/schemas/org.cangjians.ibus.quick.gschema.xml
|
||||
%%DATADIR%%/setup.ui
|
||||
share/ibus/component/cangjie.xml
|
||||
share/ibus/component/quick.xml
|
||||
share/icons/hicolor/16x16/intl/cangjie.png
|
||||
share/icons/hicolor/16x16/intl/quick.png
|
||||
share/icons/hicolor/scalable/intl/cangjie.svg
|
||||
share/icons/hicolor/scalable/intl/quick.svg
|
||||
share/locale/pt_BR/LC_MESSAGES/ibus-cangjie.mo
|
||||
share/locale/zh_HK/LC_MESSAGES/ibus-cangjie.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/ibus-cangjie.mo
|
Loading…
Reference in New Issue
Block a user