o New port mpeg4ip-libmp4v2 version 1.1: Mpeg-4 library and tools

from mpeg4ip
o These tools were separated from the main mpeg4ip port so that
  some ports such as audio/faad can depend on this smaller port
  rather than the big mpeg4ip one

PR:		72204
Submitted by:	ahze
This commit is contained in:
Mario Sergio Fujikawa Ferreira 2004-11-10 01:42:24 +00:00
parent 0d5722c076
commit bc96b55f4b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=121268
17 changed files with 261 additions and 0 deletions

View File

@ -82,6 +82,7 @@
SUBDIR += mpeg2codec
SUBDIR += mpeg2play
SUBDIR += mpeg4ip
SUBDIR += mpeg4ip-libmp4v2
SUBDIR += mpeg_encode
SUBDIR += mpeg_play
SUBDIR += mpeg_stat

43
multimedia/mp4v2/Makefile Normal file
View File

@ -0,0 +1,43 @@
# New ports collection makefile for: mpeg4ip-libmp4v2
# Date created: 28 Sep 2004
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= mpeg4ip
PORTVERSION= 1.1
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMESUFFIX= -libmp4v2
MAINTAINER= ahze@FreeBSD.org
COMMENT= Mpeg-4 library and tools from mpeg4ip
USE_GMAKE= yes
USE_GNOME= gnometarget
USE_INC_LIBTOOL_VER=15
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
INSTALLS_SHLIB= yes
BUILD_WRKSRC= ${WRKSRC}/lib/mp4v2
INSTALL_WRKSRC= ${WRKSRC}/lib/mp4v2
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 502110
USE_GCC= 3.4
.endif
post-patch:
@${REINPLACE_CMD} \
-e 's|>&/|>/|; s|-Wmissing-declarations||; \
s|-Wmissing-prototypes||' \
${WRKSRC}/configure
pre-build:
@cd ${WRKSRC}/lib/gnu && ${MAKE}
.include <bsd.port.post.mk>

View File

@ -0,0 +1,2 @@
MD5 (mpeg4ip-1.1.tar.gz) = fef0224a45485653a8db87bdd5c9e745
SIZE (mpeg4ip-1.1.tar.gz) = 4351378

View File

@ -0,0 +1,19 @@
--- include/mpeg4ip.h.orig Wed Sep 29 14:43:52 2004
+++ include/mpeg4ip.h Wed Sep 29 14:44:10 2004
@@ -160,14 +160,14 @@
#include <errno.h>
#include <stdlib.h>
-#ifdef HAVE_INTTYPES_H
#include <inttypes.h>
-#endif
#ifdef HAVE_STDINT_H
#include <stdint.h>
#endif
+#if 0
#if !defined(HAVE_INTTYPES_H) || !defined(HAVE_STDINT_H)
#error "Don't have stdint.h or inttypes.h - no way to get uint8_t"
+#endif
#endif
#include <unistd.h>

View File

@ -0,0 +1,12 @@
--- include/mpeg4ip_getopt.h.orig Tue Oct 15 13:12:27 2002
+++ include/mpeg4ip_getopt.h Mon Feb 24 05:23:50 2003
@@ -11,6 +11,9 @@
#endif
#ifdef HAVE_GETOPT_H
+#ifdef __FreeBSD__
+#define __GNU_LIBRARY__
+#endif
#include <getopt.h>
#endif

View File

@ -0,0 +1,15 @@
--- ltmain.sh.orig Thu Sep 30 04:09:46 2004
+++ ltmain.sh Thu Sep 30 04:11:06 2004
@@ -5425,10 +5425,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View File

@ -0,0 +1,27 @@
--- mpeg4ip_config.h.in.orig Tue May 18 13:31:06 2004
+++ mpeg4ip_config.h.in Wed Sep 29 14:40:59 2004
@@ -25,16 +25,12 @@
#undef HAVE_FPOS_T___POS
/* Define to 1 if you have the `getopt' function. */
-#undef HAVE_GETOPT
/* Define to 1 if you have the <getopt.h> header file. */
-#undef HAVE_GETOPT_H
/* Define to 1 if you have the `getopt_long' function. */
-#undef HAVE_GETOPT_LONG
/* Define to 1 if you have the `getopt_long_only' function. */
-#undef HAVE_GETOPT_LONG_ONLY
/* Define to 1 if you have the `getrusage' function. */
#undef HAVE_GETRUSAGE
@@ -67,7 +63,6 @@
#undef HAVE_IPv6
/* Define to 1 if you have the `gnugetopt' library (-lgnugetopt). */
-#undef HAVE_LIBGNUGETOPT
/* have libmpeg2 decoder library */
#undef HAVE_LIBMPEG2

View File

@ -0,0 +1,3 @@
Mpeg4 library and tools from mpeg4ip
WWW: http://mpeg4ip.sourceforge.net/

View File

@ -0,0 +1,9 @@
bin/mp4dump
bin/mp4extract
bin/mp4info
bin/mp4tags
bin/mp4trackdump
include/mp4.h
lib/libmp4v2.a
lib/libmp4v2.so
lib/libmp4v2.so.0

View File

@ -0,0 +1,43 @@
# New ports collection makefile for: mpeg4ip-libmp4v2
# Date created: 28 Sep 2004
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= mpeg4ip
PORTVERSION= 1.1
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMESUFFIX= -libmp4v2
MAINTAINER= ahze@FreeBSD.org
COMMENT= Mpeg-4 library and tools from mpeg4ip
USE_GMAKE= yes
USE_GNOME= gnometarget
USE_INC_LIBTOOL_VER=15
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
INSTALLS_SHLIB= yes
BUILD_WRKSRC= ${WRKSRC}/lib/mp4v2
INSTALL_WRKSRC= ${WRKSRC}/lib/mp4v2
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 502110
USE_GCC= 3.4
.endif
post-patch:
@${REINPLACE_CMD} \
-e 's|>&/|>/|; s|-Wmissing-declarations||; \
s|-Wmissing-prototypes||' \
${WRKSRC}/configure
pre-build:
@cd ${WRKSRC}/lib/gnu && ${MAKE}
.include <bsd.port.post.mk>

View File

@ -0,0 +1,2 @@
MD5 (mpeg4ip-1.1.tar.gz) = fef0224a45485653a8db87bdd5c9e745
SIZE (mpeg4ip-1.1.tar.gz) = 4351378

View File

@ -0,0 +1,19 @@
--- include/mpeg4ip.h.orig Wed Sep 29 14:43:52 2004
+++ include/mpeg4ip.h Wed Sep 29 14:44:10 2004
@@ -160,14 +160,14 @@
#include <errno.h>
#include <stdlib.h>
-#ifdef HAVE_INTTYPES_H
#include <inttypes.h>
-#endif
#ifdef HAVE_STDINT_H
#include <stdint.h>
#endif
+#if 0
#if !defined(HAVE_INTTYPES_H) || !defined(HAVE_STDINT_H)
#error "Don't have stdint.h or inttypes.h - no way to get uint8_t"
+#endif
#endif
#include <unistd.h>

View File

@ -0,0 +1,12 @@
--- include/mpeg4ip_getopt.h.orig Tue Oct 15 13:12:27 2002
+++ include/mpeg4ip_getopt.h Mon Feb 24 05:23:50 2003
@@ -11,6 +11,9 @@
#endif
#ifdef HAVE_GETOPT_H
+#ifdef __FreeBSD__
+#define __GNU_LIBRARY__
+#endif
#include <getopt.h>
#endif

View File

@ -0,0 +1,15 @@
--- ltmain.sh.orig Thu Sep 30 04:09:46 2004
+++ ltmain.sh Thu Sep 30 04:11:06 2004
@@ -5425,10 +5425,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View File

@ -0,0 +1,27 @@
--- mpeg4ip_config.h.in.orig Tue May 18 13:31:06 2004
+++ mpeg4ip_config.h.in Wed Sep 29 14:40:59 2004
@@ -25,16 +25,12 @@
#undef HAVE_FPOS_T___POS
/* Define to 1 if you have the `getopt' function. */
-#undef HAVE_GETOPT
/* Define to 1 if you have the <getopt.h> header file. */
-#undef HAVE_GETOPT_H
/* Define to 1 if you have the `getopt_long' function. */
-#undef HAVE_GETOPT_LONG
/* Define to 1 if you have the `getopt_long_only' function. */
-#undef HAVE_GETOPT_LONG_ONLY
/* Define to 1 if you have the `getrusage' function. */
#undef HAVE_GETRUSAGE
@@ -67,7 +63,6 @@
#undef HAVE_IPv6
/* Define to 1 if you have the `gnugetopt' library (-lgnugetopt). */
-#undef HAVE_LIBGNUGETOPT
/* have libmpeg2 decoder library */
#undef HAVE_LIBMPEG2

View File

@ -0,0 +1,3 @@
Mpeg4 library and tools from mpeg4ip
WWW: http://mpeg4ip.sourceforge.net/

View File

@ -0,0 +1,9 @@
bin/mp4dump
bin/mp4extract
bin/mp4info
bin/mp4tags
bin/mp4trackdump
include/mp4.h
lib/libmp4v2.a
lib/libmp4v2.so
lib/libmp4v2.so.0