games/tome4: drop gcc on powerpc

This commit is contained in:
Piotr Kubaj 2023-01-04 23:56:49 +01:00
parent fbf53dfd85
commit bc5017985f
2 changed files with 24 additions and 8 deletions

View File

@ -1,6 +1,6 @@
PORTNAME= tome4
DISTVERSION?= 1.7.4
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= https://te4.org/dl/t-engine/ \
SF/lifanov-ports-distfiles/${PORTNAME}/:icons
@ -19,7 +19,7 @@ BUILD_DEPENDS= premake4:devel/premake4
LIB_DEPENDS= libvorbisfile.so:audio/libvorbis \
libpng.so:graphics/png
USES= gl gmake openal:al sdl tar:bzip2 xorg
USES= compiler:c++11-lang gl gmake openal:al sdl tar:bzip2 xorg
USE_SDL= image2 sdl2 ttf2
USE_GL= gl glu
SUB_FILES= tome4
@ -34,12 +34,11 @@ WRKSRC= ${WRKDIR}/t-engine4-src-${DISTVERSION}
MAKE_ARGS+= config=release verbose=yes ARCH="" CC=${CC} CXX=${CXX}
LDFLAGS_i386= -Wl,-znotext
.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
.if ${ARCH} == powerpc
USES+= compiler:gcc-c++11-lib
.else
USES+= compiler:c++11-lang
.if ${ARCH:Mpowerpc*} && ${COMPILER_VERSION} < 140
BUILD_DEPENDS+= as:devel/binutils
CFLAGS+= -fno-integrated-as
.endif
pre-build:
@ -61,4 +60,4 @@ do-install:
${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -0,0 +1,17 @@
--- src/luajit2/src/lj_arch.h.orig 2023-01-04 21:49:40 UTC
+++ src/luajit2/src/lj_arch.h
@@ -291,8 +291,14 @@
#error "Need at least GCC 4.2 or newer"
#endif
#elif !LJ_TARGET_PS3
+#if __clang__
+#if ((__clang_major__ < 3) || ((__clang_major__ == 3) && __clang_minor__ < 5))
+#error "Need at least Clang 3.5 or newer"
+#endif
+#else
#if (__GNUC__ < 4) || ((__GNUC__ == 4) && __GNUC_MINOR__ < 3)
#error "Need at least GCC 4.3 or newer"
+#endif
#endif
#endif
#endif