update lang/sbcl to 1.0.54, and adjust dependent ports (this allows sbcl to
be build WITH_THREADS on recent versions of FreeBSD once again) [1]; rename *.core files in sbcl and math/maxima so that they are not removed by disk-cleaning scripts [2]; make it possible to use the makesum target in sbcl WITH_SBCL; fix maxima build WITH_CMUCL, and place a default memory cap of 1GiB on amd64; reduce default output from a few targets in maxima, and defer patch cleaning to the pre-build target to make debugging easier PR: 162017 [1], 162680 [2] Approved by: pav (portmgr) Feature safe: yes
This commit is contained in:
parent
43e194e1e9
commit
bc2f8854ca
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=287114
@ -9,14 +9,11 @@
|
||||
#
|
||||
|
||||
PORTNAME= sbcl
|
||||
PORTVERSION= 1.0.53.0
|
||||
PORTVERSION= 1.0.54.0
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= lang lisp
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R} \
|
||||
ftp://ftp.SpringDaemons.com/soft/sbcl-binary/:binaries
|
||||
#MASTER_SITES= ftp://ftp.SpringDaemons.com/soft/ \
|
||||
# ftp://ftp.SpringDaemons.com/soft/sbcl-binary/:binaries
|
||||
#MASTER_SITE_SUBDIR= sbcl/${PORTVERSION:R}
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION:R}-source${SBCLPATCHLEVEL}
|
||||
|
||||
MAINTAINER= bf@FreeBSD.org
|
||||
@ -37,8 +34,6 @@ OPTIONS= SBCL "Use installed SBCL binary if available" off \
|
||||
PDF "Build PDF documentation" on \
|
||||
PS "Build PostScript documentation" off
|
||||
|
||||
#LICENSE= BSD
|
||||
#LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
MAN1= sbcl.1
|
||||
INFODIR= ${PREFIX}/${INFO_PATH}
|
||||
.if !defined(NOPORTDOCS)
|
||||
@ -87,10 +82,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITH_THREADS) && ${OSVERSION} > 900027
|
||||
BROKEN = 'thread was already on queue' crash with libthr after r216641
|
||||
.endif
|
||||
|
||||
.if !defined(NOPORTDOCS) && (defined(WITH_PDF) || defined(WITH_PS))
|
||||
BUILD_DEPENDS+= dot:${PORTSDIR}/graphics/graphviz
|
||||
.endif
|
||||
@ -121,17 +112,18 @@ DYNAMIC_SPACE_SIZE?= 512
|
||||
.else
|
||||
PLIST_SUB+= I386_ONLY="@comment " AMD64_ONLY=""
|
||||
SBCLCONFIG= Config.x86-64-freebsd
|
||||
DYNAMIC_SPACE_SIZE?= 1024
|
||||
.endif
|
||||
|
||||
# If WITH_SBCL is defined, try to use existing "sbcl" first.
|
||||
.if defined(WITH_SBCL) && exists(${LOCALBASE}/bin/sbcl)
|
||||
.if defined(WITH_SBCL) && exists(${LOCALBASE}/bin/sbcl) && !make(makesum)
|
||||
LISP_CMD= ""
|
||||
.else
|
||||
BOOT_VERSION= 1.0.31
|
||||
|
||||
. if make(makesum)
|
||||
BOOT_ARCH_OS_LIST= amd64-freebsd8 amd64-freebsd7 amd64-freebsd6 \
|
||||
i386-freebsd8 i386-freebsd7 i386-freebsd6
|
||||
BOOT_ARCH_OS_LIST= amd64-freebsd8 amd64-freebsd7 i386-freebsd8 \
|
||||
i386-freebsd7
|
||||
. else
|
||||
. if ${OSVER_MAJOR} > 8 # We'll use 8.x bootstrap for now
|
||||
BOOT_ARCH_OS_LIST= ${ARCH}-freebsd8
|
||||
@ -179,6 +171,8 @@ post-patch:
|
||||
.ifdef(NM)
|
||||
@${ECHO_CMD} "NM=${NM} -gp" >> ${WRKSRC}/src/runtime/${SBCLCONFIG}
|
||||
.endif
|
||||
@${GREP} -Fe '.core' -l -r ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} \
|
||||
-e 's|\.core|_core|g'
|
||||
@${REINPLACE_CMD} \
|
||||
-e 's|/etc/sbclrc|${PREFIX}&|g' \
|
||||
-e 's|/usr/local|${PREFIX}|g' \
|
||||
@ -220,7 +214,7 @@ do-build:
|
||||
do-install:
|
||||
${MKDIR} ${SBCL_HOME}/
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/runtime/sbcl ${PREFIX}/bin/
|
||||
${INSTALL_DATA} ${WRKSRC}/output/sbcl.core ${SBCL_HOME}/
|
||||
${INSTALL_DATA} ${WRKSRC}/output/sbcl_core ${SBCL_HOME}/
|
||||
.for MOD in ${CONTRIB_MODULES}
|
||||
${MKDIR} ${SBCL_HOME}/${MOD}
|
||||
${INSTALL_DATA} ${WRKSRC}/contrib/${MOD}/*.lisp ${SBCL_HOME}/${MOD}/
|
||||
|
@ -1,14 +1,10 @@
|
||||
SHA256 (sbcl-1.0.53-source.tar.bz2) = 49c15dda91fd27f0e7d71a349e391d2c9a4fa753c452881873695309fe154b0a
|
||||
SIZE (sbcl-1.0.53-source.tar.bz2) = 3583606
|
||||
SHA256 (sbcl-1.0.54-source.tar.bz2) = 8d850d94f8f6fb8dcc6dcb44fcc0ec07e97e95037d7864fc1edaeb5f3e1ce1c6
|
||||
SIZE (sbcl-1.0.54-source.tar.bz2) = 3600921
|
||||
SHA256 (sbcl-1.0.31-amd64-freebsd8-binary.tar.bz2) = 06a1e4e3a5f5f8e012ff6037a51624d7d1f34bff0979ce45e70418a293412b4e
|
||||
SIZE (sbcl-1.0.31-amd64-freebsd8-binary.tar.bz2) = 8397764
|
||||
SHA256 (sbcl-1.0.31-amd64-freebsd7-binary.tar.bz2) = fcbd5ed1948312a7b6eff7e6daf736e41be945a2c57bcee4b64f172ddde518b8
|
||||
SIZE (sbcl-1.0.31-amd64-freebsd7-binary.tar.bz2) = 8398964
|
||||
SHA256 (sbcl-1.0.31-amd64-freebsd6-binary.tar.bz2) = f527e60d58960f68130ee735f7a24f409dd5f87f530264e77251ba402c42921d
|
||||
SIZE (sbcl-1.0.31-amd64-freebsd6-binary.tar.bz2) = 8393398
|
||||
SHA256 (sbcl-1.0.31-i386-freebsd8-binary.tar.bz2) = fd2348749a2babf301a99449d246b349a1285fc0bca8b83bde0bfa7187cf3dd7
|
||||
SIZE (sbcl-1.0.31-i386-freebsd8-binary.tar.bz2) = 8475244
|
||||
SHA256 (sbcl-1.0.31-i386-freebsd7-binary.tar.bz2) = 5202f6d7a8a1f3b1f19cbd4c65d874b85e8015fc5efec71bffef407c25edbe77
|
||||
SIZE (sbcl-1.0.31-i386-freebsd7-binary.tar.bz2) = 8474568
|
||||
SHA256 (sbcl-1.0.31-i386-freebsd6-binary.tar.bz2) = 601efa15c3b9d6b3d3b350d743ae819118f832d1fa29bd9e1eedef99c1e5952f
|
||||
SIZE (sbcl-1.0.31-i386-freebsd6-binary.tar.bz2) = 8473661
|
||||
|
@ -4,5 +4,4 @@
|
||||
(disable (x)
|
||||
(setf features (remove x features))))
|
||||
(enable :sb-thread)
|
||||
(enable :sb-lutex)
|
||||
features))
|
||||
|
@ -1,20 +0,0 @@
|
||||
--- contrib/sb-posix/posix-tests.lisp.orig 2011-11-06 15:31:02.000000000 -0500
|
||||
+++ contrib/sb-posix/posix-tests.lisp 2011-11-22 10:26:13.000000000 -0500
|
||||
@@ -174,7 +174,7 @@
|
||||
(typep
|
||||
(sb-posix:syscall-errno c)
|
||||
'(member
|
||||
- #+darwin
|
||||
+ #+(or darwin freebsd)
|
||||
#.sb-posix:eisdir
|
||||
#+win32
|
||||
#.sb-posix::eacces
|
||||
@@ -182,7 +182,7 @@
|
||||
#.sb-posix::enotempty
|
||||
#+sunos
|
||||
#.sb-posix::einval
|
||||
- #-(or darwin win32 sunos)
|
||||
+ #-(or darwin freebsd win32 sunos)
|
||||
#.sb-posix::ebusy)))) t)
|
||||
|
||||
(deftest rmdir.error.4
|
@ -56,6 +56,8 @@ lib/sbcl/sb-cltl2/sb-cltl2.asd
|
||||
lib/sbcl/sb-cltl2/sb-cltl2.fasl
|
||||
lib/sbcl/sb-cltl2/tests.fasl
|
||||
lib/sbcl/sb-cltl2/tests.lisp
|
||||
lib/sbcl/sb-concurrency/gate.fasl
|
||||
lib/sbcl/sb-concurrency/gate.lisp
|
||||
lib/sbcl/sb-concurrency/mailbox.fasl
|
||||
lib/sbcl/sb-concurrency/mailbox.lisp
|
||||
lib/sbcl/sb-concurrency/package.fasl
|
||||
@ -175,7 +177,7 @@ lib/sbcl/sb-simple-streams/terminal.fasl
|
||||
lib/sbcl/sb-simple-streams/terminal.lisp
|
||||
lib/sbcl/sb-sprof/sb-sprof.fasl
|
||||
lib/sbcl/sb-sprof/sb-sprof.lisp
|
||||
lib/sbcl/sbcl.core
|
||||
lib/sbcl/sbcl_core
|
||||
lib/sbcl/site-systems/.keep_me
|
||||
%%PORTDOCS%%%%DOCSDIR%%/BUGS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/COPYING
|
||||
|
@ -7,7 +7,7 @@
|
||||
|
||||
PORTNAME= fricas
|
||||
PORTVERSION= 1.1.4
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= SF
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}-full
|
||||
|
@ -7,20 +7,21 @@
|
||||
|
||||
PORTNAME= maxima
|
||||
PORTVERSION= 5.25.1
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= math lisp tk
|
||||
MASTER_SITES= SF/maxima/Maxima-source/${PORTVERSION}-source
|
||||
|
||||
MAINTAINER= bf@FreeBSD.org
|
||||
COMMENT= Symbolic mathematics program
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/bin/${LISPPORT}
|
||||
PATCH_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
|
||||
RUN_DEPENDS= ${LOCALBASE}/bin/${LISPPORT} \
|
||||
${LOCALBASE}/bin/gnuplot:${PORTSDIR}/math/gnuplot \
|
||||
${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
|
||||
|
||||
LICENSE= GPLv2
|
||||
USE_TK = 84+
|
||||
USE_GMAKE= yes
|
||||
USE_PERL5_BUILD= yes
|
||||
@ -60,7 +61,8 @@ LISPPORT= lisp:${PORTSDIR}/lang/cmucl
|
||||
BINDIRECTORY= binary-cmucl
|
||||
LISPBINARY= lisp
|
||||
PLIST_SUB+= LISPBINARY=""
|
||||
MAXIMABINARY= maxima.core
|
||||
MAXIMABINARY= maxima_core
|
||||
STRIP= #strip(1) chokes on LISPBINARY
|
||||
.elif defined(WITHOUT_CLISP) && defined(WITHOUT_CMUCL) && defined(WITH_GCL) && defined(WITHOUT_SBCL)
|
||||
LISPSELECT= --enable-gcl
|
||||
LISPPORT= gcl:${PORTSDIR}/lang/gcl
|
||||
@ -71,6 +73,8 @@ MAXIMABINARY= maxima
|
||||
.elif defined(WITHOUT_CLISP) && defined(WITHOUT_CMUCL) && defined(WITHOUT_GCL) && defined(WITH_SBCL)
|
||||
. if ${ARCH} == "i386"
|
||||
DYNAMIC_SPACE_SIZE?= 512
|
||||
. else
|
||||
DYNAMIC_SPACE_SIZE?= 1024
|
||||
. endif
|
||||
. if defined(DYNAMIC_SPACE_SIZE)
|
||||
MAXIMA_LISP_OPTIONS+= --dynamic-space-size ${DYNAMIC_SPACE_SIZE}
|
||||
@ -84,29 +88,37 @@ LISPPORT= sbcl:${PORTSDIR}/lang/sbcl
|
||||
BINDIRECTORY= binary-sbcl
|
||||
#LISPBINARY is null so fudge this so deinstall works cleanly
|
||||
PLIST_SUB+= LISPBINARY="@comment "
|
||||
MAXIMABINARY= maxima.core
|
||||
MAXIMABINARY= maxima_core
|
||||
.else
|
||||
IGNORE= define only one lisp
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
${FIND} -X ${WRKSRC}/archive ${WRKSRC}/interfaces/xmaxima \
|
||||
-name 'Makefile.in' | ${XARGS} ${REINPLACE_CMD} -e "s;tclsh;${TCLSH};g"
|
||||
${REINPLACE_CMD} -e "s;/usr;${LOCALBASE};g" ${WRKSRC}/src/intl.lisp
|
||||
(cd ${WRKSRC}/doc/info ; ${LOCALBASE}/bin/bash ./fix_crlf ; \
|
||||
${LOCALBASE}/bin/bash ./fix_tab)
|
||||
@${GREP} -Fe '.core' -l -r ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} \
|
||||
-e 's;\.core;_core;g'
|
||||
@${FIND} -X ${WRKSRC}/interfaces/xmaxima -name 'Makefile.in' | ${XARGS} \
|
||||
${REINPLACE_CMD} -e "s;tclsh;${TCLSH};g"
|
||||
@${REINPLACE_CMD} -e "s;/usr;${LOCALBASE};g" ${WRKSRC}/src/intl.lisp
|
||||
@cd ${WRKSRC}/doc/info ; ${LOCALBASE}/bin/bash ./fix_crlf ; \
|
||||
${LOCALBASE}/bin/bash ./fix_tab
|
||||
@${REINPLACE_CMD} -e 's;$$maxima_image_base;$${maxima_image_base};g' \
|
||||
${WRKSRC}/src/maxima.in
|
||||
.if defined(MAXIMA_LISP_OPTIONS) && !empty(MAXIMA_LISP_OPTIONS)
|
||||
${REINPLACE_CMD} -e 's;"@SBCL_NAME@";@SBCL_NAME@;' \
|
||||
@${REINPLACE_CMD} -e 's;"@SBCL_NAME@";@SBCL_NAME@;g' \
|
||||
${WRKSRC}/src/maxima.in
|
||||
.endif
|
||||
|
||||
pre-build:
|
||||
@${FIND} ${WRKSRC} \( -name '*.bak' -o -name '*.fbsd10bak' -o \
|
||||
-name '*.orig' \) -delete
|
||||
|
||||
post-install:
|
||||
@${ECHO_MSG} ""
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
@${ECHO_MSG} ""
|
||||
|
||||
test check: build
|
||||
(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${_MAKE_JOBS} \
|
||||
${MAKE_ARGS} check)
|
||||
check test: build
|
||||
@cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${_MAKE_JOBS} \
|
||||
${MAKE_ARGS} check
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,7 +1,5 @@
|
||||
When built with sbcl, maxima imposes a default memory
|
||||
limit of 512MB on i386. A limit can be imposed on other
|
||||
architectures, or changed on i386, by defining
|
||||
DYNAMIC_SPACE_SIZE appropriately in the build environment.
|
||||
The limit can be overridden at runtime, via the
|
||||
-X/--lisp-options option, or by defining the environment
|
||||
variable MAXIMA_LISP_OPTIONS.
|
||||
When built with sbcl, maxima imposes a default memory limit of 512MiB on i386,
|
||||
and 1GiB on amd64. The limit can be changed by defining DYNAMIC_SPACE_SIZE
|
||||
in the build environment. The limit can be overridden later, at run-time,
|
||||
via the -X or --lisp-options options, or by defining the environment variable
|
||||
MAXIMA_LISP_OPTIONS.
|
||||
|
@ -7,6 +7,7 @@
|
||||
|
||||
PORTNAME= open-axiom
|
||||
PORTVERSION= 1.4.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
|
||||
|
||||
|
@ -7,7 +7,7 @@
|
||||
|
||||
PORTNAME= stumpwm
|
||||
PORTVERSION= 0.9.7
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= x11-wm lisp
|
||||
MASTER_SITES= SAVANNAH
|
||||
DISTFILES= ${DISTNAME}.tgz
|
||||
|
@ -7,7 +7,7 @@
|
||||
|
||||
PORTNAME= stumpwm
|
||||
PORTVERSION= 0.9.7
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= x11-wm lisp
|
||||
MASTER_SITES= SAVANNAH
|
||||
DISTFILES= ${DISTNAME}.tgz
|
||||
|
Loading…
Reference in New Issue
Block a user