Update to 4.2.4.
Reported by: portscout Sponsored by: Absolight
This commit is contained in:
parent
25be77d69c
commit
bc0be36fe7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=429068
@ -2,11 +2,11 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= nagios
|
||||
PORTVERSION= 4.1.1
|
||||
PORTREVISION= 5
|
||||
PORTVERSION= 4.2.4
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= net-mgmt
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-4.x/${PORTNAME}-${PORTVERSION}
|
||||
MASTER_SITES= https://assets.nagios.com/downloads/nagioscore/releases/ \
|
||||
SF/${PORTNAME}/${PORTNAME}-4.x/${PORTNAME}-${PORTVERSION}
|
||||
PKGNAMESUFFIX= 4
|
||||
|
||||
MAINTAINER= mat@FreeBSD.org
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1471962949
|
||||
SHA256 (nagios-4.1.1.tar.gz) = 58218e5e66c8078fc578a60db33b5c3da10fc6a793e97d2b00780517e3efa0a7
|
||||
SIZE (nagios-4.1.1.tar.gz) = 11142182
|
||||
TIMESTAMP = 1482317499
|
||||
SHA256 (nagios-4.2.4.tar.gz) = b0055c475683ce50d77b1536ff0cec9abf89139adecf771601fa021ef9a20b70
|
||||
SIZE (nagios-4.2.4.tar.gz) = 11088206
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- configure.orig 2015-08-19 21:49:52 UTC
|
||||
--- configure.orig 2016-12-07 16:31:10 UTC
|
||||
+++ configure
|
||||
@@ -6016,7 +6016,6 @@ cat >>confdefs.h <<_ACEOF
|
||||
@@ -4769,7 +4769,6 @@ cat >>confdefs.h <<_ACEOF
|
||||
#define DEFAULT_NAGIOS_GROUP "$nagios_grp"
|
||||
_ACEOF
|
||||
|
||||
@ -8,7 +8,7 @@
|
||||
|
||||
|
||||
|
||||
@@ -6037,7 +6036,6 @@ fi
|
||||
@@ -4790,7 +4789,6 @@ fi
|
||||
|
||||
|
||||
|
||||
@ -16,12 +16,3 @@
|
||||
|
||||
|
||||
MAIL_PROG=no
|
||||
@@ -7768,7 +7766,7 @@ $as_echo_n "checking for linker flags fo
|
||||
MOD_LDFLAGS="-shared"
|
||||
MOD_CFLAGS="-fPIC"
|
||||
;;
|
||||
- freebsd*)
|
||||
+ dragonfly*|freebsd*)
|
||||
MOD_LDFLAGS="-shared"
|
||||
MOD_CFLAGS="-fPIC"
|
||||
;;
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- html/Makefile.in.orig 2015-08-19 21:49:52 UTC
|
||||
--- html/Makefile.in.orig 2016-12-07 16:31:10 UTC
|
||||
+++ html/Makefile.in
|
||||
@@ -45,11 +45,8 @@ devclean: distclean
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- html/index.php.orig 2015-08-19 21:49:52 UTC
|
||||
--- html/index.php.orig 2016-12-07 16:31:10 UTC
|
||||
+++ html/index.php
|
||||
@@ -1,6 +1,7 @@
|
||||
<?php
|
||||
@ -6,6 +6,6 @@
|
||||
// Allow specifying main window URL for permalinks, etc.
|
||||
-$url = 'main.php';
|
||||
+$url = $cfg['cgi_base_url'].'/tac.cgi';
|
||||
|
||||
if (isset($_GET['corewindow'])) {
|
||||
|
||||
// The default window url may have been overridden with a permalink...
|
@ -1,9 +1,9 @@
|
||||
--- html/main.php.orig 2015-08-19 21:49:52 UTC
|
||||
--- html/main.php.orig 2016-12-07 16:31:10 UTC
|
||||
+++ html/main.php
|
||||
@@ -130,31 +130,6 @@ $this_year = '2015';
|
||||
@@ -130,31 +130,6 @@ $this_year = '2016';
|
||||
<div class="product">Nagios<sup><span style="font-size: small;">®</span></sup> Core<sup><span style="font-size: small;">™</span></sup></div>
|
||||
<div class="version">Version <?php echo $this_version; ?></div>
|
||||
<div class="releasedate">August 19, 2015</div>
|
||||
<div class="releasedate">December 07, 2016</div>
|
||||
- <div class="checkforupdates"><a href="https://www.nagios.org/checkforupdates/?version=<?php echo $this_version; ?>&product=nagioscore" target="_blank">Check for updates</a></div>
|
||||
-</div>
|
||||
-
|
@ -1,16 +0,0 @@
|
||||
--- lib/iobroker.c.orig 2014-08-12 15:00:01 UTC
|
||||
+++ lib/iobroker.c
|
||||
@@ -415,11 +415,11 @@ int iobroker_poll(iobroker_set *iobs, in
|
||||
iobs->pfd[p].events = POLLIN;
|
||||
p++;
|
||||
}
|
||||
- nfds = poll(iobs->pfd, iobs->num_fds, timeout);
|
||||
+ nfds = poll(iobs->pfd, p, timeout);
|
||||
if (nfds < 0) {
|
||||
return IOBROKER_ELIB;
|
||||
}
|
||||
- for (i = 0; i < iobs->num_fds; i++) {
|
||||
+ for (i = 0; i < p; i++) {
|
||||
iobroker_fd *s;
|
||||
if ((iobs->pfd[i].revents & POLLIN) != POLLIN) {
|
||||
continue;
|
@ -1,11 +0,0 @@
|
||||
--- lib/nsock.c.orig 2014-08-12 15:00:01 UTC
|
||||
+++ lib/nsock.c
|
||||
@@ -81,7 +81,7 @@ int nsock_unix(const char *path, unsigne
|
||||
if(flags & NSOCK_UDP)
|
||||
return sock;
|
||||
|
||||
- if(listen(sock, 3) < 0) {
|
||||
+ if(listen(sock, 48) < 0) {
|
||||
close(sock);
|
||||
return NSOCK_ELISTEN;
|
||||
}
|
@ -1,6 +1,6 @@
|
||||
--- sample-config/cgi.cfg.in.orig 2014-08-12 15:00:01 UTC
|
||||
--- sample-config/cgi.cfg.in.orig 2016-12-07 16:31:10 UTC
|
||||
+++ sample-config/cgi.cfg.in
|
||||
@@ -263,7 +263,7 @@ default_statuswrl_layout=4
|
||||
@@ -277,7 +277,7 @@ default_statuswrl_layout=4
|
||||
# OS and distribution, so you may have to tweak this to
|
||||
# work on your system.
|
||||
|
@ -222,6 +222,9 @@
|
||||
%%WWWDIR%%/images/logos/nagios.gd2
|
||||
%%WWWDIR%%/images/logos/nagios.gif
|
||||
%%WWWDIR%%/images/logos/nagiosvrml.png
|
||||
%%WWWDIR%%/images/logos/netbsd.gif
|
||||
%%WWWDIR%%/images/logos/netbsd.jpg
|
||||
%%WWWDIR%%/images/logos/netbsd.png
|
||||
%%WWWDIR%%/images/logos/next.gd2
|
||||
%%WWWDIR%%/images/logos/next.gif
|
||||
%%WWWDIR%%/images/logos/next.jpg
|
||||
@ -280,6 +283,9 @@
|
||||
%%WWWDIR%%/images/logos/sunlogo.gif
|
||||
%%WWWDIR%%/images/logos/sunlogo.jpg
|
||||
%%WWWDIR%%/images/logos/sunlogo.png
|
||||
%%WWWDIR%%/images/logos/suse.gif
|
||||
%%WWWDIR%%/images/logos/suse.jpg
|
||||
%%WWWDIR%%/images/logos/suse.png
|
||||
%%WWWDIR%%/images/logos/switch.gd2
|
||||
%%WWWDIR%%/images/logos/switch.gif
|
||||
%%WWWDIR%%/images/logos/switch40.gd2
|
||||
@ -358,17 +364,9 @@
|
||||
%%WWWDIR%%/images/weblogo1.png
|
||||
%%WWWDIR%%/images/zoom1.gif
|
||||
%%WWWDIR%%/images/zoom2.gif
|
||||
%%WWWDIR%%/includes/jquery-1.7.1.min.js
|
||||
%%WWWDIR%%/includes/rss/extlib/Snoopy.class.inc
|
||||
%%WWWDIR%%/includes/rss/rss_cache.inc
|
||||
%%WWWDIR%%/includes/rss/rss_fetch.inc
|
||||
%%WWWDIR%%/includes/rss/rss_parse.inc
|
||||
%%WWWDIR%%/includes/rss/rss_utils.inc
|
||||
%%WWWDIR%%/includes/utils.inc.php
|
||||
%%WWWDIR%%/index.php
|
||||
%%WWWDIR%%/infobox.html
|
||||
%%WWWDIR%%/js/%%NAGIOSUSER%%-decorations.js
|
||||
%%WWWDIR%%/js/%%NAGIOSUSER%%-time.js
|
||||
%%WWWDIR%%/js/histogram-events.js
|
||||
%%WWWDIR%%/js/histogram-form.js
|
||||
%%WWWDIR%%/js/histogram-graph.js
|
||||
@ -378,6 +376,8 @@
|
||||
%%WWWDIR%%/js/map-directive.js
|
||||
%%WWWDIR%%/js/map-form.js
|
||||
%%WWWDIR%%/js/map.js
|
||||
%%WWWDIR%%/js/nagios-decorations.js
|
||||
%%WWWDIR%%/js/nagios-time.js
|
||||
%%WWWDIR%%/js/trends-form.js
|
||||
%%WWWDIR%%/js/trends-graph.js
|
||||
%%WWWDIR%%/js/trends.js
|
||||
@ -387,13 +387,8 @@
|
||||
%%WWWDIR%%/map-form.html
|
||||
%%WWWDIR%%/map-links.html
|
||||
%%WWWDIR%%/map-popup.html
|
||||
%%WWWDIR%%/map.html
|
||||
%%WWWDIR%%/map.php
|
||||
%%WWWDIR%%/robots.txt
|
||||
%%WWWDIR%%/rss-corebanner.php
|
||||
%%WWWDIR%%/rss-corefeed.html
|
||||
%%WWWDIR%%/rss-corefeed.php
|
||||
%%WWWDIR%%/rss-newsfeed.html
|
||||
%%WWWDIR%%/rss-newsfeed.php
|
||||
%%WWWDIR%%/side.php
|
||||
%%WWWDIR%%/spin/spin.min.js
|
||||
%%WWWDIR%%/stylesheets/avail.css
|
||||
|
Loading…
Reference in New Issue
Block a user