- Update cad/freecad to 0.17.12018

- Use upstream version numbering
- Reset maintainership on his request
- While here, silence portlint warning about USES variable position

PR:		222195
Submitted by:	Thibault Jouan <tj+freebsd_ports@a13.fr> (maintainer)
This commit is contained in:
Guido Falsi 2017-10-08 12:40:34 +00:00
parent 8096b08a8f
commit bbd458c1cf
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=451522
6 changed files with 148 additions and 46 deletions

View File

@ -1,11 +1,10 @@
# $FreeBSD$
PORTNAME= FreeCAD
DISTVERSION= 0.17.g20170616
PORTREVISION= 4
DISTVERSION= 0.17.12018
CATEGORIES= cad
MAINTAINER= tj+freebsd_ports@a13.fr
MAINTAINER= ports@FreeBSD.org
COMMENT= General purpose 3D CAD modeller
LICENSE= LGPL20+
@ -32,9 +31,6 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
libhdf5.so:science/hdf5
RUN_DEPENDS= pivy>0:graphics/py-pivy
USE_GITHUB= yes
GH_TAGNAME= d28bae3
USES= dos2unix compiler:c++11-lib cmake:outsource fortran jpeg \
python localbase
USE_XORG= ice sm x11 xext xt
@ -56,6 +52,9 @@ CFLAGS+= -I${LOCALBASE}/include/hdf5-18
CMAKE_INSTALL_PREFIX= ${PREFIX}/${PORTNAME}
USE_GITHUB= yes
GH_TAGNAME= f27617e
OPTIONS_DEFINE= COLLADA
COLLADA_DESC= Install pycollada for Collada files import
@ -69,6 +68,8 @@ post-patch:
${WRKSRC}/src/Gui/CMakeLists.txt
pre-configure:
@${CP} ${FILESDIR}/version.h \
${WRKSRC}/src/Build/Version.h
# To be removed when french/med will be built against science/hdf5
@${REINPLACE_CMD} -e 's|find_package(HDF5 REQUIRED)|#find_package(HDF5 REQUIRED)|' \
${WRKSRC}/CMakeLists.txt

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1497621665
SHA256 (FreeCAD-FreeCAD-0.17.g20170616-d28bae3_GH0.tar.gz) = 3da1d1384bfdf573a4edca04ba97be8abfa4847d0479ec3cc8d11aa73a193a82
SIZE (FreeCAD-FreeCAD-0.17.g20170616-d28bae3_GH0.tar.gz) = 120122816
TIMESTAMP = 1504952593
SHA256 (FreeCAD-FreeCAD-0.17.12018-f27617e_GH0.tar.gz) = d52c88ab3a96ef43c4d87998913a523ba2c0f47418abffecf4d72dc3429bc796
SIZE (FreeCAD-FreeCAD-0.17.12018-f27617e_GH0.tar.gz) = 120335253

View File

@ -0,0 +1,37 @@
--- CMakeLists.txt.orig 2017-07-28 17:35:48 UTC
+++ CMakeLists.txt
@@ -661,33 +661,7 @@ endif(${CMAKE_SYSTEM_NAME} MATCHES "Darw
if (WIN32)
find_package(HDF5 COMPONENTS NO_MODULE REQUIRED static)
else()
- find_package(PkgConfig)
- pkg_search_module(HDF5 hdf5-serial)
- if(NOT HDF5_FOUND)
- find_package(HDF5 REQUIRED)
- else()
- add_compile_options(${HDF5_CFLAGS})
- link_directories(${HDF5_LIBRARY_DIRS})
- link_libraries(${HDF5_LIBRARIES})
- find_file(Hdf5dotH hdf5.h PATHS ${HDF5_INCLUDE_DIRS} NO_DEFAULT_PATH)
- if(NOT Hdf5dotH)
- message( FATAL_ERROR "hdf5-serial not found in an error message above.")
- endif()
- endif()
- check_include_file_cxx(hdf5.h HDF5_FOUND)
- if(NOT HDF5_FOUND)
- message( FATAL_ERROR "hdf5.h was not found.")
- endif()
-
- # Med Fichier can require MPI
- pkg_search_module(OPENMPI ompi-cxx)
- add_compile_options(${OPENMPI_CFLAGS})
- link_directories(${OPENMPI_LIBRARY_DIRS})
- link_libraries(${OPENMPI_LIBRARIES})
- find_file(MpidotH mpi.h PATHS ${OPENMPI_INCLUDE_DIRS} NO_DEFAULT_PATH)
- if(NOT MpidotH)
- message( WARNING "mpi.h was not found. Check for error above.")
- endif()
+ find_package(HDF5 REQUIRED)
endif()
find_package(MEDFile REQUIRED)
set(SMESH_INCLUDE_DIR ${CMAKE_SOURCE_DIR}/src/3rdParty/salomesmesh/inc)

View File

@ -1,11 +0,0 @@
--- src/Base/Console.cpp.orig 2017-06-16 13:04:23 UTC
+++ src/Base/Console.cpp
@@ -714,7 +714,7 @@ void ConsoleObserverFile::Log (const
ConsoleObserverStd::ConsoleObserverStd() :
# if defined(FC_OS_WIN32)
useColorStderr( true )
-# elif defined(FC_OS_LINUX) || defined(FC_OS_MACOSX)
+# else
useColorStderr( isatty(STDERR_FILENO) )
# endif
{

View File

@ -0,0 +1,12 @@
// Version Number
#define FCVersionMajor "0"
#define FCVersionMinor "17"
#define FCVersionName "Vulcan"
// test: $Format:Hash (%H), Date: %ci$
#define FCRevision "12018 (Git)" //Highest committed revision number
#define FCRevisionDate "2017/09/08 12:52:12" //Date of highest committed revision
#define FCRepositoryURL "git://github.com/FreeCAD/FreeCAD.git master" //Repository URL of the working copy
// Git relevant stuff
#define FCRepositoryHash "f27617e63e4cd0ea00dd307577abe465d9a709fa"
#define FCRepositoryBranch "master"

View File

@ -12,6 +12,7 @@ FreeCAD/Mod/Arch/ArchEquipment.py
FreeCAD/Mod/Arch/ArchFloor.py
FreeCAD/Mod/Arch/ArchFrame.py
FreeCAD/Mod/Arch/ArchMaterial.py
FreeCAD/Mod/Arch/ArchNesting.py
FreeCAD/Mod/Arch/ArchPanel.py
FreeCAD/Mod/Arch/ArchPipe.py
FreeCAD/Mod/Arch/ArchPrecast.py
@ -38,6 +39,7 @@ FreeCAD/Mod/Arch/import3DS.py
FreeCAD/Mod/Arch/importDAE.py
FreeCAD/Mod/Arch/importIFC.py
FreeCAD/Mod/Arch/importIFClegacy.py
FreeCAD/Mod/Arch/importJSON.py
FreeCAD/Mod/Arch/importOBJ.py
FreeCAD/Mod/Arch/importSH3D.py
FreeCAD/Mod/Arch/importWebGL.py
@ -71,6 +73,7 @@ FreeCAD/Mod/Fem/FemInputWriterCcx.py
FreeCAD/Mod/Fem/FemInputWriterZ88.py
FreeCAD/Mod/Fem/FemMesh2Mesh.py
FreeCAD/Mod/Fem/FemMeshTools.py
FreeCAD/Mod/Fem/FemResultTools.py
FreeCAD/Mod/Fem/FemSelectionObserver.py
FreeCAD/Mod/Fem/FemTools.py
FreeCAD/Mod/Fem/FemToolsCcx.py
@ -83,8 +86,10 @@ FreeCAD/Mod/Fem/PyGui/TaskPanelFemElementFluid1D.ui
FreeCAD/Mod/Fem/PyGui/TaskPanelFemElementGeometry1D.ui
FreeCAD/Mod/Fem/PyGui/TaskPanelFemElementGeometry2D.ui
FreeCAD/Mod/Fem/PyGui/TaskPanelFemMaterial.ui
FreeCAD/Mod/Fem/PyGui/TaskPanelFemMeshBoundaryLayer.ui
FreeCAD/Mod/Fem/PyGui/TaskPanelFemMeshGmsh.ui
FreeCAD/Mod/Fem/PyGui/TaskPanelFemMeshGroup.ui
FreeCAD/Mod/Fem/PyGui/TaskPanelFemMeshGroupXDMFExport.ui
FreeCAD/Mod/Fem/PyGui/TaskPanelFemMeshRegion.ui
FreeCAD/Mod/Fem/PyGui/TaskPanelFemResultShow.ui
FreeCAD/Mod/Fem/PyGui/TaskPanelFemSolverCalculix.ui
@ -97,6 +102,7 @@ FreeCAD/Mod/Fem/PyGui/_CommandFemMaterialFluid.py
FreeCAD/Mod/Fem/PyGui/_CommandFemMaterialMechanicalNonlinear.py
FreeCAD/Mod/Fem/PyGui/_CommandFemMaterialSolid.py
FreeCAD/Mod/Fem/PyGui/_CommandFemMesh2Mesh.py
FreeCAD/Mod/Fem/PyGui/_CommandFemMeshBoundaryLayer.py
FreeCAD/Mod/Fem/PyGui/_CommandFemMeshClear.py
FreeCAD/Mod/Fem/PyGui/_CommandFemMeshGmshFromShape.py
FreeCAD/Mod/Fem/PyGui/_CommandFemMeshGroup.py
@ -113,6 +119,7 @@ FreeCAD/Mod/Fem/PyGui/_TaskPanelFemElementFluid1D.py
FreeCAD/Mod/Fem/PyGui/_TaskPanelFemElementGeometry1D.py
FreeCAD/Mod/Fem/PyGui/_TaskPanelFemElementGeometry2D.py
FreeCAD/Mod/Fem/PyGui/_TaskPanelFemMaterial.py
FreeCAD/Mod/Fem/PyGui/_TaskPanelFemMeshBoundaryLayer.py
FreeCAD/Mod/Fem/PyGui/_TaskPanelFemMeshGmsh.py
FreeCAD/Mod/Fem/PyGui/_TaskPanelFemMeshGroup.py
FreeCAD/Mod/Fem/PyGui/_TaskPanelFemMeshRegion.py
@ -124,9 +131,11 @@ FreeCAD/Mod/Fem/PyGui/_ViewProviderFemElementGeometry1D.py
FreeCAD/Mod/Fem/PyGui/_ViewProviderFemElementGeometry2D.py
FreeCAD/Mod/Fem/PyGui/_ViewProviderFemMaterial.py
FreeCAD/Mod/Fem/PyGui/_ViewProviderFemMaterialMechanicalNonlinear.py
FreeCAD/Mod/Fem/PyGui/_ViewProviderFemMeshBoundaryLayer.py
FreeCAD/Mod/Fem/PyGui/_ViewProviderFemMeshGmsh.py
FreeCAD/Mod/Fem/PyGui/_ViewProviderFemMeshGroup.py
FreeCAD/Mod/Fem/PyGui/_ViewProviderFemMeshRegion.py
FreeCAD/Mod/Fem/PyGui/_ViewProviderFemMeshResult.py
FreeCAD/Mod/Fem/PyGui/_ViewProviderFemResultMechanical.py
FreeCAD/Mod/Fem/PyGui/_ViewProviderFemSolverCalculix.py
FreeCAD/Mod/Fem/PyGui/_ViewProviderFemSolverZ88.py
@ -137,9 +146,11 @@ FreeCAD/Mod/Fem/PyObjects/_FemElementGeometry1D.py
FreeCAD/Mod/Fem/PyObjects/_FemElementGeometry2D.py
FreeCAD/Mod/Fem/PyObjects/_FemMaterial.py
FreeCAD/Mod/Fem/PyObjects/_FemMaterialMechanicalNonlinear.py
FreeCAD/Mod/Fem/PyObjects/_FemMeshBoundaryLayer.py
FreeCAD/Mod/Fem/PyObjects/_FemMeshGmsh.py
FreeCAD/Mod/Fem/PyObjects/_FemMeshGroup.py
FreeCAD/Mod/Fem/PyObjects/_FemMeshRegion.py
FreeCAD/Mod/Fem/PyObjects/_FemMeshResult.py
FreeCAD/Mod/Fem/PyObjects/_FemResultMechanical.py
FreeCAD/Mod/Fem/PyObjects/_FemSolverCalculix.py
FreeCAD/Mod/Fem/PyObjects/_FemSolverZ88.py
@ -157,6 +168,13 @@ FreeCAD/Mod/Fem/importZ88O2Results.py
FreeCAD/Mod/Fem/readFenicsXDMF.py
FreeCAD/Mod/Fem/readFenicsXML.py
FreeCAD/Mod/Fem/test_files/__init__.py
FreeCAD/Mod/Fem/test_files/ccx/Flow1D_mesh.py
FreeCAD/Mod/Fem/test_files/ccx/Flow1D_thermomech.dat
FreeCAD/Mod/Fem/test_files/ccx/Flow1D_thermomech.fcstd
FreeCAD/Mod/Fem/test_files/ccx/Flow1D_thermomech.frd
FreeCAD/Mod/Fem/test_files/ccx/Flow1D_thermomech.inp
FreeCAD/Mod/Fem/test_files/ccx/Flow1D_thermomech_expected_values
FreeCAD/Mod/Fem/test_files/ccx/Flow1D_thermomech_inout_nodes.txt
FreeCAD/Mod/Fem/test_files/ccx/__init__.py
FreeCAD/Mod/Fem/test_files/ccx/cube.fcstd
FreeCAD/Mod/Fem/test_files/ccx/cube_frequency.dat
@ -214,6 +232,7 @@ FreeCAD/Mod/Idf/Idflibs/footprints_models.csv
FreeCAD/Mod/Idf/Init.py
FreeCAD/Mod/Image/Init.py
FreeCAD/Mod/Image/InitGui.py
FreeCAD/Mod/Import/Import_rc.py
FreeCAD/Mod/Import/Init.py
FreeCAD/Mod/Import/InitGui.py
FreeCAD/Mod/Inspection/Init.py
@ -275,6 +294,25 @@ FreeCAD/Mod/PartDesign/Init.py
FreeCAD/Mod/PartDesign/InitGui.py
FreeCAD/Mod/PartDesign/InvoluteGearFeature.py
FreeCAD/Mod/PartDesign/InvoluteGearFeature.ui
FreeCAD/Mod/PartDesign/PartDesignTests/TestBoolean.py
FreeCAD/Mod/PartDesign/PartDesignTests/TestChamfer.py
FreeCAD/Mod/PartDesign/PartDesignTests/TestDatum.py
FreeCAD/Mod/PartDesign/PartDesignTests/TestDraft.py
FreeCAD/Mod/PartDesign/PartDesignTests/TestFillet.py
FreeCAD/Mod/PartDesign/PartDesignTests/TestHole.py
FreeCAD/Mod/PartDesign/PartDesignTests/TestLinearPattern.py
FreeCAD/Mod/PartDesign/PartDesignTests/TestLoft.py
FreeCAD/Mod/PartDesign/PartDesignTests/TestMirrored.py
FreeCAD/Mod/PartDesign/PartDesignTests/TestMultiTransform.py
FreeCAD/Mod/PartDesign/PartDesignTests/TestPad.py
FreeCAD/Mod/PartDesign/PartDesignTests/TestPipe.py
FreeCAD/Mod/PartDesign/PartDesignTests/TestPocket.py
FreeCAD/Mod/PartDesign/PartDesignTests/TestPolarPattern.py
FreeCAD/Mod/PartDesign/PartDesignTests/TestPrimitive.py
FreeCAD/Mod/PartDesign/PartDesignTests/TestRevolve.py
FreeCAD/Mod/PartDesign/PartDesignTests/TestShapeBinder.py
FreeCAD/Mod/PartDesign/PartDesignTests/TestThickness.py
FreeCAD/Mod/PartDesign/PartDesignTests/__init__.py
FreeCAD/Mod/PartDesign/Scripts/DistanceBolt.py
FreeCAD/Mod/PartDesign/Scripts/Epitrochoid.py
FreeCAD/Mod/PartDesign/Scripts/FilletArc.py
@ -302,76 +340,101 @@ FreeCAD/Mod/PartDesign/fcgear/svggear.py
FreeCAD/Mod/Path/Init.py
FreeCAD/Mod/Path/InitGui.py
FreeCAD/Mod/Path/PathCommands.py
FreeCAD/Mod/Path/PathScripts/PathAreaUtils.py
FreeCAD/Mod/Path/PathScripts/PathAreaOp.py
FreeCAD/Mod/Path/PathScripts/PathArray.py
FreeCAD/Mod/Path/PathScripts/PathCircularHoleBase.py
FreeCAD/Mod/Path/PathScripts/PathCircularHoleBaseGui.py
FreeCAD/Mod/Path/PathScripts/PathCommands.py
FreeCAD/Mod/Path/PathScripts/PathComment.py
FreeCAD/Mod/Path/PathScripts/PathCompoundExtended.py
FreeCAD/Mod/Path/PathScripts/PathContour.py
FreeCAD/Mod/Path/PathScripts/PathCopy.py
FreeCAD/Mod/Path/PathScripts/PathCustom.py
FreeCAD/Mod/Path/PathScripts/PathDressup.py
FreeCAD/Mod/Path/PathScripts/PathDressupDogbone.py
FreeCAD/Mod/Path/PathScripts/PathDressupDragknife.py
FreeCAD/Mod/Path/PathScripts/PathDressupHoldingTags.py
FreeCAD/Mod/Path/PathScripts/PathDressupRampEntry.py
FreeCAD/Mod/Path/PathScripts/PathDressupTag.py
FreeCAD/Mod/Path/PathScripts/PathDressupTagGui.py
FreeCAD/Mod/Path/PathScripts/PathDressupTagPreferences.py
FreeCAD/Mod/Path/PathScripts/PathDrilling.py
FreeCAD/Mod/Path/PathScripts/PathDrillingGui.py
FreeCAD/Mod/Path/PathScripts/PathEngrave.py
FreeCAD/Mod/Path/PathScripts/PathFacePocket.py
FreeCAD/Mod/Path/PathScripts/PathFaceProfile.py
FreeCAD/Mod/Path/PathScripts/PathEngraveGui.py
FreeCAD/Mod/Path/PathScripts/PathFixture.py
FreeCAD/Mod/Path/PathScripts/PathFromShape.py
FreeCAD/Mod/Path/PathScripts/PathGeom.py
FreeCAD/Mod/Path/PathScripts/PathGetPoint.py
FreeCAD/Mod/Path/PathScripts/PathHelix.py
FreeCAD/Mod/Path/PathScripts/PathHelixGui.py
FreeCAD/Mod/Path/PathScripts/PathHop.py
FreeCAD/Mod/Path/PathScripts/PathIconViewProvider.py
FreeCAD/Mod/Path/PathScripts/PathInspect.py
FreeCAD/Mod/Path/PathScripts/PathJob.py
FreeCAD/Mod/Path/PathScripts/PathKurveUtils.py
FreeCAD/Mod/Path/PathScripts/PathLoadTool.py
FreeCAD/Mod/Path/PathScripts/PathJobCmd.py
FreeCAD/Mod/Path/PathScripts/PathJobGui.py
FreeCAD/Mod/Path/PathScripts/PathLog.py
FreeCAD/Mod/Path/PathScripts/PathMillFace.py
FreeCAD/Mod/Path/PathScripts/PathMillFaceGui.py
FreeCAD/Mod/Path/PathScripts/PathOp.py
FreeCAD/Mod/Path/PathScripts/PathOpGui.py
FreeCAD/Mod/Path/PathScripts/PathPlane.py
FreeCAD/Mod/Path/PathScripts/PathPocket.py
FreeCAD/Mod/Path/PathScripts/PathPocketBase.py
FreeCAD/Mod/Path/PathScripts/PathPocketBaseGui.py
FreeCAD/Mod/Path/PathScripts/PathPocketGui.py
FreeCAD/Mod/Path/PathScripts/PathPost.py
FreeCAD/Mod/Path/PathScripts/PathPostProcessor.py
FreeCAD/Mod/Path/PathScripts/PathPreferences.py
FreeCAD/Mod/Path/PathScripts/PathPreferencesPathDressup.py
FreeCAD/Mod/Path/PathScripts/PathPreferencesPathJob.py
FreeCAD/Mod/Path/PathScripts/PathProfile.py
FreeCAD/Mod/Path/PathScripts/PathProfileBase.py
FreeCAD/Mod/Path/PathScripts/PathProfileBaseGui.py
FreeCAD/Mod/Path/PathScripts/PathProfileContour.py
FreeCAD/Mod/Path/PathScripts/PathProfileContourGui.py
FreeCAD/Mod/Path/PathScripts/PathProfileEdges.py
FreeCAD/Mod/Path/PathScripts/PathProfileEdgesGui.py
FreeCAD/Mod/Path/PathScripts/PathProfileFaces.py
FreeCAD/Mod/Path/PathScripts/PathProfileFacesGui.py
FreeCAD/Mod/Path/PathScripts/PathSanity.py
FreeCAD/Mod/Path/PathScripts/PathSelection.py
FreeCAD/Mod/Path/PathScripts/PathSimpleCopy.py
FreeCAD/Mod/Path/PathScripts/PathStock.py
FreeCAD/Mod/Path/PathScripts/PathStop.py
FreeCAD/Mod/Path/PathScripts/PathSurface.py
FreeCAD/Mod/Path/PathScripts/PathToolController.py
FreeCAD/Mod/Path/PathScripts/PathToolLenOffset.py
FreeCAD/Mod/Path/PathScripts/PathToolLibraryManager.py
FreeCAD/Mod/Path/PathScripts/PathUtil.py
FreeCAD/Mod/Path/PathScripts/PathUtils.py
FreeCAD/Mod/Path/PathScripts/PostUtils.py
FreeCAD/Mod/Path/PathScripts/__init__.py
FreeCAD/Mod/Path/PathScripts/centroid_post.py
FreeCAD/Mod/Path/PathScripts/comparams_post.py
FreeCAD/Mod/Path/PathScripts/dumper_post.py
FreeCAD/Mod/Path/PathScripts/dynapath_post.py
FreeCAD/Mod/Path/PathScripts/example_post.py
FreeCAD/Mod/Path/PathScripts/example_pre.py
FreeCAD/Mod/Path/PathScripts/kdtree.py
FreeCAD/Mod/Path/PathScripts/linuxcnc_post.py
FreeCAD/Mod/Path/PathScripts/opensbp_post.py
FreeCAD/Mod/Path/PathScripts/opensbp_pre.py
FreeCAD/Mod/Path/PathScripts/phillips_post.py
FreeCAD/Mod/Path/PathScripts/PathDressupRampEntry.py
FreeCAD/Mod/Path/PathScripts/rml_post.py
FreeCAD/Mod/Path/PathScripts/slic3r_pre.py
FreeCAD/Mod/Path/PathScripts/smoothie_post.py
FreeCAD/Mod/Path/PathScripts/post/__init__.py
FreeCAD/Mod/Path/PathScripts/post/centroid_post.py
FreeCAD/Mod/Path/PathScripts/post/comparams_post.py
FreeCAD/Mod/Path/PathScripts/post/dumper_post.py
FreeCAD/Mod/Path/PathScripts/post/dynapath_post.py
FreeCAD/Mod/Path/PathScripts/post/example_post.py
FreeCAD/Mod/Path/PathScripts/post/example_pre.py
FreeCAD/Mod/Path/PathScripts/post/grbl_post.py
FreeCAD/Mod/Path/PathScripts/post/linuxcnc_post.py
FreeCAD/Mod/Path/PathScripts/post/opensbp_post.py
FreeCAD/Mod/Path/PathScripts/post/opensbp_pre.py
FreeCAD/Mod/Path/PathScripts/post/phillips_post.py
FreeCAD/Mod/Path/PathScripts/post/rml_post.py
FreeCAD/Mod/Path/PathScripts/post/slic3r_pre.py
FreeCAD/Mod/Path/PathScripts/post/smoothie_post.py
FreeCAD/Mod/Path/PathTests/PathTestUtils.py
FreeCAD/Mod/Path/PathTests/TestPathCore.py
FreeCAD/Mod/Path/PathTests/TestPathDepthParams.py
FreeCAD/Mod/Path/PathTests/TestPathDressupDogbone.py
FreeCAD/Mod/Path/PathTests/TestPathDressupHoldingTags.py
FreeCAD/Mod/Path/PathTests/TestPathGeom.py
FreeCAD/Mod/Path/PathTests/TestPathLog.py
FreeCAD/Mod/Path/PathTests/TestPathPost.py
FreeCAD/Mod/Path/PathTests/TestPathStock.py
FreeCAD/Mod/Path/PathTests/TestPathUtil.py
FreeCAD/Mod/Path/PathTests/__init__.py
FreeCAD/Mod/Path/PathTests/boxtest.fcstd
FreeCAD/Mod/Path/PathTests/test_centroid_00.ngc
FreeCAD/Mod/Path/PathTests/test_linuxcnc_00.ngc
FreeCAD/Mod/Path/TestPathApp.py
FreeCAD/Mod/Plot/InitGui.py
@ -506,10 +569,10 @@ FreeCAD/Mod/Test/__init__.py
FreeCAD/Mod/Test/qtunittest.py
FreeCAD/Mod/Test/testmakeWireString.py
FreeCAD/Mod/Test/unittestgui.py
FreeCAD/Mod/Tux/PersistentToolbars.py
FreeCAD/Mod/Tux/PersistentToolbarsGui.py
FreeCAD/Mod/Tux/InitGui.py
FreeCAD/Mod/Tux/NavigationIndicatorGui.py
FreeCAD/Mod/Tux/PersistentToolbars.py
FreeCAD/Mod/Tux/PersistentToolbarsGui.py
FreeCAD/Mod/Tux/Tux_rc.py
FreeCAD/Mod/Web/Init.py
FreeCAD/Mod/Web/InitGui.py