math/maxima: Update to 5.43.0
PR: 238268 Submitted by: Lorenzo Salvadore <phascolarctos@protonmail.ch> (maintainer)
This commit is contained in:
parent
c2aceaf65b
commit
bbba940adf
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=503694
@ -2,8 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= maxima
|
||||
PORTVERSION= 5.42.2
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 5.43.0
|
||||
CATEGORIES= math lisp tk
|
||||
MASTER_SITES= SF/maxima/Maxima-source/${PORTVERSION}-source
|
||||
|
||||
@ -27,6 +26,11 @@ CONFIGURE_ARGS= PYTHON=dummy
|
||||
INFO= imaxima maxima xmaxima abs_integrate drawutils kovacicODE logic
|
||||
|
||||
PLIST_SUB+= PORTVERSION=${PORTVERSION}
|
||||
PORTDOCS= *
|
||||
PORTDATA= *
|
||||
PORTEXAMPLES= *
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
OPTIONS_DEFINE= EXAMPLES DOCS NOUSERINIT MANPAGES TEST
|
||||
OPTIONS_SINGLE= LISP
|
||||
@ -55,7 +59,6 @@ SBCL_RUN_DEPENDS= sbcl:lang/sbcl
|
||||
SBCL_CONFIGURE_ON= --enable-sbcl
|
||||
SBCL_PLIST_SUB= BINDIR=binary-sbcl BINNAME=maxima_core
|
||||
|
||||
NO_ARCH= yes
|
||||
TEST_TARGET= check
|
||||
TEST_BUILD_DEPENDS= gnuplot:math/gnuplot \
|
||||
rlwrap:devel/rlwrap
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1548327238
|
||||
SHA256 (maxima-5.42.2.tar.gz) = 167e11d6513a65c829a35f24d4ba539bcd0a82fc3dc7a6721e4f9f118c67b64d
|
||||
SIZE (maxima-5.42.2.tar.gz) = 41840181
|
||||
TIMESTAMP = 1559293706
|
||||
SHA256 (maxima-5.43.0.tar.gz) = dcfda54511035276fd074ac736e97d41905171e43a5802bb820914c3c885ca77
|
||||
SIZE (maxima-5.43.0.tar.gz) = 34605709
|
||||
|
@ -1,74 +0,0 @@
|
||||
--- tests/Makefile.am.orig 2018-10-21 19:17:00 UTC
|
||||
+++ tests/Makefile.am
|
||||
@@ -21,7 +21,7 @@ cmucl-test.sh: test.sh.in
|
||||
-e 's#!LOCAL_MAXIMA!#$(MAXIMA)#' \
|
||||
-e 's#!LISPNAME!#cmucl#' \
|
||||
-e 's#!OUTPUT_LOG!#$(top_builddir)/tests/cmucl.log#' \
|
||||
- -e 's#!OUTPUT_LOG!#$(top_builddir)/tests/cmucl_share.log#'
|
||||
+ -e 's#!OUTPUT_SHARE_LOG!#$(top_builddir)/tests/cmucl_share.log#'
|
||||
chmod a+x "$@"
|
||||
endif
|
||||
|
||||
@@ -32,7 +32,7 @@ scl-test.sh: test.sh.in
|
||||
-e 's#!LOCAL_MAXIMA!#$(MAXIMA)#' \
|
||||
-e 's#!LISPNAME!#scl#' \
|
||||
-e 's#!OUTPUT_LOG!#$(top_builddir)/tests/scl.log#' \
|
||||
- -e 's#!OUTPUT_LOG!#$(top_builddir)/tests/scl_share.log#'
|
||||
+ -e 's#!OUTPUT_SHARE_LOG!#$(top_builddir)/tests/scl_share.log#'
|
||||
chmod a+x "$@"
|
||||
endif
|
||||
|
||||
@@ -43,7 +43,7 @@ sbcl-test.sh: test.sh.in
|
||||
-e 's#!LOCAL_MAXIMA!#$(MAXIMA)#' \
|
||||
-e 's#!LISPNAME!#sbcl#' \
|
||||
-e 's#!OUTPUT_LOG!#$(top_builddir)/tests/sbcl.log#' \
|
||||
- -e 's#!OUTPUT_LOG!#$(top_builddir)/tests/sbcl_share.log#'
|
||||
+ -e 's#!OUTPUT_SHARE_LOG!#$(top_builddir)/tests/sbcl_share.log#'
|
||||
chmod a+x "$@"
|
||||
endif
|
||||
|
||||
@@ -54,7 +54,7 @@ gcl-test.sh: test.sh.in
|
||||
-e 's#!LOCAL_MAXIMA!#$(MAXIMA)#' \
|
||||
-e 's#!LISPNAME!#gcl#' \
|
||||
-e 's#!OUTPUT_LOG!#$(top_builddir)/tests/gcl.log#' \
|
||||
- -e 's#!OUTPUT_LOG!#$(top_builddir)/tests/gcl_share.log#'
|
||||
+ -e 's#!OUTPUT_SHARE_LOG!#$(top_builddir)/tests/gcl_share.log#'
|
||||
chmod a+x "$@"
|
||||
endif
|
||||
|
||||
@@ -65,7 +65,7 @@ acl-test.sh: test.sh.in
|
||||
-e 's#!LOCAL_MAXIMA!#$(MAXIMA)#' \
|
||||
-e 's#!LISPNAME!#acl#' \
|
||||
-e 's#!OUTPUT_LOG!#$(top_builddir)/tests/acl.log#' \
|
||||
- -e 's#!OUTPUT_LOG!#$(top_builddir)/tests/acl_share.log#'
|
||||
+ -e 's#!OUTPUT_SHARE_LOG!#$(top_builddir)/tests/acl_share.log#'
|
||||
chmod a+x "$@"
|
||||
endif
|
||||
|
||||
@@ -76,7 +76,7 @@ openmcl-test.sh: test.sh.in
|
||||
-e 's#!LOCAL_MAXIMA!#$(MAXIMA)#' \
|
||||
-e 's#!LISPNAME!#openmcl#' \
|
||||
-e 's#!OUTPUT_LOG!#$(top_builddir)/tests/openmcl.log#' \
|
||||
- -e 's#!OUTPUT_LOG!#$(top_builddir)/tests/openmcl_share.log#'
|
||||
+ -e 's#!OUTPUT_SHARE_LOG!#$(top_builddir)/tests/openmcl_share.log#'
|
||||
chmod a+x "$@"
|
||||
endif
|
||||
|
||||
@@ -87,7 +87,7 @@ ccl64-test.sh: test.sh.in
|
||||
-e 's#!LOCAL_MAXIMA!#$(MAXIMA)#' \
|
||||
-e 's#!LISPNAME!#ccl64#' \
|
||||
-e 's#!OUTPUT_LOG!#$(top_builddir)/tests/ccl64.log#' \
|
||||
- -e 's#!OUTPUT_LOG!#$(top_builddir)/tests/ccl64_share.log#'
|
||||
+ -e 's#!OUTPUT_SHARE_LOG!#$(top_builddir)/tests/ccl64_share.log#'
|
||||
chmod a+x "$@"
|
||||
endif
|
||||
|
||||
@@ -98,7 +98,7 @@ ecl-test.sh: test.sh.in
|
||||
-e 's#!LOCAL_MAXIMA!#$(MAXIMA)#' \
|
||||
-e 's#!LISPNAME!#ecl#' \
|
||||
-e 's#!OUTPUT_LOG!#$(top_builddir)/tests/ecl.log#' \
|
||||
- -e 's#!OUTPUT_LOG!#$(top_builddir)/tests/ecl_share.log#'
|
||||
+ -e 's#!OUTPUT_SHARE_LOG!#$(top_builddir)/tests/ecl_share.log#'
|
||||
chmod a+x "$@"
|
||||
endif
|
||||
|
@ -1,31 +0,0 @@
|
||||
--- tests/test.sh.in.orig 2018-10-24 11:11:22 UTC
|
||||
+++ tests/test.sh.in
|
||||
@@ -11,7 +11,6 @@ OUTPUT_SHARE_LOG="!OUTPUT_SHARE_LOG!"
|
||||
LISP="!LISPNAME!"
|
||||
|
||||
# Die if a command fails
|
||||
-set -e
|
||||
|
||||
# This command doesn't exit with a helpful status if the lisp survives
|
||||
# but the test fails so we must check by hand that nothing untoward
|
||||
@@ -25,19 +24,4 @@ echo "Running the share testsuite..."
|
||||
$LOCAL_MAXIMA --lisp=$LISP --batch-string='build_info();run_testsuite(share_tests=only);' 2>&1 | tee "$OUTPUT_SHARE_LOG"
|
||||
echo "Running the testsuite for the maxima core..."
|
||||
$LOCAL_MAXIMA --lisp=$LISP --batch-string='build_info();load("testsuite.lisp");testsuite_files:cons("rtest_ask.mac",testsuite_files);run_testsuite();' < rtest_ask_input.mac 2>&1 | tee "$OUTPUT_LOG"
|
||||
-
|
||||
-grep -q 'No unexpected errors' <"$OUTPUT_LOG"
|
||||
-if test $? -ne 0 ; then
|
||||
- # We'll have another copy of the log from the output of this script,
|
||||
- # so there's no point in leaving the greppable one lying around.
|
||||
- rm "$OUTPUT_LOG"
|
||||
- rm "$OUTPUT_SHARE_LOG"
|
||||
- exit 1
|
||||
-fi;
|
||||
-
|
||||
-grep -q 'No unexpected errors' <"$OUTPUT_SHARE_LOG"
|
||||
-
|
||||
-# We'll have another copy of the log from the output of this script,
|
||||
-# so there's no point in leaving the greppable one lying around.
|
||||
-rm "$OUTPUT_LOG"
|
||||
-rm "$OUTPUT_SHARE_LOG"
|
||||
+exit 0
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user