- Update to 2.0
- Remove obsoleted patch (included to the upstream) - Honor openssl CFLAGS and LDFLAGS to use the proper version
This commit is contained in:
parent
a8e090d578
commit
bbb87bd1e2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=381935
@ -1,8 +1,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= hpenc
|
||||
PORTVERSION= 1.0
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 2.0
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://highsecure.ru/distfiles/
|
||||
|
||||
@ -17,9 +16,10 @@ PLIST_FILES= bin/hpenc
|
||||
|
||||
MAKE_ARGS+= "ARCH=${ARCH:S/amd64/x86/:S/i386/x86/}"
|
||||
CXXFLAGS+= -std=c++11 \
|
||||
-I${WRKSRC}/chacha-opt/app/include \
|
||||
-I${WRKSRC}/poly1305-opt/app/include
|
||||
LDFLAGS+= -pthread -lcrypto
|
||||
-I${WRKSRC}/chacha-opt/app/include \
|
||||
-I${WRKSRC}/poly1305-opt/app/include \
|
||||
-I${OPENSSLINC}
|
||||
LDFLAGS+= -pthread -lcrypto -L${OPENSSLLIB}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (hpenc-1.0.tar.xz) = 81a87c05b693285c26585053d34c49cda158f2f07f64b71202bf48ef48a5ea4d
|
||||
SIZE (hpenc-1.0.tar.xz) = 612044
|
||||
SHA256 (hpenc-2.0.tar.xz) = 4fa26a5ee88cbc85c4117e13295f3ee9ec4b959bf6077f6f65be3fddc6f30351
|
||||
SIZE (hpenc-2.0.tar.xz) = 612404
|
||||
|
@ -1,33 +0,0 @@
|
||||
--- poly1305-opt/app/extensions/poly1305/poly1305_avx-32.inc
|
||||
+++ poly1305-opt/app/extensions/poly1305/poly1305_avx-32.inc
|
||||
@@ -7,7 +7,7 @@ FN_END poly1305_block_size_avx
|
||||
|
||||
|
||||
GLOBAL_HIDDEN_FN poly1305_auth_avx
|
||||
+cmpl $64, 12(%esp)
|
||||
-cmp $64, 12(%esp)
|
||||
jbe poly1305_auth_x86_local
|
||||
pushl %ebp
|
||||
movl %esp, %ebp
|
||||
--- poly1305-opt/app/extensions/poly1305/poly1305_avx2-32.inc
|
||||
+++ poly1305-opt/app/extensions/poly1305/poly1305_avx2-32.inc
|
||||
@@ -8,7 +8,7 @@ FN_END poly1305_block_size_avx2
|
||||
|
||||
|
||||
GLOBAL_HIDDEN_FN poly1305_auth_avx2
|
||||
+cmpl $64, 12(%esp)
|
||||
-cmp $64, 12(%esp)
|
||||
jbe poly1305_auth_x86_local
|
||||
pushl %ebp
|
||||
movl %esp, %ebp
|
||||
--- poly1305-opt/app/extensions/poly1305/poly1305_sse2-32.inc
|
||||
+++ poly1305-opt/app/extensions/poly1305/poly1305_sse2-32.inc
|
||||
@@ -6,7 +6,7 @@ ret
|
||||
FN_END poly1305_block_size_sse2
|
||||
|
||||
GLOBAL_HIDDEN_FN poly1305_auth_sse2
|
||||
-cmp $64, 12(%esp)
|
||||
+cmpl $64, 12(%esp)
|
||||
jb poly1305_auth_x86_local
|
||||
pushl %ebp
|
||||
movl %esp, %ebp
|
Loading…
Reference in New Issue
Block a user