Initial import of tcl-Mysql version 990813.

A Tcl modules for accessing MySQL databases.

PR:		13361
Submitted by:	Mikhail Teterin <mi@aldan.algebra.com>
This commit is contained in:
Steve Price 1999-11-01 04:15:01 +00:00
parent 8f9522902e
commit bb8bd53d53
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=22829
7 changed files with 79 additions and 0 deletions

View File

@ -0,0 +1,38 @@
# New ports collection makefile for: p5-Mysql-modules
# Version required: 990813
# Date created: 24 August 1999
# Whom: Mikhail Teterin <mi@aldan.algebra.com>
#
# $FreeBSD$
#
DISTNAME= tcl-sql-990813
CATEGORIES= databases tcl80
MASTER_SITES= http://www.binevolve.com/~tdarugar/tcl-sql/download/
EXTRACT_SUFX= .tgz
MAINTAINER= mi@aldan.algebra.com
LIB_DEPENDS= mysqlclient.6:${PORTSDIR}/databases/mysql322-client
RUN_DEPENDS= tclsh8.0:${PORTSDIR}/lang/tcl80
WRKSRC= ${WRKDIR}/tcl-sql/
do-build:
cd ${WRKSRC} && ${MAKE} PREFIX="${PREFIX}" -f ${FILESDIR}/Makefile.bsd
SQL_DIR= ${PREFIX}/lib/tcl8.0/sql1.0
do-install:
${MKDIR} ${SQL_DIR}
${INSTALL_DATA} ${WRKSRC}/obj/libTclMySQL.so.* ${SQL_DIR}
${ECHO} "package ifneeded sql 1.0 \
{load \$$tcl_library/sql1.0/`${MAKE} -f \
${FILESDIR}/Makefile.bsd printname` sql}" \
> ${SQL_DIR}/pkgIndex.tcl
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/tcl-MySQL/
${INSTALL_DATA} ${WRKSRC}/docs/*.* ${PREFIX}/share/doc/tcl-MySQL/
.endif
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (tcl-sql-990813.tgz) = 0307bba44f17b30e8a1204a78ca65181

View File

@ -0,0 +1,16 @@
LIB = TclMySQL
SHLIB_MAJOR= 1
SHLIB_MINOR= 0
SRCS = sql-mysql.cc sql.cc sql-manager.cc
CFLAGS += -I${PREFIX}/include/tcl8.0/ -I${PREFIX}/include/mysql/
LDADD += -L${PREFIX}/lib -ltcl80
LDADD += -L${PREFIX}/lib/mysql -lmysqlclient
LDADD += -lgcc
all: ${SHLIB_NAME}
printname:
@echo ${SHLIB_NAME}
.include <bsd.lib.mk>

View File

@ -0,0 +1,9 @@
--- sql.cc.orig Fri Aug 13 15:28:56 1999
+++ sql.cc Tue Aug 24 21:34:01 1999
@@ -281,4 +281,4 @@
- // Provide a package called Sample
- if (Tcl_PkgProvide(interp, "Sql", "1.0") == TCL_ERROR)
+ // Provide a package called ``sql''
+ if (Tcl_PkgProvide(interp, "sql", "1.0") == TCL_ERROR)
return TCL_ERROR;

View File

@ -0,0 +1 @@
TCL module for accessing MySQL databases

View File

@ -0,0 +1,7 @@
The sql package adds the command sql to tcl. The author's intention is
to build generic database interface for TCL, but currently he only
supports MySQL.
The author's web-site is:
WWW: http://www.binaryevolution.com/~tdarugar/

View File

@ -0,0 +1,7 @@
lib/tcl8.0/sql1.0/libTclMySQL.so.1
lib/tcl8.0/sql1.0/pkgIndex.tcl
@dirrm lib/tcl8.0/sql1.0
share/doc/tcl-MySQL/api.html
share/doc/tcl-MySQL/sample.full.txt
share/doc/tcl-MySQL/sample.simple.txt
@dirrm share/doc/tcl-MySQL