- Security Fix, Update to 0.9.7c

- Fix manpages
This commit is contained in:
Dirk Meyer 2003-09-30 17:48:20 +00:00
parent 1e7c4b7de5
commit baa90b8ff0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=89911
13 changed files with 94 additions and 138 deletions

View File

@ -9,8 +9,7 @@ PORTNAME= openssl
.ifdef OPENSSL_SNAPSHOT
PORTREVISION!= date -v-1d +%Y%m%d
.else
PORTVERSION= 0.9.7b
PORTREVISION= 1
PORTVERSION= 0.9.7c
.endif
CATEGORIES= security devel
.ifdef OPENSSL_SNAPSHOT
@ -828,9 +827,7 @@ MLINKS= dgst.1 md4.1 \
ui_compat.3 des_read_password.3 \
ui_compat.3 des_read_pw.3 \
ui_compat.3 des_read_pw_string.3 \
des_modes.7 DES.7 \
des_modes.7 Modes.7 \
des_modes.7 of.7
des_modes.7 Modes_of_DES.7
.include <bsd.port.pre.mk>

View File

@ -1 +1 @@
MD5 (openssl-0.9.7b.tar.gz) = fae4bec090fa78e20f09d76d55b6ccff
MD5 (openssl-0.9.7c.tar.gz) = c54fb36218adaaaba01ef733cd88c8ec

View File

@ -0,0 +1,11 @@
--- doc/crypto/EVP_BytesToKey.pod.orig Mon Dec 3 04:07:37 2001
+++ doc/crypto/EVP_BytesToKey.pod Tue Sep 30 18:55:24 2003
@@ -2,7 +2,7 @@
=head1 NAME
- EVP_BytesToKey - password based encryption routine
+EVP_BytesToKey - password based encryption routine
=head1 SYNOPSIS

View File

@ -0,0 +1,11 @@
--- doc/crypto/EVP_DigestInit.pod.orig Thu Jul 18 20:55:04 2002
+++ doc/crypto/EVP_DigestInit.pod Tue Sep 30 18:57:18 2003
@@ -4,7 +4,7 @@
EVP_MD_CTX_init, EVP_MD_CTX_create, EVP_DigestInit_ex, EVP_DigestUpdate,
EVP_DigestFinal_ex, EVP_MD_CTX_cleanup, EVP_MD_CTX_destroy, EVP_MAX_MD_SIZE,
-EVP_MD_CTX_copy_ex EVP_MD_CTX_copy, EVP_MD_type, EVP_MD_pkey_type, EVP_MD_size,
+EVP_MD_CTX_copy_ex, EVP_MD_CTX_copy, EVP_MD_type, EVP_MD_pkey_type, EVP_MD_size,
EVP_MD_block_size, EVP_MD_CTX_md, EVP_MD_CTX_size, EVP_MD_CTX_block_size, EVP_MD_CTX_type,
EVP_md_null, EVP_md2, EVP_md5, EVP_sha, EVP_sha1, EVP_dss, EVP_dss1, EVP_mdc2,
EVP_ripemd160, EVP_get_digestbyname, EVP_get_digestbynid, EVP_get_digestbyobj -

View File

@ -0,0 +1,11 @@
--- doc/crypto/des_modes.pod.orig Tue Mar 5 16:30:13 2002
+++ doc/crypto/des_modes.pod Tue Sep 30 18:58:27 2003
@@ -2,7 +2,7 @@
=head1 NAME
-Modes of DES - the variants of DES and other crypto algorithms of OpenSSL
+Modes_of_DES - the variants of DES and other crypto algorithms of OpenSSL
=head1 DESCRIPTION

View File

@ -0,0 +1,11 @@
--- doc/crypto/ui.pod.orig Thu Oct 25 18:55:17 2001
+++ doc/crypto/ui.pod Tue Sep 30 18:59:45 2003
@@ -5,7 +5,7 @@
UI_new, UI_new_method, UI_free, UI_add_input_string, UI_dup_input_string,
UI_add_verify_string, UI_dup_verify_string, UI_add_input_boolean,
UI_dup_input_boolean, UI_add_info_string, UI_dup_info_string,
-UI_add_error_string, UI_dup_error_string, UI_construct_prompt
+UI_add_error_string, UI_dup_error_string, UI_construct_prompt,
UI_add_user_data, UI_get0_user_data, UI_get0_result, UI_process,
UI_ctrl, UI_set_default_method, UI_get_default_method, UI_get_method,
UI_set_method, UI_OpenSSL, ERR_load_UI_strings - New User Interface

View File

@ -6,8 +6,7 @@
#
PORTNAME= openssl
PORTVERSION= 0.9.7b
PORTREVISION= 1
PORTVERSION= 0.9.7c
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/source/ \
ftp://ftp.openssl.org/source/ \
@ -813,9 +812,7 @@ MLINKS= dgst.1 md4.1 \
ui_compat.3 des_read_password.3 \
ui_compat.3 des_read_pw.3 \
ui_compat.3 des_read_pw_string.3 \
des_modes.7 DES.7 \
des_modes.7 Modes.7 \
des_modes.7 of.7
des_modes.7 Modes_of_DES.7
.include <bsd.port.pre.mk>

View File

@ -1,126 +0,0 @@
# makefile for use of: OpenSSH
# Date created: 31 May 2002
# Whom: dinoex
#
# $FreeBSD: /tmp/pcvs/ports/security/openssl/Attic/bsd.openssl.mk,v 1.5 2003-05-07 20:08:00 dinoex Exp $
#
# this substitutes USE_OPENSSL=yes
# just include this makefile after bsd.ports.pre.mk
#
# the user/port can now set this options in the makefiles.
#
# WITH_OPENSSL_BASE=yes - Use the version in the base system.
# WITH_OPENSSL_PORT=yes - Use the port, even if base if up to date
# WITH_OPENSSL_BETA=yes - Use a snapshot of recent openssl
#
# Overrideable defaults:
#
# OPENSSL_SHLIBVER= 3
# OPENSSL_PORT= security/openssl
#
# The makefile sets this variables:
# OPENSSLBASE - "/usr" or ${LOCALBASE}
# OPENSSLDIR - path to openssl
# OPENSSLLIB - path to the libs
# OPENSSLINC - path to the matching includes
#
# MAKE_ENV - extended with the variables above
# LIB_DEPENDS - are added if needed
# honor obsolete options for a bit
.if defined(USE_OPENSSL_BASE) && !defined(WITH_OPENSSL_BASE)
WITH_OPENSSL_BASE=yes
.endif
.if defined(USE_OPENSSL_PORT) && !defined(WITH_OPENSSL_PORT)
WITH_OPENSSL_PORT=yes
.endif
# if no preference was set, check for an up to date base version
# but give an installed port preference over it.
.if !defined(WITH_OPENSSL_BASE) && \
!defined(WITH_OPENSSL_BETA) && \
!defined(WITH_OPENSSL_PORT) && \
!exists(${LOCALBASE}/lib/libcrypto.so) && \
exists(/usr/include/openssl/opensslv.h)
# Security: version in base must be 0.9.7a
OPENSSLVER!= ${AWK} '/OPENSSL_VERSION_NUMBER/ { print $$3 }' \
/usr/include/openssl/opensslv.h
.if ${OPENSSLVER} == 0x0090701fL || ${OPENSSLVER} == 0x0090702fL
WITH_OPENSSL_BASE=yes
.endif
.endif
.if defined(WITH_OPENSSL_BASE)
OPENSSLBASE= /usr
OPENSSLDIR= /etc/ssl
.if !exists(/usr/lib/libcrypto.so)
.BEGIN:
@${ECHO_CMD} "This port requires the OpenSSL library, which is part of"
@${ECHO_CMD} "the FreeBSD crypto distribution but not installed on your"
@${ECHO_CMD} "machine. Please see the \"OpenSSL\" section in the handbook"
@${ECHO_CMD} "(at \"http://www.FreeBSD.org/doc/en_US.ISO8859-1/books/handbook/openssl.html\", for instance)"
@${ECHO_CMD} "for instructions on how to obtain and install the FreeBSD"
@${ECHO_CMD} "OpenSSL distribution."
@${FALSE}
.endif
.if exists(${LOCALBASE}/lib/libcrypto.so)
.BEGIN:
@${ECHO_CMD} "This port wants the OpenSSL library from the FreeBSD"
@${ECHO_CMD} "base system. You can't build against it, while a newer"
@${ECHO_CMD} "Version is installed by a port."
@${ECHO_CMD} "Please deinstall the port or undefine WITH_OPENSSL_BASE."
@${FALSE}
.endif
# OpenSSL in the base system may not include IDEA for patent licensing reasons.
.if defined(MAKE_IDEA) && !defined(OPENSSL_IDEA)
OPENSSL_IDEA= ${MAKE_IDEA}
.else
OPENSSL_IDEA?= NO
.endif
.if ${OPENSSL_IDEA} == "NO"
# XXX This is a hack to work around the fact that /etc/make.conf clobbers
# our CFLAGS. It might not be enough for all future ports.
.if defined(HAS_CONFIGURE)
CFLAGS+= -DNO_IDEA
.else
OPENSSL_CFLAGS+= -DNO_IDEA
.endif
MAKE_ARGS+= OPENSSL_CFLAGS="${OPENSSL_CFLAGS}"
.endif
CFLAGS+= -Wl,-rpath,/usr/lib:${LOCALBASE}/lib
OPENSSL_LDFLAGS+= -rpath=/usr/lib:${LOCALBASE}/lib
.else
OPENSSLBASE= ${LOCALBASE}
.if defined(WITH_OPENSSL_BETA)
OPENSSL_SHLIBVER?= 4
OPENSSL_PORT?= security/openssl-beta
.else
OPENSSL_SHLIBVER?= 3
OPENSSL_PORT?= security/openssl
.endif
OPENSSLDIR= ${OPENSSLBASE}/openssl
LIB_DEPENDS+= crypto.${OPENSSL_SHLIBVER}:${PORTSDIR}/${OPENSSL_PORT}
CFLAGS+= -Wl,-rpath,${LOCALBASE}/lib
OPENSSL_LDFLAGS+= -rpath=${LOCALBASE}/lib
.endif
OPENSSLLIB= ${OPENSSLBASE}/lib
OPENSSLINC= ${OPENSSLBASE}/include
MAKE_ENV+= OPENSSLLIB=${OPENSSLLIB} OPENSSLINC=${OPENSSLINC} \
OPENSSLBASE=${OPENSSLBASE} OPENSSLDIR=${OPENSSLDIR}
.if defined(LDFLAGS) && !empty(LDFLAGS)
LDFLAGS+=${OPENSSL_LDFLAGS}
.else
LDFLAGS=${OPENSSL_LDFLAGS}
.endif
### crypto
#RESTRICTED= "Contains cryptography."

View File

@ -1 +1 @@
MD5 (openssl-0.9.7b.tar.gz) = fae4bec090fa78e20f09d76d55b6ccff
MD5 (openssl-0.9.7c.tar.gz) = c54fb36218adaaaba01ef733cd88c8ec

View File

@ -0,0 +1,11 @@
--- doc/crypto/EVP_BytesToKey.pod.orig Mon Dec 3 04:07:37 2001
+++ doc/crypto/EVP_BytesToKey.pod Tue Sep 30 18:55:24 2003
@@ -2,7 +2,7 @@
=head1 NAME
- EVP_BytesToKey - password based encryption routine
+EVP_BytesToKey - password based encryption routine
=head1 SYNOPSIS

View File

@ -0,0 +1,11 @@
--- doc/crypto/EVP_DigestInit.pod.orig Thu Jul 18 20:55:04 2002
+++ doc/crypto/EVP_DigestInit.pod Tue Sep 30 18:57:18 2003
@@ -4,7 +4,7 @@
EVP_MD_CTX_init, EVP_MD_CTX_create, EVP_DigestInit_ex, EVP_DigestUpdate,
EVP_DigestFinal_ex, EVP_MD_CTX_cleanup, EVP_MD_CTX_destroy, EVP_MAX_MD_SIZE,
-EVP_MD_CTX_copy_ex EVP_MD_CTX_copy, EVP_MD_type, EVP_MD_pkey_type, EVP_MD_size,
+EVP_MD_CTX_copy_ex, EVP_MD_CTX_copy, EVP_MD_type, EVP_MD_pkey_type, EVP_MD_size,
EVP_MD_block_size, EVP_MD_CTX_md, EVP_MD_CTX_size, EVP_MD_CTX_block_size, EVP_MD_CTX_type,
EVP_md_null, EVP_md2, EVP_md5, EVP_sha, EVP_sha1, EVP_dss, EVP_dss1, EVP_mdc2,
EVP_ripemd160, EVP_get_digestbyname, EVP_get_digestbynid, EVP_get_digestbyobj -

View File

@ -0,0 +1,11 @@
--- doc/crypto/des_modes.pod.orig Tue Mar 5 16:30:13 2002
+++ doc/crypto/des_modes.pod Tue Sep 30 18:58:27 2003
@@ -2,7 +2,7 @@
=head1 NAME
-Modes of DES - the variants of DES and other crypto algorithms of OpenSSL
+Modes_of_DES - the variants of DES and other crypto algorithms of OpenSSL
=head1 DESCRIPTION

View File

@ -0,0 +1,11 @@
--- doc/crypto/ui.pod.orig Thu Oct 25 18:55:17 2001
+++ doc/crypto/ui.pod Tue Sep 30 18:59:45 2003
@@ -5,7 +5,7 @@
UI_new, UI_new_method, UI_free, UI_add_input_string, UI_dup_input_string,
UI_add_verify_string, UI_dup_verify_string, UI_add_input_boolean,
UI_dup_input_boolean, UI_add_info_string, UI_dup_info_string,
-UI_add_error_string, UI_dup_error_string, UI_construct_prompt
+UI_add_error_string, UI_dup_error_string, UI_construct_prompt,
UI_add_user_data, UI_get0_user_data, UI_get0_result, UI_process,
UI_ctrl, UI_set_default_method, UI_get_default_method, UI_get_method,
UI_set_method, UI_OpenSSL, ERR_load_UI_strings - New User Interface