net/py-netaddr: Update to 0.7.14

- Update to 0.7.14
- Add NO_ARCH [1]
- Add uniquefiles:dirs [1]
- Remove DOCSDIR override [1]
- Refactor regression-test target
- Patch setup.py and release.py to add proper test command support
- Update pkg-descr according to upstream (setup.py) long_description

Inspired by:	Patch by tkato432 yahoo com [1]
PR:		197447 [1]
This commit is contained in:
Kubilay Kocak 2015-05-27 06:50:22 +00:00
parent 901c00a64e
commit baa1ae204c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=387543
5 changed files with 50 additions and 24 deletions

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= netaddr
PORTVERSION= 0.7.13
PORTVERSION= 0.7.14
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -13,21 +13,18 @@ COMMENT= Manipulation of IPv4, IPv6, CIDR, EUI and MAC network addresses
LICENSE= BSD3CLAUSE MIT
LICENSE_COMB= multi
USES= python
USE_PYTHON= autoplist distutils
NO_ARCH= yes
DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
USES= python
USE_PYTHON= autoplist distutils uniquefiles:dirs
PORTDOCS= AUTHORS CHANGELOG README
TESTFILES= __init__.py
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
regression-test:
.for f in ${TESTFILES}
(cd ${WRKSRC}/netaddr/tests && ${PYTHON_CMD} $f)
.endfor
regression-test: build
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (netaddr-0.7.13.tar.gz) = ca42c260b49e5fd74ba9104efa6a4fca6b55316ca42714d20d2b9b8e751e0412
SIZE (netaddr-0.7.13.tar.gz) = 1548094
SHA256 (netaddr-0.7.14.tar.gz) = 02abbb54c9edd6a3046385d2634f51c1dbddbbc9b5816599ecd052b1d9ff445f
SIZE (netaddr-0.7.14.tar.gz) = 1560641

View File

@ -0,0 +1,11 @@
--- release.py.orig 2015-05-27 06:43:45 UTC
+++ release.py
@@ -161,3 +161,8 @@ install_requires = [
setup_requires = [
]
+
+tests_require = [
+]
+
+test_suite = 'netaddr.tests.test_suite_all'

View File

@ -0,0 +1,11 @@
--- setup.py.orig 2015-05-27 06:43:40 UTC
+++ setup.py
@@ -41,6 +41,8 @@ def main():
version = release.version,
install_requires = release.install_requires,
setup_requires = release.setup_requires,
+ tests_require = release.tests_require,
+ test_suite = release.test_suite,
options = {
'build_scripts': {
'executable': '/usr/bin/env python',

View File

@ -1,17 +1,24 @@
netaddr is a Python library for the manipulation of various common
network address notations and representations.
A pure Python network address representation and manipulation library.
It takes the hassle out of fiddling with innumerable variations of
network addresses, presenting a consistent, extensible, easy-to-use
and (above all) Pythonic API.
netaddr provides a Pythonic way of working with:
With it you can validate, convert, categorise, iterate, generate,
slice (and dice):
- IPv4 and IPv6 addresses and subnets
- MAC addresses, OUI and IAB identifiers, IEEE EUI-64 identifiers
- Arbitrary (non-aligned) IP address ranges and IP address sets
- Various non-CIDR IP range formats such as nmap and glob-style formats
* IP version 4
* IP version 6
* CIDR (Classless Inter-Domain Routing)
* MAC (Media Access Control)
* IEEE EUI-48 and EUI-64
Included are routines for:
WWW: https://github.com/drkjam/netaddr
- Generating, sorting and summarizing IP addresses and networks
- Performing easy conversions between address notations and formats
- Detecting, parsing and formatting network address representations
- Performing set-based operations on groups of IP addresses and subnets
- Working with arbitrary IP address ranges and formats
- Accessing OUI and IAB organisational information published by IEEE
- Accessing IP address and block information published by IANA
API documentation for the latest release is available here:
https://pythonhosted.org/netaddr/
WWW: https://github.com/drkjam/netaddr/