LCLint is a tool for statically checking C programs. With minimal

effort, LCLint can be used as a better lint.  If additional effort is
invested adding annotations to programs, LCLint can perform stronger
checks than can be done by any standard lint.

Check the LCLint home page at
        http://larch-www.lcs.mit.edu:8001/larch/lclint/

Closes-PR:	ports/1646
Submitted by:	Stefan Moeding <moeding@bn.DeTeMobil.de>
This commit is contained in:
David E. O'Brien 1996-12-11 22:51:22 +00:00
parent 159c85cecf
commit ba8ea5d95e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=4937
12 changed files with 258 additions and 0 deletions

26
devel/lclint/Makefile Normal file
View File

@ -0,0 +1,26 @@
# New ports collection makefile for: lclint
# Version required: 2.2a
# Date created: 9 September 1996
# Whom: moeding
#
# $Id: porting.sgml,v 1.2.4.5 1996/06/19 20:28:08 jkh Exp $
#
DISTNAME= lclint-2.2a.src
PKGNAME= lclint-2.2a
CATEGORIES= devel
MASTER_SITES= ftp://larch.lcs.mit.edu/pub/Larch/lclint/
MAINTAINER= moeding@bn.DeTeMobil.de
WRKSRC= ${WRKDIR}/${PKGNAME}
GNU_CONFIGURE= yes
USE_GMAKE= yes
do-build:
@(cd ${WRKSRC}; ${GMAKE})
post-install:
@strip ${PREFIX}/bin/lclint
.include <bsd.port.mk>

1
devel/lclint/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (lclint-2.2a.src.tar.gz) = 5eba0bfd1d4d981a3352fce88e7d6e4f

View File

@ -0,0 +1,47 @@
--- Makefile.in.orig Wed Sep 4 20:18:10 1996
+++ Makefile.in Wed Dec 11 21:57:01 1996
@@ -40,16 +40,16 @@
###
### directory for lclint libraries
-LIBDIR = @installdir@/lib
+LIBDIR = @installdir@/share/lclint-2.2a/lib
### directory for lclint standard imports
-IMPORTSDIR = @installdir@/imports
+IMPORTSDIR = @installdir@/share/lclint-2.2a/imports
### directory for lclint binary
INSTALLDIR = @installdir@/bin
### directory for installing lclint.el[c]
-EMACSLIBDIR = @installdir@/emacs
+EMACSLIBDIR = @installdir@/share/emacs/site-lisp
### this should be the complete path for the directory where this
### Makefile is, with no trailing / or spaces.
@@ -232,6 +232,7 @@
@echo '// Installation complete.'
doemacs:
+ @mkdir -p $(EMACSLIBDIR)
@$(CP) $(LCLINTEMACS) $(EMACSLIBDIR)
@$(CP) $(LCLINTEMACSC) $(EMACSLIBDIR)
@@ -243,14 +244,14 @@
dolibraries:
@echo '// Installing libraries in '$(LIBDIR)
@echo " (This will complain if the directory already exists, don't worry about it.)"
- -mkdir $(LIBDIR)
+ mkdir -p $(LIBDIR)
$(CP) $(LCLINTLIB)/* $(LIBDIR)
@echo '// Installed libraries.'
doimports:
@echo '// Installing imports in '$(IMPORTSDIR)
@echo " (This will complain if the directory already exists, don't worry about it.)"
- -mkdir $(IMPORTSDIR)
+ mkdir -p $(IMPORTSDIR)
$(CP) $(LCLINTIMPORTS)/* $(IMPORTSDIR)
@echo '// Installed imports.'

1
devel/lclint/pkg-comment Normal file
View File

@ -0,0 +1 @@
A tool for statically checking C programs.

8
devel/lclint/pkg-descr Normal file
View File

@ -0,0 +1,8 @@
LCLint is a tool for statically checking C programs. With minimal
effort, LCLint can be used as a better lint. If additional effort is
invested adding annotations to programs, LCLint can perform stronger
checks than can be done by any standard lint.
Check the LCLint home page at
http://larch-www.lcs.mit.edu:8001/larch/lclint/
for more information and complete documentation.

46
devel/lclint/pkg-plist Normal file
View File

@ -0,0 +1,46 @@
bin/lclint
share/emacs/site-lisp/lclint.el
share/emacs/site-lisp/lclint.elc
share/lclint-2.2a/lib/CTrait.syms
share/lclint-2.2a/lib/unix.lcd
share/lclint-2.2a/lib/unix.h
share/lclint-2.2a/lib/posixstrict.lcd
share/lclint-2.2a/lib/posix.lcd
share/lclint-2.2a/lib/posix.h
share/lclint-2.2a/lib/lslinit.lsi
share/lclint-2.2a/lib/lclinit.lci
share/lclint-2.2a/lib/bool.h
share/lclint-2.2a/lib/ansistrict.lcd
share/lclint-2.2a/lib/ansi.lcd
share/lclint-2.2a/lib/ansi.h
share/lclint-2.2a/lib/README
share/lclint-2.2a/lib/CTraitGen.lcl
share/lclint-2.2a/lib/unixstrict.lcd
share/lclint-2.2a/imports/assert.lcl
share/lclint-2.2a/imports/time.lcl
share/lclint-2.2a/imports/strings.lcs
share/lclint-2.2a/imports/strings.lcl
share/lclint-2.2a/imports/string.lcs
share/lclint-2.2a/imports/string.lcl
share/lclint-2.2a/imports/stdlib.lcs
share/lclint-2.2a/imports/stdlib.lcl
share/lclint-2.2a/imports/stdio.lcs
share/lclint-2.2a/imports/stdio.lcl
share/lclint-2.2a/imports/stdarg.lcs
share/lclint-2.2a/imports/stdarg.lcl
share/lclint-2.2a/imports/signal.lcs
share/lclint-2.2a/imports/signal.lcl
share/lclint-2.2a/imports/setjmp.lcs
share/lclint-2.2a/imports/setjmp.lcl
share/lclint-2.2a/imports/math.lcs
share/lclint-2.2a/imports/math.lcl
share/lclint-2.2a/imports/locale.lcs
share/lclint-2.2a/imports/locale.lcl
share/lclint-2.2a/imports/limits.lcs
share/lclint-2.2a/imports/limits.lcl
share/lclint-2.2a/imports/errno.lcs
share/lclint-2.2a/imports/errno.lcl
share/lclint-2.2a/imports/ctype.lcs
share/lclint-2.2a/imports/ctype.lcl
share/lclint-2.2a/imports/assert.lcs
share/lclint-2.2a/imports/time.lcs

26
devel/splint/Makefile Normal file
View File

@ -0,0 +1,26 @@
# New ports collection makefile for: lclint
# Version required: 2.2a
# Date created: 9 September 1996
# Whom: moeding
#
# $Id: porting.sgml,v 1.2.4.5 1996/06/19 20:28:08 jkh Exp $
#
DISTNAME= lclint-2.2a.src
PKGNAME= lclint-2.2a
CATEGORIES= devel
MASTER_SITES= ftp://larch.lcs.mit.edu/pub/Larch/lclint/
MAINTAINER= moeding@bn.DeTeMobil.de
WRKSRC= ${WRKDIR}/${PKGNAME}
GNU_CONFIGURE= yes
USE_GMAKE= yes
do-build:
@(cd ${WRKSRC}; ${GMAKE})
post-install:
@strip ${PREFIX}/bin/lclint
.include <bsd.port.mk>

1
devel/splint/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (lclint-2.2a.src.tar.gz) = 5eba0bfd1d4d981a3352fce88e7d6e4f

View File

@ -0,0 +1,47 @@
--- Makefile.in.orig Wed Sep 4 20:18:10 1996
+++ Makefile.in Wed Dec 11 21:57:01 1996
@@ -40,16 +40,16 @@
###
### directory for lclint libraries
-LIBDIR = @installdir@/lib
+LIBDIR = @installdir@/share/lclint-2.2a/lib
### directory for lclint standard imports
-IMPORTSDIR = @installdir@/imports
+IMPORTSDIR = @installdir@/share/lclint-2.2a/imports
### directory for lclint binary
INSTALLDIR = @installdir@/bin
### directory for installing lclint.el[c]
-EMACSLIBDIR = @installdir@/emacs
+EMACSLIBDIR = @installdir@/share/emacs/site-lisp
### this should be the complete path for the directory where this
### Makefile is, with no trailing / or spaces.
@@ -232,6 +232,7 @@
@echo '// Installation complete.'
doemacs:
+ @mkdir -p $(EMACSLIBDIR)
@$(CP) $(LCLINTEMACS) $(EMACSLIBDIR)
@$(CP) $(LCLINTEMACSC) $(EMACSLIBDIR)
@@ -243,14 +244,14 @@
dolibraries:
@echo '// Installing libraries in '$(LIBDIR)
@echo " (This will complain if the directory already exists, don't worry about it.)"
- -mkdir $(LIBDIR)
+ mkdir -p $(LIBDIR)
$(CP) $(LCLINTLIB)/* $(LIBDIR)
@echo '// Installed libraries.'
doimports:
@echo '// Installing imports in '$(IMPORTSDIR)
@echo " (This will complain if the directory already exists, don't worry about it.)"
- -mkdir $(IMPORTSDIR)
+ mkdir -p $(IMPORTSDIR)
$(CP) $(LCLINTIMPORTS)/* $(IMPORTSDIR)
@echo '// Installed imports.'

1
devel/splint/pkg-comment Normal file
View File

@ -0,0 +1 @@
A tool for statically checking C programs.

8
devel/splint/pkg-descr Normal file
View File

@ -0,0 +1,8 @@
LCLint is a tool for statically checking C programs. With minimal
effort, LCLint can be used as a better lint. If additional effort is
invested adding annotations to programs, LCLint can perform stronger
checks than can be done by any standard lint.
Check the LCLint home page at
http://larch-www.lcs.mit.edu:8001/larch/lclint/
for more information and complete documentation.

46
devel/splint/pkg-plist Normal file
View File

@ -0,0 +1,46 @@
bin/lclint
share/emacs/site-lisp/lclint.el
share/emacs/site-lisp/lclint.elc
share/lclint-2.2a/lib/CTrait.syms
share/lclint-2.2a/lib/unix.lcd
share/lclint-2.2a/lib/unix.h
share/lclint-2.2a/lib/posixstrict.lcd
share/lclint-2.2a/lib/posix.lcd
share/lclint-2.2a/lib/posix.h
share/lclint-2.2a/lib/lslinit.lsi
share/lclint-2.2a/lib/lclinit.lci
share/lclint-2.2a/lib/bool.h
share/lclint-2.2a/lib/ansistrict.lcd
share/lclint-2.2a/lib/ansi.lcd
share/lclint-2.2a/lib/ansi.h
share/lclint-2.2a/lib/README
share/lclint-2.2a/lib/CTraitGen.lcl
share/lclint-2.2a/lib/unixstrict.lcd
share/lclint-2.2a/imports/assert.lcl
share/lclint-2.2a/imports/time.lcl
share/lclint-2.2a/imports/strings.lcs
share/lclint-2.2a/imports/strings.lcl
share/lclint-2.2a/imports/string.lcs
share/lclint-2.2a/imports/string.lcl
share/lclint-2.2a/imports/stdlib.lcs
share/lclint-2.2a/imports/stdlib.lcl
share/lclint-2.2a/imports/stdio.lcs
share/lclint-2.2a/imports/stdio.lcl
share/lclint-2.2a/imports/stdarg.lcs
share/lclint-2.2a/imports/stdarg.lcl
share/lclint-2.2a/imports/signal.lcs
share/lclint-2.2a/imports/signal.lcl
share/lclint-2.2a/imports/setjmp.lcs
share/lclint-2.2a/imports/setjmp.lcl
share/lclint-2.2a/imports/math.lcs
share/lclint-2.2a/imports/math.lcl
share/lclint-2.2a/imports/locale.lcs
share/lclint-2.2a/imports/locale.lcl
share/lclint-2.2a/imports/limits.lcs
share/lclint-2.2a/imports/limits.lcl
share/lclint-2.2a/imports/errno.lcs
share/lclint-2.2a/imports/errno.lcl
share/lclint-2.2a/imports/ctype.lcs
share/lclint-2.2a/imports/ctype.lcl
share/lclint-2.2a/imports/assert.lcs
share/lclint-2.2a/imports/time.lcs