Add pspell, a library to provide a generic interface to

installed spell checker libraries (aspell, ispell, etc..)
This commit is contained in:
Ade Lovett 2000-06-13 23:01:16 +00:00
parent 4e5bcedf20
commit ba74761a29
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=29582
9 changed files with 176 additions and 0 deletions

View File

@ -65,6 +65,7 @@
SUBDIR += p5-XML-Parser
SUBDIR += par
SUBDIR += perl2html
SUBDIR += pspell
SUBDIR += py-mxTextTools
SUBDIR += py-xml
SUBDIR += rand

26
textproc/pspell/Makefile Normal file
View File

@ -0,0 +1,26 @@
# New ports collection makefile for: pspell
# Date created: 13th June 2000
# Whom: Ade Lovett <ade@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= pspell
PORTVERSION= 0.11.0.1
CATEGORIES= textproc
MASTER_SITES= http://download.sourceforge.net/pspell/
DISTNAME= ${PORTNAME}-.11.0.1
MAINTAINER= ade@FreeBSD.org
USE_NEWGCC= yes
USE_LIBTOOL= yes
LIBTOOLFILES= configure modules/configure
CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS} -I${WRKSRC}"
MAKE_ARGS+= NOPORTDOCS=${NOPORTDOCS}
.if !defined(NOPORTDOCS)
CONFIGURE_ARGS= --enable-doc-dir=${PREFIX}/share/doc/pspell
.endif
USE_GMAKE= yes
.include <bsd.port.mk>

1
textproc/pspell/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (pspell-.11.0.1.tar.gz) = 4ec6fe1195b18418569aee16752b2ba1

View File

@ -0,0 +1,26 @@
--- configure.orig Sun Jun 11 02:08:24 2000
+++ configure Tue Jun 13 13:30:58 2000
@@ -2268,7 +2268,7 @@
objext="$OBJEXT" exeext="$EXEEXT" reload_flag="$reload_flag" \
deplibs_check_method="$deplibs_check_method" file_magic_cmd="$file_magic_cmd" \
${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
-$libtool_flags --no-verify --build="$build" $ac_aux_dir/ltmain.sh $lt_target \
+$libtool_flags $ac_aux_dir/ltmain.sh $lt_target \
|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
# Reload cache, that may have been modified by ltconfig
@@ -2676,10 +2676,10 @@
*) # Relative path.
ac_sub_cache_file="$ac_dots$cache_file" ;;
esac
- case "$ac_given_INSTALL" in
- [/$]*) INSTALL="$ac_given_INSTALL" ;;
- *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
- esac
+# case "$ac_given_INSTALL" in
+# [/$]*) INSTALL="$ac_given_INSTALL" ;;
+# *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
+# esac
echo "running ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir"
# The eval makes quoting arguments work.

View File

@ -0,0 +1,11 @@
--- modules/configure.orig Fri Jun 9 20:49:40 2000
+++ modules/configure Tue Jun 13 13:32:00 2000
@@ -2149,7 +2149,7 @@
objext="$OBJEXT" exeext="$EXEEXT" reload_flag="$reload_flag" \
deplibs_check_method="$deplibs_check_method" file_magic_cmd="$file_magic_cmd" \
${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
-$libtool_flags --no-verify --build="$build" $ac_aux_dir/ltmain.sh $lt_target \
+$libtool_flags $ac_aux_dir/ltmain.sh $lt_target \
|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
# Reload cache, that may have been modified by ltconfig

View File

@ -0,0 +1,15 @@
--- Makefile.in.orig Sun Jun 11 02:09:26 2000
+++ Makefile.in Tue Jun 13 13:49:49 2000
@@ -81,7 +81,11 @@
AUTOMAKE_OPTIONS = foreign
-SUBDIRS = modules @libltdl_dir@ interface manual examples scripts data
+ifndef NOPORTDOCS
+MANUALSUBDIR = manual
+endif
+
+SUBDIRS = modules @libltdl_dir@ interface $(MANUALSUBDIR) examples scripts data
EXTRA_DIST = README-CVS autoconf-exeext.patch
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4

View File

@ -0,0 +1 @@
Generic interface to spell checker libraries

View File

@ -0,0 +1,4 @@
The goal of the pspell library is to provide a generic interface
to spell checker libraries installed on the system.
WWW: http://pspell.sourceforge.net/

91
textproc/pspell/pkg-plist Normal file
View File

@ -0,0 +1,91 @@
bin/pspell-config
include/pspell/app_string.hh
include/pspell/config.h
include/pspell/config_impl.hh
include/pspell/convert.hh
include/pspell/error.h
include/pspell/error_impl.hh
include/pspell/error_messages.hh
include/pspell/file_util.hh
include/pspell/getdata.hh
include/pspell/itemize.hh
include/pspell/manager.h
include/pspell/manager_impl.hh
include/pspell/mutable_container.h
include/pspell/pspell.h
include/pspell/string.hh
include/pspell/string_emulation.h
include/pspell/string_list.h
include/pspell/string_list.hh
include/pspell/string_list_impl.hh
include/pspell/string_map.h
include/pspell/string_map_impl.hh
include/pspell/string_pair.h
include/pspell/string_pair_emulation.h
include/pspell/wordlist.h
lib/libpspell-impl.a
lib/libpspell-impl.so
lib/libpspell-impl.so.2
lib/libpspell-modules.a
lib/libpspell-modules.so
lib/libpspell-modules.so.1
lib/libpspell.a
lib/libpspell.so
lib/libpspell.so.2
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
share/doc/pspell/man-html/1_Introduction.html
share/doc/pspell/man-html/2_Getting.html
share/doc/pspell/man-html/3_Library.html
share/doc/pspell/man-html/4_Status.html
share/doc/pspell/man-html/5_Feedback.html
share/doc/pspell/man-html/6_Changelog.html
share/doc/pspell/man-html/6_Copyright.html
share/doc/pspell/man-html/7_Copyright.html
share/doc/pspell/man-html/About_this.html
share/doc/pspell/man-html/Contents.html
share/doc/pspell/man-html/contents.png
share/doc/pspell/man-html/index.html
share/doc/pspell/man-html/manual.css
share/doc/pspell/man-html/manual.html
share/doc/pspell/man-html/next.png
share/doc/pspell/man-html/next_g.png
share/doc/pspell/man-html/prev.png
share/doc/pspell/man-html/prev_g.png
share/doc/pspell/man-html/up.png
share/doc/pspell/man-html/up_g.png
share/doc/pspell/man-text/1_Introduction.txt
share/doc/pspell/man-text/2_Getting.txt
share/doc/pspell/man-text/3_Library.txt
share/doc/pspell/man-text/4_Status.txt
share/doc/pspell/man-text/5_Feedback.txt
share/doc/pspell/man-text/6_Changelog.txt
share/doc/pspell/man-text/6_Copyright.txt
share/doc/pspell/man-text/7_Copyright.txt
share/doc/pspell/man-text/About_this.txt
share/doc/pspell/man-text/Contents.txt
share/doc/pspell/man-text/index.txt
share/doc/pspell/man-text/manual.txt
share/doc/pspell/manual.aux
share/doc/pspell/manual.dvi
share/doc/pspell/manual.lyx
share/doc/pspell/manual.tex
share/pspell/cp1252.map
share/pspell/iso8859-1.map
share/pspell/iso8859-10.map
share/pspell/iso8859-15.map
share/pspell/iso8859-2.map
share/pspell/iso8859-3.map
share/pspell/iso8859-4.map
share/pspell/iso8859-5.map
share/pspell/iso8859-6.map
share/pspell/iso8859-7.map
share/pspell/iso8859-8.map
share/pspell/iso8859-9.map
share/pspell/koi8-r.map
share/pspell/viscii.map
@dirrm share/pspell
@dirrm share/doc/pspell/man-text
@dirrm share/doc/pspell/man-html
@dirrm share/doc/pspell
@dirrm include/pspell