DeaDBeeF (as in 0xDEADBEEF) is an audio player for GNU/Linux systems with
X11 (though now it also runs in plain console without X, in FreeBSD, and in OpenSolaris). Main features: - mp3, ogg vorbis, flac, ape, wv, wav, m4a, mpc, cd audio (and many more) - sid, nsf and lots of other popular chiptune formats - ID3v1, ID3v2.2, ID3v2.3, ID3v2.4, APEv2, xing/info tags support - character set detection for non-unicode id3 tags - supports cp1251 and iso8859-1 - unicode tags are fully supported as well (both utf8 and ucs2) - cuesheet (.cue files) support, with charset detection (utf8/cp1251/iso8859-1) - tracker modules like mod, s3m, it, xm, etc - HVSC song length database support for sid - minimize to tray, with scrollwheel volume control - drag and drop, both inside of playlist, and from filemanagers and such - control playback from command line - plugin support; bundled with lots of plugins, such as global hotkeys and last.fm scrobbler; sdk is included - duration calculation is as precise as possible for vbr mp3 files (with and without xing/info tags) WWW: http://deadbeef.sourceforge.net/ PR: 143670 Submitted by: zloidemon <g.veniamin@googlemail.com>
This commit is contained in:
parent
75cc4a36b8
commit
b9f0cc060a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=249492
@ -120,6 +120,7 @@
|
||||
SUBDIR += dap
|
||||
SUBDIR += darkice
|
||||
SUBDIR += dcd
|
||||
SUBDIR += deadbeef
|
||||
SUBDIR += dekagen
|
||||
SUBDIR += denemo
|
||||
SUBDIR += dir2ogg
|
||||
|
35
audio/deadbeef/Makefile
Normal file
35
audio/deadbeef/Makefile
Normal file
@ -0,0 +1,35 @@
|
||||
# New ports collection makefile for: deadbeef
|
||||
# Date created: 2010-01-17
|
||||
# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= deadbeef
|
||||
PORTVERSION= 0.3.3
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= SF/${PORTNAME}/
|
||||
|
||||
MAINTAINER= g.veniamin@googlemail.com
|
||||
COMMENT= DeaDBeeF is an audio player for GNU/Linux systems with X11
|
||||
|
||||
LIB_DEPENDS= samplerate.1:${PORTSDIR}/audio/libsamplerate \
|
||||
curl.5:${PORTSDIR}/ftp/curl \
|
||||
vorbis.4:${PORTSDIR}/audio/libvorbis \
|
||||
mad.2:${PORTSDIR}/audio/libmad \
|
||||
FLAC.10:${PORTSDIR}/audio/flac \
|
||||
wavpack.1:${PORTSDIR}/audio/wavpack \
|
||||
sndfile.1:${PORTSDIR}/audio/libsndfile \
|
||||
cdio.12:${PORTSDIR}/sysutils/libcdio \
|
||||
avcodec.1:${PORTSDIR}/multimedia/ffmpeg \
|
||||
avformat:${PORTSDIR}/multimedia/ffmpeg \
|
||||
avutil.1:${PORTSDIR}/multimedia/ffmpeg
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I../dumb/dumb-kode54/include -I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
USE_GNOME= gtk20 glib20
|
||||
INSTALLS_ICONS= yes
|
||||
MAKE_JOBS_SAFE= yes
|
||||
|
||||
.include <bsd.port.mk>
|
3
audio/deadbeef/distinfo
Normal file
3
audio/deadbeef/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
MD5 (deadbeef-0.3.3.tar.gz) = 5f6a00dd18cd27f488f0660ce675182a
|
||||
SHA256 (deadbeef-0.3.3.tar.gz) = b86517e22e834a9af5403f61b180572e55f379b547d64f41181bc78705b0f455
|
||||
SIZE (deadbeef-0.3.3.tar.gz) = 1420029
|
13
audio/deadbeef/files/patch-Makefile.am
Normal file
13
audio/deadbeef/files/patch-Makefile.am
Normal file
@ -0,0 +1,13 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- Makefile.am.orig
|
||||
+++ Makefile.am
|
||||
@@ -10,7 +10,6 @@
|
||||
plugins/adplug\
|
||||
${HOTKEYS_DIR}\
|
||||
${ALSA_DIR}\
|
||||
- ${LFM_DIR}\
|
||||
${MPGMAD_DIR}\
|
||||
${VORBIS_DIR}\
|
||||
${FLAC_DIR}\
|
21
audio/deadbeef/files/patch-Makefile.in
Normal file
21
audio/deadbeef/files/patch-Makefile.in
Normal file
@ -0,0 +1,21 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- Makefile.in.orig
|
||||
+++ Makefile.in
|
||||
@@ -219,7 +219,6 @@
|
||||
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
|
||||
LD = @LD@
|
||||
LDFLAGS = @LDFLAGS@
|
||||
-LFM_DIR = @LFM_DIR@
|
||||
LIBOBJS = @LIBOBJS@
|
||||
LIBS = @LIBS@
|
||||
LIBTOOL = @LIBTOOL@
|
||||
@@ -327,7 +326,6 @@
|
||||
plugins/adplug\
|
||||
${HOTKEYS_DIR}\
|
||||
${ALSA_DIR}\
|
||||
- ${LFM_DIR}\
|
||||
${MPGMAD_DIR}\
|
||||
${VORBIS_DIR}\
|
||||
${FLAC_DIR}\
|
57
audio/deadbeef/files/patch-configure
Normal file
57
audio/deadbeef/files/patch-configure
Normal file
@ -0,0 +1,57 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- configure.orig
|
||||
+++ configure
|
||||
@@ -786,7 +786,6 @@
|
||||
MAD_LIBS
|
||||
HAVE_LIBMAD_FALSE
|
||||
HAVE_LIBMAD_TRUE
|
||||
-LFM_DIR
|
||||
CURL_LIBS
|
||||
HAVE_CURL_FALSE
|
||||
HAVE_CURL_TRUE
|
||||
@@ -15315,11 +15314,6 @@
|
||||
|
||||
fi
|
||||
|
||||
-if test ${HAVE_CURL}; then
|
||||
- LFM_DIR="plugins/lastfm"
|
||||
-
|
||||
-fi
|
||||
-
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for main in -lmad" >&5
|
||||
$as_echo_n "checking for main in -lmad... " >&6; }
|
||||
if test "${ac_cv_lib_mad_main+set}" = set; then :
|
||||
@@ -15901,14 +15895,6 @@
|
||||
|
||||
|
||||
|
||||
- if test $HAVE_CURL ; then
|
||||
- echo " lastfm: yes - last.fm scrobbler"
|
||||
- else
|
||||
- echo " lastfm: no - last.fm scrobbler"
|
||||
- fi
|
||||
-
|
||||
-
|
||||
-
|
||||
if test $HAVE_LIBMAD ; then
|
||||
echo " mpgmad: yes - mpeg player based on libmad"
|
||||
else
|
||||
@@ -16022,7 +16008,7 @@
|
||||
|
||||
echo
|
||||
|
||||
-ac_config_files="$ac_config_files Makefile pixmaps/Makefile icons/Makefile gme/Game_Music_Emu-0.5.2/Makefile gme/Game_Music_Emu-0.5.2/gme/Makefile sid/sidplay-libs-2.1.0/Makefile dumb/Makefile plugins/alsa/Makefile plugins/hotkeys/Makefile plugins/lastfm/Makefile plugins/ffap/Makefile plugins/mpgmad/Makefile plugins/vorbis/Makefile plugins/flac/Makefile plugins/wavpack/Makefile plugins/sndfile/Makefile plugins/vfs_curl/Makefile plugins/cdda/Makefile plugins/gtkui/Makefile plugins/nullout/Makefile plugins/vtx/Makefile plugins/adplug/Makefile plugins/ffmpeg/Makefile plugins/oss/Makefile deadbeef.desktop"
|
||||
+ac_config_files="$ac_config_files Makefile pixmaps/Makefile icons/Makefile gme/Game_Music_Emu-0.5.2/Makefile gme/Game_Music_Emu-0.5.2/gme/Makefile sid/sidplay-libs-2.1.0/Makefile dumb/Makefile plugins/alsa/Makefile plugins/hotkeys/Makefile plugins/ffap/Makefile plugins/mpgmad/Makefile plugins/vorbis/Makefile plugins/flac/Makefile plugins/wavpack/Makefile plugins/sndfile/Makefile plugins/vfs_curl/Makefile plugins/cdda/Makefile plugins/gtkui/Makefile plugins/nullout/Makefile plugins/vtx/Makefile plugins/adplug/Makefile plugins/ffmpeg/Makefile plugins/oss/Makefile deadbeef.desktop"
|
||||
|
||||
cat >confcache <<\_ACEOF
|
||||
# This file is a shell script that caches the results of configure
|
||||
@@ -17158,7 +17144,6 @@
|
||||
"dumb/Makefile") CONFIG_FILES="$CONFIG_FILES dumb/Makefile" ;;
|
||||
"plugins/alsa/Makefile") CONFIG_FILES="$CONFIG_FILES plugins/alsa/Makefile" ;;
|
||||
"plugins/hotkeys/Makefile") CONFIG_FILES="$CONFIG_FILES plugins/hotkeys/Makefile" ;;
|
||||
- "plugins/lastfm/Makefile") CONFIG_FILES="$CONFIG_FILES plugins/lastfm/Makefile" ;;
|
||||
"plugins/ffap/Makefile") CONFIG_FILES="$CONFIG_FILES plugins/ffap/Makefile" ;;
|
||||
"plugins/mpgmad/Makefile") CONFIG_FILES="$CONFIG_FILES plugins/mpgmad/Makefile" ;;
|
||||
"plugins/vorbis/Makefile") CONFIG_FILES="$CONFIG_FILES plugins/vorbis/Makefile" ;;
|
34
audio/deadbeef/files/patch-configure.ac
Normal file
34
audio/deadbeef/files/patch-configure.ac
Normal file
@ -0,0 +1,34 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- configure.ac.orig
|
||||
+++ configure.ac
|
||||
@@ -77,12 +77,6 @@
|
||||
AC_SUBST(CURL_LIBS)
|
||||
fi
|
||||
|
||||
-dnl lastfm plugin
|
||||
-if test ${HAVE_CURL}; then
|
||||
- LFM_DIR="plugins/lastfm"
|
||||
- AC_SUBST(LFM_DIR)
|
||||
-fi
|
||||
-
|
||||
dnl mpgmad plugin
|
||||
AC_CHECK_LIB([mad], [main], [HAVE_LIBMAD=1])
|
||||
AM_CONDITIONAL(HAVE_LIBMAD, test $HAVE_LIBMAD)
|
||||
@@ -273,7 +267,6 @@
|
||||
PRINT_PLUGIN_INFO([gme],[chiptune music player based on GME],[true])
|
||||
PRINT_PLUGIN_INFO([dumb],[module player based on DUMB library],[true])
|
||||
PRINT_PLUGIN_INFO([ffap],[Monkey's audio (APE) decoder],[true])
|
||||
-PRINT_PLUGIN_INFO([lastfm],[last.fm scrobbler],[test $HAVE_CURL])
|
||||
PRINT_PLUGIN_INFO([mpgmad],[mpeg player based on libmad],[test $HAVE_LIBMAD])
|
||||
PRINT_PLUGIN_INFO([vorbis],[ogg vorbis player],[test $HAVE_VORBISFILE && test $HAVE_VORBIS])
|
||||
PRINT_PLUGIN_INFO([flac],[flac player],[test $HAVE_FLAC])
|
||||
@@ -301,7 +294,6 @@
|
||||
dumb/Makefile
|
||||
plugins/alsa/Makefile
|
||||
plugins/hotkeys/Makefile
|
||||
-plugins/lastfm/Makefile
|
||||
plugins/ffap/Makefile
|
||||
plugins/mpgmad/Makefile
|
||||
plugins/vorbis/Makefile
|
23
audio/deadbeef/pkg-descr
Normal file
23
audio/deadbeef/pkg-descr
Normal file
@ -0,0 +1,23 @@
|
||||
DeaDBeeF (as in 0xDEADBEEF) is an audio player for GNU/Linux systems with
|
||||
X11 (though now it also runs in plain console without X, in FreeBSD,
|
||||
and in OpenSolaris).
|
||||
|
||||
Main features:
|
||||
- mp3, ogg vorbis, flac, ape, wv, wav, m4a, mpc, cd audio (and many more)
|
||||
- sid, nsf and lots of other popular chiptune formats
|
||||
- ID3v1, ID3v2.2, ID3v2.3, ID3v2.4, APEv2, xing/info tags support
|
||||
- character set detection for non-unicode id3 tags - supports cp1251 and
|
||||
iso8859-1
|
||||
- unicode tags are fully supported as well (both utf8 and ucs2)
|
||||
- cuesheet (.cue files) support, with charset detection (utf8/cp1251/iso8859-1)
|
||||
- tracker modules like mod, s3m, it, xm, etc
|
||||
- HVSC song length database support for sid
|
||||
- minimize to tray, with scrollwheel volume control
|
||||
- drag and drop, both inside of playlist, and from filemanagers and such
|
||||
- control playback from command line
|
||||
- plugin support; bundled with lots of plugins, such as global hotkeys and
|
||||
last.fm scrobbler; sdk is included
|
||||
- duration calculation is as precise as possible for vbr mp3 files (with and
|
||||
without xing/info tags)
|
||||
|
||||
WWW: http://deadbeef.sourceforge.net/
|
87
audio/deadbeef/pkg-plist
Normal file
87
audio/deadbeef/pkg-plist
Normal file
@ -0,0 +1,87 @@
|
||||
bin/deadbeef
|
||||
include/deadbeef/deadbeef.h
|
||||
lib/deadbeef/adplug.a
|
||||
lib/deadbeef/adplug.la
|
||||
lib/deadbeef/adplug.so
|
||||
lib/deadbeef/adplug.so.0
|
||||
lib/deadbeef/cdda.a
|
||||
lib/deadbeef/cdda.la
|
||||
lib/deadbeef/cdda.so
|
||||
lib/deadbeef/cdda.so.0
|
||||
lib/deadbeef/ffap.a
|
||||
lib/deadbeef/ffap.la
|
||||
lib/deadbeef/ffap.so
|
||||
lib/deadbeef/ffap.so.0
|
||||
lib/deadbeef/ffmpeg.a
|
||||
lib/deadbeef/ffmpeg.la
|
||||
lib/deadbeef/ffmpeg.so
|
||||
lib/deadbeef/ffmpeg.so.0
|
||||
lib/deadbeef/flac.a
|
||||
lib/deadbeef/flac.la
|
||||
lib/deadbeef/flac.so
|
||||
lib/deadbeef/flac.so.0
|
||||
lib/deadbeef/gtkui.a
|
||||
lib/deadbeef/gtkui.la
|
||||
lib/deadbeef/gtkui.so
|
||||
lib/deadbeef/gtkui.so.0
|
||||
lib/deadbeef/hotkeys.a
|
||||
lib/deadbeef/hotkeys.la
|
||||
lib/deadbeef/hotkeys.so
|
||||
lib/deadbeef/hotkeys.so.0
|
||||
lib/deadbeef/mpgmad.a
|
||||
lib/deadbeef/mpgmad.la
|
||||
lib/deadbeef/mpgmad.so
|
||||
lib/deadbeef/mpgmad.so.0
|
||||
lib/deadbeef/nullout.a
|
||||
lib/deadbeef/nullout.la
|
||||
lib/deadbeef/nullout.so
|
||||
lib/deadbeef/nullout.so.0
|
||||
lib/deadbeef/oss.a
|
||||
lib/deadbeef/oss.la
|
||||
lib/deadbeef/oss.so
|
||||
lib/deadbeef/oss.so.0
|
||||
lib/deadbeef/sndfile.a
|
||||
lib/deadbeef/sndfile.la
|
||||
lib/deadbeef/sndfile.so
|
||||
lib/deadbeef/sndfile.so.0
|
||||
lib/deadbeef/vfs_curl.a
|
||||
lib/deadbeef/vfs_curl.la
|
||||
lib/deadbeef/vfs_curl.so
|
||||
lib/deadbeef/vfs_curl.so.0
|
||||
lib/deadbeef/vorbis.a
|
||||
lib/deadbeef/vorbis.la
|
||||
lib/deadbeef/vorbis.so
|
||||
lib/deadbeef/vorbis.so.0
|
||||
lib/deadbeef/vtx.a
|
||||
lib/deadbeef/vtx.la
|
||||
lib/deadbeef/vtx.so
|
||||
lib/deadbeef/vtx.so.0
|
||||
lib/deadbeef/wavpack.a
|
||||
lib/deadbeef/wavpack.la
|
||||
lib/deadbeef/wavpack.so
|
||||
lib/deadbeef/wavpack.so.0
|
||||
share/applications/deadbeef.desktop
|
||||
%%DATADIR%%/pixmaps/buffering_16.png
|
||||
%%DATADIR%%/pixmaps/next_24.png
|
||||
%%DATADIR%%/pixmaps/pause_16.png
|
||||
%%DATADIR%%/pixmaps/pause_24.png
|
||||
%%DATADIR%%/pixmaps/play_16.png
|
||||
%%DATADIR%%/pixmaps/play_24.png
|
||||
%%DATADIR%%/pixmaps/prev_24.png
|
||||
%%DATADIR%%/pixmaps/random_24.png
|
||||
%%DATADIR%%/pixmaps/stop_24.png
|
||||
%%DOCSDIR%%/COPYING.GPLv2
|
||||
%%DOCSDIR%%/COPYING.LGPLv2.1
|
||||
%%DOCSDIR%%/ChangeLog
|
||||
%%DOCSDIR%%/README
|
||||
%%DOCSDIR%%/about.txt
|
||||
%%DOCSDIR%%/help.txt
|
||||
share/icons/hicolor/16x16/apps/deadbeef.png
|
||||
share/icons/hicolor/32x32/apps/deadbeef.png
|
||||
share/icons/hicolor/48x48/apps/deadbeef.png
|
||||
@dirrm %%DOCSDIR%%
|
||||
@dirrm %%DATADIR%%/pixmaps
|
||||
@dirrm %%DATADIR%%
|
||||
@dirrm lib/deadbeef
|
||||
@dirrm include/deadbeef
|
||||
@dirrmtry share/applications
|
Loading…
Reference in New Issue
Block a user