There were a few others _FreeBSD_9 things around.

Sponsored by:	Absolight
This commit is contained in:
Mathieu Arnold 2017-02-17 16:54:34 +00:00
parent 121dfb0a23
commit b9ee513e08
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=434304
9 changed files with 0 additions and 89 deletions

View File

@ -134,7 +134,6 @@ PERFSCHM_SUB_LIST_OFF+= PERFSCHEMRC="--skip-performance-schema"
.include <bsd.port.pre.mk>
.if ${SSL_DEFAULT} == base
BROKEN_FreeBSD_9= FreeBSD 9.x requires SSL from ports
CMAKE_ARGS+= -DWITH_SSL=system
.else
CMAKE_ARGS+= -DWITH_SSL=${OPENSSLBASE}

View File

@ -21,8 +21,6 @@ BUILD_DEPENDS= bash:shells/bash \
# candidates.
FINALRC= 1
BROKEN_FreeBSD_9= fails with static_assert expression error in src/main/cpp/util/numbers.cc
NO_WRKSUBDIR= YES
USES= shebangfix zip
SHEBANG_FILES= ${WRKSRC}/tools/cpp/link_dynamic_library.sh

View File

@ -55,7 +55,6 @@ OPTIONS_EXCLUDE_DragonFly= HIPE NATIVE SCTP
OPTIONS_EXCLUDE+= DTRACE
.endif
OPTIONS_EXCLUDE_FreeBSD_9= DTRACE
OPTIONS_EXCLUDE_FreeBSD_10= DTRACE
OPTIONS_EXCLUDE_i386= DTRACE
# ld(1) fails to link probes: missing __dtrace_erlang___* symbols

View File

@ -60,7 +60,6 @@ OPTIONS_EXCLUDE_DragonFly= HIPE NATIVE SCTP
OPTIONS_EXCLUDE+= DTRACE
.endif
OPTIONS_EXCLUDE_FreeBSD_9= DTRACE
OPTIONS_EXCLUDE_FreeBSD_10= DTRACE
OPTIONS_EXCLUDE_i386= DTRACE
# ld(1) fails to link probes: missing __dtrace_erlang___* symbols

View File

@ -457,7 +457,6 @@ CONFIGURE_ARGS+=--prefix="${PREFIX}" \
CONFIGURE_ENV_armv6_clang= ASFLAGS=-no-integrated-as
CONFIGURE_ARGS_armv6= --disable-fast-unaligned
CONFIGURE_ARGS_FreeBSD_9= --enable-memalign-hack
DOC_FILES= Changelog CREDITS INSTALL.md LICENSE.md MAINTAINERS \
README.md RELEASE_NOTES

View File

@ -23,7 +23,4 @@ TEST_TARGET= check
PLIST_SUB+= LIBVER=0.10400.2
EXTRA_PATCHES+= ${EXTRA_PATCHES_${OPSYS}_${OSREL:R}}
EXTRA_PATCHES_FreeBSD_9= ${PATCHDIR}/extra-src_hb-open-type-private.hh
.include <bsd.port.mk>

View File

@ -1,25 +0,0 @@
$NetBSD: patch-src_hb-open-type-private.hh,v 1.1 2013/02/03 05:13:26 ryoon Exp $
--- src/hb-open-type-private.hh.orig 2013-01-08 22:13:42.000000000 +0000
+++ src/hb-open-type-private.hh
@@ -941,6 +941,11 @@ struct HeadlessArrayOf
DEFINE_SIZE_ARRAY (sizeof (USHORT), array);
};
+#if __GNUC__ && (__GNUC__ < 4 || (__GNUC__ == 4 && __GNUC_MINOR__ < 4))
+// work around GCC 4.3 bug where the search() function gets improperly
+// optimized away from some instantiations of this template
+#pragma GCC visibility push(default)
+#endif
/* An array with sorted elements. Supports binary searching. */
template <typename Type>
@@ -968,5 +973,8 @@ struct SortedArrayOf : ArrayOf<Type> {
} /* namespace OT */
+#if __GNUC__ && (__GNUC__ < 4 || (__GNUC__ == 4 && __GNUC_MINOR__ < 4))
+#pragma GCC visibility pop
+#endif
#endif /* HB_OPEN_TYPE_PRIVATE_HH */

View File

@ -24,9 +24,6 @@ GH_ACCOUNT= rhinstaller
USES= gmake localbase pkgconfig
USE_LDCONFIG= yes
EXTRA_PATCHES= ${EXTRA_PATCHES_${OPSYS}_${OSREL:R}}
EXTRA_PATCHES_FreeBSD_9= ${FILESDIR}/extra-patch-src_client.c
ONLY_FOR_ARCHS= aarch64 armv6 amd64 i386
ONLY_FOR_ARCHS_REASON= UEFI specification only supports little-endian processors
BROKEN_armv6= fails to compile: error: EFI_VARIABLE_NON_VOLATILE redefined

View File

@ -1,52 +0,0 @@
--- src/client.c.orig 2014-10-24 19:51:06 UTC
+++ src/client.c
@@ -47,6 +47,49 @@ static struct {
{FLAG_LIST_END, NULL},
};
+#if defined(__FreeBSD__) && __FreeBSD__ < 10
+/*-
+ * Copyright (c) 2013 Niclas Zeising
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
+ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
+ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ * SUCH DAMAGE.
+ *
+ * $FreeBSD: head/lib/libc/string/strchrnul.c 288004 2015-09-20 03:51:15Z rodrigc
+ */
+
+static char *
+strchrnul(const char *p, int ch)
+{
+ char c;
+
+ c = ch;
+ for (;; ++p) {
+ if (*p == c || *p == '\0')
+ return ((char *)p);
+ }
+ /* NOTREACHED */
+}
+#endif
+
static void
print_flag_name(FILE *f, int flag)
{