New port: kaffe-devel, development release of kaffe Java VM

Multi-platform Java virtual machine with JIT compiler and AWT package

PR:		ports/55270
Submitted by:	Mark Huizer <xaa+ports@timewasters.nl>
This commit is contained in:
Edwin Groothuis 2003-09-07 12:06:27 +00:00
parent d056c2d956
commit b9976edf43
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=88678
6 changed files with 159 additions and 0 deletions

View File

@ -67,6 +67,7 @@
SUBDIR += jump
SUBDIR += junit
SUBDIR += kaffe
SUBDIR += kaffe-devel
SUBDIR += linux-blackdown-jdk12
SUBDIR += linux-blackdown-jdk13
SUBDIR += linux-blackdown-jdk14

60
java/kaffe-devel/Makefile Normal file
View File

@ -0,0 +1,60 @@
# New ports collection makefile for: kaffe
# Date created: 4 August 2003
# Whom: Mark Huizer <xaa+ports@timewasters.nl>
#
# $FreeBSD$
#
# Configure AWT implementation used (this can be put in make.conf)
#
# KAFFE_AWT = no No AWT classes
# KAFFE_AWT = X X AWT classes
# KAFFE_AWT = QT Qt AWT classes
PORTNAME= kaffe
PORTVERSION= 1.1.0
CATEGORIES= java
MASTER_SITES= ftp://ftp.kaffe.org/pub/kaffe/v1.1.x-development/
PKGNAMESUFFIX= -devel
MAINTAINER= xaa+ports@timewasters.nl
COMMENT= Multi-platform Java virtual machine with JIT compiler and AWT package
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
ungif.5:${PORTSDIR}/graphics/libungif \
png.5:${PORTSDIR}/graphics/png \
iconv.3:${PORTSDIR}/converters/libiconv
WRKSRC= ${WRKDIR}/kaffe-${PORTVERSION}
USE_LIBTOOL= yes
USE_GMAKE= yes
LIBTOOLFLAGS=
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-iconv-prefix=${LOCALBASE}
.if defined(KAFFE_AWT)
.if ${KAFFE_AWT} == "X"
CONFIGURE_ARGS+= --with-awt=X
USE_XLIB= yes
.endif
.if ${KAFFE_AWT} == "QT"
CONFIGURE_ARGS+= --with-awt=qt --with-qtdir=${X11BASE}
USE_QT_VER= 3
.endif
.if ${KAFFE_AWT} == "no"
CONFIGURE_ARGS+= --with-awt=no
.endif
.endif
PLIST_SUB+= PORTVER=${PORTVERSION} ARCH=${ARCH}
MAN1= kaffe.1
post-install:
@${MKDIR} ${DATADIR}
${INSTALL_SCRIPT} ${WRKSRC}/BUILD_ENVIRONMENT ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/license.terms ${DATADIR}
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (kaffe-1.1.0.tar.gz) = b761b506bfb1d0995f4dd20abba9e24f

View File

@ -0,0 +1,12 @@
--- config/i386/freebsd2/md.h.orig Sat Sep 6 01:38:48 2003
+++ config/i386/freebsd2/md.h Sat Sep 6 01:38:52 2003
@@ -39,8 +39,8 @@
asm("frstor %0": :"m"(*fdata))
/* Define signal context macros for xprofiling */
-#define SIGNAL_ARGS(sig, sc) int sig, int __code, struct sigcontext *##sc
-#define SIGNAL_CONTEXT_POINTER(scp) struct sigcontext *##scp
+#define SIGNAL_ARGS(sig, sc) int sig, int __code, struct sigcontext *sc
+#define SIGNAL_CONTEXT_POINTER(scp) struct sigcontext *scp
#define GET_SIGNAL_CONTEXT_POINTER(sc) (sc)
#define SIGNAL_PC(scp) (scp)->sc_pc

View File

@ -0,0 +1,8 @@
Kaffe is multi-platform Java virtual machine. It includes its own
implementation of the Java JDK 1.2 standard classes, including the
AWT classes. Kaffe also does "just-in-time" compilation of Java
bytecode into machine code for increased execution speed.
WWW: http://www.kaffe.org/
* Java and Javasoft are registered trademark of Sun Microsystems, Inc.

View File

@ -0,0 +1,77 @@
bin/appletviewer
bin/install-jar
bin/jar
bin/java
bin/javac
bin/javadoc
bin/javah
bin/javakey
bin/javap
bin/jdb
bin/kaffe
bin/kaffeh
bin/kjc
bin/kopi
bin/native2ascii
bin/rmic
bin/rmiregistry
bin/serialver
include/kaffe/Arrays.h
include/kaffe/errors.h
include/kaffe/java_lang_Object.h
include/kaffe/java_lang_String.h
include/kaffe/java_lang_Thread.h
include/kaffe/java_lang_ThreadGroup.h
include/kaffe/java_lang_Throwable.h
include/kaffe/jmalloc.h
include/kaffe/jni_cpp.h
include/kaffe/jsyscall.h
include/kaffe/jtypes.h
include/kaffe/native.h
include/jni.h
jre/bin/kaffe-bin
jre/bin/java
jre/bin/kaffe
jre/bin/rmiregistry
jre/lib/%%ARCH%%/libawt-%%PORTVER%%.so
jre/lib/%%ARCH%%/libawt.so
jre/lib/%%ARCH%%/libawt.la
jre/lib/%%ARCH%%/libio-%%PORTVER%%.so
jre/lib/%%ARCH%%/libio.so
jre/lib/%%ARCH%%/libio.la
jre/lib/%%ARCH%%/libkaffevm-%%PORTVER%%.so
jre/lib/%%ARCH%%/libkaffevm.so
jre/lib/%%ARCH%%/libkaffevm.la
jre/lib/%%ARCH%%/libmanagement-%%PORTVER%%.so
jre/lib/%%ARCH%%/libmanagement.so
jre/lib/%%ARCH%%/libmanagement.la
jre/lib/%%ARCH%%/libmath-%%PORTVER%%.so
jre/lib/%%ARCH%%/libmath.so
jre/lib/%%ARCH%%/libmath.la
jre/lib/%%ARCH%%/libnative-%%PORTVER%%.so
jre/lib/%%ARCH%%/libnative.so
jre/lib/%%ARCH%%/libnative.la
jre/lib/%%ARCH%%/libnet-%%PORTVER%%.so
jre/lib/%%ARCH%%/libnet.so
jre/lib/%%ARCH%%/libnet.la
jre/lib/%%ARCH%%/libsecurity-%%PORTVER%%.so
jre/lib/%%ARCH%%/libsecurity.so
jre/lib/%%ARCH%%/libsecurity.la
jre/lib/%%ARCH%%/libtritonuscommon-%%PORTVER%%.so
jre/lib/%%ARCH%%/libtritonuscommon.so
jre/lib/%%ARCH%%/libtritonuscommon.la
jre/lib/%%ARCH%%/libzip-%%PORTVER%%.so
jre/lib/%%ARCH%%/libzip.so
jre/lib/%%ARCH%%/libzip.la
jre/lib/security/java.security
jre/lib/rt.jar
lib/kjc.jar
share/kaffe/BUILD_ENVIRONMENT
share/kaffe/license.terms
@dirrm include/kaffe
@dirrm jre/bin
@dirrm jre/lib/%%ARCH%%
@dirrm jre/lib/security
@dirrm jre/lib
@dirrm jre
@dirrm share/kaffe