- Fix RUN_DEPENDS (:=), mostly for portlint
- Change WITH_PCAP_PORT to LIB_DEPENDS, not BUILD_DEPENDS - add stopdaemon to pkg-plist - need chown in pkg-plist so that .tbz (package building) works - clean up install message (patch-Makefile.am) - add test in pkg-deinstall.in to test for DBDIR PR: ports/163682 Submitted by: scheidell@
This commit is contained in:
parent
170c06e7ec
commit
b959d3d904
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=289193
@ -7,7 +7,7 @@
|
||||
|
||||
PORTNAME= ntop
|
||||
PORTVERSION= 4.1.0
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= net
|
||||
#MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Stable
|
||||
@ -21,10 +21,8 @@ LIB_DEPENDS= gdbm.4:${PORTSDIR}/databases/gdbm \
|
||||
BUILD_DEPENDS= rrdtool>=1.2:${PORTSDIR}/databases/rrdtool \
|
||||
dot:${PORTSDIR}/graphics/graphviz \
|
||||
geoiplookup:${PORTSDIR}/net/GeoIP
|
||||
RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz \
|
||||
${LOCALBASE}/lib/X11/fonts/URW/a010013l.afm:${PORTSDIR}/x11-fonts/urwfonts \
|
||||
rrdtool>=1.2:${PORTSDIR}/databases/rrdtool \
|
||||
geoiplookup:${PORTSDIR}/net/GeoIP
|
||||
RUN_DEPENDS:= ${BUILD_DEPENDS} \
|
||||
${LOCALBASE}/lib/X11/fonts/URW/a010013l.afm:${PORTSDIR}/x11-fonts/urwfonts
|
||||
|
||||
DBDIR?= /var/db
|
||||
|
||||
@ -53,7 +51,6 @@ USE_RC_SUBR= ntop.sh
|
||||
|
||||
##
|
||||
## Available knobs:
|
||||
## WITH_LOCALE: Enable locale (i18n) support.
|
||||
## WITH_PCAP_PORT: Use libpcap from ports.
|
||||
## WITH_XMLDUMP: Enable XML Dump support.
|
||||
##
|
||||
@ -64,7 +61,7 @@ OPTIONS= PCAP_PORT "Use libpcap from ports." Off \
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITH_PCAP_PORT)
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
|
||||
LIB_DEPENDS+= pcap.1:${PORTSDIR}/net/libpcap
|
||||
CONFIGURE_ARGS+= --with-pcap-root=${LOCALBASE}
|
||||
.else
|
||||
CONFIGURE_ARGS+= --with-pcap-root=/usr
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- ./Makefile.am.orig 2011-02-02 10:24:56.000000000 +0100
|
||||
+++ ./Makefile.am 2011-02-02 10:50:06.000000000 +0100
|
||||
@@ -68,8 +68,6 @@
|
||||
--- Makefile.am.orig 2011-03-03 08:44:59.000000000 -0500
|
||||
+++ Makefile.am 2011-12-28 14:25:08.000000000 -0500
|
||||
@@ -61,8 +61,6 @@
|
||||
|
||||
ETTER_PASSIVE_FILE = etter.finger.os
|
||||
ETTER_PASSIVE = $(ETTER_PASSIVE_FILE).gz
|
||||
@ -9,7 +9,25 @@
|
||||
|
||||
NTOPDATA = ntop-cert.pem \
|
||||
$(ETTER_PASSIVE) \
|
||||
@@ -337,7 +335,6 @@
|
||||
@@ -303,15 +301,14 @@
|
||||
echo " WARNING: This install created a directory for the ntop"; \
|
||||
echo " files and databases:"; \
|
||||
echo ""; \
|
||||
- echo " $(DESTDIR)/$(datadir)/ntop"; \
|
||||
+ echo " $(CFG_DBFILE_DIR)"; \
|
||||
echo ""; \
|
||||
echo " This directory MUST be owned by the user"; \
|
||||
echo " which you are going to use to run ntop."; \
|
||||
echo ""; \
|
||||
echo " The command you must issue is something like:"; \
|
||||
echo ""; \
|
||||
- echo " chown -R ntop.ntop $(DESTDIR)/$(datadir)/ntop"; \
|
||||
- echo " or chown -R ntop:users $(DESTDIR)/$(datadir)/ntop"; \
|
||||
+ echo " chown -R nobody:nobody $(CFG_DBFILE_DIR)"; \
|
||||
echo ""; \
|
||||
echo " man chown to check the syntax for YOUR system"; \
|
||||
echo ""; \
|
||||
@@ -329,7 +326,6 @@
|
||||
chcon -t textrel_shlib_t $(DESTDIR)$(libdir)/*ntop*.so
|
||||
|
||||
install-data-local: ntop.txt ntop.html faq.html dnetter
|
||||
@ -17,7 +35,7 @@
|
||||
@if ! test -d $(DESTDIR)/$(datadir)/ntop; then \
|
||||
$(top_srcdir)/mkinstalldirs $(DESTDIR)/$(datadir)/ntop; \
|
||||
touch $(DESTDIR)/$(datadir)/ntop/warnuser; \
|
||||
@@ -373,21 +370,6 @@
|
||||
@@ -365,21 +361,6 @@
|
||||
@echo ""
|
||||
@echo ""
|
||||
@echo -n "Preparing "
|
||||
@ -39,7 +57,7 @@
|
||||
@echo -n "New file lines are: "
|
||||
@gunzip -c oui.txt.gz | wc -l
|
||||
@echo ""
|
||||
@@ -406,34 +388,6 @@
|
||||
@@ -398,34 +379,6 @@
|
||||
@echo "Preparing "
|
||||
@echo ""
|
||||
|
||||
|
@ -7,6 +7,7 @@ case $2 in
|
||||
DEINSTALL)
|
||||
;;
|
||||
POST-DEINSTALL)
|
||||
if [ -d %%DBDIR%%/ntop ];then
|
||||
echo "===> post-deinstallation information for $1"
|
||||
echo ""
|
||||
echo " Please note that ntop was not completely removed"
|
||||
@ -15,6 +16,7 @@ case $2 in
|
||||
echo " %%DBDIR%%/ntop can be removed if this port will not be"
|
||||
echo " reinstalled."
|
||||
echo ""
|
||||
fi
|
||||
;;
|
||||
*)
|
||||
exit 64
|
||||
|
@ -1,3 +1,4 @@
|
||||
@stopdaemon ntop
|
||||
bin/ntop
|
||||
etc/ntop/GeoIPASNum.dat
|
||||
etc/ntop/GeoLiteCity.dat
|
||||
@ -453,7 +454,6 @@ lib/ntop/plugins/sflowPlugin.so
|
||||
%%DATADIR%%/python/templates/rrdAlarmConfigurator.tmpl
|
||||
%%DATADIR%%/python/templates/rrdAlarmConfiguratorHelp.tmpl
|
||||
%%DATADIR%%/python/templates/rrdAlarmStart.tmpl
|
||||
@exec mkdir -p %%DBDIR%%/ntop
|
||||
@dirrm %%DATADIR%%/html/MochiKit
|
||||
@dirrm %%DATADIR%%/html/PlotKit
|
||||
@dirrm %%DATADIR%%/html/img_inquisitor
|
||||
@ -475,3 +475,7 @@ lib/ntop/plugins/sflowPlugin.so
|
||||
@dirrm etc/ntop
|
||||
@dirrm lib/ntop/plugins
|
||||
@dirrm lib/ntop
|
||||
@exec mkdir -p %%DBDIR%%/ntop
|
||||
@exec chown -R nobody:nobody %%DBDIR%%/ntop
|
||||
@unexec rmdir %%DBDIR%%/ntop 2>/dev/null || true
|
||||
@unexec rmdir %%DBDIR%% 2>/dev/null || true
|
||||
|
Loading…
Reference in New Issue
Block a user