Respect CC and CFLAGS.
Define and use SWIG instead of hardcoding swig's executable name in a patch. Remove the "chmod 755 xxx.so" line from the distributed Makefile.
This commit is contained in:
parent
3673ac35bb
commit
b932b246ac
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=33922
@ -14,7 +14,7 @@ EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= knu@FreeBSD.org
|
||||
|
||||
BUILD_DEPENDS= swig1.3:${PORTSDIR}/devel/SWIG-devel
|
||||
BUILD_DEPENDS= ${SWIG}:${PORTSDIR}/devel/SWIG-devel
|
||||
LIB_DEPENDS= ming.0:${PORTSDIR}/graphics/ming
|
||||
|
||||
USE_PYTHON= yes
|
||||
@ -22,7 +22,9 @@ USE_PYTHON= yes
|
||||
MD5_FILE= ${PORTSDIR}/graphics/ming/distinfo
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/py_ext
|
||||
MAKE_ARGS= PYTHON_VERSION="${PYTHON_VERSION}"
|
||||
MAKE_ARGS= PYTHON_VERSION="${PYTHON_VERSION}" SWIG="${SWIG}"
|
||||
|
||||
SWIG= swig1.3
|
||||
|
||||
EXAMPLES= shape.py test.py
|
||||
|
||||
|
@ -1,13 +1,13 @@
|
||||
--- Makefile.orig Fri Oct 13 15:26:29 2000
|
||||
+++ Makefile Mon Oct 16 19:08:12 2000
|
||||
@@ -1,11 +1,11 @@
|
||||
+++ Makefile Tue Oct 17 17:43:54 2000
|
||||
@@ -1,11 +1,10 @@
|
||||
all:
|
||||
- swig -python ming.i
|
||||
- gcc -I .. -I /usr/include/python1.5/ -fpic -c ming_wrap.c
|
||||
- gcc -L .. -shared -o mingcmodule.so ming_wrap.o -lming
|
||||
+ swig1.3 -python ming.i
|
||||
+ gcc -I${LOCALBASE}/include/ming -I${LOCALBASE}/include/${PYTHON_VERSION} -fpic -c ming_wrap.c
|
||||
+ gcc -L${LOCALBASE}/lib -shared -o mingcmodule.so ming_wrap.o -lming
|
||||
+ ${SWIG} -python ming.i
|
||||
+ ${CC} ${CFLAGS} -I${LOCALBASE}/include/ming -I${LOCALBASE}/include/${PYTHON_VERSION} -fpic -c ming_wrap.c
|
||||
+ ${CC} -shared -o mingcmodule.so ming_wrap.o -L${LOCALBASE}/lib -lming
|
||||
|
||||
clean:
|
||||
rm -f mingcmodule.so core *~ *.o ming_wrap*
|
||||
@ -15,5 +15,4 @@
|
||||
install:
|
||||
- cp mingcmodule.so ming.py /usr/lib/python1.5/site-packages
|
||||
- chmod 755 /usr/lib/python1.5/site-packages/mingcmodule.so
|
||||
+ cp mingcmodule.so ming.py ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages
|
||||
+ chmod 755 ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages/mingcmodule.so
|
||||
+ ${BSD_INSTALL_DATA} mingcmodule.so ming.py ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages
|
||||
|
Loading…
Reference in New Issue
Block a user