- Add patch to fix MySQL protocol testing with MySQL 5.1.57+ and 5.5.12+.

Taken from vendor repo (r372).
- Remove CPPFLAGS from CONFIGURE_ARGS as it is inherently passed via use of
  GNU_CONFIGURE. (quiets lint warning)
- Remove WITH_SSL option conditional and replace it with a WITHOUT_SSL
  conditional. SSL support is enabled by default in configure and the
  --enable-SSL and --with-openssl knobs have been removed. (quiets configure
  warning)
- Change Mk includes to use new options style.
- Fix WWW in pkg-descr.

PR:		ports/158198
Submitted by:	Jase Thew <freebsd@beardz.net>
Approved by:	Martin Pala <martinp@tildeslash.com> (maintainer)
This commit is contained in:
Wesley Shields 2011-06-25 12:37:57 +00:00
parent 389eb0fdb2
commit b92554180c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=276368
3 changed files with 20 additions and 9 deletions

View File

@ -7,6 +7,7 @@
PORTNAME= monit
PORTVERSION= 5.2.5
PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.mmonit.com/monit/dist/
@ -20,8 +21,8 @@ USE_BISON= build
USE_GMAKE= yes
USE_RC_SUBR= ${PORTNAME}.sh
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
CONFIG_SHELL="${SH}" LOCALBASE="${LOCALBASE}"
CONFIGURE_ENV= LDFLAGS="${LDFLAGS}" CONFIG_SHELL="${SH}" \
LOCALBASE="${LOCALBASE}"
OPTIONS= SSL "Enable SSL support" on
@ -35,12 +36,9 @@ DOCS= CHANGES.txt LICENSE README README.SSL \
doc/examples.html doc/monit.html
PORTDOCS= ${DOCS:T}
.include <bsd.port.pre.mk>
.include <bsd.port.options.mk>
.if defined(WITH_SSL)
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
CONFIGURE_ARGS+= --enable-ssl --with-openssl="${OPENSSLBASE}"
.else
.if defined(WITHOUT_SSL)
CONFIGURE_ARGS+= --without-ssl
.endif
@ -52,4 +50,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -0,0 +1,13 @@
--- protocols/mysql.c.orig 2011-02-07 20:04:08.000000000 +0000
+++ protocols/mysql.c 2011-05-23 12:35:35.000000000 +0100
@@ -160,8 +160,8 @@
}
return TRUE;
- } else if((buf[4] == 0xFF) && ((buf[5] == 0x15 && buf[6] == 0x04) || (buf[5] == 0xE3 && buf[6] == 0x04))) {
- /* If access denied (1045) or server requires newer authentication protocol (1251), return success immediately */
+ } else if((buf[4] == 0xFF) && ((buf[5] == 0x15 && buf[6] == 0x04) || (buf[5] == 0xE3 && buf[6] == 0x04) || (buf[5] == 0x13 && buf[6] == 0x04))) {
+ /* If access denied (1045) or server requires newer authentication protocol (1251) or bad handshake (1043) return success immediately */
return TRUE;
}

View File

@ -21,4 +21,4 @@ monit supports:
* A HTTP interface with XML output option
and many more features :)
WWW: http://www.tildeslash.com/monit/
WWW: http://mmonit.com/monit/