Add lazperf to the ports tree
and reenable databases/pointcloud PR: 221577
This commit is contained in:
parent
2b6d8e396c
commit
b90c8f8a63
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=450694
@ -54,6 +54,7 @@
|
||||
SUBDIR += kf5-karchive
|
||||
SUBDIR += kzip
|
||||
SUBDIR += laszip
|
||||
SUBDIR += lazperf
|
||||
SUBDIR += lbrate
|
||||
SUBDIR += lbzip2
|
||||
SUBDIR += lcab
|
||||
|
23
archivers/lazperf/Makefile
Normal file
23
archivers/lazperf/Makefile
Normal file
@ -0,0 +1,23 @@
|
||||
# Created by: lbartoletti <lbartoletti@tuxfamily.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= lazperf
|
||||
PORTVERSION= 1.1.0
|
||||
CATEGORIES= archivers databases geography
|
||||
|
||||
MAINTAINER= lbartoletti@tuxfamily.org
|
||||
COMMENT= Alternative LAZ implementation for C++ and JavaScript
|
||||
|
||||
LICENSE= LGPL21
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
USES= cmake
|
||||
CMAKE_ARGS+= -DWITH_TESTS:BOOL=FALSE
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= hobu
|
||||
GH_PROJECT= laz-perf
|
||||
|
||||
post-build:
|
||||
${RM} ${WRKSRC}/laz-perf/portable_endian.hpp.orig
|
||||
.include <bsd.port.mk>
|
3
archivers/lazperf/distinfo
Normal file
3
archivers/lazperf/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1502918669
|
||||
SHA256 (hobu-laz-perf-1.1.0_GH0.tar.gz) = 5413bb3e727d8b7155900f35b8f5e487eee418957d251fb3799d2cd3e17b2158
|
||||
SIZE (hobu-laz-perf-1.1.0_GH0.tar.gz) = 4025260
|
16
archivers/lazperf/files/patch-laz-perf_portable__endian.hpp
Normal file
16
archivers/lazperf/files/patch-laz-perf_portable__endian.hpp
Normal file
@ -0,0 +1,16 @@
|
||||
--- laz-perf/portable_endian.hpp.orig 2017-08-16 21:27:03 UTC
|
||||
+++ laz-perf/portable_endian.hpp
|
||||
@@ -41,11 +41,11 @@
|
||||
# define __PDP_ENDIAN PDP_ENDIAN
|
||||
**/
|
||||
|
||||
-#elif defined(__OpenBSD__) || defined(EMSCRIPTEN_OPEN_BSD)
|
||||
+#elif defined(__OpenBSD__) || defined(__FreeBSD__) || defined(EMSCRIPTEN_OPEN_BSD)
|
||||
|
||||
# include <sys/endian.h>
|
||||
|
||||
-#elif defined(__NetBSD__) || defined(__FreeBSD__) || defined(__DragonFly__) || defined(EMSCRIPTEN_BSD)
|
||||
+#elif defined(__NetBSD__) || defined(__DragonFly__) || defined(EMSCRIPTEN_BSD)
|
||||
|
||||
# include <sys/endian.h>
|
||||
|
5
archivers/lazperf/pkg-descr
Normal file
5
archivers/lazperf/pkg-descr
Normal file
@ -0,0 +1,5 @@
|
||||
Alternative LAZ implementation. It supports compilation and usage in JavaScript,
|
||||
usage in database contexts such as pgpointcloud and Oracle Point Cloud, and it
|
||||
executes faster than the LASzip codebase.
|
||||
|
||||
WWW: https://github.com/hobu/laz-perf
|
22
archivers/lazperf/pkg-plist
Normal file
22
archivers/lazperf/pkg-plist
Normal file
@ -0,0 +1,22 @@
|
||||
include/laz-perf/common/common.hpp
|
||||
include/laz-perf/common/types.hpp
|
||||
include/laz-perf/compressor.hpp
|
||||
include/laz-perf/decoder.hpp
|
||||
include/laz-perf/decompressor.hpp
|
||||
include/laz-perf/detail/field_gpstime.hpp
|
||||
include/laz-perf/detail/field_point10.hpp
|
||||
include/laz-perf/detail/field_rgb.hpp
|
||||
include/laz-perf/detail/field_xyz.hpp
|
||||
include/laz-perf/encoder.hpp
|
||||
include/laz-perf/excepts.hpp
|
||||
include/laz-perf/factory.hpp
|
||||
include/laz-perf/formats.hpp
|
||||
include/laz-perf/io.hpp
|
||||
include/laz-perf/las.hpp
|
||||
include/laz-perf/main.cpp
|
||||
include/laz-perf/model.hpp
|
||||
include/laz-perf/portable_endian.hpp
|
||||
include/laz-perf/streams.hpp
|
||||
include/laz-perf/util.hpp
|
||||
lib/cmake/lazperf/lazperf-config.cmake
|
||||
lib/cmake/lazperf/lazperf-configVersion.cmake
|
@ -660,6 +660,7 @@
|
||||
SUBDIR += phppgadmin
|
||||
SUBDIR += pldebugger
|
||||
SUBDIR += plpgsql_check
|
||||
SUBDIR += pointcloud
|
||||
SUBDIR += postgis-jdbc
|
||||
SUBDIR += postgis20
|
||||
SUBDIR += postgis21
|
||||
|
Loading…
Reference in New Issue
Block a user