Taisei (lit. Occident) is a fan-made Open Source clone of the Touhou

series, written in C using SDL/OpenGL.

Basically, it is a shoot'em up game with lots of bullets (the genre
is literally called bullet hell). The game is mostly done and very
playable, so feel free to give it a try!

WWW: https://taisei-project.org/
This commit is contained in:
Dmitry Marakasov 2017-11-24 16:02:29 +00:00
parent 26253817ff
commit b90ac5538b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=454826
6 changed files with 77 additions and 0 deletions

View File

@ -954,6 +954,7 @@
SUBDIR += syobon
SUBDIR += tads
SUBDIR += taipan
SUBDIR += taisei
SUBDIR += tali
SUBDIR += tanglet
SUBDIR += tanks-of-freedom

34
games/taisei/Makefile Normal file
View File

@ -0,0 +1,34 @@
# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
# $FreeBSD$
PORTNAME= taisei
PORTVERSION= 1.1.2
DISTVERSIONPREFIX= v
CATEGORIES= games
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Open source Touhou clone
LICENSE= MIT CC0-1.0 PD
LICENSE_COMB= multi
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpng.so:graphics/png \
libzip.so:archivers/libzip
USE_GITHUB= yes
GH_ACCOUNT= ${PORTNAME}-project
USES= cmake pkgconfig
CMAKE_ARGS= -DTAISEI_VERSION_OVERRIDE=${PORTVERSION}
USE_SDL= sdl2 ttf2 mixer2
PORTDOCS= *
PORTDATA= *
OPTIONS_DEFINE= DOCS
post-install:
@${RM} ${STAGEDIR}${DOCSDIR}/COPYING.txt
.include <bsd.port.mk>

3
games/taisei/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1511265010
SHA256 (taisei-project-taisei-v1.1.2_GH0.tar.gz) = 9b9ce2828a9c1fcc1de148e927c00b8bd541f891cae2df50552b9bba8f34122f
SIZE (taisei-project-taisei-v1.1.2_GH0.tar.gz) = 36400214

View File

@ -0,0 +1,28 @@
--- src/CMakeLists.txt.orig 2017-11-20 04:24:23 UTC
+++ src/CMakeLists.txt
@@ -205,25 +205,10 @@ if(DEBUG_USE_ASAN AND DEFINED DEBUG_BUIL
CHECK_AND_SET_FLAGS(COMPILER_SUPPORTS_ASAN "-fsanitize=address" DEBUG_FLAGS "-fsanitize=address")
endif()
-if(RELEASE_USE_LTO)
- set(RELEASE_FLAGS "${RELEASE_FLAGS} -flto")
-endif()
-
-set(CMAKE_C_FLAGS_DEBUG "${DEBUG_FLAGS} -DDEBUG")
-set(CMAKE_C_FLAGS_RELEASE "${RELEASE_FLAGS} -O3")
-set(CMAKE_C_FLAGS_RELWITHDEBINFO "${RELEASE_FLAGS} -O2")
-set(CMAKE_C_FLAGS_MINSIZEREL "${RELEASE_FLAGS} -Os")
-
if(RELWITHDEBINFO_USE_DEBUG_FLAGS)
set(CMAKE_C_FLAGS_RELWITHDEBINFO "${CMAKE_C_FLAGS_RELWITHDEBINFO} ${DEBUG_FLAGS}")
endif()
-check_symbol_exists(backtrace "execinfo.h" HAVE_BACKTRACE)
-if(${HAVE_BACKTRACE})
- set(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -DLOG_ENABLE_BACKTRACE")
- set(CMAKE_C_FLAGS_RELWITHDEBINFO "${CMAKE_C_FLAGS_RELWITHDEBINFO} -DLOG_ENABLE_BACKTRACE")
-endif()
-
set(WANT_WARNINGS
"all"
"pedantic"

8
games/taisei/pkg-descr Normal file
View File

@ -0,0 +1,8 @@
Taisei (lit. Occident) is a fan-made Open Source clone of the Touhou
series, written in C using SDL/OpenGL.
Basically, it is a shoot'em up game with lots of bullets (the genre
is literally called bullet hell). The game is mostly done and very
playable, so feel free to give it a try!
WWW: https://taisei-project.org/

3
games/taisei/pkg-plist Normal file
View File

@ -0,0 +1,3 @@
bin/taisei
share/applications/taisei.desktop
share/icons/hicolor/128x128/apps/taisei.png