- Fix SSH option and openssl related scripts [1].

- Change UNIQUENAME and LATEST_LINK to use separated options db.

PR:		ports/125566 [1]
Submitted by:	Franz Schwartau <franz@electromail.org> [1]
This commit is contained in:
Jun Kuriyama 2008-07-24 23:27:50 +00:00
parent d2ddcad204
commit b9074b86bf
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=217450
16 changed files with 172 additions and 40 deletions

View File

@ -6,7 +6,7 @@
#
PKGNAMESUFFIX= -client
PORTREVISION= 2
PORTREVISION= 3
COMMENT= The Advanced Maryland Automatic Network Disk Archiver (client)

View File

@ -7,7 +7,7 @@
PORTNAME= amanda
PORTVERSION= 2.5.1p3
PORTREVISION?= 4
PORTREVISION?= 5
PKGNAMESUFFIX?= -server
PORTEPOCH= 1
CATEGORIES= misc
@ -20,9 +20,10 @@ COMMENT?= The Advanced Maryland Automatic Network Disk Archiver (server)
WRKSRC= ${WRKDIR}/amanda-${PORTVERSION}
SLAVEDIRS= misc/amanda-client
NO_LATEST_LINK= yes
LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
USE_AUTOTOOLS= autoconf:261
USE_GMAKE= yes
USE_OPENSSL= yes
PATCH_STRIP=
CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--with-amandahosts --with-fqdn \
@ -32,7 +33,8 @@ CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
USE_LDCONFIG= yes
WANT_PERL= yes
OPTIONS= GNUTAR "use GNU tar" on
OPTIONS= GNUTAR "use GNU tar" on \
SSH "enable ssh-auth" off
.include <bsd.port.pre.mk>
@ -57,6 +59,10 @@ CONFIGURE_ARGS+= --with-config=${AMANDA_CONFIG}
CONFIGURE_ARGS+= --with-udpportrange=${AMANDA_UDPPORTRANGE}
.endif
.if defined (WITH_SSH)
CONFIGURE_ARGS+= --with-ssh-security
.endif
# AMANDA_PORTRANGE is obsoleted. Use AMANDA_TCPPORTRANGE instead.
.if defined (AMANDA_PORTRANGE)
AMANDA_TCPPORTRANGE= ${AMANDA_PORTRANGE}
@ -99,6 +105,12 @@ pre-fetch:
@${ECHO} " The default is no restriction on UDP ports."
@${ECHO} ""
post-patch:
@${REINPLACE_CMD} \
-e 's|^OPENSSL=.*$$|OPENSSL=${OPENSSLBASE}/bin/openssl|' \
${WRKSRC}/server-src/amcrypt-ossl.sh.in \
${WRKSRC}/server-src/amcrypt-ossl-asym.sh.in
USE_PERL5= yes
BUILD_DEPENDS+= ${LOCALBASE}/sbin/amrecover:${PORTSDIR}/misc/amanda-client
@ -116,8 +128,7 @@ MAN8= amadmin.8 amaespipe.8 amcheck.8 \
OPTIONS+= PLOT "enable ploting, requires X11 libraries" off\
SAMBA "enable the use of smbclient" off \
MTX "enable the use of mtx changer scripts" off \
AESPIPE "enable encryption. Needed by amcrypt" off \
SSH "enable ssh-auth" off
AESPIPE "enable encryption. Needed by amcrypt" off
.if defined (WITH_PLOT)
BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
@ -143,10 +154,6 @@ RUN_DEPENDS+= mtx:${PORTSDIR}/misc/mtx
RUN_DEPENDS+= aespipe:${PORTSDIR}/security/aespipe
.endif
.if defined (WITH_SSL)
CONFIGURE_ARGS+= --with-ssh-security
.endif
.if defined (AMANDA_TAPE)
CONFIGURE_ARGS+= --with-tape-device=${AMANDA_TAPE}
.endif
@ -214,4 +221,8 @@ EXTRA_PATCHES= ${FILESDIR}/extra-patch-sendbackup-dump.c
.endif
# Maintainer TODO:
# o amanda-server installs lib/libamandad.a which should be handled by
# amanda-client only.
.include <bsd.port.post.mk>

View File

@ -0,0 +1,11 @@
--- server-src/amcrypt-ossl-asym.sh.in.orig 2006-07-04 13:28:47.000000000 +0200
+++ server-src/amcrypt-ossl-asym.sh.in 2008-07-12 12:11:30.000000000 +0200
@@ -36,7 +36,7 @@
# change these as needed
OPENSSL= # whatever's in $PATH
CIPHER=aes-256-cbc # see `openssl help` for more ciphers
-AMANDA_HOME=~amandabackup
+AMANDA_HOME=~@CLIENT_LOGIN@
RANDFILE=$AMANDA_HOME/.rnd
export RANDFILE
PASSPHRASE=$AMANDA_HOME/.am_passphrase # optional

View File

@ -0,0 +1,11 @@
--- server-src/amcrypt-ossl.sh.in.orig 2006-07-04 13:28:47.000000000 +0200
+++ server-src/amcrypt-ossl.sh.in 2008-07-12 12:11:35.000000000 +0200
@@ -7,7 +7,7 @@
# change these as needed
OPENSSL= # whatever's in $PATH
CIPHER=aes-256-cbc # see `openssl help` for more ciphers
-AMANDA_HOME=~amandabackup
+AMANDA_HOME=~@CLIENT_LOGIN@
RANDFILE=$AMANDA_HOME/.rnd
export RANDFILE
PASSPHRASE=$AMANDA_HOME/.am_passphrase # required

View File

@ -6,7 +6,7 @@
#
PKGNAMESUFFIX= -client
PORTREVISION= 2
PORTREVISION= 3
COMMENT= The Advanced Maryland Automatic Network Disk Archiver (client)

View File

@ -7,7 +7,7 @@
PORTNAME= amanda
PORTVERSION= 2.5.1p3
PORTREVISION?= 4
PORTREVISION?= 5
PKGNAMESUFFIX?= -server
PORTEPOCH= 1
CATEGORIES= misc
@ -20,9 +20,10 @@ COMMENT?= The Advanced Maryland Automatic Network Disk Archiver (server)
WRKSRC= ${WRKDIR}/amanda-${PORTVERSION}
SLAVEDIRS= misc/amanda-client
NO_LATEST_LINK= yes
LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
USE_AUTOTOOLS= autoconf:261
USE_GMAKE= yes
USE_OPENSSL= yes
PATCH_STRIP=
CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--with-amandahosts --with-fqdn \
@ -32,7 +33,8 @@ CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
USE_LDCONFIG= yes
WANT_PERL= yes
OPTIONS= GNUTAR "use GNU tar" on
OPTIONS= GNUTAR "use GNU tar" on \
SSH "enable ssh-auth" off
.include <bsd.port.pre.mk>
@ -57,6 +59,10 @@ CONFIGURE_ARGS+= --with-config=${AMANDA_CONFIG}
CONFIGURE_ARGS+= --with-udpportrange=${AMANDA_UDPPORTRANGE}
.endif
.if defined (WITH_SSH)
CONFIGURE_ARGS+= --with-ssh-security
.endif
# AMANDA_PORTRANGE is obsoleted. Use AMANDA_TCPPORTRANGE instead.
.if defined (AMANDA_PORTRANGE)
AMANDA_TCPPORTRANGE= ${AMANDA_PORTRANGE}
@ -99,6 +105,12 @@ pre-fetch:
@${ECHO} " The default is no restriction on UDP ports."
@${ECHO} ""
post-patch:
@${REINPLACE_CMD} \
-e 's|^OPENSSL=.*$$|OPENSSL=${OPENSSLBASE}/bin/openssl|' \
${WRKSRC}/server-src/amcrypt-ossl.sh.in \
${WRKSRC}/server-src/amcrypt-ossl-asym.sh.in
USE_PERL5= yes
BUILD_DEPENDS+= ${LOCALBASE}/sbin/amrecover:${PORTSDIR}/misc/amanda-client
@ -116,8 +128,7 @@ MAN8= amadmin.8 amaespipe.8 amcheck.8 \
OPTIONS+= PLOT "enable ploting, requires X11 libraries" off\
SAMBA "enable the use of smbclient" off \
MTX "enable the use of mtx changer scripts" off \
AESPIPE "enable encryption. Needed by amcrypt" off \
SSH "enable ssh-auth" off
AESPIPE "enable encryption. Needed by amcrypt" off
.if defined (WITH_PLOT)
BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
@ -143,10 +154,6 @@ RUN_DEPENDS+= mtx:${PORTSDIR}/misc/mtx
RUN_DEPENDS+= aespipe:${PORTSDIR}/security/aespipe
.endif
.if defined (WITH_SSL)
CONFIGURE_ARGS+= --with-ssh-security
.endif
.if defined (AMANDA_TAPE)
CONFIGURE_ARGS+= --with-tape-device=${AMANDA_TAPE}
.endif
@ -214,4 +221,8 @@ EXTRA_PATCHES= ${FILESDIR}/extra-patch-sendbackup-dump.c
.endif
# Maintainer TODO:
# o amanda-server installs lib/libamandad.a which should be handled by
# amanda-client only.
.include <bsd.port.post.mk>

View File

@ -0,0 +1,11 @@
--- server-src/amcrypt-ossl-asym.sh.in.orig 2006-07-04 13:28:47.000000000 +0200
+++ server-src/amcrypt-ossl-asym.sh.in 2008-07-12 12:11:30.000000000 +0200
@@ -36,7 +36,7 @@
# change these as needed
OPENSSL= # whatever's in $PATH
CIPHER=aes-256-cbc # see `openssl help` for more ciphers
-AMANDA_HOME=~amandabackup
+AMANDA_HOME=~@CLIENT_LOGIN@
RANDFILE=$AMANDA_HOME/.rnd
export RANDFILE
PASSPHRASE=$AMANDA_HOME/.am_passphrase # optional

View File

@ -0,0 +1,11 @@
--- server-src/amcrypt-ossl.sh.in.orig 2006-07-04 13:28:47.000000000 +0200
+++ server-src/amcrypt-ossl.sh.in 2008-07-12 12:11:35.000000000 +0200
@@ -7,7 +7,7 @@
# change these as needed
OPENSSL= # whatever's in $PATH
CIPHER=aes-256-cbc # see `openssl help` for more ciphers
-AMANDA_HOME=~amandabackup
+AMANDA_HOME=~@CLIENT_LOGIN@
RANDFILE=$AMANDA_HOME/.rnd
export RANDFILE
PASSPHRASE=$AMANDA_HOME/.am_passphrase # required

View File

@ -6,7 +6,7 @@
#
PKGNAMESUFFIX= -client
PORTREVISION= 2
PORTREVISION= 3
COMMENT= The Advanced Maryland Automatic Network Disk Archiver (client)

View File

@ -7,7 +7,7 @@
PORTNAME= amanda
PORTVERSION= 2.5.1p3
PORTREVISION?= 4
PORTREVISION?= 5
PKGNAMESUFFIX?= -server
PORTEPOCH= 1
CATEGORIES= misc
@ -20,9 +20,10 @@ COMMENT?= The Advanced Maryland Automatic Network Disk Archiver (server)
WRKSRC= ${WRKDIR}/amanda-${PORTVERSION}
SLAVEDIRS= misc/amanda-client
NO_LATEST_LINK= yes
LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
USE_AUTOTOOLS= autoconf:261
USE_GMAKE= yes
USE_OPENSSL= yes
PATCH_STRIP=
CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--with-amandahosts --with-fqdn \
@ -32,7 +33,8 @@ CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
USE_LDCONFIG= yes
WANT_PERL= yes
OPTIONS= GNUTAR "use GNU tar" on
OPTIONS= GNUTAR "use GNU tar" on \
SSH "enable ssh-auth" off
.include <bsd.port.pre.mk>
@ -57,6 +59,10 @@ CONFIGURE_ARGS+= --with-config=${AMANDA_CONFIG}
CONFIGURE_ARGS+= --with-udpportrange=${AMANDA_UDPPORTRANGE}
.endif
.if defined (WITH_SSH)
CONFIGURE_ARGS+= --with-ssh-security
.endif
# AMANDA_PORTRANGE is obsoleted. Use AMANDA_TCPPORTRANGE instead.
.if defined (AMANDA_PORTRANGE)
AMANDA_TCPPORTRANGE= ${AMANDA_PORTRANGE}
@ -99,6 +105,12 @@ pre-fetch:
@${ECHO} " The default is no restriction on UDP ports."
@${ECHO} ""
post-patch:
@${REINPLACE_CMD} \
-e 's|^OPENSSL=.*$$|OPENSSL=${OPENSSLBASE}/bin/openssl|' \
${WRKSRC}/server-src/amcrypt-ossl.sh.in \
${WRKSRC}/server-src/amcrypt-ossl-asym.sh.in
USE_PERL5= yes
BUILD_DEPENDS+= ${LOCALBASE}/sbin/amrecover:${PORTSDIR}/misc/amanda-client
@ -116,8 +128,7 @@ MAN8= amadmin.8 amaespipe.8 amcheck.8 \
OPTIONS+= PLOT "enable ploting, requires X11 libraries" off\
SAMBA "enable the use of smbclient" off \
MTX "enable the use of mtx changer scripts" off \
AESPIPE "enable encryption. Needed by amcrypt" off \
SSH "enable ssh-auth" off
AESPIPE "enable encryption. Needed by amcrypt" off
.if defined (WITH_PLOT)
BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
@ -143,10 +154,6 @@ RUN_DEPENDS+= mtx:${PORTSDIR}/misc/mtx
RUN_DEPENDS+= aespipe:${PORTSDIR}/security/aespipe
.endif
.if defined (WITH_SSL)
CONFIGURE_ARGS+= --with-ssh-security
.endif
.if defined (AMANDA_TAPE)
CONFIGURE_ARGS+= --with-tape-device=${AMANDA_TAPE}
.endif
@ -214,4 +221,8 @@ EXTRA_PATCHES= ${FILESDIR}/extra-patch-sendbackup-dump.c
.endif
# Maintainer TODO:
# o amanda-server installs lib/libamandad.a which should be handled by
# amanda-client only.
.include <bsd.port.post.mk>

View File

@ -0,0 +1,11 @@
--- server-src/amcrypt-ossl-asym.sh.in.orig 2006-07-04 13:28:47.000000000 +0200
+++ server-src/amcrypt-ossl-asym.sh.in 2008-07-12 12:11:30.000000000 +0200
@@ -36,7 +36,7 @@
# change these as needed
OPENSSL= # whatever's in $PATH
CIPHER=aes-256-cbc # see `openssl help` for more ciphers
-AMANDA_HOME=~amandabackup
+AMANDA_HOME=~@CLIENT_LOGIN@
RANDFILE=$AMANDA_HOME/.rnd
export RANDFILE
PASSPHRASE=$AMANDA_HOME/.am_passphrase # optional

View File

@ -0,0 +1,11 @@
--- server-src/amcrypt-ossl.sh.in.orig 2006-07-04 13:28:47.000000000 +0200
+++ server-src/amcrypt-ossl.sh.in 2008-07-12 12:11:35.000000000 +0200
@@ -7,7 +7,7 @@
# change these as needed
OPENSSL= # whatever's in $PATH
CIPHER=aes-256-cbc # see `openssl help` for more ciphers
-AMANDA_HOME=~amandabackup
+AMANDA_HOME=~@CLIENT_LOGIN@
RANDFILE=$AMANDA_HOME/.rnd
export RANDFILE
PASSPHRASE=$AMANDA_HOME/.am_passphrase # required

View File

@ -6,7 +6,7 @@
#
PKGNAMESUFFIX= -client
PORTREVISION= 2
PORTREVISION= 3
COMMENT= The Advanced Maryland Automatic Network Disk Archiver (client)

View File

@ -7,7 +7,7 @@
PORTNAME= amanda
PORTVERSION= 2.5.1p3
PORTREVISION?= 4
PORTREVISION?= 5
PKGNAMESUFFIX?= -server
PORTEPOCH= 1
CATEGORIES= misc
@ -20,9 +20,10 @@ COMMENT?= The Advanced Maryland Automatic Network Disk Archiver (server)
WRKSRC= ${WRKDIR}/amanda-${PORTVERSION}
SLAVEDIRS= misc/amanda-client
NO_LATEST_LINK= yes
LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
USE_AUTOTOOLS= autoconf:261
USE_GMAKE= yes
USE_OPENSSL= yes
PATCH_STRIP=
CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--with-amandahosts --with-fqdn \
@ -32,7 +33,8 @@ CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
USE_LDCONFIG= yes
WANT_PERL= yes
OPTIONS= GNUTAR "use GNU tar" on
OPTIONS= GNUTAR "use GNU tar" on \
SSH "enable ssh-auth" off
.include <bsd.port.pre.mk>
@ -57,6 +59,10 @@ CONFIGURE_ARGS+= --with-config=${AMANDA_CONFIG}
CONFIGURE_ARGS+= --with-udpportrange=${AMANDA_UDPPORTRANGE}
.endif
.if defined (WITH_SSH)
CONFIGURE_ARGS+= --with-ssh-security
.endif
# AMANDA_PORTRANGE is obsoleted. Use AMANDA_TCPPORTRANGE instead.
.if defined (AMANDA_PORTRANGE)
AMANDA_TCPPORTRANGE= ${AMANDA_PORTRANGE}
@ -99,6 +105,12 @@ pre-fetch:
@${ECHO} " The default is no restriction on UDP ports."
@${ECHO} ""
post-patch:
@${REINPLACE_CMD} \
-e 's|^OPENSSL=.*$$|OPENSSL=${OPENSSLBASE}/bin/openssl|' \
${WRKSRC}/server-src/amcrypt-ossl.sh.in \
${WRKSRC}/server-src/amcrypt-ossl-asym.sh.in
USE_PERL5= yes
BUILD_DEPENDS+= ${LOCALBASE}/sbin/amrecover:${PORTSDIR}/misc/amanda-client
@ -116,8 +128,7 @@ MAN8= amadmin.8 amaespipe.8 amcheck.8 \
OPTIONS+= PLOT "enable ploting, requires X11 libraries" off\
SAMBA "enable the use of smbclient" off \
MTX "enable the use of mtx changer scripts" off \
AESPIPE "enable encryption. Needed by amcrypt" off \
SSH "enable ssh-auth" off
AESPIPE "enable encryption. Needed by amcrypt" off
.if defined (WITH_PLOT)
BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
@ -143,10 +154,6 @@ RUN_DEPENDS+= mtx:${PORTSDIR}/misc/mtx
RUN_DEPENDS+= aespipe:${PORTSDIR}/security/aespipe
.endif
.if defined (WITH_SSL)
CONFIGURE_ARGS+= --with-ssh-security
.endif
.if defined (AMANDA_TAPE)
CONFIGURE_ARGS+= --with-tape-device=${AMANDA_TAPE}
.endif
@ -214,4 +221,8 @@ EXTRA_PATCHES= ${FILESDIR}/extra-patch-sendbackup-dump.c
.endif
# Maintainer TODO:
# o amanda-server installs lib/libamandad.a which should be handled by
# amanda-client only.
.include <bsd.port.post.mk>

View File

@ -0,0 +1,11 @@
--- server-src/amcrypt-ossl-asym.sh.in.orig 2006-07-04 13:28:47.000000000 +0200
+++ server-src/amcrypt-ossl-asym.sh.in 2008-07-12 12:11:30.000000000 +0200
@@ -36,7 +36,7 @@
# change these as needed
OPENSSL= # whatever's in $PATH
CIPHER=aes-256-cbc # see `openssl help` for more ciphers
-AMANDA_HOME=~amandabackup
+AMANDA_HOME=~@CLIENT_LOGIN@
RANDFILE=$AMANDA_HOME/.rnd
export RANDFILE
PASSPHRASE=$AMANDA_HOME/.am_passphrase # optional

View File

@ -0,0 +1,11 @@
--- server-src/amcrypt-ossl.sh.in.orig 2006-07-04 13:28:47.000000000 +0200
+++ server-src/amcrypt-ossl.sh.in 2008-07-12 12:11:35.000000000 +0200
@@ -7,7 +7,7 @@
# change these as needed
OPENSSL= # whatever's in $PATH
CIPHER=aes-256-cbc # see `openssl help` for more ciphers
-AMANDA_HOME=~amandabackup
+AMANDA_HOME=~@CLIENT_LOGIN@
RANDFILE=$AMANDA_HOME/.rnd
export RANDFILE
PASSPHRASE=$AMANDA_HOME/.am_passphrase # required