Update to 1.8, and retain shared lib version of 3.

Reviewed by:	sobomax
This commit is contained in:
Joe Marcus Clarke 2002-06-16 19:11:11 +00:00
parent 1350c19569
commit b8c5a741af
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=61388
6 changed files with 30 additions and 25 deletions

View File

@ -6,14 +6,10 @@
#
PORTNAME= libiconv
PORTVERSION= 1.7.0.1
PORTVERSION= 1.8
CATEGORIES= converters devel
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://www.marcuscom.com/downloads/ \
ftp://ftp.ilog.fr/pub/Users/haible/gnu/ \
${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= marcus \
${PORTNAME}
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= gnome@FreeBSD.org
@ -36,6 +32,6 @@ GPERF= /usr/bin/gperf
.endif
pre-build:
@cd ${WRKSRC} ; ${GPERF} -t -L ANSI-C -H aliases_hash -N aliases_lookup -7 -C -k '1,3-11,$$' -i 1 lib/aliases.gperf > lib/aliases.h
@cd ${WRKSRC} ; ${GPERF} -t -L ANSI-C -H aliases_hash -N aliases_lookup -G -W aliases -7 -C -k '1,3-11,$$' -i 1 lib/aliases.gperf > lib/aliases.h
.include <bsd.port.post.mk>

View File

@ -1 +1 @@
MD5 (libiconv-1.7.0.1.tar.gz) = b4bcf45da1208360647c8a0928acf03d
MD5 (libiconv-1.8.tar.gz) = fd2a95a4b79fbdc8ea55ad093a8bb6cf

View File

@ -1,13 +1,10 @@
$FreeBSD$
--- lib/Makefile.in.orig Thu Jun 28 01:37:49 2001
+++ lib/Makefile.in Sun Mar 17 11:34:57 2002
--- lib/Makefile.in.orig Sat Jun 15 14:42:20 2002
+++ lib/Makefile.in Sat Jun 15 14:42:27 2002
@@ -39,7 +39,7 @@
# Before making a release, change this according to the libtool documentation,
# section "Library interface versions".
-LIBICONV_VERSION_INFO = 2:4:0
-LIBICONV_VERSION_INFO = 3:0:1
+LIBICONV_VERSION_INFO = 3
# Needed by $(LIBTOOL).

View File

@ -1,9 +1,9 @@
$FreeBSD$
--- include/iconv.h.in.orig Mon Jun 25 15:06:22 2001
+++ include/iconv.h.in Sun Mar 17 15:41:14 2002
@@ -21,6 +21,10 @@
--- include/iconv.h.in.orig Thu May 23 07:48:42 2002
+++ include/iconv.h.in Sat Jun 15 14:04:11 2002
@@ -21,6 +21,11 @@
#ifndef _LIBICONV_H
#define _LIBICONV_H
@ -11,10 +11,11 @@ $FreeBSD$
+#define LIBICONV_PLUG
+#endif
+
#define _LIBICONV_VERSION 0x0107 /* version number: (major<<8) + minor */
+
#define _LIBICONV_VERSION 0x0108 /* version number: (major<<8) + minor */
extern int _libiconv_version; /* Likewise */
@@ -68,6 +72,8 @@
@@ -68,6 +73,8 @@
encoding `tocode'. */
#ifndef LIBICONV_PLUG
#define iconv_open libiconv_open
@ -23,7 +24,7 @@ $FreeBSD$
#endif
extern iconv_t iconv_open (const char* tocode, const char* fromcode);
@@ -78,17 +84,21 @@
@@ -78,17 +85,21 @@
Decrements `*outbytesleft' and increments `*outbuf' by the same amount. */
#ifndef LIBICONV_PLUG
#define iconv libiconv

View File

@ -1,5 +1,5 @@
--- lib/loop_unicode.h.orig Fri Jun 8 22:04:33 2001
+++ lib/loop_unicode.h Mon Apr 29 05:12:08 2002
--- lib/loop_unicode.h.orig Mon May 6 06:17:43 2002
+++ lib/loop_unicode.h Sat Jun 15 14:07:14 2002
@@ -52,8 +52,7 @@
cd->ostate = backup_state;
outptr = backup_outptr;
@ -16,7 +16,7 @@
outleft = backup_outleft;
- if (sub_outcount < 0)
- return RET_TOOSMALL;
+ return sub_outcount;
+ return sub_outcount;
}
if (last)
break;
@ -24,7 +24,7 @@
cd->ostate = backup_state;
outptr = backup_outptr;
outleft = backup_outleft;
- if (sub_outcount < 0)
- if (sub_outcount != RET_ILUNI)
- return RET_TOOSMALL;
+ return sub_outcount;
}

View File

@ -0,0 +1,11 @@
--- src/Makefile.in.orig Sat Jun 15 14:25:55 2002
+++ src/Makefile.in Sat Jun 15 14:26:05 2002
@@ -77,7 +77,7 @@
if [ ! -d $(DESTDIR)$(exec_prefix) ] ; then mkdir $(DESTDIR)$(exec_prefix) ; fi
if [ ! -d $(DESTDIR)$(bindir) ] ; then mkdir $(DESTDIR)$(bindir) ; fi
case "@host_os@" in \
- hpux*) $(CC) $(LDFLAGS) iconv.@OBJEXT@ -L$(libdir) -liconv @LIBINTL@ -o iconv;; \
+ hpux*|freebsd*) $(CC) $(LDFLAGS) iconv.@OBJEXT@ -L$(libdir) -liconv @LIBINTL@ -o iconv;; \
*) $(LIBTOOL_LINK) $(CC) $(LDFLAGS) iconv.@OBJEXT@ $(libdir)/libiconv.la @LTLIBINTL@ -o iconv;; \
esac
$(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) iconv $(DESTDIR)$(bindir)/iconv