Stagify the port; fix Makefile header.

This commit is contained in:
Alexey Dokuchaev 2014-06-10 06:31:31 +00:00
parent dd17040118
commit b8ba0aab09
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=357272
2 changed files with 16 additions and 2 deletions

View File

@ -1,4 +1,4 @@
# Created by: freebsd@spatula.net
# Created by: Nicklas Johnson <freebsd@spatula.net>
# $FreeBSD$
PORTNAME= speak
@ -11,5 +11,4 @@ COMMENT= Generates random middle-management synergy speak
CONFLICTS= espeak-1.[0-9]*
NO_STAGE= yes
.include <bsd.port.mk>

View File

@ -0,0 +1,15 @@
--- Makefile.orig 2000-02-16 03:45:31 +0800
+++ Makefile
@@ -11,9 +11,9 @@ speak: speak.o
${CC} -o speak speak.o
install: all
- ${INSTALL} -c -s -o root -g games -m 755 speak ${BINDIR}
- ${INSTALL} -d -o root -g games -m 755 ${SPEAKDIR}
- ${INSTALL} -c -o root -g games -m 644 speak.nouns speak.actions speak.wrk speak.leadins README ${SPEAKDIR}
+ ${INSTALL} -s -m 755 speak ${DESTDIR}${BINDIR}
+ ${INSTALL} -d -m 755 ${DESTDIR}${SPEAKDIR}
+ ${INSTALL} -m 644 speak.nouns speak.actions speak.wrk speak.leadins README ${DESTDIR}${SPEAKDIR}
clean:
rm -f *.core *.o speak