Update to 1.9.98
PR: 214212 Submitted by: Max Kostikov <max@kostikov.co> (maintainer)
This commit is contained in:
parent
d4b0dd66c9
commit
b8891ea033
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=425492
@ -2,35 +2,30 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= megatools
|
||||
PORTVERSION= 1.9.97
|
||||
PORTVERSION= 1.9.98
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://megatools.megous.com/builds/
|
||||
|
||||
MAINTAINER= max@kostikov.co
|
||||
COMMENT= Tools for MEGA.CO.NZ cloud drive
|
||||
COMMENT= Command line tools for MEGA.NZ cloud drive
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
LIB_DEPENDS= libcurl.so:ftp/curl
|
||||
BUILD_DEPENDS= asciidoc:textproc/asciidoc
|
||||
RUN_DEPENDS= glib-networking>=2.32.0:net/glib-networking
|
||||
|
||||
CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
|
||||
OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto -lssl"
|
||||
USES= gmake pkgconfig libtool pathfix
|
||||
USE_LDCONFIG= yes
|
||||
USES= gettext-runtime gmake libtool pathfix pkgconfig ssl
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GNOME= glib20
|
||||
USE_OPENSSL= yes
|
||||
|
||||
INSTALL_TARGET= install-strip
|
||||
CONFIGURE_ARGS= --enable-introspection=no
|
||||
|
||||
OPTIONS_DEFINE= FUSE
|
||||
OPTIONS_DEFAULT= FUSE
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
FUSE_USES= fuse
|
||||
FUSE_CONFIGURE_WITH= fuse
|
||||
post-patch:
|
||||
# Unsilence build
|
||||
${REINPLACE_CMD} -e '/^export\ MAKEFLAGS/s|^|#|' ${WRKSRC}/Makefile.in
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (megatools-1.9.97.tar.gz) = 3316c56ee55adef0ab113aad41ef95eb28fc15218639f69b1e04362b1c725af3
|
||||
SIZE (megatools-1.9.97.tar.gz) = 446801
|
||||
TIMESTAMP = 1478256777
|
||||
SHA256 (megatools-1.9.98.tar.gz) = 9b0521a4d27dbc417fc8e12610ac1e1da729bf6d6eb5bef927ef3670b372a16f
|
||||
SIZE (megatools-1.9.98.tar.gz) = 285805
|
||||
|
33
net/megatools/files/patch-lib_mega.c
Normal file
33
net/megatools/files/patch-lib_mega.c
Normal file
@ -0,0 +1,33 @@
|
||||
Fix build for FreeBSD 9.x base OpenSSL and LibreSSL. Fix for LibreSSL is
|
||||
already in upstream repository, so this file can be removed once FreeBSD 9.x
|
||||
support is dropped AND the next version of megatools is released.
|
||||
--- lib/mega.c.orig 2016-11-03 13:45:42 UTC
|
||||
+++ lib/mega.c
|
||||
@@ -29,7 +29,9 @@
|
||||
#include <string.h>
|
||||
#include <time.h>
|
||||
#include <openssl/aes.h>
|
||||
+#if OPENSSL_VERSION_NUMBER >= 0x101000000L && !defined(LIBRESSL_VERSION_NUMBER)
|
||||
#include <openssl/modes.h>
|
||||
+#endif
|
||||
#include <openssl/bn.h>
|
||||
#include <openssl/rsa.h>
|
||||
#include <openssl/rand.h>
|
||||
@@ -803,7 +805,7 @@ static gboolean rsa_key_gen(rsa_key* k)
|
||||
return FALSE;
|
||||
}
|
||||
|
||||
-#if OPENSSL_VERSION_NUMBER >= 0x10100000L
|
||||
+#if OPENSSL_VERSION_NUMBER >= 0x101000000L && !defined(LIBRESSL_VERSION_NUMBER)
|
||||
RSA_get0_key(key, &k->m, &k->e, &k->d);
|
||||
RSA_get0_factors(key, &k->q, &k->p);
|
||||
RSA_get0_crt_params(key, NULL, NULL, &k->u);
|
||||
@@ -2988,7 +2990,7 @@ struct _put_data
|
||||
GByteArray* buffer;
|
||||
};
|
||||
|
||||
-#if OPENSSL_VERSION_NUMBER >= 0x10100000L
|
||||
+#if OPENSSL_VERSION_NUMBER >= 0x101000000L && !defined(LIBRESSL_VERSION_NUMBER)
|
||||
void AES_ctr128_encrypt(
|
||||
const unsigned char *in,
|
||||
unsigned char *out,
|
@ -1,29 +1,15 @@
|
||||
bin/megacopy
|
||||
bin/megadf
|
||||
bin/megadl
|
||||
%%FUSE%%bin/megafs
|
||||
bin/megaget
|
||||
bin/megals
|
||||
bin/megamkdir
|
||||
bin/megaput
|
||||
bin/megareg
|
||||
bin/megarm
|
||||
include/mega/mega-aes-ctr-encryptor.h
|
||||
include/mega/mega-aes-key.h
|
||||
include/mega/mega-chunked-cbc-mac.h
|
||||
include/mega/mega-enum-types.h
|
||||
include/mega/mega-rsa-key.h
|
||||
include/mega/mega.h
|
||||
include/mega/utils.h
|
||||
lib/libmega.a
|
||||
lib/libmega.so
|
||||
lib/libmega.so.0
|
||||
lib/libmega.so.0.0.0
|
||||
libdata/pkgconfig/libmega.pc
|
||||
man/man1/megacopy.1.gz
|
||||
man/man1/megadf.1.gz
|
||||
man/man1/megadl.1.gz
|
||||
%%FUSE%%man/man1/megafs.1.gz
|
||||
man/man1/megaget.1.gz
|
||||
man/man1/megals.1.gz
|
||||
man/man1/megamkdir.1.gz
|
||||
|
Loading…
Reference in New Issue
Block a user