- Update to 1.0

Submitted by:	portscout via miwibot
This commit is contained in:
Thomas Abthorpe 2010-05-20 15:14:14 +00:00
parent d566cd0b47
commit b880ed17ee
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=254656
3 changed files with 16 additions and 14 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= since
PORTVERSION= 0.9
PORTVERSION= 1.0
CATEGORIES= misc
MASTER_SITES= http://welz.org.za/projects/since/

View File

@ -1,3 +1,3 @@
MD5 (since-0.9.tar.gz) = f33295867f2e0674e69de59bee2eb6a7
SHA256 (since-0.9.tar.gz) = 118fe2275f77039cce56161ea067d3731f690fb9446942d7bf249253d7c9de83
SIZE (since-0.9.tar.gz) = 24804
MD5 (since-1.0.tar.gz) = 65b35887f3d285cb5190a9002e9d9d05
SHA256 (since-1.0.tar.gz) = 3fb71bb78cb65e998aa7d4ddf49af66d6565cda6d1efe390149ff557f816cbf0
SIZE (since-1.0.tar.gz) = 24815

View File

@ -1,27 +1,29 @@
--- ./Makefile.orig 2009-01-05 15:52:55.000000000 -0500
+++ ./Makefile 2009-06-17 14:05:36.000000000 -0400
@@ -1,4 +1,4 @@
-prefix=/usr/local
+#prefix=/usr/local
--- ./Makefile.orig 2009-07-11 16:45:30.000000000 -0400
+++ ./Makefile 2010-05-20 10:53:02.000000000 -0400
@@ -1,25 +1,22 @@
# IMHO auto{make,conf} is overkill. Simple, readable makefiles improve security
-prefix=/usr/local
NAME = since
VERSION = 0.9
@@ -9,16 +9,16 @@
VERSION = 1.0
-CFLAGS = -Wall -O2 -DVERSION=\"$(VERSION)\"
+CFLAGS += -Wall -DVERSION=\"$(VERSION)\"
# disable/enable as desired
CFLAGS += $(shell test -f /usr/include/sys/inotify.h && echo -DUSE_INOTIFY)
CFLAGS += -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
#CFLAGS += -DDEBUG
-CC = gcc
+#CC = gcc
RM = rm -f
-INSTALL = install -D
+#INSTALL = install -D
$(NAME): $(NAME).c
$(CC) $(CFLAGS) -o $@ $^
install: $(NAME)
- $(INSTALL) $(NAME) $(prefix)/bin/$(NAME)
- $(INSTALL) $(NAME).1 $(prefix)/share/man1/$(NAME).1
- $(INSTALL) $(NAME).1 $(prefix)/share/man/man1/$(NAME).1
+ $(BSD_INSTALL_PROGRAM) $(NAME) $(PREFIX)/bin/$(NAME)
+ $(BSD_INSTALL_MAN) $(NAME).1 $(PREFIX)/man/man1/$(NAME).1