- Fix build on -current

PR:		58876
Submitted by:	Ports Fury
This commit is contained in:
Kirill Ponomarev 2003-11-03 18:59:15 +00:00
parent 96a6a859cb
commit b87ad4546b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=92985
26 changed files with 317 additions and 26 deletions

View File

@ -17,6 +17,9 @@ COMMENT= A fast-action, networked, anti-social, kill-everything game
USE_X_PREFIX= yes
USE_ZIP= yes
USE_XPM= yes
USE_REINPLACE= yes
MAKE_ENV= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}"
MAKEFILE= makefile
ALL_TARGET= freebsd
.include <bsd.port.pre.mk>
@ -26,26 +29,19 @@ ALL_TARGET= freebsd
CFLAGS+="-DXEVIL_KEYSET=UIalpha"
.endif
.if ${OSVERSION} >= 501000
BROKEN= "Does not compile on FreeBSD ${OSVERSION}"
.endif
pre-extract:
@${MKDIR} ${WRKDIR}/${DISTNAME}
do-extract:
@unzip -aqo ${DISTDIR}/${DISTFILES} -d ${WRKSRC}
post-extract:
@${MV} -f ${WRKDIR}/${DISTNAME}/makefile ${WRKDIR}/${DISTNAME}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/x11/FREEBSD/xevil ${PREFIX}/bin/xevil
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/xevil/instructions
${INSTALL_DATA} ${WRKSRC}/readme.txt ${PREFIX}/share/doc/xevil
${INSTALL_DATA} ${WRKSRC}/instructions/* \
${PREFIX}/share/doc/xevil/instructions
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
@${MKDIR} ${DOCSDIR}/instructions
${INSTALL_DATA} ${WRKSRC}/instructions/* ${DOCSDIR}/instructions
.endif
.include <bsd.port.post.mk>

View File

@ -1,5 +1,5 @@
--- config.mk.orig Sun Mar 23 00:08:58 2003
+++ config.mk Sun May 18 12:02:44 2003
+++ config.mk Sat Oct 25 21:05:31 2003
@@ -34,7 +34,7 @@
# You can add -DNDEBUG to speed up a release build by removing the assert()
# calls. But, on a really obscure Linux machine, this caused Xlib to blow up
@ -20,12 +20,14 @@
archit=$$HOSTTYPE ; \
elif [ $${hosttype-bob} != bob ] ; then \
archit=$$hosttype ; \
@@ -162,7 +164,7 @@
@@ -161,8 +163,8 @@
# The -DMSEC_PER_CLOCK=8 is kind of a hack, take it out if the game speed of
# XEvil is all screwed up.
freebsd:
@$(MAKE) CC="c++" \
- @$(MAKE) CC="c++" \
-CFLAGS="-DUSE_RANDOM -DPROTECTED_IS_PUBLIC -DMSEC_PER_CLOCK=8 -DUNAME_USR_BIN" \
+CFLAGS="-DUSE_RANDOM -DUSE_UINT_NET_LENGTH -DUNAME_USR_BIN ${CFLAGS}" \
+ @$(MAKE) CC="${CXX}" \
+CFLAGS="-DUSE_RANDOM -DUSE_UINT_NET_LENGTH -DUNAME_USR_BIN ${CXXFLAGS}" \
INCL_DIRS="-I/usr/X11R6/include" LIBS_DIRS="-L/usr/X11R6/lib" \
OBJ_DIR=$(DEPTH)/x11/FREEBSD PCKG_NAME="freebsd" \
LIBS="-lXpm -lX11 -lm" $(TARGETS)

View File

@ -1,5 +1,5 @@
--- Makefile.orig Sun Mar 23 00:09:08 2003
+++ Makefile Sun May 18 12:05:08 2003
--- makefile.orig Sun Mar 23 00:09:08 2003
+++ makefile Sun May 18 12:05:08 2003
@@ -63,11 +63,6 @@
# Could also include serverping in the distribution

View File

@ -0,0 +1,12 @@
--- cmn/actual.cpp.orig Wed Jan 19 12:54:36 2000
+++ cmn/actual.cpp Sat Oct 25 21:39:07 2003
@@ -32,7 +32,8 @@
// Include Files
#if X11
-#include <strstream.h>
+#include <strstream>
+using namespace std;
#endif
#if WIN32
#include <strstrea.h>

View File

@ -0,0 +1,12 @@
--- cmn/area.cpp.orig Wed Mar 19 10:04:22 2003
+++ cmn/area.cpp Sat Oct 25 21:39:50 2003
@@ -34,7 +34,8 @@
extern "C" {
#include <limits.h> // For INT_MAX
}
-#include <iostream.h>
+#include <iostream>
+using namespace std;
#include "utils.h"
#include "coord.h"
#include "area.h"

View File

@ -0,0 +1,12 @@
--- cmn/game.cpp.orig Sat Mar 22 22:20:00 2003
+++ cmn/game.cpp Sat Oct 25 21:40:23 2003
@@ -34,7 +34,8 @@
}
#if X11
-#include <strstream.h>
+#include <strstream>
+using namespace std;
#endif
#if WIN32
#include <strstrea.h>

View File

@ -0,0 +1,12 @@
--- cmn/game.h.dist Sat Mar 22 20:44:32 2003
+++ cmn/game.h Sat Oct 25 21:40:54 2003
@@ -35,7 +35,8 @@
extern "C" {
#include <time.h>
}
-#include <iostream.h>
+#include <iostream>
+using namespace std;
#include "utils.h"
#include "ui.h"
#include "world.h"

View File

@ -0,0 +1,12 @@
--- cmn/game_style.cpp.orig Sat Mar 22 20:47:42 2003
+++ cmn/game_style.cpp Sat Oct 25 21:41:21 2003
@@ -34,7 +34,8 @@
}
#if X11
-#include <strstream.h>
+#include <strstream>
+using namespace std;
#endif
#if WIN32

View File

@ -0,0 +1,12 @@
--- cmn/game_style.h.dist Sat Mar 22 20:22:30 2003
+++ cmn/game_style.h Sat Oct 25 21:41:50 2003
@@ -31,7 +31,8 @@
#endif
#if X11
-#include <strstream.h>
+#include <strstream>
+using namespace std;
#endif
#if WIN32
#include <strstrea.h>

View File

@ -0,0 +1,12 @@
--- cmn/intel.cpp.orig Wed Mar 19 09:49:22 2003
+++ cmn/intel.cpp Sat Oct 25 21:42:14 2003
@@ -35,7 +35,8 @@
#include <string.h>
}
#if X11
-#include <strstream.h>
+#include <strstream>
+using namespace std;
#endif
#if WIN32
#include <strstrea.h>

View File

@ -0,0 +1,12 @@
--- cmn/locator.h.dist Sat Mar 22 20:35:30 2003
+++ cmn/locator.h Sat Oct 25 21:42:46 2003
@@ -47,7 +47,8 @@
// Include Files
-#include <iostream.h>
+#include <iostream>
+using namespace std;
#include "utils.h"
#include "coord.h"

View File

@ -0,0 +1,16 @@
--- cmn/physical.cpp.orig Wed Jan 19 20:38:14 2000
+++ cmn/physical.cpp Sat Oct 25 21:43:15 2003
@@ -33,10 +33,11 @@
// Include Files
#include "xdata.h"
#include "physical.h"
-#include <iostream.h>
+#include <iostream>
+using namespace std;
#if X11
-#include <strstream.h>
+#include <strstream>
#endif
#if WIN32
#include <strstrea.h>

View File

@ -0,0 +1,11 @@
--- cmn/physical.h.orig Wed Jan 19 12:54:08 2000
+++ cmn/physical.h Mon Nov 3 21:36:14 2003
@@ -93,7 +93,7 @@
CLASSNAME::CLASSNAME(InStreamP in,const CLASSNAME ## Context &cx, \
CLASSNAME ## Xdata &x_data, \
WorldP w,LocatorP l) \
- : PARENT(in,cx. ## parent ## Context,x_data,w,l)
+ : PARENT(in,cx. parent ## Context,x_data,w,l)
// Used by internal nodes and leaves.
#define DEFINE_UPDATE_FROM_STREAM(CLASSNAME,PARENT) \

View File

@ -0,0 +1,15 @@
--- cmn/role.cpp.orig Wed Jan 19 12:54:34 2000
+++ cmn/role.cpp Sat Oct 25 21:43:43 2003
@@ -29,9 +29,10 @@
#include "stdafx.h"
-#include <iostream.h>
+#include <iostream>
+using namespace std;
#if X11
-#include <strstream.h>
+#include <strstream>
#include <time.h>
#endif
#if WIN32

View File

@ -0,0 +1,12 @@
--- cmn/streams.cpp.orig Wed Jan 19 12:54:32 2000
+++ cmn/streams.cpp Sat Oct 25 21:44:08 2003
@@ -31,7 +31,8 @@
#include "utils.h"
#include "neth.h" // needed for recv, send, recvfrom, sendto
-#include <iostream.h>
+#include <iostream>
+using namespace std;
#include "streams.h"
#include "xetp.h" // yuck, need this for XETP::versionStr

View File

@ -0,0 +1,26 @@
--- cmn/utils.cpp.orig Wed Mar 19 10:05:12 2003
+++ cmn/utils.cpp Sat Oct 25 21:45:15 2003
@@ -30,16 +30,17 @@
// Include Files
#include "stdafx.h"
-#include <iostream.h>
-#include <limits.h>
-#include <string.h>
-#include <ctype.h>
-#include <fstream.h>
+#include <iostream>
+#include <climits>
+#include <cstring>
+#include <cctype>
+#include <fstream>
+using namespace std;
#if WIN32
#include <strstrea.h>
#endif
#if X11
-#include <strstream.h>
+#include <strstream>
#endif
#ifdef WIN32

View File

@ -0,0 +1,12 @@
--- cmn/world.cpp.orig Wed Jan 19 21:15:08 2000
+++ cmn/world.cpp Sat Oct 25 21:45:40 2003
@@ -35,7 +35,8 @@
#endif
// Include Files.
-#include <iostream.h>
+#include <iostream>
+using namespace std;
#include "utils.h"
#include "coord.h"

View File

@ -0,0 +1,15 @@
--- cmn/xetp.cpp.orig Wed Jan 19 12:54:30 2000
+++ cmn/xetp.cpp Sat Oct 25 21:46:02 2003
@@ -29,9 +29,10 @@
#include "stdafx.h"
-#include <iostream.h>
+#include <iostream>
+using namespace std;
#if X11
-#include <strstream.h>
+#include <strstream>
#endif
#if WIN32
#include <strstrea.h>

View File

@ -0,0 +1,12 @@
--- x11/l_agreement_dlg.cpp.orig Wed Jan 19 12:55:04 2000
+++ x11/l_agreement_dlg.cpp Sat Oct 25 21:46:33 2003
@@ -31,7 +31,8 @@
#include <X11/Xatom.h>
}
-#include <strstream.h>
+#include <strstream>
+using namespace std;
#include "xdata.h"
#include "panel.h"

View File

@ -0,0 +1,12 @@
--- x11/main.cpp.orig Sat Mar 22 20:52:14 2003
+++ x11/main.cpp Sat Oct 25 21:47:04 2003
@@ -33,7 +33,8 @@
#include <X11/Xos.h>
}
-#include <iostream.h>
+#include <iostream>
+using namespace std;
#include "utils.h"
#include "neth.h"

View File

@ -0,0 +1,14 @@
--- x11/panel.cpp.orig Sat Mar 22 20:50:44 2003
+++ x11/panel.cpp Sat Oct 25 21:47:34 2003
@@ -31,8 +31,9 @@
#include <X11/Xutil.h>
#include <X11/keysym.h>
}
-#include <iostream.h>
-#include <strstream.h>
+#include <iostream>
+#include <strstream>
+using namespace std;
#include "utils.h"
#include "xdata.h"

View File

@ -0,0 +1,14 @@
--- x11/serverping.cpp.orig Sat Mar 22 21:55:12 2003
+++ x11/serverping.cpp Sat Oct 25 21:48:03 2003
@@ -25,8 +25,9 @@
// code and should be reasonably easy to compile on Windows.
-#include <iostream.h>
-#include <strstream.h>
+#include <iostream>
+#include <strstream>
+using namespace std;
#include "utils.h"
#include "streams.h"
#include "xetp_basic.h"

View File

@ -0,0 +1,14 @@
--- x11/ui.cpp.orig Wed Mar 19 10:05:38 2003
+++ x11/ui.cpp Sat Oct 25 21:48:32 2003
@@ -40,8 +40,9 @@
#include <X11/Xatom.h>
}
-#include <iostream.h>
-#include <strstream.h>
+#include <iostream>
+#include <strstream>
+using namespace std;
#include "coord.h"
#include "area.h"

View File

@ -0,0 +1,12 @@
--- x11/viewport.cpp.orig Wed Jan 19 12:54:14 2000
+++ x11/viewport.cpp Sat Oct 25 21:49:00 2003
@@ -44,7 +44,8 @@
#include <X11/Xos.h>
#include <X11/keysym.h>
}
-#include <strstream.h>
+#include <strstream>
+using namespace std;
#define TICK_BORDER_WIDTH 5 // border width big enough for a tick mark.

View File

@ -0,0 +1,12 @@
--- x11/xdata.cpp.orig Wed Jan 19 12:54:14 2000
+++ x11/xdata.cpp Sat Oct 25 21:49:26 2003
@@ -30,7 +30,8 @@
#include "xdata.h"
#include "area.h"
-#include <iostream.h>
+#include <iostream>
+using namespace std;
#include <X11/Xutil.h>
#include <X11/xpm.h>
#include <X11/Xatom.h>

View File

@ -1,10 +1,10 @@
bin/xevil
share/doc/xevil/instructions/UNIXSetControls.gif
share/doc/xevil/instructions/UNIXShowControls.gif
share/doc/xevil/instructions/UNIXmenu.gif
share/doc/xevil/instructions/instructions.html
share/doc/xevil/instructions/keysdlg.gif
share/doc/xevil/instructions/optionsdlg.gif
share/doc/xevil/readme.txt
@dirrm share/doc/xevil/instructions
@dirrm share/doc/xevil
%%PORTDOCS%%%%DOCSDIR%%/instructions/UNIXSetControls.gif
%%PORTDOCS%%%%DOCSDIR%%/instructions/UNIXShowControls.gif
%%PORTDOCS%%%%DOCSDIR%%/instructions/UNIXmenu.gif
%%PORTDOCS%%%%DOCSDIR%%/instructions/instructions.html
%%PORTDOCS%%%%DOCSDIR%%/instructions/keysdlg.gif
%%PORTDOCS%%%%DOCSDIR%%/instructions/optionsdlg.gif
%%PORTDOCS%%%%DOCSDIR%%/readme.txt
%%PORTDOCS%%@dirrm %%DOCSDIR%%/instructions
%%PORTDOCS%%@dirrm %%DOCSDIR%%