- Synchronized with latest version (1.1.4).
- Deleted dependency on japanese Tcl/Tk 8.0.5 - Added dependency on Tcl/Tk 8.3. - Works also with japanese messages. - (Info) To input japanese, execute: env LANG=ja_JP.eucJP XMODIFIERS=@im=kinput2 tkfax PR: ports/73930 Submitted by: Lupe Christoph <lupe@lupe-christoph.de> pointed out the dependency problem.
This commit is contained in:
parent
2580a857ec
commit
b8460b50ff
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=121810
@ -6,16 +6,16 @@
|
||||
#
|
||||
|
||||
PORTNAME= tkscanfax
|
||||
PORTVERSION= 1.02
|
||||
CATEGORIES= comms
|
||||
MASTER_SITES= http://shino.pos.to/linux/
|
||||
PORTVERSION= 1.1.4
|
||||
CATEGORIES= comms tk83
|
||||
MASTER_SITES= http://shino.pos.to/linux/tkscanfax/
|
||||
|
||||
MAINTAINER= mita@FreeBSD.org
|
||||
COMMENT= Tcl/Tk frontend for fax scan/receive/send program (command is tkfax)
|
||||
|
||||
RUN_DEPENDS= wish8.0jp:${PORTSDIR}/japanese/tk80
|
||||
RUN_DEPENDS= wish8.3:${PORTSDIR}/x11-toolkits/tk83
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}1
|
||||
NO_BUILD= YES
|
||||
|
||||
post-extract:
|
||||
@ -24,10 +24,10 @@ post-extract:
|
||||
do-install:
|
||||
(\
|
||||
cd ${WRKDIR}; \
|
||||
${TAR} '--exclude=*.orig' -cf - tkscanfax | \
|
||||
${TAR} '--exclude=*.orig' -cf - tkscanfax1 | \
|
||||
${TAR} -C ${PREFIX}/lib -xf - ; \
|
||||
${LN} -sf ${PREFIX}/lib/tkscanfax/tkscan ${PREFIX}/bin ; \
|
||||
${LN} -sf ${PREFIX}/lib/tkscanfax/tkfax ${PREFIX}/bin \
|
||||
${LN} -sf ${PREFIX}/lib/tkscanfax1/tkscan ${PREFIX}/bin ; \
|
||||
${LN} -sf ${PREFIX}/lib/tkscanfax1/tkfax ${PREFIX}/bin \
|
||||
)
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (tkscanfax-1.02.tar.gz) = 89dab477e35d02b71d747ab61151c89f
|
||||
SIZE (tkscanfax-1.02.tar.gz) = 167608
|
||||
MD5 (tkscanfax-1.1.4.tar.gz) = 689ce34520a566d22756c8e25c9cf7f7
|
||||
SIZE (tkscanfax-1.1.4.tar.gz) = 224163
|
||||
|
10
comms/tkscanfax/files/patch-src:fax-init.tcl
Normal file
10
comms/tkscanfax/files/patch-src:fax-init.tcl
Normal file
@ -0,0 +1,10 @@
|
||||
--- fax-init.tcl.orig Wed Nov 17 20:07:15 2004
|
||||
+++ fax-init.tcl Wed Nov 17 20:07:34 2004
|
||||
@@ -409,6 +409,7 @@
|
||||
set fid [open $lockfile r]
|
||||
gets $fid pid
|
||||
close $fid
|
||||
+ set notrun 1
|
||||
catch {set notrun [exec sh -c "ps -p $pid > /dev/null; echo $?"]}
|
||||
if {! $notrun} {
|
||||
if [tk_dialog .dialog "TkFax lock file found" \
|
@ -1,19 +0,0 @@
|
||||
*** fax-lib.tcl.orig Thu May 23 19:49:44 2002
|
||||
--- fax-lib.tcl Thu May 23 19:53:24 2002
|
||||
***************
|
||||
*** 675,681 ****
|
||||
foreach dir {userdir texdir pbookdir tmpdir} {
|
||||
exec mkdir $fax($dir)
|
||||
}
|
||||
! exec echo -e "Misc\tMiscellaneous fax numbers" \
|
||||
> $fax(pbookdir)/group.pbd
|
||||
exec touch $fax(pbookdir)/Misc.pbd
|
||||
}
|
||||
--- 675,681 ----
|
||||
foreach dir {userdir texdir pbookdir tmpdir} {
|
||||
exec mkdir $fax($dir)
|
||||
}
|
||||
! exec printf "Misc\tMiscellaneous fax numbers" \
|
||||
> $fax(pbookdir)/group.pbd
|
||||
exec touch $fax(pbookdir)/Misc.pbd
|
||||
}
|
@ -1,20 +1,20 @@
|
||||
--- tkfax.orig Sat May 11 15:24:22 2002
|
||||
+++ tkfax Sat May 11 15:25:18 2002
|
||||
--- tkfax.orig Sun Nov 14 20:59:03 2004
|
||||
+++ tkfax Sun Nov 14 20:59:40 2004
|
||||
@@ -1,6 +1,6 @@
|
||||
#!/bin/sh
|
||||
# the next line restarts using wish \
|
||||
-exec wish "$0" "$@"
|
||||
+exec wish8.0jp "$0" "$@"
|
||||
+exec wish8.3 "$0" "$@"
|
||||
|
||||
set fax(libdir) /usr/local/lib/tkscanfax
|
||||
set c(libdir) $fax(libdir)
|
||||
--- tkscan.orig Sat May 11 15:25:57 2002
|
||||
+++ tkscan Sat May 11 15:26:04 2002
|
||||
set fax(libdir) /usr/local/lib/tkscanfax1
|
||||
if [ file exist fax-init.tcl ] { set fax(libdir) [pwd] }
|
||||
--- tkscan.orig Sun Nov 14 20:59:24 2004
|
||||
+++ tkscan Sun Nov 14 20:59:33 2004
|
||||
@@ -1,6 +1,6 @@
|
||||
#!/bin/sh
|
||||
# the next line restarts using wish \
|
||||
-exec wish "$0" "$@"
|
||||
+exec wish8.0jp "$0" "$@"
|
||||
+exec wish8.3 "$0" "$@"
|
||||
|
||||
# Set TkScan installation directory.
|
||||
|
||||
|
@ -1,77 +1,107 @@
|
||||
lib/tkscanfax/fax-about.tcl
|
||||
lib/tkscanfax/images/hbkim.gif
|
||||
lib/tkscanfax/images/tkfax-s.gif
|
||||
lib/tkscanfax/msg_C.tcl
|
||||
lib/tkscanfax/fax-conf-win.tcl
|
||||
lib/tkscanfax/fax-conf.tcl
|
||||
lib/tkscanfax/fax-faxwin.tcl
|
||||
lib/tkscanfax/fax-file.tcl
|
||||
lib/tkscanfax/fax-init.tcl
|
||||
lib/tkscanfax/fax-lib.tcl
|
||||
lib/tkscanfax/fax-mkpg.tcl
|
||||
lib/tkscanfax/fax-pbook.tcl
|
||||
lib/tkscanfax/fax-queue.tcl
|
||||
lib/tkscanfax/fax-received.tcl
|
||||
lib/tkscanfax/fax-scan.tcl
|
||||
lib/tkscanfax/scan-about.tcl
|
||||
lib/tkscanfax/msg_ja.tcl
|
||||
lib/tkscanfax/scan-drivers/microtek-mtekscan.tcl
|
||||
lib/tkscanfax/scan-drivers/epson-ep_scan.tcl
|
||||
lib/tkscanfax/scan-drivers/epson-scanimage.tcl
|
||||
lib/tkscanfax/scan-drivers/epson.tcl
|
||||
lib/tkscanfax/scan-drivers/hp-hpscanpbm.tcl
|
||||
lib/tkscanfax/scan-drivers/mustek-scanimage.tcl
|
||||
lib/tkscanfax/scan-drivers/mustek-mscan.tcl
|
||||
lib/tkscanfax/scan-drivers/sharp.tcl
|
||||
lib/tkscanfax/tex/covermacro-aux.tex
|
||||
lib/tkscanfax/tex/covermacro-en.tex
|
||||
lib/tkscanfax/tex/covermacro-ja.tex
|
||||
lib/tkscanfax/tex/covermacro-kr.tex
|
||||
lib/tkscanfax/tex/covermacro-ja.tex.rpmsave.rpmorig
|
||||
lib/tkscanfax/tex/covermacro-en.tex.rpmsave.rpmorig.rpmorig
|
||||
lib/tkscanfax/scan-conf.tcl
|
||||
lib/tkscanfax/scan-scanwin.tcl
|
||||
lib/tkscanfax/scan-file.tcl
|
||||
lib/tkscanfax/scan-init.tcl
|
||||
lib/tkscanfax/scan-lib.tcl
|
||||
lib/tkscanfax/scan-out.tcl
|
||||
lib/tkscanfax/scan-scan.tcl
|
||||
lib/tkscanfax/scan-win.tcl
|
||||
lib/tkscanfax/tkfax
|
||||
lib/tkscanfax/tkscan
|
||||
lib/tkscanfax/doc/efax.html
|
||||
lib/tkscanfax/doc/efax.rc.sample
|
||||
lib/tkscanfax/doc/efax.rc.sample.ja
|
||||
lib/tkscanfax/doc/fax.html
|
||||
lib/tkscanfax/doc/tkscanfax.html
|
||||
lib/tkscanfax/doc/tkscanfax_e.html
|
||||
lib/tkscanfax/doc/tkscanfax_ja.html
|
||||
lib/tkscanfax/doc/INSTALL
|
||||
lib/tkscanfax/doc/INSTALL.ja
|
||||
lib/tkscanfax/doc/README.ja
|
||||
lib/tkscanfax/doc/TRANSLATION
|
||||
lib/tkscanfax/doc/images/gfax.png
|
||||
lib/tkscanfax/doc/images/jamain2.png
|
||||
lib/tkscanfax/doc/images/ref.gif
|
||||
lib/tkscanfax/doc/images/shinobas.gif
|
||||
lib/tkscanfax/doc/images/tkfax-b.xpm
|
||||
lib/tkscanfax/doc/images/tkfax-s.xpm
|
||||
lib/tkscanfax/doc/images/tkfax-s.png
|
||||
lib/tkscanfax/doc/images/tux.gif
|
||||
lib/tkscanfax/doc/printcap.sample
|
||||
lib/tkscanfax/doc/fax
|
||||
lib/tkscanfax/doc/tkfax_tips_ja.html
|
||||
lib/tkscanfax/doc/sysreport.sh
|
||||
lib/tkscanfax/tkscanfax.spec
|
||||
lib/tkscanfax/fax-logbrowse.tcl
|
||||
lib/tkscanfax/fax-balloon.tcl
|
||||
@exec /bin/ln -sf %D/lib/tkscanfax/tkscan %D/bin
|
||||
@exec /bin/ln -sf %D/lib/tkscanfax/tkfax %D/bin
|
||||
lib/tkscanfax1/fax-about.tcl
|
||||
lib/tkscanfax1/images/hbkim.gif
|
||||
lib/tkscanfax1/images/tkfax-s.gif
|
||||
lib/tkscanfax1/fax-balloon.tcl
|
||||
lib/tkscanfax1/fax-conf-win.tcl
|
||||
lib/tkscanfax1/fax-conf.tcl
|
||||
lib/tkscanfax1/fax-faxwin.tcl
|
||||
lib/tkscanfax1/fax-file.tcl
|
||||
lib/tkscanfax1/fax-init.tcl
|
||||
lib/tkscanfax1/fax-lib.tcl
|
||||
lib/tkscanfax1/fax-logbrowse.tcl
|
||||
lib/tkscanfax1/fax-mkpg.tcl
|
||||
lib/tkscanfax1/fax-pbook.tcl
|
||||
lib/tkscanfax1/fax-queue.tcl
|
||||
lib/tkscanfax1/fax-received.tcl
|
||||
lib/tkscanfax1/scan-drivers/microtek-mtekscan.tcl
|
||||
lib/tkscanfax1/scan-drivers/epson-ep_scan.tcl
|
||||
lib/tkscanfax1/scan-drivers/epson-scanimage.tcl
|
||||
lib/tkscanfax1/scan-drivers/epson.tcl
|
||||
lib/tkscanfax1/scan-drivers/hp-hpscanpbm.tcl
|
||||
lib/tkscanfax1/scan-drivers/mustek-scanimage.tcl
|
||||
lib/tkscanfax1/scan-drivers/mustek-mscan.tcl
|
||||
lib/tkscanfax1/scan-drivers/sharp.tcl
|
||||
lib/tkscanfax1/scan-drivers/umax.tcl
|
||||
lib/tkscanfax1/tex/covermacro-aux.tex
|
||||
lib/tkscanfax1/tex/covermacro-en.tex
|
||||
lib/tkscanfax1/tex/covermacro-ja.tex
|
||||
lib/tkscanfax1/tex/covermacro-kr.tex
|
||||
lib/tkscanfax1/tex/covermacro-C.tex
|
||||
lib/tkscanfax1/fax-scan.tcl
|
||||
lib/tkscanfax1/getfont.tcl
|
||||
lib/tkscanfax1/html_library.tcl
|
||||
lib/tkscanfax1/html_viewer.tcl
|
||||
lib/tkscanfax1/doc/efax.html
|
||||
lib/tkscanfax1/doc/efax.rc.sample
|
||||
lib/tkscanfax1/doc/efax.rc.sample.ja
|
||||
lib/tkscanfax1/doc/fax.html
|
||||
lib/tkscanfax1/doc/tkscanfax.html
|
||||
lib/tkscanfax1/doc/tkkinput2.sh
|
||||
lib/tkscanfax1/doc/INSTALL
|
||||
lib/tkscanfax1/doc/INSTALL.ja
|
||||
lib/tkscanfax1/doc/README.ja
|
||||
lib/tkscanfax1/doc/TRANSLATION
|
||||
lib/tkscanfax1/doc/fax
|
||||
lib/tkscanfax1/doc/images/gfax.png
|
||||
lib/tkscanfax1/doc/images/jamain2.png
|
||||
lib/tkscanfax1/doc/images/ref.gif
|
||||
lib/tkscanfax1/doc/images/shinobas.gif
|
||||
lib/tkscanfax1/doc/images/tkfax-b.xpm
|
||||
lib/tkscanfax1/doc/images/tkfax-s.xpm
|
||||
lib/tkscanfax1/doc/images/tkfax-s.png
|
||||
lib/tkscanfax1/doc/images/tux.gif
|
||||
lib/tkscanfax1/doc/images/tkfax-s.gif
|
||||
lib/tkscanfax1/doc/images/download.png
|
||||
lib/tkscanfax1/doc/printcap.sample
|
||||
lib/tkscanfax1/doc/tkscanfax_e.html
|
||||
lib/tkscanfax1/doc/sysreport.sh
|
||||
lib/tkscanfax1/doc/tkscanfax_ja.html
|
||||
lib/tkscanfax1/doc/C/scan-msg.tcl
|
||||
lib/tkscanfax1/doc/C/fax-msg.tcl
|
||||
lib/tkscanfax1/doc/C/Config_Help.html
|
||||
lib/tkscanfax1/doc/C/Cover_Page_Help.html
|
||||
lib/tkscanfax1/doc/C/HTML_Viewer.html
|
||||
lib/tkscanfax1/doc/C/Users_Guide.html
|
||||
lib/tkscanfax1/doc/C/Phone_Book_Help.html
|
||||
lib/tkscanfax1/doc/ja/fax-msg.tcl
|
||||
lib/tkscanfax1/doc/ja/scan-msg.tcl
|
||||
lib/tkscanfax1/doc/ja/Config_Help.html
|
||||
lib/tkscanfax1/doc/ja/Cover_Page_Help.html
|
||||
lib/tkscanfax1/doc/ja/HTML_Viewer.html
|
||||
lib/tkscanfax1/doc/ja/Users_Guide.html
|
||||
lib/tkscanfax1/doc/ja/Phone_Book_Help.html
|
||||
lib/tkscanfax1/doc/ja/FAQ.html
|
||||
lib/tkscanfax1/doc/ja/ToDo-2003-0316.html
|
||||
lib/tkscanfax1/doc/tkfax_tips_ja.html
|
||||
lib/tkscanfax1/doc/INSTALL1.1.ja
|
||||
lib/tkscanfax1/doc/tkscanfax_rpm.html
|
||||
lib/tkscanfax1/doc/INSTALL1.1
|
||||
lib/tkscanfax1/doc/zh_TW/fax-msg.tcl
|
||||
lib/tkscanfax1/scan-about.tcl
|
||||
lib/tkscanfax1/scan-conf.tcl
|
||||
lib/tkscanfax1/scan-file.tcl
|
||||
lib/tkscanfax1/scan-init.tcl
|
||||
lib/tkscanfax1/scan-lib.tcl
|
||||
lib/tkscanfax1/scan-out.tcl
|
||||
lib/tkscanfax1/scan-scan.tcl
|
||||
lib/tkscanfax1/scan-win.tcl
|
||||
lib/tkscanfax1/scan-scanwin.tcl
|
||||
lib/tkscanfax1/tkfax
|
||||
lib/tkscanfax1/tkscan
|
||||
lib/tkscanfax1/tkscanfax.spec
|
||||
lib/tkscanfax1/Makefile
|
||||
lib/tkscanfax1/tkscan.desktop
|
||||
lib/tkscanfax1/tkfax.desktop
|
||||
@exec /bin/ln -sf %D/lib/tkscanfax1/tkscan %D/bin
|
||||
@exec /bin/ln -sf %D/lib/tkscanfax1/tkfax %D/bin
|
||||
@unexec /bin/rm -f %D/bin/tkscan
|
||||
@unexec /bin/rm -f %D/bin/tkfax
|
||||
@dirrm lib/tkscanfax/doc/images
|
||||
@dirrm lib/tkscanfax/doc
|
||||
@dirrm lib/tkscanfax/tex
|
||||
@dirrm lib/tkscanfax/scan-drivers
|
||||
@dirrm lib/tkscanfax/images
|
||||
@dirrm lib/tkscanfax
|
||||
@dirrm lib/tkscanfax1/tex
|
||||
@dirrm lib/tkscanfax1/scan-drivers
|
||||
@dirrm lib/tkscanfax1/images
|
||||
@dirrm lib/tkscanfax1/doc/zh_TW
|
||||
@dirrm lib/tkscanfax1/doc/ja
|
||||
@dirrm lib/tkscanfax1/doc/images
|
||||
@dirrm lib/tkscanfax1/doc/C
|
||||
@dirrm lib/tkscanfax1/doc
|
||||
@dirrm lib/tkscanfax1
|
||||
|
Loading…
Reference in New Issue
Block a user