Use gmake instead of using rules that may or may not work depending of the
version of sys.mk This fixes build on head after r279980
This commit is contained in:
parent
fc6f57637f
commit
b828827f99
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=381523
@ -12,7 +12,7 @@ COMMENT= File compression utility specializing in Quake demo compression
|
||||
|
||||
LICENSE= ZLIB
|
||||
|
||||
USES= dos2unix zip
|
||||
USES= dos2unix gmake zip
|
||||
|
||||
NO_WRKSUBDIR= yes
|
||||
MAKEFILE= ${WRKSRC}/Makefile.linux
|
||||
@ -27,7 +27,6 @@ post-extract: .SILENT
|
||||
${WRKSRC}/dzip.h ${WRKSRC}/conmain.c
|
||||
${REINPLACE_CMD} -e '4s,^,#include <machine/endian.h>,' \
|
||||
${WRKSRC}/dzip.h
|
||||
${REINPLACE_CMD} -e 's/) $$(OBJECTS/&:T/' ${MAKEFILE}
|
||||
${REINPLACE_CMD} -e '21d;23d' ${WRKSRC}/dzipcon.h
|
||||
|
||||
do-install:
|
||||
|
@ -12,6 +12,7 @@ COMMENT= Library to access directory structure and file attributes
|
||||
LICENSE= MIT
|
||||
|
||||
USES?= lua
|
||||
USES+= gmake
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= keplerproject
|
||||
|
@ -5,7 +5,7 @@
|
||||
|
||||
src/lfs.so: $(OBJS)
|
||||
- MACOSX_DEPLOYMENT_TARGET="10.3"; export MACOSX_DEPLOYMENT_TARGET; $(CC) $(CFLAGS) $(LIB_OPTION) -o src/lfs.so $(OBJS)
|
||||
+ $(CC) $(CFLAGS) $(LIB_OPTION) -o src/lfs.so $T.o
|
||||
+ $(CC) $(CFLAGS) $(LIB_OPTION) -o src/lfs.so $(OBJS)
|
||||
|
||||
test: lib
|
||||
LUA_CPATH=./src/?.so lua tests/test.lua
|
||||
|
@ -10,6 +10,7 @@ MASTER_SITES= http://sammy.net/~sammy/hacks/
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= TCP connection redirection utility
|
||||
|
||||
USES= gmake
|
||||
USE_RC_SUBR= redir
|
||||
|
||||
PLIST_FILES= bin/redir man/man1/redir.1.gz
|
||||
|
@ -23,12 +23,3 @@
|
||||
LDFLAGS = -s
|
||||
|
||||
# solaris, and others, may also need these libraries to link
|
||||
@@ -49,7 +48,7 @@
|
||||
rm -f $(OBJS) redir core
|
||||
|
||||
redir: ${OBJS}
|
||||
- ${CC} ${LDFLAGS} -o redir ${OBJS} ${LIBS}
|
||||
+ ${CC} ${LDFLAGS} -o redir redir.o getopt.o getopt1.o ${LIBS}
|
||||
|
||||
|
||||
|
||||
|
@ -10,6 +10,7 @@ MASTER_SITES= http://shapeshifter.se/pub/xacpim/
|
||||
MAINTAINER= henriknj@0xmilk.org
|
||||
COMMENT= Utility to display battery status and temperature on the root-display
|
||||
|
||||
USES= gmake
|
||||
USE_XORG= x11
|
||||
PLIST_FILES= bin/xacpim
|
||||
|
||||
|
@ -9,7 +9,7 @@
|
||||
|
||||
all:: ${OBJS}
|
||||
- ${CC} -o xacpim *.o -lX11 -L/usr/X11R6/lib -I/usr/X11R6/include
|
||||
+ ${CC} -o xacpim *.o -lX11 -L${LOCALBASE}/lib -I${LOCALBASE}/include
|
||||
+ ${CC} -o xacpim ${OBJS} -lX11 -L${LOCALBASE}/lib -I${LOCALBASE}/include
|
||||
|
||||
install:: xacpim
|
||||
strip xacpim
|
||||
|
@ -14,7 +14,7 @@ COMMENT= Clipboard history management dockapp for Window Maker
|
||||
|
||||
SUB_FILES= pkg-message
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
USES= pkgconfig
|
||||
USES= gmake pkgconfig
|
||||
USE_GNOME= gtk20
|
||||
USE_XORG= x11
|
||||
|
||||
|
@ -21,12 +21,3 @@
|
||||
|
||||
OBJECTS = wmcliphist.o clipboard.o gui.o rcconfig.o history.o hotkeys.o utils.o $(DEBUG)
|
||||
TARGET = wmcliphist
|
||||
@@ -23,7 +23,7 @@ lclint:
|
||||
lclint $(INCLUDES) +posixlib *.c >lclint.log
|
||||
|
||||
wmcliphist: $(OBJECTS) foodock/foodock.o
|
||||
- $(CC) $(LDFLAGS) $(OBJECTS) foodock/foodock.o $(LIBS) -o $@
|
||||
+ $(CC) $(LDFLAGS) $(OBJECTS) foodock.o $(LIBS) -o $@
|
||||
|
||||
wmcliphist.o: wmcliphist.c wmcliphist.h \
|
||||
icon/ico_60x60_black.xpm icon/ico_60x60_gray.xpm \
|
||||
|
Loading…
Reference in New Issue
Block a user