Update to version 0.4.1

PR: 20651
Submitted by: Ports Fury
This commit is contained in:
Kevin Lo 2000-08-18 16:44:39 +00:00
parent 463ca00a31
commit b7ff70393f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=31745
8 changed files with 204 additions and 19 deletions

View File

@ -1,30 +1,29 @@
# New ports collection makefile for: x48 # New ports collection makefile for: x48
# Date created: Thu Oct 24 13:10:59 CDT 1996 # Date created: Thu Oct 24 13:10:59 CDT 1996
# Whom: erich@FreeBSD.org # Whom: erich@FreeBSD.org
# #
# $FreeBSD$ # $FreeBSD$
# #
PORTNAME= x48 PORTNAME= x48
PORTVERSION= 0.4.1d PORTVERSION= 0.4.1
CATEGORIES= emulators CATEGORIES= emulators
MASTER_SITES= http://home.earthlink.net/~rmmlgetz/ MASTER_SITES= http://home.earthlink.net/~rmmlgetz/
DISTNAME= ${PORTNAME}_041d DISTNAME= ${PORTNAME}_${PORTVERSION:S/.//g}
MAINTAINER= ports@FreeBSD.org MAINTAINER= ports@FreeBSD.org
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_IMAKE= yes USE_IMAKE= yes
NO_INSTALL_MANPAGES= yes NO_INSTALL_MANPAGES= yes
WRKSRC= ${WRKDIR}/x48-0.4.1
post-extract:
cd ${WRKSRC}/readline && ${RM} *.o
post-install: post-install:
${MKDIR} ${PREFIX}/share/x48 .if !defined(NOPORTDOCS)
${CP} ${WRKSRC}/README ${PREFIX}/share/x48/README-x48 @${MKDIR} ${PREFIX}/share/doc/x48
${CP} ${WRKSRC}/doc/CARDS.doc ${WRKSRC}/doc/ROMDump.doc ${PREFIX}/share/x48 .for file in README doc/CARDS.doc doc/ROMDump.doc
${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/x48
.endfor
.endif
.include <bsd.port.mk> .include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (x48_041d.tar.gz) = 13ad77a3cedf910703155d1f2fdb639b MD5 (x48_041.tar.gz) = f74af15851d1feb9d80ec6ef4ccc3c83

View File

@ -0,0 +1,17 @@
--- config.h.orig Tue Jun 29 07:36:58 1999
+++ config.h Tue Aug 15 20:52:55 2000
@@ -56,12 +56,12 @@
/*
* Which Compiler to use:
*/
-#define CC_DEF gcc
+/* #define CC_DEF gcc */
/*
* Which Optimization Flags:
*/
-#define CDEBUGFLAGS_DEF -O6 -Wall
+/* #define CDEBUGFLAGS_DEF -O6 -Wall */
/*
* Which Flags to pass to the Linker:

View File

@ -0,0 +1,44 @@
--- src/Imakefile.orig Thu Jun 17 00:32:19 1999
+++ src/Imakefile Tue Aug 15 22:07:30 2000
@@ -60,7 +60,7 @@
LDOPTIONS = LDOPTIONS_DEF
#endif
- DEFINES = -I/usr/openwin/include UNIX_DEF XSHM_DEF READLINE_DEF
+ DEFINES = UNIX_DEF XSHM_DEF READLINE_DEF
HDRS = annunc.h append.h buttons.h constants.h debugger.h \
device.h disasm.h errors.h global.h hp.h hp48.h \
hp48_emu.h hp48char.h icon.h mmu.h options.h resources.h \
@@ -87,9 +87,9 @@
CO = co -l
TARFILES = Imakefile X48.ad $(TARS1) $(SRCS2) $(SRCS3) $(SRCS4) $(HDRS)
-all:: $(BIN)/x48 $(BIN)/dump2rom $(BIN)/checkrom $(BIN)/mkcard
+all:: x48 dump2rom checkrom mkcard
- PROGRAMS = $(BIN)/x48 $(BIN)/dump2rom $(BIN)/checkrom $(BIN)/mkcard
+ PROGRAMS = x48 dump2rom checkrom mkcard
depend:: version.c X48.ad.h
@@ -102,16 +102,15 @@
RemoveTargetProgram($@) @@\
$(CC) -o $@ $(LDOPTIONS) $(OBJS4) locallib $(LDLIBS) syslib $(EXTRA_LOAD_FLAGS) @@\
@@\
-SaberProgramTarget(program,$(SRCS4),$(OBJS4),locallib,syslib) @@\
@@\
InstallProgram(program,$(BINDIR)) @@\
InstallManPage(program,$(MANDIR))
#endif /* ComplexProgramTarget_4 */
-ComplexProgramTarget_1($(BIN)/x48, $(X48LIBS),)
-ComplexProgramTarget_2($(BIN)/dump2rom,,)
-ComplexProgramTarget_3($(BIN)/checkrom,,)
-ComplexProgramTarget_4($(BIN)/mkcard,,)
+ComplexProgramTarget_1(x48, $(X48LIBS),)
+ComplexProgramTarget_2(dump2rom,,)
+ComplexProgramTarget_3(checkrom,,)
+ComplexProgramTarget_4(mkcard,,)
InstallAppDefaults(X48)

View File

@ -0,0 +1,112 @@
--- src/serial.c.orig Tue Jun 29 07:12:29 1999
+++ src/serial.c Tue Aug 15 20:46:02 2000
@@ -77,6 +77,8 @@
#ifdef SOLARIS
#include <sys/stream.h>
#include <sys/stropts.h>
+#endif
+#if defined(SOLARIS) || defined(__FreeBSD__) || defined (__bsdi__)
#include <sys/termios.h>
#endif
@@ -238,7 +240,7 @@
if (ttyp >= 0)
{
-#if defined(SUNOS) || defined(HPUX)
+#if defined(SUNOS) || defined(HPUX) || defined(__FreeBSD__) || defined (__bsdi__)
if (tcgetattr(ttyp, &ttybuf) < 0)
#else
if (ioctl(ttyp, TCGETS, (char *)&ttybuf) < 0)
@@ -263,7 +265,7 @@
if (ttyp >= 0)
{
-#if defined(SUNOS) || defined (HPUX)
+#if defined(SUNOS) || defined (HPUX) || defined(__FreeBSD__) || defined (__bsdi__)
if (tcsetattr(ttyp, TCSANOW, &ttybuf) < 0)
#else
if (ioctl(ttyp, TCSETS, (char *)&ttybuf) < 0)
@@ -291,7 +293,7 @@
if (ir_fd >= 0)
{
-#if defined(SUNOS) || defined (HPUX)
+#if defined(SUNOS) || defined (HPUX) || defined (__FreeBSD__) || defined (__bsdi__)
if (tcgetattr(ir_fd, &ttybuf) < 0)
#else
if (ioctl(ir_fd, TCGETS, (char *)&ttybuf) < 0)
@@ -315,7 +317,7 @@
if (ir_fd >= 0)
{
-#if defined(SUNOS) || defined(HPUX)
+#if defined(SUNOS) || defined(HPUX) || defined (__FreeBSD__) || defined (__bsdi__)
if (tcsetattr(ir_fd, TCSANOW, &ttybuf) < 0)
#else
if (ioctl(ir_fd, TCSETS, (char *)&ttybuf) < 0)
@@ -344,7 +346,7 @@
if (ir_fd >= 0)
{
-#if defined(SUNOS) || defined (HPUX)
+#if defined(SUNOS) || defined (HPUX) || defined (__FreeBSD__) || defined (__bsdi__)
if (tcgetattr(ir_fd, &ttybuf) < 0)
#else
if (ioctl(ir_fd, TCGETS, (char *)&ttybuf) < 0)
@@ -358,6 +360,10 @@
}
}
+#if defined(__FreeBSD__) || defined(__bsdi__)
+ cfsetspeed(&ttybuf, baud);
+#else
+
ttybuf.c_cflag &= ~CBAUD;
baud &= 0x7;
@@ -404,9 +410,11 @@
ttybuf.c_cflag |= B9600;
}
+#endif /* FreeBSD */
+
if (ir_fd >= 0)
{
-#if defined(SUNOS) || defined(HPUX)
+#if defined(SUNOS) || defined(HPUX) || defined (__FreeBSD__) || defined(__bsdi__)
if (tcsetattr(ir_fd, TCSANOW, &ttybuf) < 0)
#else
if (ioctl(ir_fd, TCSETS, (char *)&ttybuf) < 0)
@@ -422,7 +430,7 @@
if (ttyp >= 0)
{
-#if defined(SUNOS) || defined(HPUX)
+#if defined(SUNOS) || defined(HPUX) || defined (__FreeBSD__) || defined(__bsdi__)
if (tcgetattr(ttyp, &ttybuf) < 0)
#else
if (ioctl(ttyp, TCGETS, (char *)&ttybuf) < 0)
@@ -437,6 +445,9 @@
}
}
+#if defined(__FreeBSD__) || defined(__bsdi__)
+ cfsetspeed(&ttybuf, baud);
+#else
ttybuf.c_cflag &= ~CBAUD;
baud &= 0x7;
@@ -482,10 +493,11 @@
fprintf(stderr, "%s: can\'t set baud rate, using 9600\n", progname);
ttybuf.c_cflag |= B9600;
}
+#endif
if (ttyp >= 0)
{
-#if defined(SUNOS) || defined(HPUX)
+#if defined(SUNOS) || defined(HPUX) || defined (__FreeBSD__) || defined(__bsdi__)
if (tcsetattr(ttyp, TCSANOW, &ttybuf) < 0)
#else
if (ioctl(ttyp, TCSETS, (char *)&ttybuf) < 0)

View File

@ -0,0 +1,11 @@
--- src/x48_x11.c.orig Tue Jun 29 07:12:29 1999
+++ src/x48_x11.c Tue Aug 15 22:30:17 2000
@@ -3605,6 +3605,8 @@
break;
case XK_Alt_L:
case XK_Alt_R:
+ case XK_Meta_L:
+ case XK_Meta_R:
key_event(BUTTON_ALPHA, xev);
wake = 1;
break;

View File

@ -6,3 +6,5 @@ running this program. Of course you can run this program without a
copy of the ROM software in order to write trivial machine code copy of the ROM software in order to write trivial machine code
programs but you will not be able to access any of the calculator programs but you will not be able to access any of the calculator
functionality. functionality.
WWW: http://home.earthlink.net/~rmmlgetz/

View File

@ -3,7 +3,7 @@ bin/dump2rom
bin/mkcard bin/mkcard
bin/x48 bin/x48
lib/X11/app-defaults/X48 lib/X11/app-defaults/X48
share/x48/CARDS.doc share/doc/x48/CARDS.doc
share/x48/README-x48 share/doc/x48/README
share/x48/ROMDump.doc share/doc/x48/ROMDump.doc
@dirrm share/x48 @dirrm share/doc/x48