Add ktorrent 1.0, a BitTorrent client for KDE.

Its main features are:

  o Download torrent files
  o Upload speed capping, seeing that most people can't upload infinite
    amounts of data
  o Internet searching using The Bittorrent website's search engine
  o UDP Trackers

WWW: http://ktorrent.pwsp.net/
This commit is contained in:
Markus Brueffer 2005-07-13 10:51:35 +00:00
parent 0ea29f07c2
commit b7fade6f89
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=139052
21 changed files with 561 additions and 0 deletions

View File

@ -0,0 +1,24 @@
# New ports collection makefile for: ktorrent
# Date created: Wed Jul 13 11:38:46 CEST 2005
# Whom: Markus Brueffer <markus@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= ktorrent
PORTVERSION= 1.0
CATEGORIES= net kde
MASTER_SITES= http://ktorrent.pwsp.net/downloads/
MAINTAINER= markus@FreeBSD.org
COMMENT= BitTorrent client for KDE
USE_KDELIBS_VER=3
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_REINPLACE= yes
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
MD5 (ktorrent-1.0.tar.gz) = ea1503979903566c94b809130eb57da8
SIZE (ktorrent-1.0.tar.gz) = 771010

View File

@ -0,0 +1,10 @@
--- libtorrent/udptracker.cpp.orig Wed Jul 13 12:33:37 2005
+++ libtorrent/udptracker.cpp Wed Jul 13 12:34:07 2005
@@ -18,6 +18,7 @@
* 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
***************************************************************************/
#include <stdlib.h>
+#include <sys/time.h>
#include <qsocketnotifier.h>
#include <qsocketdevice.h>

View File

@ -0,0 +1,9 @@
KTorrent is a BitTorrent client for KDE. Its main features are:
o Download torrent files
o Upload speed capping, seeing that most people can't upload infinite
amounts of data
o Internet searching using The Bittorrent website's search engine
o UDP Trackers
WWW: http://ktorrent.pwsp.net/

View File

@ -0,0 +1,95 @@
bin/ktorrent
lib/libktorrent.la
lib/libktorrent.so
lib/libktorrent.so.0
share/applications/kde/ktorrent.desktop
share/applnk/Internet/ktorrent.desktop
share/apps/ktorrent/icons/hicolor/128x128/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/16x16/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/22x22/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/32x32/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/48x48/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/64x64/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/64x64/filesystems/ktprefdownloads.png
share/apps/ktorrent/icons/hicolor/scalable/apps/ktorrent.svgz
share/apps/ktorrent/ktorrentui.rc
share/config.kcfg/ktorrent.kcfg
share/icons/hicolor/128x128/apps/ktorrent.png
share/icons/hicolor/16x16/apps/ktorrent.png
share/icons/hicolor/22x22/apps/ktorrent.png
share/icons/hicolor/32x32/apps/ktorrent.png
share/icons/hicolor/48x48/apps/ktorrent.png
share/icons/hicolor/64x64/apps/ktorrent.png
share/icons/hicolor/scalable/apps/ktorrent.svgz
share/locale/br/LC_MESSAGES/ktorrent.mo
share/locale/cs/LC_MESSAGES/ktorrent.mo
share/locale/da/LC_MESSAGES/ktorrent.mo
share/locale/de/LC_MESSAGES/ktorrent.mo
share/locale/el/LC_MESSAGES/ktorrent.mo
share/locale/en_GB/LC_MESSAGES/ktorrent.mo
share/locale/et/LC_MESSAGES/ktorrent.mo
share/locale/fr/LC_MESSAGES/ktorrent.mo
share/locale/ga/LC_MESSAGES/ktorrent.mo
share/locale/hu/LC_MESSAGES/ktorrent.mo
share/locale/it/LC_MESSAGES/ktorrent.mo
share/locale/nl/LC_MESSAGES/ktorrent.mo
share/locale/pl/LC_MESSAGES/ktorrent.mo
share/locale/pt/LC_MESSAGES/ktorrent.mo
share/locale/ru/LC_MESSAGES/ktorrent.mo
share/locale/sr/LC_MESSAGES/ktorrent.mo
share/locale/sr@Latn/LC_MESSAGES/ktorrent.mo
share/locale/sv/LC_MESSAGES/ktorrent.mo
share/locale/tr/LC_MESSAGES/ktorrent.mo
share/locale/uk/LC_MESSAGES/ktorrent.mo
@unexec rmdir %D/share/locale/uk/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/uk 2>/dev/null || true
@unexec rmdir %D/share/locale/sr/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/sr 2>/dev/null || true
@unexec rmdir %D/share/locale/pt/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/pt 2>/dev/null || true
@unexec rmdir %D/share/locale/pl/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/pl 2>/dev/null || true
@unexec rmdir %D/share/locale/el/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/el 2>/dev/null || true
@unexec rmdir %D/share/locale/cs/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/cs 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/scalable/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/scalable 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/64x64/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/64x64 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/48x48/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/48x48 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/32x32/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/32x32 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/22x22/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/22x22 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/16x16/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/16x16 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/128x128/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/128x128 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor 2>/dev/null || true
@unexec rmdir %D/share/icons 2>/dev/null || true
@unexec rmdir %D/share/config.kcfg 2>/dev/null || true
@dirrm share/apps/ktorrent/icons/hicolor/scalable/apps
@dirrm share/apps/ktorrent/icons/hicolor/scalable
@dirrm share/apps/ktorrent/icons/hicolor/64x64/filesystems
@dirrm share/apps/ktorrent/icons/hicolor/64x64/apps
@dirrm share/apps/ktorrent/icons/hicolor/64x64
@dirrm share/apps/ktorrent/icons/hicolor/48x48/apps
@dirrm share/apps/ktorrent/icons/hicolor/48x48
@dirrm share/apps/ktorrent/icons/hicolor/32x32/apps
@dirrm share/apps/ktorrent/icons/hicolor/32x32
@dirrm share/apps/ktorrent/icons/hicolor/22x22/apps
@dirrm share/apps/ktorrent/icons/hicolor/22x22
@dirrm share/apps/ktorrent/icons/hicolor/16x16/apps
@dirrm share/apps/ktorrent/icons/hicolor/16x16
@dirrm share/apps/ktorrent/icons/hicolor/128x128/apps
@dirrm share/apps/ktorrent/icons/hicolor/128x128
@dirrm share/apps/ktorrent/icons/hicolor
@dirrm share/apps/ktorrent/icons
@dirrm share/apps/ktorrent
@unexec rmdir %D/share/apps 2>/dev/null || true
@unexec rmdir %D/share/applnk/Internet 2>/dev/null || true
@unexec rmdir %D/share/applnk 2>/dev/null || true
@unexec rmdir %D/share/applications/kde 2>/dev/null || true
@unexec rmdir %D/share/applications 2>/dev/null || true

24
net-p2p/ktorrent/Makefile Normal file
View File

@ -0,0 +1,24 @@
# New ports collection makefile for: ktorrent
# Date created: Wed Jul 13 11:38:46 CEST 2005
# Whom: Markus Brueffer <markus@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= ktorrent
PORTVERSION= 1.0
CATEGORIES= net kde
MASTER_SITES= http://ktorrent.pwsp.net/downloads/
MAINTAINER= markus@FreeBSD.org
COMMENT= BitTorrent client for KDE
USE_KDELIBS_VER=3
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_REINPLACE= yes
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
MD5 (ktorrent-1.0.tar.gz) = ea1503979903566c94b809130eb57da8
SIZE (ktorrent-1.0.tar.gz) = 771010

View File

@ -0,0 +1,10 @@
--- libtorrent/udptracker.cpp.orig Wed Jul 13 12:33:37 2005
+++ libtorrent/udptracker.cpp Wed Jul 13 12:34:07 2005
@@ -18,6 +18,7 @@
* 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
***************************************************************************/
#include <stdlib.h>
+#include <sys/time.h>
#include <qsocketnotifier.h>
#include <qsocketdevice.h>

View File

@ -0,0 +1,9 @@
KTorrent is a BitTorrent client for KDE. Its main features are:
o Download torrent files
o Upload speed capping, seeing that most people can't upload infinite
amounts of data
o Internet searching using The Bittorrent website's search engine
o UDP Trackers
WWW: http://ktorrent.pwsp.net/

View File

@ -0,0 +1,95 @@
bin/ktorrent
lib/libktorrent.la
lib/libktorrent.so
lib/libktorrent.so.0
share/applications/kde/ktorrent.desktop
share/applnk/Internet/ktorrent.desktop
share/apps/ktorrent/icons/hicolor/128x128/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/16x16/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/22x22/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/32x32/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/48x48/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/64x64/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/64x64/filesystems/ktprefdownloads.png
share/apps/ktorrent/icons/hicolor/scalable/apps/ktorrent.svgz
share/apps/ktorrent/ktorrentui.rc
share/config.kcfg/ktorrent.kcfg
share/icons/hicolor/128x128/apps/ktorrent.png
share/icons/hicolor/16x16/apps/ktorrent.png
share/icons/hicolor/22x22/apps/ktorrent.png
share/icons/hicolor/32x32/apps/ktorrent.png
share/icons/hicolor/48x48/apps/ktorrent.png
share/icons/hicolor/64x64/apps/ktorrent.png
share/icons/hicolor/scalable/apps/ktorrent.svgz
share/locale/br/LC_MESSAGES/ktorrent.mo
share/locale/cs/LC_MESSAGES/ktorrent.mo
share/locale/da/LC_MESSAGES/ktorrent.mo
share/locale/de/LC_MESSAGES/ktorrent.mo
share/locale/el/LC_MESSAGES/ktorrent.mo
share/locale/en_GB/LC_MESSAGES/ktorrent.mo
share/locale/et/LC_MESSAGES/ktorrent.mo
share/locale/fr/LC_MESSAGES/ktorrent.mo
share/locale/ga/LC_MESSAGES/ktorrent.mo
share/locale/hu/LC_MESSAGES/ktorrent.mo
share/locale/it/LC_MESSAGES/ktorrent.mo
share/locale/nl/LC_MESSAGES/ktorrent.mo
share/locale/pl/LC_MESSAGES/ktorrent.mo
share/locale/pt/LC_MESSAGES/ktorrent.mo
share/locale/ru/LC_MESSAGES/ktorrent.mo
share/locale/sr/LC_MESSAGES/ktorrent.mo
share/locale/sr@Latn/LC_MESSAGES/ktorrent.mo
share/locale/sv/LC_MESSAGES/ktorrent.mo
share/locale/tr/LC_MESSAGES/ktorrent.mo
share/locale/uk/LC_MESSAGES/ktorrent.mo
@unexec rmdir %D/share/locale/uk/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/uk 2>/dev/null || true
@unexec rmdir %D/share/locale/sr/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/sr 2>/dev/null || true
@unexec rmdir %D/share/locale/pt/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/pt 2>/dev/null || true
@unexec rmdir %D/share/locale/pl/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/pl 2>/dev/null || true
@unexec rmdir %D/share/locale/el/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/el 2>/dev/null || true
@unexec rmdir %D/share/locale/cs/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/cs 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/scalable/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/scalable 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/64x64/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/64x64 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/48x48/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/48x48 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/32x32/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/32x32 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/22x22/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/22x22 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/16x16/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/16x16 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/128x128/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/128x128 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor 2>/dev/null || true
@unexec rmdir %D/share/icons 2>/dev/null || true
@unexec rmdir %D/share/config.kcfg 2>/dev/null || true
@dirrm share/apps/ktorrent/icons/hicolor/scalable/apps
@dirrm share/apps/ktorrent/icons/hicolor/scalable
@dirrm share/apps/ktorrent/icons/hicolor/64x64/filesystems
@dirrm share/apps/ktorrent/icons/hicolor/64x64/apps
@dirrm share/apps/ktorrent/icons/hicolor/64x64
@dirrm share/apps/ktorrent/icons/hicolor/48x48/apps
@dirrm share/apps/ktorrent/icons/hicolor/48x48
@dirrm share/apps/ktorrent/icons/hicolor/32x32/apps
@dirrm share/apps/ktorrent/icons/hicolor/32x32
@dirrm share/apps/ktorrent/icons/hicolor/22x22/apps
@dirrm share/apps/ktorrent/icons/hicolor/22x22
@dirrm share/apps/ktorrent/icons/hicolor/16x16/apps
@dirrm share/apps/ktorrent/icons/hicolor/16x16
@dirrm share/apps/ktorrent/icons/hicolor/128x128/apps
@dirrm share/apps/ktorrent/icons/hicolor/128x128
@dirrm share/apps/ktorrent/icons/hicolor
@dirrm share/apps/ktorrent/icons
@dirrm share/apps/ktorrent
@unexec rmdir %D/share/apps 2>/dev/null || true
@unexec rmdir %D/share/applnk/Internet 2>/dev/null || true
@unexec rmdir %D/share/applnk 2>/dev/null || true
@unexec rmdir %D/share/applications/kde 2>/dev/null || true
@unexec rmdir %D/share/applications 2>/dev/null || true

View File

@ -0,0 +1,24 @@
# New ports collection makefile for: ktorrent
# Date created: Wed Jul 13 11:38:46 CEST 2005
# Whom: Markus Brueffer <markus@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= ktorrent
PORTVERSION= 1.0
CATEGORIES= net kde
MASTER_SITES= http://ktorrent.pwsp.net/downloads/
MAINTAINER= markus@FreeBSD.org
COMMENT= BitTorrent client for KDE
USE_KDELIBS_VER=3
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_REINPLACE= yes
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
MD5 (ktorrent-1.0.tar.gz) = ea1503979903566c94b809130eb57da8
SIZE (ktorrent-1.0.tar.gz) = 771010

View File

@ -0,0 +1,10 @@
--- libtorrent/udptracker.cpp.orig Wed Jul 13 12:33:37 2005
+++ libtorrent/udptracker.cpp Wed Jul 13 12:34:07 2005
@@ -18,6 +18,7 @@
* 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
***************************************************************************/
#include <stdlib.h>
+#include <sys/time.h>
#include <qsocketnotifier.h>
#include <qsocketdevice.h>

View File

@ -0,0 +1,9 @@
KTorrent is a BitTorrent client for KDE. Its main features are:
o Download torrent files
o Upload speed capping, seeing that most people can't upload infinite
amounts of data
o Internet searching using The Bittorrent website's search engine
o UDP Trackers
WWW: http://ktorrent.pwsp.net/

View File

@ -0,0 +1,95 @@
bin/ktorrent
lib/libktorrent.la
lib/libktorrent.so
lib/libktorrent.so.0
share/applications/kde/ktorrent.desktop
share/applnk/Internet/ktorrent.desktop
share/apps/ktorrent/icons/hicolor/128x128/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/16x16/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/22x22/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/32x32/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/48x48/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/64x64/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/64x64/filesystems/ktprefdownloads.png
share/apps/ktorrent/icons/hicolor/scalable/apps/ktorrent.svgz
share/apps/ktorrent/ktorrentui.rc
share/config.kcfg/ktorrent.kcfg
share/icons/hicolor/128x128/apps/ktorrent.png
share/icons/hicolor/16x16/apps/ktorrent.png
share/icons/hicolor/22x22/apps/ktorrent.png
share/icons/hicolor/32x32/apps/ktorrent.png
share/icons/hicolor/48x48/apps/ktorrent.png
share/icons/hicolor/64x64/apps/ktorrent.png
share/icons/hicolor/scalable/apps/ktorrent.svgz
share/locale/br/LC_MESSAGES/ktorrent.mo
share/locale/cs/LC_MESSAGES/ktorrent.mo
share/locale/da/LC_MESSAGES/ktorrent.mo
share/locale/de/LC_MESSAGES/ktorrent.mo
share/locale/el/LC_MESSAGES/ktorrent.mo
share/locale/en_GB/LC_MESSAGES/ktorrent.mo
share/locale/et/LC_MESSAGES/ktorrent.mo
share/locale/fr/LC_MESSAGES/ktorrent.mo
share/locale/ga/LC_MESSAGES/ktorrent.mo
share/locale/hu/LC_MESSAGES/ktorrent.mo
share/locale/it/LC_MESSAGES/ktorrent.mo
share/locale/nl/LC_MESSAGES/ktorrent.mo
share/locale/pl/LC_MESSAGES/ktorrent.mo
share/locale/pt/LC_MESSAGES/ktorrent.mo
share/locale/ru/LC_MESSAGES/ktorrent.mo
share/locale/sr/LC_MESSAGES/ktorrent.mo
share/locale/sr@Latn/LC_MESSAGES/ktorrent.mo
share/locale/sv/LC_MESSAGES/ktorrent.mo
share/locale/tr/LC_MESSAGES/ktorrent.mo
share/locale/uk/LC_MESSAGES/ktorrent.mo
@unexec rmdir %D/share/locale/uk/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/uk 2>/dev/null || true
@unexec rmdir %D/share/locale/sr/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/sr 2>/dev/null || true
@unexec rmdir %D/share/locale/pt/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/pt 2>/dev/null || true
@unexec rmdir %D/share/locale/pl/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/pl 2>/dev/null || true
@unexec rmdir %D/share/locale/el/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/el 2>/dev/null || true
@unexec rmdir %D/share/locale/cs/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/cs 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/scalable/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/scalable 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/64x64/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/64x64 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/48x48/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/48x48 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/32x32/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/32x32 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/22x22/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/22x22 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/16x16/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/16x16 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/128x128/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/128x128 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor 2>/dev/null || true
@unexec rmdir %D/share/icons 2>/dev/null || true
@unexec rmdir %D/share/config.kcfg 2>/dev/null || true
@dirrm share/apps/ktorrent/icons/hicolor/scalable/apps
@dirrm share/apps/ktorrent/icons/hicolor/scalable
@dirrm share/apps/ktorrent/icons/hicolor/64x64/filesystems
@dirrm share/apps/ktorrent/icons/hicolor/64x64/apps
@dirrm share/apps/ktorrent/icons/hicolor/64x64
@dirrm share/apps/ktorrent/icons/hicolor/48x48/apps
@dirrm share/apps/ktorrent/icons/hicolor/48x48
@dirrm share/apps/ktorrent/icons/hicolor/32x32/apps
@dirrm share/apps/ktorrent/icons/hicolor/32x32
@dirrm share/apps/ktorrent/icons/hicolor/22x22/apps
@dirrm share/apps/ktorrent/icons/hicolor/22x22
@dirrm share/apps/ktorrent/icons/hicolor/16x16/apps
@dirrm share/apps/ktorrent/icons/hicolor/16x16
@dirrm share/apps/ktorrent/icons/hicolor/128x128/apps
@dirrm share/apps/ktorrent/icons/hicolor/128x128
@dirrm share/apps/ktorrent/icons/hicolor
@dirrm share/apps/ktorrent/icons
@dirrm share/apps/ktorrent
@unexec rmdir %D/share/apps 2>/dev/null || true
@unexec rmdir %D/share/applnk/Internet 2>/dev/null || true
@unexec rmdir %D/share/applnk 2>/dev/null || true
@unexec rmdir %D/share/applications/kde 2>/dev/null || true
@unexec rmdir %D/share/applications 2>/dev/null || true

View File

@ -294,6 +294,7 @@
SUBDIR += kphone
SUBDIR += kpopup
SUBDIR += krdesktop
SUBDIR += ktorrent
SUBDIR += l2tpd
SUBDIR += lam
SUBDIR += lam7

24
net/ktorrent/Makefile Normal file
View File

@ -0,0 +1,24 @@
# New ports collection makefile for: ktorrent
# Date created: Wed Jul 13 11:38:46 CEST 2005
# Whom: Markus Brueffer <markus@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= ktorrent
PORTVERSION= 1.0
CATEGORIES= net kde
MASTER_SITES= http://ktorrent.pwsp.net/downloads/
MAINTAINER= markus@FreeBSD.org
COMMENT= BitTorrent client for KDE
USE_KDELIBS_VER=3
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_REINPLACE= yes
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
.include <bsd.port.mk>

2
net/ktorrent/distinfo Normal file
View File

@ -0,0 +1,2 @@
MD5 (ktorrent-1.0.tar.gz) = ea1503979903566c94b809130eb57da8
SIZE (ktorrent-1.0.tar.gz) = 771010

View File

@ -0,0 +1,10 @@
--- libtorrent/udptracker.cpp.orig Wed Jul 13 12:33:37 2005
+++ libtorrent/udptracker.cpp Wed Jul 13 12:34:07 2005
@@ -18,6 +18,7 @@
* 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
***************************************************************************/
#include <stdlib.h>
+#include <sys/time.h>
#include <qsocketnotifier.h>
#include <qsocketdevice.h>

9
net/ktorrent/pkg-descr Normal file
View File

@ -0,0 +1,9 @@
KTorrent is a BitTorrent client for KDE. Its main features are:
o Download torrent files
o Upload speed capping, seeing that most people can't upload infinite
amounts of data
o Internet searching using The Bittorrent website's search engine
o UDP Trackers
WWW: http://ktorrent.pwsp.net/

95
net/ktorrent/pkg-plist Normal file
View File

@ -0,0 +1,95 @@
bin/ktorrent
lib/libktorrent.la
lib/libktorrent.so
lib/libktorrent.so.0
share/applications/kde/ktorrent.desktop
share/applnk/Internet/ktorrent.desktop
share/apps/ktorrent/icons/hicolor/128x128/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/16x16/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/22x22/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/32x32/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/48x48/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/64x64/apps/ktorrent.png
share/apps/ktorrent/icons/hicolor/64x64/filesystems/ktprefdownloads.png
share/apps/ktorrent/icons/hicolor/scalable/apps/ktorrent.svgz
share/apps/ktorrent/ktorrentui.rc
share/config.kcfg/ktorrent.kcfg
share/icons/hicolor/128x128/apps/ktorrent.png
share/icons/hicolor/16x16/apps/ktorrent.png
share/icons/hicolor/22x22/apps/ktorrent.png
share/icons/hicolor/32x32/apps/ktorrent.png
share/icons/hicolor/48x48/apps/ktorrent.png
share/icons/hicolor/64x64/apps/ktorrent.png
share/icons/hicolor/scalable/apps/ktorrent.svgz
share/locale/br/LC_MESSAGES/ktorrent.mo
share/locale/cs/LC_MESSAGES/ktorrent.mo
share/locale/da/LC_MESSAGES/ktorrent.mo
share/locale/de/LC_MESSAGES/ktorrent.mo
share/locale/el/LC_MESSAGES/ktorrent.mo
share/locale/en_GB/LC_MESSAGES/ktorrent.mo
share/locale/et/LC_MESSAGES/ktorrent.mo
share/locale/fr/LC_MESSAGES/ktorrent.mo
share/locale/ga/LC_MESSAGES/ktorrent.mo
share/locale/hu/LC_MESSAGES/ktorrent.mo
share/locale/it/LC_MESSAGES/ktorrent.mo
share/locale/nl/LC_MESSAGES/ktorrent.mo
share/locale/pl/LC_MESSAGES/ktorrent.mo
share/locale/pt/LC_MESSAGES/ktorrent.mo
share/locale/ru/LC_MESSAGES/ktorrent.mo
share/locale/sr/LC_MESSAGES/ktorrent.mo
share/locale/sr@Latn/LC_MESSAGES/ktorrent.mo
share/locale/sv/LC_MESSAGES/ktorrent.mo
share/locale/tr/LC_MESSAGES/ktorrent.mo
share/locale/uk/LC_MESSAGES/ktorrent.mo
@unexec rmdir %D/share/locale/uk/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/uk 2>/dev/null || true
@unexec rmdir %D/share/locale/sr/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/sr 2>/dev/null || true
@unexec rmdir %D/share/locale/pt/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/pt 2>/dev/null || true
@unexec rmdir %D/share/locale/pl/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/pl 2>/dev/null || true
@unexec rmdir %D/share/locale/el/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/el 2>/dev/null || true
@unexec rmdir %D/share/locale/cs/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/cs 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/scalable/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/scalable 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/64x64/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/64x64 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/48x48/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/48x48 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/32x32/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/32x32 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/22x22/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/22x22 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/16x16/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/16x16 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/128x128/apps 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor/128x128 2>/dev/null || true
@unexec rmdir %D/share/icons/hicolor 2>/dev/null || true
@unexec rmdir %D/share/icons 2>/dev/null || true
@unexec rmdir %D/share/config.kcfg 2>/dev/null || true
@dirrm share/apps/ktorrent/icons/hicolor/scalable/apps
@dirrm share/apps/ktorrent/icons/hicolor/scalable
@dirrm share/apps/ktorrent/icons/hicolor/64x64/filesystems
@dirrm share/apps/ktorrent/icons/hicolor/64x64/apps
@dirrm share/apps/ktorrent/icons/hicolor/64x64
@dirrm share/apps/ktorrent/icons/hicolor/48x48/apps
@dirrm share/apps/ktorrent/icons/hicolor/48x48
@dirrm share/apps/ktorrent/icons/hicolor/32x32/apps
@dirrm share/apps/ktorrent/icons/hicolor/32x32
@dirrm share/apps/ktorrent/icons/hicolor/22x22/apps
@dirrm share/apps/ktorrent/icons/hicolor/22x22
@dirrm share/apps/ktorrent/icons/hicolor/16x16/apps
@dirrm share/apps/ktorrent/icons/hicolor/16x16
@dirrm share/apps/ktorrent/icons/hicolor/128x128/apps
@dirrm share/apps/ktorrent/icons/hicolor/128x128
@dirrm share/apps/ktorrent/icons/hicolor
@dirrm share/apps/ktorrent/icons
@dirrm share/apps/ktorrent
@unexec rmdir %D/share/apps 2>/dev/null || true
@unexec rmdir %D/share/applnk/Internet 2>/dev/null || true
@unexec rmdir %D/share/applnk 2>/dev/null || true
@unexec rmdir %D/share/applications/kde 2>/dev/null || true
@unexec rmdir %D/share/applications 2>/dev/null || true