graphics/mesa-devel: update to 22.2.b.1696
Changes: d3642a0e02...a03ce740bb
This commit is contained in:
parent
b67f754617
commit
b7e360bd9f
@ -1,6 +1,6 @@
|
||||
PORTNAME= mesa
|
||||
DISTVERSION= 22.2-branchpoint-1392
|
||||
DISTVERSIONSUFFIX= -gd3642a0e027
|
||||
DISTVERSION= 22.2-branchpoint-1696
|
||||
DISTVERSIONSUFFIX= -ga03ce740bbb
|
||||
CATEGORIES= graphics
|
||||
PKGNAMESUFFIX= -devel
|
||||
|
||||
@ -51,12 +51,12 @@ OPTIONS_DEFINE= LIBUNWIND LLVM LTO VAAPI VDPAU VKLAYERS WAYLAND X11 ZSTD
|
||||
OPTIONS_DEFAULT= LIBUNWIND LLVM LTO VAAPI VDPAU VKLAYERS WAYLAND X11 ZSTD
|
||||
OPTIONS_GROUP= GALLIUM VULKAN
|
||||
OPTIONS_GROUP_GALLIUM= crocus iris panfrost r600 radeonsi
|
||||
OPTIONS_GROUP_VULKAN= anv radv
|
||||
OPTIONS_EXCLUDE_DragonFly= LIBUNWIND anv
|
||||
OPTIONS_GROUP_VULKAN= anv hasvk radv
|
||||
OPTIONS_EXCLUDE_DragonFly= LIBUNWIND anv hasvk
|
||||
OPTIONS_EXCLUDE_i386= LTO # anv: vkcube fails on vkCreateSwapchainKHR
|
||||
OPTIONS_EXCLUDE_powerpc64= ${"${/usr/bin/ld:L:tA}"==/usr/bin/ld.lld:?LTO:} # https://github.com/llvm/llvm-project/issues/46697
|
||||
OPTIONS_EXCLUDE+= ${ARCH:Naarch64:C/.+/panfrost/}
|
||||
OPTIONS_EXCLUDE+= ${ARCH:Namd64:Ni386:Nx86_64:C/.+/anv crocus iris/}
|
||||
OPTIONS_EXCLUDE+= ${ARCH:Namd64:Ni386:Nx86_64:C/.+/anv crocus hasvk iris/}
|
||||
OPTIONS_EXCLUDE+= ${ARCH:Naarch64:Namd64:Ni386:Npowerpc64:Npowerpc64le:Nx86_64:C/.+/LIBUNWIND/}
|
||||
OPTIONS_EXCLUDE+= ${"${GL_DEFAULT:S/,/ /g:[-1]}"==${.CURDIR:T}:?COINST:}
|
||||
OPTIONS_SLAVE+= ${"${GL_DEFAULT:S/,/ /g:[-1]}"!=${.CURDIR:T}:?COINST:}
|
||||
@ -67,7 +67,7 @@ OPTIONS_SUB= yes
|
||||
MESON_ARGS+= -D${i:tl}-drivers=${${i}_DRIVERS:ts,}
|
||||
. for j in ${OPTIONS_GROUP_${i}}
|
||||
OPTIONS_DEFAULT+= ${j}
|
||||
${j}_VARS+= ${i}_DRIVERS+=${j:S/anv/intel/:S/radv/amd/}
|
||||
${j}_VARS+= ${i}_DRIVERS+=${j:S/anv/intel/:S/hasvk/intel_&/:S/radv/amd/}
|
||||
. endfor
|
||||
.endfor
|
||||
|
||||
@ -79,7 +79,8 @@ r600_DESC= R600, R700, Evergreen, Northern Islands (implies LLVM)
|
||||
radeonsi_DESC= Southern Islands and newer (implies LLVM)
|
||||
|
||||
VULKAN_DESC= Vulkan drivers
|
||||
anv_DESC= Haswell and newer
|
||||
anv_DESC= Skylake and newer
|
||||
hasvk_DESC= Ivy Bridge, Haswell, Broadwell
|
||||
radv_DESC= Southern Islands and newer (implies LLVM)
|
||||
radv_BUILD_DEPENDS= glslangValidator:graphics/glslang
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
TIMESTAMP = 1661989484
|
||||
SHA256 (mesa3d-mesa-22.2-branchpoint-1392-gd3642a0e027_GH0.tar.gz) = 8f789ebe45addac3ca223663c490f475f976a28b8cdfc1d89d814f98aef25ed1
|
||||
SIZE (mesa3d-mesa-22.2-branchpoint-1392-gd3642a0e027_GH0.tar.gz) = 25193856
|
||||
TIMESTAMP = 1662236871
|
||||
SHA256 (mesa3d-mesa-22.2-branchpoint-1696-ga03ce740bbb_GH0.tar.gz) = 30b211eb55a75d56ff8e5cc7bea29f72df3aed50d502bd3598d97b57dc12c4ca
|
||||
SIZE (mesa3d-mesa-22.2-branchpoint-1696-ga03ce740bbb_GH0.tar.gz) = 25575567
|
||||
SHA256 (700efacda59c.patch) = f034cfbe09edff0baba67e46e7e3812fdef73ff3cf3e579050c024c95234c8d5
|
||||
SIZE (700efacda59c.patch) = 981
|
||||
SHA256 (50433886a3e3.patch) = 15af265e9dbb5dec7514062cfa549d1c1053f567395d9d133611c2a5138da470
|
||||
|
@ -125,6 +125,17 @@ Library selection is handled by libglvnd and/or libmap.conf.
|
||||
[files('anv_gem.c'), anv_entrypoints[0]],
|
||||
include_directories : [
|
||||
inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_intel, inc_compiler, inc_vulkan_wsi,
|
||||
--- src/intel/vulkan_hasvk/meson.build.orig 2022-09-03 20:27:51 UTC
|
||||
+++ src/intel/vulkan_hasvk/meson.build
|
||||
@@ -181,7 +181,7 @@ libvulkan_intel_hasvk = shared_library(
|
||||
)
|
||||
|
||||
libvulkan_intel_hasvk = shared_library(
|
||||
- 'vulkan_intel_hasvk',
|
||||
+ 'vulkan_intel_hasvk' + get_option('egl-lib-suffix'),
|
||||
[files('anv_gem.c'), anv_hasvk_entrypoints[0]],
|
||||
include_directories : [
|
||||
inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_intel, inc_compiler,
|
||||
--- src/mapi/es1api/meson.build.orig 2020-05-30 21:28:01 UTC
|
||||
+++ src/mapi/es1api/meson.build
|
||||
@@ -33,7 +33,7 @@ if with_platform_windows
|
||||
|
@ -73,3 +73,27 @@ https://github.com/FreeBSDDesktop/kms-drm/issues/197
|
||||
|
||||
return userptr.handle;
|
||||
}
|
||||
--- src/intel/vulkan_hasvk/anv_gem.c.orig 2022-09-03 20:27:51 UTC
|
||||
+++ src/intel/vulkan_hasvk/anv_gem.c
|
||||
@@ -179,9 +179,19 @@ anv_gem_userptr(struct anv_device *device, void *mem,
|
||||
if (device->physical->has_userptr_probe)
|
||||
userptr.flags |= I915_USERPTR_PROBE;
|
||||
|
||||
- int ret = intel_ioctl(device->fd, DRM_IOCTL_I915_GEM_USERPTR, &userptr);
|
||||
- if (ret == -1)
|
||||
+ int ret;
|
||||
+retry:
|
||||
+ ret = intel_ioctl(device->fd, DRM_IOCTL_I915_GEM_USERPTR, &userptr);
|
||||
+ if (ret == -1) {
|
||||
+ if (errno == ENODEV && userptr.flags == 0) {
|
||||
+ userptr.flags = I915_USERPTR_UNSYNCHRONIZED;
|
||||
+ goto retry;
|
||||
+ }
|
||||
+ if (geteuid() != 0) {
|
||||
+ fprintf(stderr, "%s", "ioctl(I915_GEM_USERPTR) failed. Try running as root but expect poor stability.\n");
|
||||
+ }
|
||||
return 0;
|
||||
+ }
|
||||
|
||||
return userptr.handle;
|
||||
}
|
||||
|
@ -27,6 +27,7 @@ lib/libgbm%%SUFFIX%%.so.1.0.0
|
||||
lib/libglapi%%SUFFIX%%.so.0
|
||||
lib/libglapi%%SUFFIX%%.so.0.0.0
|
||||
%%anv%%lib/libvulkan_intel%%SUFFIX%%.so
|
||||
%%hasvk%%lib/libvulkan_intel_hasvk%%SUFFIX%%.so
|
||||
%%radv%%lib/libvulkan_radeon%%SUFFIX%%.so
|
||||
%%VDPAU%%%%r600%%lib/vdpau%%SUFFIX%%/libvdpau_r600.so
|
||||
%%VDPAU%%%%r600%%lib/vdpau%%SUFFIX%%/libvdpau_r600.so.1
|
||||
@ -43,5 +44,6 @@ share/drirc.d/00-mesa%%SUFFIX%%-defaults.conf
|
||||
%%NO_COINST%%share/glvnd/egl_vendor.d/50_mesa.json
|
||||
%%VKLAYERS%%share/vulkan/explicit_layer.d/VkLayer_MESA_overlay.json
|
||||
%%anv%%%%NO_COINST%%share/vulkan/icd.d/intel_icd.%%ARCH%%.json
|
||||
%%hasvk%%%%NO_COINST%%share/vulkan/icd.d/intel_hasvk_icd.%%ARCH%%.json
|
||||
%%radv%%%%NO_COINST%%share/vulkan/icd.d/radeon_icd.%%ARCH%%.json
|
||||
%%VKLAYERS%%share/vulkan/implicit_layer.d/VkLayer_MESA_device_select.json
|
||||
|
Loading…
Reference in New Issue
Block a user