- Update to 2.0
PR: 191076
This commit is contained in:
parent
748c5a4d34
commit
b7ad989463
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=358223
@ -2,11 +2,9 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= glances
|
||||
PORTVERSION= 1.7.7
|
||||
PORTVERSION= 2.0
|
||||
CATEGORIES= sysutils python
|
||||
MASTER_SITES= https://github.com/nicolargo/glances/archive/
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
DISTNAME= v${PORTVERSION}
|
||||
|
||||
MAINTAINER= gasol.wu@gmail.com
|
||||
COMMENT= CLI curses based monitoring tool for GNU/Linux and BSD OS
|
||||
@ -19,21 +17,19 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Jinja2>=2.0.0:${PORTSDIR}/devel/py-Jinja2 \
|
||||
OPTIONS_DEFINE= DOCS NLS
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= nicolargo
|
||||
GH_TAGNAME= v${PORTVERSION}
|
||||
GH_COMMIT= 2484bea
|
||||
|
||||
USE_PYTHON= yes
|
||||
USE_PYDISTUTILS=yes
|
||||
PYDISTUTILS_AUTOPLIST= yes
|
||||
|
||||
PLIST_FILES= %%ETCDIR%%/glances.conf.sample \
|
||||
man/man1/glances.1.gz \
|
||||
%%NLS%%share/locale/de/LC_MESSAGES/glances.mo \
|
||||
%%NLS%%share/locale/es/LC_MESSAGES/glances.mo \
|
||||
%%NLS%%share/locale/fr/LC_MESSAGES/glances.mo \
|
||||
%%NLS%%share/locale/it/LC_MESSAGES/glances.mo \
|
||||
%%NLS%%share/locale/pt_BR/LC_MESSAGES/glances.mo \
|
||||
%%NLS%%share/locale/zh_CN/LC_MESSAGES/glances.mo
|
||||
%%NLS%%share/locale/de/LC_MESSAGES/glances.mo
|
||||
PLIST_DIRS= etc/glances
|
||||
PORTDOCS= *
|
||||
|
||||
NLS_USES= gettext
|
||||
|
||||
@ -41,9 +37,7 @@ post-install:
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/glances
|
||||
${INSTALL_DATA} ${WRKSRC}/conf/glances.conf ${STAGEDIR}${PREFIX}/etc/glances/glances.conf.sample
|
||||
${INSTALL_MAN} ${WRKSRC}/man/glances.1 ${STAGEDIR}${MANPREFIX}/man/man1/
|
||||
.for lang in de es fr it pt_BR zh_CN
|
||||
${INSTALL_DATA} ${WRKSRC}/i18n/${lang}/LC_MESSAGES/glances.mo \
|
||||
${STAGEDIR}${PREFIX}/share/locale/${lang}/LC_MESSAGES/
|
||||
.endfor
|
||||
${INSTALL_DATA} ${WRKSRC}/i18n/de/LC_MESSAGES/glances.mo \
|
||||
${STAGEDIR}${PREFIX}/share/locale/de/LC_MESSAGES/
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (v1.7.7.tar.gz) = 13c783333d4223040120f32665195694413f52a240cebfff48c154ca769efeff
|
||||
SIZE (v1.7.7.tar.gz) = 596125
|
||||
SHA256 (glances-2.0.tar.gz) = 544e66cbc6dab3f8485a8f889fe2927d1acf5b9136104bb44cf2c7d0075ad77b
|
||||
SIZE (glances-2.0.tar.gz) = 1692473
|
||||
|
@ -1,23 +1,23 @@
|
||||
--- ./setup.py.orig 2013-12-15 17:23:06.000000000 +0800
|
||||
+++ ./setup.py 2013-12-16 21:45:25.000000000 +0800
|
||||
@@ -9,8 +9,7 @@
|
||||
data_files = [
|
||||
('share/doc/glances', ['AUTHORS', 'COPYING', 'NEWS', 'README.rst',
|
||||
'conf/glances.conf', 'docs/glances-doc.html']),
|
||||
- ('share/doc/glances/images', glob.glob('docs/images/*.png')),
|
||||
- ('share/man/man1', ['man/glances.1'])
|
||||
+ ('share/doc/glances/images', glob.glob('docs/images/*.png'))
|
||||
]
|
||||
--- ./setup.py.orig 2014-06-16 10:56:37.000000000 +0800
|
||||
+++ ./setup.py 2014-06-16 10:57:02.000000000 +0800
|
||||
@@ -11,8 +11,7 @@
|
||||
data_files = [
|
||||
('share/doc/glances', ['AUTHORS', 'COPYING', 'NEWS', 'README.rst',
|
||||
'conf/glances.conf', 'docs/glances-doc.html']),
|
||||
- ('share/doc/glances/images', glob.glob('docs/images/*.png')),
|
||||
- ('share/man/man1', ['man/glances.1'])
|
||||
+ ('share/doc/glances/images', glob.glob('docs/images/*.png'))
|
||||
]
|
||||
|
||||
if hasattr(sys, 'real_prefix') or 'bsd' in sys.platform:
|
||||
@@ -21,10 +20,6 @@
|
||||
conf_path = os.path.join('/usr/local', 'etc', 'glances')
|
||||
elif 'win32' in sys.platform:
|
||||
conf_path = os.path.join(os.environ.get('APPDATA'), 'glances')
|
||||
-data_files.append((conf_path, ['conf/glances.conf']))
|
||||
if hasattr(sys, 'real_prefix') or 'bsd' in sys.platform:
|
||||
@@ -23,10 +22,6 @@
|
||||
conf_path = os.path.join('/usr/local', 'etc', 'glances')
|
||||
elif 'win32' in sys.platform:
|
||||
conf_path = os.path.join(os.environ.get('APPDATA'), 'glances')
|
||||
- data_files.append((conf_path, ['conf/glances.conf']))
|
||||
-
|
||||
-for mo in glob.glob('i18n/*/LC_MESSAGES/*.mo'):
|
||||
- data_files.append((os.path.dirname(mo).replace('i18n/', 'share/locale/'), [mo]))
|
||||
- for mo in glob.glob('i18n/*/LC_MESSAGES/*.mo'):
|
||||
- data_files.append((os.path.dirname(mo).replace('i18n/', 'share/locale/'), [mo]))
|
||||
|
||||
return data_files
|
||||
|
||||
if sys.platform.startswith('win'):
|
||||
requires = ['psutil>=0.5.1', 'colorconsole==0.6']
|
||||
|
Loading…
Reference in New Issue
Block a user