- Update to version 1.4.3 (upstream does not embed version in the source

file, but comparing both files' contents shows that it is legit update)
- Convert rather cumbersome `post-patch' target to patches, removing the
  changes that were integrated upstream
- Actualize USES and USE_XORG lists, reword the COMMENT text while here
This commit is contained in:
Alexey Dokuchaev 2019-09-27 11:05:57 +00:00
parent c719ad78b4
commit b788976fec
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=513022
7 changed files with 93 additions and 61 deletions

View File

@ -2,42 +2,26 @@
# $FreeBSD$
PORTNAME= e93
PORTVERSION= 1.4.2
PORTVERSION= 1.4.3
CATEGORIES= editors tcl
MASTER_SITES= http://www.sqrt.com/downloads/
DISTNAME= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Tcl-based text editor oriented to the programmers
COMMENT= Tcl-based, programmer-oriented text editor
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
BROKEN= unfetchable
DEPRECATED= Unfetchable, unmaintained
EXPIRATION_DATE= 2019-10-16
USES= tar:tgz tcl xorg
USE_XORG= x11 xinerama xmu
USES= tar:tgz tcl
USE_XORG= x11 xinerama
MAKE_ENV= TCL_VERSION=${TCL_SHLIB_VER}
MAKE_ENV= TCL_INCLUDEDIR=${TCL_INCLUDEDIR} TCL_VERSION=${TCL_SHLIB_VER}
PORTDOCS= README* TODO
OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -E \
'/^TCL_INCLUDE=/s,/usr/local/include,${TCL_INCLUDEDIR}, \
;/^X_(INCLUDE|LIB)=/s,/usr/X11R6,${LOCALBASE}, \
;/^EXTRALIBS=/s, -ldl,, \
;/^OPTIONS=/s,-O2.*-g,${CFLAGS}, \
;/^(PREFIX|CC)/s,=,?=,' ${WRKSRC}/machdef.mk
@${REINPLACE_CMD} -e '30s,^,#include <stdbool.h>,' \
${WRKSRC}/includes.h
@${REINPLACE_CMD} -E '/X11\/(Intrinsic|Shell)\.h/d' \
${WRKSRC}/xgui/includes.h
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/e93 ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/e93lib

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1248219511
SHA256 (e93.tgz) = 750d812fe5911a71cf18a4e0d623ae6c4ee420d9c7886205d3dcf19aecfbc3c1
SIZE (e93.tgz) = 431733
TIMESTAMP = 1553982473
SHA256 (e93.tgz) = 666bedf2aae2e189cde17bffcac74136003d80280a3b7cf8311e23d9c06f9242
SIZE (e93.tgz) = 433863

View File

@ -1,24 +1,24 @@
--- Makefile.orig 2009-07-21 15:04:13 UTC
--- Makefile.orig 2013-06-14 20:51:43 UTC
+++ Makefile
@@ -49,17 +49,17 @@ OBJECTS = \
@@ -21,7 +21,7 @@
# Include machine/platform specific information
include machdef.mk
-CFLAGS=-I. $(TCL_INCLUDE) $(X_INCLUDE) $(OPTIONS) $(MACHINESPEC)
+CFLAGS+=-I. $(TCL_INCLUDE) $(X_INCLUDE) $(OPTIONS) $(MACHINESPEC)
OBJECTS = \
e93.o \
@@ -49,10 +49,10 @@ OBJECTS = \
abort.o \
errors.o
-all : libgui e93
-all : xgui/libgui.a e93
+all : e93
e93 : $(OBJECTS) xgui/libgui.a
- $(CC) -O $(OBJECTS) -Lxgui -lgui -lstdc++ \
+ $(CC) $(CFLAGS:N-D*:N-I*) $(OBJECTS) -Lxgui -lgui \
$(X_LIB) -lX11 -lXinerama \
$(X_LIB) -lX11 -lXmu -lXinerama \
$(TCL_LIB) -ltcl$(TCL_VERSION) \
$(EXTRALIBS) \
-o e93
-libgui :
- cd xgui;make
+xgui/libgui.a :
+ $(MAKE) -C xgui
clean :
cd xgui;make clean

View File

@ -0,0 +1,27 @@
--- includes.h.orig 2009-08-07 13:50:33 UTC
+++ includes.h
@@ -18,6 +18,7 @@
#include <stdio.h>
#include <stdarg.h>
+#include <stdbool.h>
#include <stdlib.h>
#include <errno.h>
#include <fcntl.h>
@@ -29,16 +30,6 @@
#include <locale.h>
#include <tcl.h>
-
-// deal with Tcl changing the way this works in newer versions
-#ifndef Tcl_GetErrorLine
-#define Tcl_GetErrorLine(interpreter) interpreter->errorLine
-#endif
-
-#ifndef Tcl_GetResult
-#define Tcl_GetResult(interpreter) interpreter->result
-#endif
-
#include "defines.h"
#include "guidefs.h"

View File

@ -0,0 +1,41 @@
--- machdef.mk.orig 2017-08-05 16:54:37 UTC
+++ machdef.mk
@@ -27,21 +27,21 @@
#
# e93 will install its single executable "e93" in $PREFIX/bin
# and it will place a directory called "e93lib" in $PREFIX/lib
-PREFIX=/usr/local
+PREFIX?=/usr/local
# The following lines may need to be altered if the Tcl
# files are located elsewhere on your system:
-TCL_INCLUDE=-I/usr/include/tcl8.5
+TCL_INCLUDE=-I$(TCL_INCLUDEDIR)
TCL_LIB=-L/usr/lib/x86_64-linux-gnu
# uncomment and change if you want to link with specific versions of Tcl
-TCL_VERSION=8.5
+#TCL_VERSION=8.5
# The following lines may need to be altered if the X include and library
# files are located elsewhere on your system:
-X_INCLUDE=-I/usr/X11R6/include
-X_LIB=-L/usr/X11R6/lib
+X_INCLUDE=-I$(LOCALBASE)/include
+X_LIB=-L$(LOCALBASE)/lib
# if your system needs some extra libraries, add them here:
@@ -51,9 +51,9 @@ EXTRALIBS=-lm -ldl
#MACHINESPEC=-DSOLARIS
# set compiler to use
-CC=gcc
+CC?=gcc
# set some compiler options
-OPTIONS=-O2 -Wall -x c++ -g -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+OPTIONS=-Wall -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
#OPTIONS = -Wall -O2 -x c++ -mcpu=21164a -Wa,-m21164a -g

View File

@ -1,19 +1,10 @@
--- shell.c.orig 2013-05-22 09:35:54.000000000 +0200
+++ shell.c 2013-05-22 09:44:04.000000000 +0200
@@ -992,7 +992,7 @@
Tcl_SetVar(interpreter,"SCRIPTPATH",scriptPath,TCL_LEAVE_ERR_MSG);
if(Tcl_EvalFile(interpreter,scriptPath)!=TCL_OK)
{
- SetError("%s:%d:%s",scriptPath,interpreter->errorLine,Tcl_GetStringResult(interpreter));
+ SetError("%s:%d:%s",scriptPath,Tcl_GetErrorLine(interpreter),Tcl_GetStringResult(interpreter));
fail=true;
}
}
@@ -1066,7 +1066,7 @@
--- shell.c.orig 2009-12-26 20:34:58 UTC
+++ shell.c
@@ -1070,7 +1070,7 @@ static bool InitTcl(char *pathName)
}
else
{
- SetError("Failed to Tcl_Init(): %s",tclInterpreter->result);
- SetError("Failed to Tcl_Init(): %s",Tcl_GetResult(tclInterpreter));
+ SetError("Failed to Tcl_Init(): %s",Tcl_GetStringResult(tclInterpreter));
}
UnInitChannels(tclInterpreter);

View File

@ -1,11 +0,0 @@
--- shellcmd.c.orig 2013-05-22 09:45:47.000000000 +0200
+++ shellcmd.c 2013-05-22 09:46:25.000000000 +0200
@@ -6354,7 +6354,7 @@
{
if(tclResult!=TCL_OK)
{
- sprintf(tempString,"Error in line %d: ",localInterpreter->errorLine);
+ sprintf(tempString,"Error in line %d: ",Tcl_GetErrorLine(localInterpreter));
EditorAuxInsert(buffer,(UINT8 *)tempString,(UINT32)strlen(tempString));
}
EditorAuxInsert(buffer,(UINT8 *)stringResult,(UINT32)strlen(stringResult));