Add winhelpcgi, a cgi program that can display winhelp files on the web.

It supports .HLP, .M14, .M13, and .MVP files.

PR:		ports/66229
Submitted by:	Robin Schoonover <end@endif.cjb.net>
This commit is contained in:
Pav Lucistnik 2004-05-04 17:49:15 +00:00
parent 342521d56c
commit b772e5e3b7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=108388
7 changed files with 68 additions and 0 deletions

View File

@ -612,6 +612,7 @@
SUBDIR += webstone
SUBDIR += webstone-ssl
SUBDIR += wiliki
SUBDIR += winhelpcgi
SUBDIR += wml
SUBDIR += wmnetselect
SUBDIR += wsmake

35
www/winhelpcgi/Makefile Normal file
View File

@ -0,0 +1,35 @@
# New ports collection makefile for: winhelpcgi
# Date created: 3 May 2004
# Whom: Robin Schoonover (endx7@users.sf.net)
#
# $FreeBSD$
#
PORTNAME= winhelpcgi
PORTVERSION= 0.93.1
CATEGORIES= www textproc
MASTER_SITES= http://www.herdsoft.com/ftp/
DISTNAME= ${PORTNAME}_0.93-1
MAINTAINER= endx7@users.sf.net
COMMENT= A winhelp converter cgi program
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
WRKSRC= ${WRKDIR}/${PORTNAME}
GNU_CONFIGURE= yes
USE_AUTOMAKE_VER= 14
AUTOMAKE_ARGS= --add-missing
PKGMESSAGE= ${WRKDIR}/pkg-message
# get rid of symlinks
pre-patch:
(cd ${WRKSRC}; ${RM} INSTALL install-sh mkinstalldirs missing COPYING)
post-build:
@${CAT} ${PKGDIR}/pkg-message | ${SED} -e 's:%%PREFIX%%:${PREFIX}:' > ${PKGMESSAGE}
do-install:
${INSTALL_PROGRAM} ${WRKDIR}/winhelpcgi/winhelpcgi/winhelpcgi.cgi ${PREFIX}/bin
.include <bsd.port.mk>

2
www/winhelpcgi/distinfo Normal file
View File

@ -0,0 +1,2 @@
MD5 (winhelpcgi_0.93-1.tar.gz) = cf6df86cb484fbb506bc721f484ae896
SIZE (winhelpcgi_0.93-1.tar.gz) = 239842

View File

@ -0,0 +1,18 @@
--- winhelpcgi/Makefile.am.orig Thu Apr 10 05:40:05 2003
+++ winhelpcgi/Makefile.am Sat May 1 15:48:37 2004
@@ -1,5 +1,5 @@
## Process this file using automake to create makefile.in
-INCLUDES = -I../include -I../include/linux
+INCLUDES = -I../include -I../include/linux -I${LOCALBASE}/include
#CFLAGS = -ggdb
bin_PROGRAMS = winhelpcgi.cgi
@@ -7,7 +7,7 @@
winhelpcgi_cgi_SOURCES=dib2png.c wc_html.c wc_kwsrch.c winhelpcgi.c
#winhelpcgi_cgi_LDFLAGS=-static
#winhelpcgi_cgi_LDADD=-L../libhlpaccess -lhlpaccess -lpng -lz
-winhelpcgi_cgi_LDADD= \
+winhelpcgi_cgi_LDADD= -L${LOCALBASE}/lib \
../libhlpaccess/libhlpaccess.a \
-lpng -lz

4
www/winhelpcgi/pkg-descr Normal file
View File

@ -0,0 +1,4 @@
winhelpcgi is a cgi program that can display winhelp files on the web.
It supports .HLP, .M14, .M13, and .MVP files.
WWW: http://www.herdsoft.com/linux/produkte/winhelpcgi.html

View File

@ -0,0 +1,7 @@
-----------------------------------------------------------------
winhelpcgi.cgi has been installed into %%PREFIX%%/bin
You now need to copy winhelpcgi.cgi along with all winhelp files
you wish for it to handle into the cgi-bin/ (or a subdir in
cgi-bin/) of a http server that can handle cgi (such as Apache).
-----------------------------------------------------------------

1
www/winhelpcgi/pkg-plist Normal file
View File

@ -0,0 +1 @@
bin/winhelpcgi.cgi