Add reed-solomon.

This is a port of Phil Karn's Reed-Solomon CODEC library. This package may be
useful to programmers working on data communications software.

WWW: http://www.ka9q.net/code/fec/

PR:		ports/82756
Submitted by:	Thomas Sandford <freebsduser@paradisegreen.co.uk>
This commit is contained in:
Jean-Yves Lefort 2005-06-29 15:04:22 +00:00
parent 9b986e19b4
commit b71ffdc0f6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=138189
6 changed files with 78 additions and 0 deletions

View File

@ -218,6 +218,7 @@
SUBDIR += qtiplot
SUBDIR += qwtplot3d
SUBDIR += rascal
SUBDIR += reed-solomon
SUBDIR += rpc
SUBDIR += rpy
SUBDIR += ruby-algebra

View File

@ -0,0 +1,27 @@
# New ports collection makefile for: reed-solomon
# Date created: 29 Jun 2005
# Whom: Thomas Sandford <freebsduser@paradisegreen.co.uk>
#
# $FreeBSD$
#
PORTNAME= reed-solomon
PORTVERSION= 4.0
CATEGORIES= math
MASTER_SITES= http://www.ka9q.net/code/fec/
MAINTAINER= freebsduser@paradisegreen.co.uk
COMMENT= A Reed-Solomon CODEC library
USE_REINPLACE= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
MAKEFILE= makefile
MAN3= rs.3
post-patch:
@${REINPLACE_CMD} -e 's|gcc|${CC}|' ${WRKSRC}/makefile.in
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
MD5 (reed-solomon-4.0.tar.gz) = 09218994c0e8e1f50e052786db1fe11b
SIZE (reed-solomon-4.0.tar.gz) = 46058

View File

@ -0,0 +1,37 @@
--- makefile.in.orig Wed Jun 29 16:52:23 2005
+++ makefile.in Wed Jun 29 16:57:01 2005
@@ -7,7 +7,7 @@
VPATH = @srcdir@
CC=@CC@
-CFLAGS=@CFLAGS@ @ARCH_OPTION@ -Wall
+CFLAGS=@CFLAGS@ -fPIC -Wall
LIB= encode_rs_char.o encode_rs_int.o encode_rs_8.o \
decode_rs_char.o decode_rs_int.o decode_rs_8.o \
@@ -24,20 +24,17 @@
gcc -g -o $@ $^
install: all
- mkdir -p @libdir@
- install -D -m 644 -p librs.a librs.so.@SO_VERSION@ @libdir@
+ $(BSD_INSTALL_DATA) librs.a @libdir@
+ $(BSD_INSTALL_PROGRAM) librs.so.@SO_VERSION@ @libdir@
(cd @libdir@;ln -f -s librs.so.@SO_VERSION@ librs.so)
- ldconfig
- mkdir -p @includedir@
- install -m 644 -p rs.h @includedir@
- mkdir -p @mandir@/man3
- install -m 644 rs.3 @mandir@/man3
+ $(BSD_INSTALL_DATA) rs.h @includedir@
+ $(BSD_INSTALL_MAN) rs.3 @mandir@/man3
librs.a: $(LIB)
ar rv $@ $^
librs.so.@SO_VERSION@: librs.a
- gcc -shared -Xlinker -soname=librs.so.@SO_NAME@ -o $@ -Wl,-whole-archive $^ -Wl,-no-whole-archive -lc
+ gcc -shared -fPIC -Xlinker -soname=librs.so.@SO_NAME@ -o $@ -Wl,-whole-archive $^ -Wl,-no-whole-archive -lc
encode_rs_char.o: encode_rs.c
gcc $(CFLAGS) -c -o $@ $^

View File

@ -0,0 +1,7 @@
This is a port of Phil Karn's Reed-Solomon CODEC library. This package may be
useful to programmers working on data communications software.
WWW: http://www.ka9q.net/code/fec/
- Thomas Sandford
freebsduser@paradisegreen.co.uk

View File

@ -0,0 +1,4 @@
include/rs.h
lib/librs.a
lib/librs.so
lib/librs.so.4.0.0