- Use gcc, as the game segfaults being compiled with clang

- Move highscores to /var/games
- Modernize plist

PR:		205630
Submitted by:	amdmi3
Approved by:	turutani@scphys.kyoto-u.ac.jp
This commit is contained in:
Dmitry Marakasov 2015-12-29 10:21:18 +00:00
parent 0c9fe0f218
commit b71bdc0e0c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=404729
3 changed files with 25 additions and 20 deletions

View File

@ -3,7 +3,7 @@
PORTNAME= xbat
PORTVERSION= 1.11
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= LOCAL/hrs
DISTNAME= xev111
@ -19,5 +19,6 @@ USES= imake
USE_XORG= x11 xext
WRKSRC= ${WRKDIR}/Xev111
ALL_TARGET= xbat
USE_GCC= yes # segfaults when compiled with clang
.include <bsd.port.mk>

View File

@ -1,10 +1,10 @@
--- Imakefile.orig Mon Mar 17 12:32:22 1997
+++ Imakefile Tue Jul 1 18:37:39 1997
--- Imakefile.orig 1997-03-17 12:32:22 UTC
+++ Imakefile
@@ -1,24 +1,24 @@
# TOP10 DIR : directory for socre files
#
-SCORE_DIR = /usr/local/games/Xbat/Score
+SCORE_DIR = ${PREFIX}/lib/X11/Xbat/Score
+SCORE_DIR = /var/games/xbat/Score
# IMAGE DIR : directory for image files
-IMAGE_DIR = /usr/local/games/Xbat/Image
@ -32,3 +32,15 @@
#######################################################################
@@ -48,9 +48,8 @@ DependTarget()
CleanTarget()
install::
- MakeDir($(DESTDIR)$(SCORE_DIR))
- chmod 777 $(DESTDIR)$(SCORE_DIR);
- @case '${MFLAGS}' in *[i]*) set +e;; esac; for i in Score/?* ; do set -x; $(INSTALL) -c -m 0666 $$i $(DESTDIR)$(SCORE_DIR) ; \
+ MakeDir($(DESTDIR)$(SCORE_DIR))
+ @case '${MFLAGS}' in *[i]*) set +e;; esac; cd Score; for i in ?* ; do set -x; $(INSTALL) -c -m 0666 $$i $(DESTDIR)$(SCORE_DIR)/$$i.sample ; \
done;
MakeDir($(DESTDIR)$(IMAGE_DIR))

View File

@ -1,8 +1,4 @@
@owner root
@group games
@mode 2755
bin/xbat
@mode 0664
@(,games,2755) bin/xbat
lib/X11/Xbat/Domo/domoX0201.dat
lib/X11/Xbat/Domo/domoX0202.dat
lib/X11/Xbat/Domo/domoX0203.dat
@ -694,14 +690,10 @@ lib/X11/Xbat/Map/kuuchuu_map6.dat
lib/X11/Xbat/Map/kuuchuu_map7.dat
lib/X11/Xbat/Map/kuuchuu_map8.dat
lib/X11/Xbat/Map/kuuchuu_map9.dat
@mode 0755
lib/X11/Xbat/Score/top10-0.txt
lib/X11/Xbat/Score/top10-1.txt
lib/X11/Xbat/Score/top10-2.txt
lib/X11/Xbat/Score/top10-3.txt
lib/X11/Xbat/Score/top10-4.txt
@dirrm lib/X11/Xbat/Domo
@dirrm lib/X11/Xbat/Image
@dirrm lib/X11/Xbat/Map
@dirrm lib/X11/Xbat/Score
@dirrm lib/X11/Xbat
@sample(,games,664) /var/games/xbat/Score/top10-0.txt.sample
@sample(,games,664) /var/games/xbat/Score/top10-1.txt.sample
@sample(,games,664) /var/games/xbat/Score/top10-2.txt.sample
@sample(,games,664) /var/games/xbat/Score/top10-3.txt.sample
@sample(,games,664) /var/games/xbat/Score/top10-4.txt.sample
@dir(,games,775) /var/games/xbat/Score
@dir /var/games/xbat