japanese/nethack34: Fix segfault on amd64 among other things
PR: 194611 Submitted by: WATANABE Kazuhiro
This commit is contained in:
parent
60f69213be
commit
b6fb83656d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=372365
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= nethack
|
||||
PORTVERSION= 3.4.3
|
||||
PORTREVISION= 6
|
||||
PORTREVISION= 7
|
||||
CATEGORIES= japanese games
|
||||
MASTER_SITES= SF
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}-src
|
||||
@ -68,6 +68,8 @@ do-configure:
|
||||
post-install:
|
||||
(cd ${WRKSRC}/doc && \
|
||||
${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} manpages)
|
||||
${INSTALL_DATA} ${WRKSRC}/win/X11/JNetHack.ad \
|
||||
${STAGEDIR}${PREFIX}/lib/X11/app-defaults/JNetHack
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
(cd ${WRKSRC} && ${INSTALL_DATA} README.j ChangeLog.j INSTALL.j \
|
||||
|
@ -1,5 +1,14 @@
|
||||
--- include/config.h.orig 2014-08-28 15:09:32.000000000 +0900
|
||||
+++ include/config.h 2014-08-28 15:10:15.000000000 +0900
|
||||
--- include/config.h.orig 2014-10-18 21:39:21.000000000 +0900
|
||||
+++ include/config.h 2014-10-18 21:48:34.000000000 +0900
|
||||
@@ -133,7 +133,7 @@
|
||||
* would allow:
|
||||
* xpmtoppm <x11tiles.xpm | pnmscale 1.25 | ppmquant 90 >x11tiles_big.xpm
|
||||
*/
|
||||
-/*# define USE_XPM*/ /* Disable if you do not have the XPM library */
|
||||
+# define USE_XPM /* Disable if you do not have the XPM library */
|
||||
# ifdef USE_XPM
|
||||
# define GRAPHIC_TOMBSTONE /* Use graphical tombstone (rip.xpm) */
|
||||
# define X11LARGETILE /* Large tile for X11 */
|
||||
@@ -219,7 +219,7 @@
|
||||
* otherwise it will be the current directory.
|
||||
*/
|
||||
|
12
japanese/nethack34/files/patch-include__xwindow.h
Normal file
12
japanese/nethack34/files/patch-include__xwindow.h
Normal file
@ -0,0 +1,12 @@
|
||||
--- include/xwindow.h.orig 2003-12-08 08:39:13.000000000 +0900
|
||||
+++ include/xwindow.h 2014-10-17 22:46:12.000000000 +0900
|
||||
@@ -78,6 +78,9 @@
|
||||
|
||||
extern XFontStruct *WindowFontStruct(/* Widget */);
|
||||
extern Font WindowFont(/* Widget */);
|
||||
+#ifdef XI18N
|
||||
+extern XFontSet WindowFontSet(/* Widget */);
|
||||
+#endif
|
||||
|
||||
#define XtCWindowResource "WindowResource"
|
||||
#define XtCRows "Rows"
|
@ -1,5 +1,5 @@
|
||||
--- sys/unix/Makefile.top.orig 2014-09-01 22:34:32.000000000 +0900
|
||||
+++ sys/unix/Makefile.top 2014-09-01 22:36:34.000000000 +0900
|
||||
--- sys/unix/Makefile.top.orig 2014-10-22 13:50:35.000000000 +0900
|
||||
+++ sys/unix/Makefile.top 2014-10-22 13:52:56.000000000 +0900
|
||||
@@ -14,7 +14,6 @@
|
||||
# MAKE = make
|
||||
|
||||
@ -112,7 +112,7 @@
|
||||
touch $(VARDIR)/perm $(VARDIR)/record
|
||||
# and a reminder
|
||||
@echo You may also want to install the man pages via the doc Makefile.
|
||||
@@ -241,20 +223,15 @@
|
||||
@@ -241,20 +223,14 @@
|
||||
install: $(GAME) recover $(VARDAT) dungeon spec_levs
|
||||
# set up the directories
|
||||
# not all mkdirs have -p; those that don't will create a -p directory
|
||||
@ -126,7 +126,6 @@
|
||||
- -$(CHOWN) $(GAMEUID) $(GAMEDIR) $(VARDIR) $(VARDIR)/save
|
||||
- $(CHGRP) $(GAMEGRP) $(GAMEDIR) $(VARDIR) $(VARDIR)/save
|
||||
- chmod $(DIRPERM) $(GAMEDIR) $(VARDIR) $(VARDIR)/save
|
||||
+ -chmod $(DIRPERM) ${DESTDIR}$(GAMEDIR) ${DESTDIR}$(VARDIR) ${DESTDIR}$(VARDIR)/save
|
||||
# set up the game files
|
||||
( $(MAKE) dofiles )
|
||||
# set up some additional files
|
||||
|
61
japanese/nethack34/files/patch-win__X11__JNetHack.ad
Normal file
61
japanese/nethack34/files/patch-win__X11__JNetHack.ad
Normal file
@ -0,0 +1,61 @@
|
||||
--- win/X11/JNetHack.ad.orig 2014-10-18 21:32:38.000000000 +0900
|
||||
+++ win/X11/JNetHack.ad 2014-10-18 21:36:57.000000000 +0900
|
||||
@@ -22,11 +22,10 @@
|
||||
! the custom format - to enlarge an XPM file, use processing tools
|
||||
! such as XV or preferably PBMplus.
|
||||
!
|
||||
-!JNetHack.tile_file: x11tiles32j
|
||||
-JNetHack.tile_file: t32-1024.xpm
|
||||
-JNetHack.tile_width: 32
|
||||
-JNetHack.tile_height: 32
|
||||
-!JNetHack.double_tile_size: True
|
||||
+!JNetHack.tile_file: x11tiles
|
||||
+!JNetHack.tile_width: 16
|
||||
+!JNetHack.tile_height: 16
|
||||
+!!JNetHack.double_tile_size: True
|
||||
!
|
||||
! The annotation of pets.
|
||||
JNetHack.pet_mark_bitmap: pet_mark.xbm
|
||||
@@ -132,6 +131,42 @@
|
||||
JNetHack*player_selection*quit.accelerators: #override\n\
|
||||
<Key>Escape: set() notify() unset()
|
||||
|
||||
+JNetHack*race_selection*random.borderColor: blue
|
||||
+JNetHack*race_selection*random.borderWidth: 2
|
||||
+JNetHack*race_selection*random.foreground: blue
|
||||
+JNetHack*race_selection*random.accelerators: #override\n\
|
||||
+ <Key>Return: set() notify() unset()
|
||||
+JNetHack*race_selection*quit.borderColor: blue
|
||||
+JNetHack*race_selection*quit.foreground: blue
|
||||
+JNetHack*race_selection*Command.borderColor: red
|
||||
+JNetHack*race_selection*Command.foreground: red
|
||||
+JNetHack*race_selection*quit.accelerators: #override\n\
|
||||
+ <Key>Escape: set() notify() unset()
|
||||
+
|
||||
+JNetHack*gender_selection*random.borderColor: blue
|
||||
+JNetHack*gender_selection*random.borderWidth: 2
|
||||
+JNetHack*gender_selection*random.foreground: blue
|
||||
+JNetHack*gender_selection*random.accelerators: #override\n\
|
||||
+ <Key>Return: set() notify() unset()
|
||||
+JNetHack*gender_selection*quit.borderColor: blue
|
||||
+JNetHack*gender_selection*quit.foreground: blue
|
||||
+JNetHack*gender_selection*Command.borderColor: red
|
||||
+JNetHack*gender_selection*Command.foreground: red
|
||||
+JNetHack*gender_selection*quit.accelerators: #override\n\
|
||||
+ <Key>Escape: set() notify() unset()
|
||||
+
|
||||
+JNetHack*alignment_selection*random.borderColor: blue
|
||||
+JNetHack*alignment_selection*random.borderWidth: 2
|
||||
+JNetHack*alignment_selection*random.foreground: blue
|
||||
+JNetHack*alignment_selection*random.accelerators: #override\n\
|
||||
+ <Key>Return: set() notify() unset()
|
||||
+JNetHack*alignment_selection*quit.borderColor: blue
|
||||
+JNetHack*alignment_selection*quit.foreground: blue
|
||||
+JNetHack*alignment_selection*Command.borderColor: red
|
||||
+JNetHack*alignment_selection*Command.foreground: red
|
||||
+JNetHack*alignment_selection*quit.accelerators: #override\n\
|
||||
+ <Key>Escape: set() notify() unset()
|
||||
+
|
||||
JNetHack*extended_commands*dismiss.borderColor: blue
|
||||
JNetHack*extended_commands*dismiss.foreground: blue
|
||||
JNetHack*extended_commands*help.borderColor: blue
|
@ -148,6 +148,7 @@ bin/%%HACKNAME%%
|
||||
@mode
|
||||
@owner
|
||||
@group
|
||||
lib/X11/app-defaults/JNetHack
|
||||
man/man6/dgn_comp.6.gz
|
||||
man/man6/dlb.6.gz
|
||||
man/man6/lev_comp.6.gz
|
||||
@ -158,8 +159,5 @@ man/man6/recover.6.gz
|
||||
%%PORTDOCS%%%%DOCSDIR%%/INSTALL.j
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README.j
|
||||
%%PORTDOCS%%%%DOCSDIR%%/jGuidebook.txt
|
||||
@exec chown games:games %D/%%DATADIR%%/save %D/%%DATADIR%%
|
||||
@exec chmod 0775 %D/%%DATADIR%%/save %D/%%DATADIR%%
|
||||
@dirrmtry %%DATADIR%%/save
|
||||
@dirrmtry %%DATADIR%%
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@dir(games,games,0775) %%DATADIR%%
|
||||
@dir(games,games,0775) %%DATADIR%%/save
|
||||
|
Loading…
Reference in New Issue
Block a user