- Update to 0.11.23

- only /dev/cd* devices will be recognized as cd drives.

PR:		79258
Submitted by:	Heiner Eichmann <h.eichmann@gmx.de>
This commit is contained in:
Tilman Keskinoz 2005-04-06 15:08:46 +00:00
parent 2e2a3a1ad0
commit b6ec54a252
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=132646
14 changed files with 34 additions and 50 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= k3b
PORTVERSION= 0.11.20
PORTREVISION= 1
PORTVERSION= 0.11.23
CATEGORIES= sysutils multimedia kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}

View File

@ -1,2 +1,2 @@
MD5 (k3b-0.11.20.tar.bz2) = 6c4844319ccb5e9be3ec69aec80c8d5f
SIZE (k3b-0.11.20.tar.bz2) = 3190897
MD5 (k3b-0.11.23.tar.bz2) = eaff485fb4c431aae715b0ef95c43fcf
SIZE (k3b-0.11.23.tar.bz2) = 3195224

View File

@ -1,6 +1,6 @@
--- src/Makefile.in.orig Sat Dec 11 17:46:26 2004
+++ src/Makefile.in Sun Jan 2 09:30:08 2005
@@ -297,7 +297,7 @@
--- src/Makefile.in.orig Wed Mar 16 10:43:55 2005
+++ src/Makefile.in Wed Mar 23 19:44:55 2005
@@ -299,7 +299,7 @@
#>+ 1
k3b_SOURCES=k3bwelcomewidget.cpp k3bapplication.cpp k3bdiroperator.cpp kdndfileview.cpp k3bfiletreeview.cpp k3bcddbmultientriesdialog.cpp k3baudioplayer.cpp k3bprojecttabbar.cpp k3bprojecttabwidget.cpp k3bsplash.cpp k3bblankingdialog.cpp k3bfileview.cpp k3bdirview.cpp k3btoolbox.cpp k3b.cpp main.cpp k3bstatusbarmanager.cpp k3bfiletreecombobox.cpp k3breadcdreader.cpp k3binterface.cpp k3bprojectinterface.cpp k3bsystemproblemdialog.cpp k3bcdcontentsview.cpp k3bwriterspeedverificationdialog.cpp k3bdatatrackreader.cpp k3binterface_skel.cpp k3bprojectinterface_skel.cpp

View File

@ -1,11 +0,0 @@
--- src/audiodecoding/flac/k3bflacdecoder.cpp.orig Tue Feb 24 16:07:27 2004
+++ src/audiodecoding/flac/k3bflacdecoder.cpp Tue Mar 22 22:08:07 2005
@@ -308,7 +308,7 @@
{
if( d->comments != 0 ) {
if( info == i18n("Vendor") )
- return QString::fromUtf8(d->comments->get_vendor_string().get_field());
+ return QString::fromUtf8((char*)d->comments->get_vendor_string());
else if( info == i18n("Channels") )
return QString::number(d->channels);
else if( info == i18n("Sampling Rate") )

View File

@ -1,5 +1,5 @@
--- src/device/k3bdevice.cpp.orig Sun Nov 28 01:22:29 2004
+++ src/device/k3bdevice.cpp Sun Jan 2 09:30:08 2005
--- src/device/k3bdevice.cpp.orig Thu Feb 24 09:15:57 2005
+++ src/device/k3bdevice.cpp Wed Mar 23 19:44:55 2005
@@ -57,6 +57,13 @@
#endif // Q_OS_LINUX
@ -58,7 +58,7 @@
else if( vendor().startsWith("MATSHITA") ) {
if( description().startsWith("CD-R CW-7501") ) {
m_writeModes = TAO|SAO;
@@ -2663,10 +2691,12 @@
@@ -2673,10 +2701,12 @@
{
// if the device is already opened we do not close it
// to allow fast multible method calls in a row
@ -71,7 +71,7 @@
// header size is 8
unsigned char* buffer = 0;
@@ -2752,13 +2782,16 @@
@@ -2762,13 +2792,16 @@
delete [] buffer;
}

View File

@ -1,5 +1,5 @@
--- src/device/k3bdevicemanager.cpp.orig Sun Nov 28 13:27:24 2004
+++ src/device/k3bdevicemanager.cpp Sun Jan 2 09:44:09 2005
+++ src/device/k3bdevicemanager.cpp Wed Mar 23 19:45:36 2005
@@ -49,6 +49,12 @@
#include <sys/stat.h>
#include <sys/ioctl.h>
@ -205,7 +205,7 @@
+#if __FreeBSD_version < 500100
+ dev += "c";
+#endif
+ if (dev1 != "" && dev2 != "")
+ if (dev1 != "" && dev2 != "" && dev.startsWith("/dev/cd"))
+ {
+ K3bDevice* device = new K3bDevice(dev.latin1());
+ device->m_bus = bus;
@ -259,7 +259,7 @@
+#if __FreeBSD_version < 500100
+ dev += "c";
+#endif
+ if (dev1 != "" && dev2 != "")
+ if (dev1 != "" && dev2 != "" && dev.startsWith("/dev/cd"))
+ {
+ K3bDevice* device = new K3bDevice(dev.latin1());
+ device->m_bus = bus;

View File

@ -207,6 +207,10 @@ share/icons/crystalsvg/16x16/apps/k3b.png
share/icons/crystalsvg/32x32/apps/k3b.png
share/icons/crystalsvg/48x48/apps/k3b.png
share/icons/crystalsvg/64x64/apps/k3b.png
share/icons/hicolor/16x16/apps/k3b.png
share/icons/hicolor/32x32/apps/k3b.png
share/icons/hicolor/48x48/apps/k3b.png
share/icons/hicolor/64x64/apps/k3b.png
share/mimelnk/application/x-k3b.desktop
share/sounds/k3b_error1.wav
share/sounds/k3b_success1.wav

View File

@ -6,8 +6,7 @@
#
PORTNAME= k3b
PORTVERSION= 0.11.20
PORTREVISION= 1
PORTVERSION= 0.11.23
CATEGORIES= sysutils multimedia kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}

View File

@ -1,2 +1,2 @@
MD5 (k3b-0.11.20.tar.bz2) = 6c4844319ccb5e9be3ec69aec80c8d5f
SIZE (k3b-0.11.20.tar.bz2) = 3190897
MD5 (k3b-0.11.23.tar.bz2) = eaff485fb4c431aae715b0ef95c43fcf
SIZE (k3b-0.11.23.tar.bz2) = 3195224

View File

@ -1,6 +1,6 @@
--- src/Makefile.in.orig Sat Dec 11 17:46:26 2004
+++ src/Makefile.in Sun Jan 2 09:30:08 2005
@@ -297,7 +297,7 @@
--- src/Makefile.in.orig Wed Mar 16 10:43:55 2005
+++ src/Makefile.in Wed Mar 23 19:44:55 2005
@@ -299,7 +299,7 @@
#>+ 1
k3b_SOURCES=k3bwelcomewidget.cpp k3bapplication.cpp k3bdiroperator.cpp kdndfileview.cpp k3bfiletreeview.cpp k3bcddbmultientriesdialog.cpp k3baudioplayer.cpp k3bprojecttabbar.cpp k3bprojecttabwidget.cpp k3bsplash.cpp k3bblankingdialog.cpp k3bfileview.cpp k3bdirview.cpp k3btoolbox.cpp k3b.cpp main.cpp k3bstatusbarmanager.cpp k3bfiletreecombobox.cpp k3breadcdreader.cpp k3binterface.cpp k3bprojectinterface.cpp k3bsystemproblemdialog.cpp k3bcdcontentsview.cpp k3bwriterspeedverificationdialog.cpp k3bdatatrackreader.cpp k3binterface_skel.cpp k3bprojectinterface_skel.cpp

View File

@ -1,11 +0,0 @@
--- src/audiodecoding/flac/k3bflacdecoder.cpp.orig Tue Feb 24 16:07:27 2004
+++ src/audiodecoding/flac/k3bflacdecoder.cpp Tue Mar 22 22:08:07 2005
@@ -308,7 +308,7 @@
{
if( d->comments != 0 ) {
if( info == i18n("Vendor") )
- return QString::fromUtf8(d->comments->get_vendor_string().get_field());
+ return QString::fromUtf8((char*)d->comments->get_vendor_string());
else if( info == i18n("Channels") )
return QString::number(d->channels);
else if( info == i18n("Sampling Rate") )

View File

@ -1,5 +1,5 @@
--- src/device/k3bdevice.cpp.orig Sun Nov 28 01:22:29 2004
+++ src/device/k3bdevice.cpp Sun Jan 2 09:30:08 2005
--- src/device/k3bdevice.cpp.orig Thu Feb 24 09:15:57 2005
+++ src/device/k3bdevice.cpp Wed Mar 23 19:44:55 2005
@@ -57,6 +57,13 @@
#endif // Q_OS_LINUX
@ -58,7 +58,7 @@
else if( vendor().startsWith("MATSHITA") ) {
if( description().startsWith("CD-R CW-7501") ) {
m_writeModes = TAO|SAO;
@@ -2663,10 +2691,12 @@
@@ -2673,10 +2701,12 @@
{
// if the device is already opened we do not close it
// to allow fast multible method calls in a row
@ -71,7 +71,7 @@
// header size is 8
unsigned char* buffer = 0;
@@ -2752,13 +2782,16 @@
@@ -2762,13 +2792,16 @@
delete [] buffer;
}

View File

@ -1,5 +1,5 @@
--- src/device/k3bdevicemanager.cpp.orig Sun Nov 28 13:27:24 2004
+++ src/device/k3bdevicemanager.cpp Sun Jan 2 09:44:09 2005
+++ src/device/k3bdevicemanager.cpp Wed Mar 23 19:45:36 2005
@@ -49,6 +49,12 @@
#include <sys/stat.h>
#include <sys/ioctl.h>
@ -205,7 +205,7 @@
+#if __FreeBSD_version < 500100
+ dev += "c";
+#endif
+ if (dev1 != "" && dev2 != "")
+ if (dev1 != "" && dev2 != "" && dev.startsWith("/dev/cd"))
+ {
+ K3bDevice* device = new K3bDevice(dev.latin1());
+ device->m_bus = bus;
@ -259,7 +259,7 @@
+#if __FreeBSD_version < 500100
+ dev += "c";
+#endif
+ if (dev1 != "" && dev2 != "")
+ if (dev1 != "" && dev2 != "" && dev.startsWith("/dev/cd"))
+ {
+ K3bDevice* device = new K3bDevice(dev.latin1());
+ device->m_bus = bus;

View File

@ -207,6 +207,10 @@ share/icons/crystalsvg/16x16/apps/k3b.png
share/icons/crystalsvg/32x32/apps/k3b.png
share/icons/crystalsvg/48x48/apps/k3b.png
share/icons/crystalsvg/64x64/apps/k3b.png
share/icons/hicolor/16x16/apps/k3b.png
share/icons/hicolor/32x32/apps/k3b.png
share/icons/hicolor/48x48/apps/k3b.png
share/icons/hicolor/64x64/apps/k3b.png
share/mimelnk/application/x-k3b.desktop
share/sounds/k3b_error1.wav
share/sounds/k3b_success1.wav