Upgrade to 1.0.1.

This commit is contained in:
Thomas Gellekum 2001-06-26 12:06:25 +00:00
parent 715b332be2
commit b6e5062e77
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=44455
8 changed files with 80 additions and 1440 deletions

View File

@ -1,21 +1,20 @@
# New ports collection makefile for: gnustep
# Date created: 03 October 1998
# New ports collection makefile for: gnustep-guile
# Date created: 24 April 2001
# Whom: Thomas Gellekum <tg@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= gnustep
PORTVERSION= 0.6.6
CATEGORIES= devel
MASTER_SITES= http://ftp.codefactory.se/pub/gnu/gstep/ \
http://planetmirror.com/pub/gnustep/core/
DISTNAME= gstep-core-${PORTVERSION}
PORTNAME= gnustep-guile
PORTVERSION= 1.0.1
CATEGORIES= lang
MASTER_SITES= ftp://ftp.gnustep.org/pub/gnustep/libs/
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff
BUILD_DEPENDS= ${SYSLIBDIR}/${GNU_ARCH}/${OPSYS:L}/gnu-gnu-gnu/libgnustep-base.so:${PORTSDIR}/devel/gnustep-base
RUN_DEPENDS= ${SYSLIBDIR}/${GNU_ARCH}/${OPSYS:L}/gnu-gnu-gnu/libgnustep-base.so:${PORTSDIR}/devel/gnustep-base
LIB_DEPENDS= guile.9:${PORTSDIR}/lang/guile
.include <bsd.port.pre.mk>
@ -23,41 +22,47 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
BROKEN= "Sorry, this port does not work on FreeBSD-2.2.x"
.endif
USE_NEWGCC= yes
PREFIX= ${LOCALBASE}/GNUstep
WRKSRC= ${WRKDIR}/${DISTNAME}
USE_NEWGCC= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= INSTALL_PROGRAM="${INSTALL} -c" INSTALL_DATA="${INSTALL} -c"
CONFIGURE_ARGS= --with-library-combo=gnu-gnu-gnu-xgps \
--with-jpeg-library=${LOCALBASE}/lib \
--with-jpeg-include=${LOCALBASE}/include \
--with-tiff-library=${LOCALBASE}/lib \
--with-tiff-include=${LOCALBASE}/include # --enable-threads=posix
CONFIGURE_TARGET=
USE_BISON= yes
USE_GMAKE= yes
USE_XLIB= yes
MAKEFILE=
MAKE_FLAGS= OPTFLAG="${CFLAGS}"
NO_MTREE= yes
MAN1= greg.1
.if ${MACHINE_ARCH} == "i386"
GNU_ARCH= ix86
.else
GNU_ARCH= ${MACHINE_ARCH}
.endif
PLIST_SUB+= GNU_ARCH=${GNU_ARCH} VERSION=${PORTVERSION}
PLIST_SUB+= GNU_ARCH=${GNU_ARCH} OPSYS=${OPSYS:L} VERSION=${PORTVERSION}
ETCDIR= ${PREFIX}/../etc
SYSLIBDIR= ${PREFIX}/System/Libraries
post-patch:
.for f in bundle gswapp gswbundle woapp wobundle
${PERL} -pi -e 's/\$$\(TAR\) ch --exclude=CVS --to-stdout/\$$\(TAR\) -ch --exclude=CVS -f -/g' ${WRKSRC}/make/${f}.make
.endfor
do-configure:
@(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
if ! ${SETENV} CC="${CC}" CXX="${CXX}" \
CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
INSTALL="/usr/bin/install -c -o ${BINOWN} -g ${BINGRP}" \
INSTALL_DATA="${INSTALL} -c" \
INSTALL_PROGRAM="${INSTALL} -c" \
INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}; then \
${ECHO} "===> Script \"${CONFIGURE_SCRIPT}\" failed: here are the contents of \"${CONFIGURE_LOG}\""; \
${CAT} ${CONFIGURE_LOG}; \
${ECHO} "(end of \"${CONFIGURE_LOG}\")"; \
${FALSE}; \
fi)
post-install:
@${MKDIR} ${ETCDIR}
${INSTALL_SCRIPT} ${FILESDIR}/GNUstep.sh ${ETCDIR}/rc.d
${INSTALL_DATA} ${FILESDIR}/gdomap_if ${ETCDIR}
do-build:
@(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})
do-install:
@(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET})
.include <bsd.port.post.mk>

View File

@ -1 +1 @@
MD5 (gstep-core-0.6.6.tar.gz) = 23d87610859a542b98c348fd9e66b8f8
MD5 (gnustep-guile-1.0.1.tar.gz) = 77e0b76f016ac2e6fa9a4896002972d2

View File

@ -1,31 +0,0 @@
#!/bin/sh
if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
echo "$0: Cannot determine the PREFIX" >&2
exit 1
fi
IFFILE=${PREFIX}/etc/gdomap_if
PIDFILE=/var/run/gdomap.pid
GNUSTEP_SYSTEM_ROOT=${PREFIX}/GNUstep/System
case "$1" in
start)
if [ -e ${GNUSTEP_SYSTEM_ROOT}/Makefiles/GNUstep.sh ]; then
. ${GNUSTEP_SYSTEM_ROOT}/Makefiles/GNUstep.sh
if [ -x ${GNUSTEP_SYSTEM_ROOT}/Tools/gdomap ]; then
rm -f ${PIDFILE}
${GNUSTEP_SYSTEM_ROOT}/Tools/gdomap -a ${IFFILE} -I ${PIDFILE}
echo -n ' GNUstep'
fi
fi
;;
stop)
[ -r ${PIDFILE} ] && kill $(cat ${PIDFILE}) && echo -n ' GNUstep'
;;
*)
echo "Usage: `basename $0` {start|stop}" >&2
;;
esac
exit 0

View File

@ -1 +0,0 @@
127.0.0.1 255.255.255.0

View File

@ -1,11 +0,0 @@
--- gui/Source/GNUmakefile.preamble.orig Sun Oct 15 21:47:59 2000
+++ gui/Source/GNUmakefile.preamble Sun Oct 15 21:48:16 2000
@@ -63,7 +63,7 @@
ADDITIONAL_CFLAGS =
# Additional include directories the compiler should search
-ADDITIONAL_INCLUDE_DIRS = -I../Headers
+ADDITIONAL_INCLUDE_DIRS = -I../Headers -I${LOCALBASE}/include
# Additional LDFLAGS to pass to the linker
ADDITIONAL_LDFLAGS =

View File

@ -1,11 +0,0 @@
--- xgps/Source/GNUmakefile.preamble.orig Sun Oct 15 22:12:02 2000
+++ xgps/Source/GNUmakefile.preamble Sun Oct 15 22:12:26 2000
@@ -55,7 +55,7 @@
ADDITIONAL_CFLAGS =
# Additional include directories the compiler should search
-ADDITIONAL_INCLUDE_DIRS = -I../Headers \
+ADDITIONAL_INCLUDE_DIRS = -I../Headers -I${LOCALBASE}/include \
-I$(GNUSTEP_TARGET_CPU)/$(GNUSTEP_TARGET_OS) \
-I./SharedX

View File

@ -1 +1 @@
Objective-C libraries based on the OpenStep standard
GNUstep interface to the GUILE scheme interpreter

File diff suppressed because it is too large Load Diff