Upgrade to 1.9.1

Use NetBSD clogf for FreeBSD systems that are not at HEAD

  Release: WSJT-X Version 1.9.1
                           June 1, 2018
                   -----------------------------

This critical bug fix release repairs an unintended restriction in the FT8
DXpedition mode. It supersedes v1.9.0 and must be used for DXpedition Fox
operators.
This commit is contained in:
Diane Bruce 2018-06-15 17:26:05 +00:00
parent f07c895496
commit b6e1af144f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=472465
7 changed files with 84 additions and 20 deletions

View File

@ -1,12 +1,10 @@
# $FreeBSD$
PORTNAME= wsjtx
PORTVERSION= 1.8.0
PORTREVISION= 1
PORTVERSION= 1.9.1
CATEGORIES= comms hamradio
MASTER_SITES= SF/wsjt/${PORTNAME}-${PORTVERSION}${DISTVERSIONSUFFIX}
DISTNAME= ${PORTNAME}-${PORTVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= hamradio@FreeBSD.org
COMMENT= Weak signal ham radio communication package
@ -19,25 +17,34 @@ LIB_DEPENDS= libfftw3.so:math/fftw3 \
libfftw3f.so:math/fftw3-float \
libhamlib.so:comms/hamlib \
libxslt.so:textproc/libxslt \
libomp.so.0:devel/openmp
libomp.so:devel/openmp
MAKE_JOBS_UNSAFE= yes
USES= cmake compiler:c++11-lib dos2unix fortran pkgconfig \
readline tar:tgz
USE_GL= yes
USE_QT5= gui buildtools qmake_build widgets multimedia concurrent printsupport serialport
USES= cmake compiler:c++11-lib dos2unix fortran pkgconfig tar:tgz
USE_QT5= core gui buildtools network qmake_build widgets \
multimedia concurrent printsupport serialport
CMAKE_ARGS+= -DPORT_BUILDING::STRING="ON" \
-DCMAKE_PREFIX_PATH+=${LOCALBASE}/wsjtx/lib \
-DLOCALBASE::STRING="${LOCALBASE}"
WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_SUB+= PORTVERSION="${PORTVERSION}"
BROKEN_i386= does not build on i386 due to openmp
#
# This nonsense is because wsjtx is shipped with a copy of hamlib
# as well as wsjtx
#
.include <bsd.port.pre.mk>
do-extract:
# clogf is only present in FreeBSD 12
${TAR} xf ${DISTDIR}/${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} -C${WRKDIR}
${TAR} xf ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src/wsjtx.tgz -C${WRKDIR}
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1200000
${CP} ${FILESDIR}/clogf.c ${WRKDIR}/wsjtx
EXTRA_PATCHES= ${FILESDIR}/add_clogf
.endif
BROKEN_i386= does not build on i386 due to openmp
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1509288321
SHA256 (wsjtx-1.8.0.tgz) = 21603ad4d5f43cd9c79a6e8cf468bde88c554654012b2c6c1ef9144cfbf668ce
SIZE (wsjtx-1.8.0.tgz) = 29041865
TIMESTAMP = 1527855810
SHA256 (wsjtx-1.9.1.tgz) = 0c6355ca3033e55669b1b41a32ddeb0302e3bb63fc8487c4e7158198dd097990
SIZE (wsjtx-1.9.1.tgz) = 29264406

View File

@ -0,0 +1,11 @@
--- CMakeLists.txt.orig 2018-06-14 09:21:04.286608000 -0400
+++ CMakeLists.txt 2018-06-14 09:20:17.307460000 -0400
@@ -313,6 +313,8 @@
main.cpp
wsprnet.cpp
WSPRBandHopping.cpp
+# No, this isn't the right place for clogf
+ clogf.c
)
set (wsjt_CXXSRCS

46
comms/wsjtx/files/clogf.c Normal file
View File

@ -0,0 +1,46 @@
/* $NetBSD: clogf.c,v 1.1 2007/08/20 16:01:35 drochner Exp $ */
/*-
* Copyright (c) 2007 The NetBSD Foundation, Inc.
* All rights reserved.
*
* This code is derived from software written by Stephen L. Moshier.
* It is redistributed by the NetBSD Foundation by permission of the author.
*
* Redistribution and use in source and binary forms, with or without
* modification, are permitted provided that the following conditions
* are met:
* 1. Redistributions of source code must retain the above copyright
* notice, this list of conditions and the following disclaimer.
* 2. Redistributions in binary form must reproduce the above copyright
* notice, this list of conditions and the following disclaimer in the
* documentation and/or other materials provided with the distribution.
*
* THIS SOFTWARE IS PROVIDED BY THE NETBSD FOUNDATION, INC. AND CONTRIBUTORS
* ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
* TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
* PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE FOUNDATION OR CONTRIBUTORS
* BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
* CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
* SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
* INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
* CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
* ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
* POSSIBILITY OF SUCH DAMAGE.
*/
#include <complex.h>
#include <math.h>
float complex
clogf(float complex z)
{
float complex w;
float p, rr;
rr = cabsf(z);
p = logf(rr);
rr = atan2f(cimagf(z), crealf(z));
w = p + rr * I;
return w;
}

View File

@ -1,4 +1,4 @@
--- CMakeLists.txt.orig 2017-10-19 22:13:49 UTC
--- CMakeLists.txt.orig 2018-06-14 13:07:32 UTC
+++ CMakeLists.txt
@@ -1,5 +1,4 @@
cmake_minimum_required (VERSION 2.8.10 FATAL_ERROR)
@ -19,12 +19,11 @@
#
# Options & features
@@ -838,7 +843,20 @@ endif ()
@@ -850,7 +855,19 @@ endif ()
#
# OpenMP
#
-find_package (OpenMP)
+message (status "ZZZ About to find_package (OpenMP)")
+# OpenMP_C_FLAGS - flags to add to the C compiler for OpenMP support
+# OpenMP_CXX_FLAGS - flags to add to the CXX compiler for OpenMP support
+# OpenMP_Fortran_FLAGS - flags to add to the Fortran compiler for OpenMP support
@ -41,7 +40,7 @@
#
# fftw3 single precision library
@@ -1282,6 +1300,13 @@ else (${OPENMP_FOUND} OR APPLE)
@@ -1297,6 +1314,13 @@ else (${OPENMP_FOUND} OR APPLE)
target_link_libraries (jt9 wsjt_fort wsjt_cxx Qt5::Core)
endif (${OPENMP_FOUND} OR APPLE)

View File

@ -1,6 +1,6 @@
--- Configuration.cpp.orig 2017-10-19 22:13:43 UTC
--- Configuration.cpp.orig 2018-06-14 13:07:01 UTC
+++ Configuration.cpp
@@ -2681,14 +2681,14 @@ void Configuration::impl::fill_port_comb
@@ -2798,14 +2798,14 @@ void Configuration::impl::fill_port_comb
auto Configuration::impl::apply_calibration (Frequency f) const -> Frequency
{
if (frequency_calibration_disabled_) return f;

View File

@ -1,6 +1,7 @@
bin/fcal
bin/fmeasure
bin/fmtave
bin/ft8code
bin/jt4code
bin/jt65code
bin/jt9
@ -34,6 +35,6 @@ share/doc/WSJT-X/README
share/doc/WSJT-X/THANKS
share/doc/WSJT-X/changelog.Debian.gz
share/doc/WSJT-X/copyright
share/doc/WSJT-X/wsjtx-main-1.8.0.html
share/doc/WSJT-X/wsjtx-main-%%PORTVERSION%%.html
share/pixmaps/wsjtx_icon.png
%%DATADIR%%/JPLEPH