add jclassinfo 0.19

Shows information about Java class, dependencies and more
This commit is contained in:
Ying-Chieh Liao 2004-05-05 01:41:12 +00:00
parent d00126fee9
commit b6d74b89ca
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=108418
7 changed files with 85 additions and 0 deletions

View File

@ -339,6 +339,7 @@
SUBDIR += ixlib
SUBDIR += jakelib2
SUBDIR += jam
SUBDIR += jclassinfo
SUBDIR += jrtplib
SUBDIR += jude_take
SUBDIR += kaptain

29
devel/jclassinfo/Makefile Normal file
View File

@ -0,0 +1,29 @@
# ex:ts=8
# Ports collection makefile for: jclassinfo
# Date created: May 5, 2004
# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= jclassinfo
PORTVERSION= 0.19
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Shows information about Java class, dependencies and more
USE_REINPLACE= yes
USE_GETOPT_LONG= yes
USE_GNOME= pkgconfig gnomehack
GNU_CONFIGURE= yes
USE_GMAKE= yes
MAN1= jclassinfo.1
post-patch:
@${REINPLACE_CMD} -e "s, docs,," ${WRKSRC}/Makefile.in
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
MD5 (jclassinfo-0.19.tar.gz) = fb512cbb399476fb4abd47df648c8b9b
SIZE (jclassinfo-0.19.tar.gz) = 385709

View File

@ -0,0 +1,11 @@
--- jclass/Makefile.in.orig Wed May 5 09:23:09 2004
+++ jclass/Makefile.in Wed May 5 09:23:17 2004
@@ -156,7 +156,7 @@
lib_LTLIBRARIES = libjclass.la
libjclass_la_LDFLAGS = -no-undefined -version-info @JCLASS_CURRENT@:@JCLASS_RELEASE@:@JCLASS_AGE@
-library_includedir = $(includedir)/jclass/jclass
+library_includedir = $(includedir)/jclass
library_include_HEADERS = \
attributes.h \

View File

@ -0,0 +1,15 @@
--- ltmain.sh.orig Wed May 5 09:16:19 2004
+++ ltmain.sh Wed May 5 09:16:29 2004
@@ -5528,10 +5528,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false ; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View File

@ -0,0 +1,4 @@
jclassinfo reads java class files and provides information about the class,
dependencies and more. It is a pure C implementantion.
WWW: http://jclassinfo.sourceforge.net/

View File

@ -0,0 +1,23 @@
bin/jclassinfo
include/jclass/attributes.h
include/jclass/bytecode.h
include/jclass/class.h
include/jclass/class_loader.h
include/jclass/constant_pool.h
include/jclass/field.h
include/jclass/jar.h
include/jclass/jclass.h
include/jclass/jstring.h
include/jclass/manifest.h
include/jclass/types.h
lib/jclass/include/jclassconfig.h
lib/libjclass.a
lib/libjclass.so
lib/libjclass.so.3
libdata/pkgconfig/jclass.pc
share/xml/jclassinfo/jclassinfo.dtd
share/xml/jclassinfo/jclassinfo2xhtml.xsl
@dirrm include/jclass
@dirrm lib/jclass/include
@dirrm lib/jclass
@dirrm share/xml/jclassinfo