update x11-toolkits/gtkmathview: 0.3.0 -> 0.4.2

PR:		54472
Submitted by:	Ying-Chieh Chen <yinjieh@csie.nctu.edu.tw>
This commit is contained in:
Daichi GOTO 2003-07-15 06:27:33 +00:00
parent 11a2f83d3b
commit b6ba8cb218
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=84906
6 changed files with 97 additions and 12 deletions

View File

@ -7,34 +7,36 @@
#
PORTNAME= gtkmathview
PORTVERSION= 0.3.0
PORTREVISION= 1
PORTVERSION= 0.4.2
CATEGORIES= x11-toolkits
MASTER_SITES= http://helm.cs.unibo.it/mml-widget/sources/
MAINTAINER= ports@FreeBSD.org
MAINTAINER= yinjieh@csie.nctu.edu.tw
COMMENT= A GTK Widget to Render MathML Documents
LIB_DEPENDS= iconv:${PORTSDIR}/converters/libiconv \
t1:${PORTSDIR}/devel/t1lib \
xml2:${PORTSDIR}/textproc/libxml2 \
xml2.5:${PORTSDIR}/textproc/libxml2 \
gmetadom_gdome_cpp_smart:${PORTSDIR}/textproc/gmetadom
BROKEN= "Configure fails"
USE_GETOPT_LONG=yes
USE_REINPLACE= yes
USE_GETOPT_LONG= yes
USE_X_PREFIX= yes
USE_GNOME= glib12 gtk12
USE_LIBTOOL= yes
CPPFLAGS= -D__GNU_LIBRARY__ -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib -lm
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ENV= CPPFLAGS="-D__GNU_LIBRARY__ -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt -lm"
USE_GMAKE= yes
INSTALLS_SHLIB= yes
MAN1= mathmlviewer.1 mathml2ps.1
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500000
BROKEN= Does not build on FreeBSD 5.x
.endif
post-patch:
.for file in src/stringAux.cc src/PS_T1_FontManager.cc
@${REINPLACE_CMD} -e "s|malloc.h|stdlib.h|g" ${WRKSRC}/${file}
@ -43,4 +45,4 @@ post-patch:
post-install:
@install-info ${PREFIX}/info/gtkmathview.info ${PREFIX}/info/dir
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1 +1 @@
MD5 (gtkmathview-0.3.0.tar.gz) = 78d36a88c565c3f38ba52d9b159c951d
MD5 (gtkmathview-0.4.2.tar.gz) = 5ffae2f3d750bb1400e8c0862aed1868

View File

@ -0,0 +1,40 @@
--- configure.orig Mon Jul 14 08:49:26 2003
+++ configure Mon Jul 14 08:50:23 2003
@@ -10352,23 +10352,23 @@
else
PKG_CONFIG_MIN_VERSION=0.9.0
if $PKG_CONFIG --atleast-pkgconfig-version $PKG_CONFIG_MIN_VERSION; then
- echo "$as_me:$LINENO: checking for gtk" >&5
-echo $ECHO_N "checking for gtk... $ECHO_C" >&6
+ echo "$as_me:$LINENO: checking for gtk+" >&5
+echo $ECHO_N "checking for gtk+... $ECHO_C" >&6
- if $PKG_CONFIG --exists "gtk" ; then
+ if $PKG_CONFIG --exists "gtk+" ; then
echo "$as_me:$LINENO: result: yes" >&5
echo "${ECHO_T}yes" >&6
succeeded=yes
echo "$as_me:$LINENO: checking GTK_CFLAGS" >&5
echo $ECHO_N "checking GTK_CFLAGS... $ECHO_C" >&6
- GTK_CFLAGS=`$PKG_CONFIG --cflags "gtk"`
+ GTK_CFLAGS=`$PKG_CONFIG --cflags "gtk+"`
echo "$as_me:$LINENO: result: $GTK_CFLAGS" >&5
echo "${ECHO_T}$GTK_CFLAGS" >&6
echo "$as_me:$LINENO: checking GTK_LIBS" >&5
echo $ECHO_N "checking GTK_LIBS... $ECHO_C" >&6
- GTK_LIBS=`$PKG_CONFIG --libs "gtk"`
+ GTK_LIBS=`$PKG_CONFIG --libs "gtk+"`
echo "$as_me:$LINENO: result: $GTK_LIBS" >&5
echo "${ECHO_T}$GTK_LIBS" >&6
else
@@ -10376,7 +10376,7 @@
GTK_LIBS=""
## If we have a custom action on failure, don't print errors, but
## do set a variable so people can do so.
- GTK_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "gtk"`
+ GTK_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "gtk+"`
fi

View File

@ -0,0 +1,15 @@
--- src/String.cc.orig Mon Jul 14 08:01:23 2003
+++ src/String.cc Mon Jul 14 08:05:56 2003
@@ -34,6 +34,12 @@
#include "String.hh"
#include "Globals.hh"
+#ifdef __FreeBSD__
+#if (__FreeBSD_version < 500000)
+#define iswspace(c) ((c) == ' ' || (c) == '\t' || (c) == '\n')
+#endif
+#endif
+
#ifdef DEBUG
int String::counter = 0;
#endif

View File

@ -0,0 +1,17 @@
--- src/StringTokenizer.cc.orig Mon Jul 14 08:15:49 2003
+++ src/StringTokenizer.cc Mon Jul 14 08:18:44 2003
@@ -34,6 +34,14 @@
#include "MathMLAttribute.hh"
#include "StringTokenizer.hh"
+#ifdef __FreeBSD__
+#if (__FreeBSD_version < 500000)
+#define iswxdigit isxdigit
+#define towupper toupper
+#define iswdigit isdigit
+#endif
+#endif
+
static unsigned hexOfChar(Char ch)
{
assert(iswxdigit(ch));

View File

@ -0,0 +1,11 @@
--- src/T1_FontManager.cc.orig Mon Jul 14 08:30:07 2003
+++ src/T1_FontManager.cc Mon Jul 14 08:30:33 2003
@@ -77,7 +77,7 @@
int
T1_FontManager::SearchT1FontId(const char* fileName) const
{
- int n = T1_Get_no_fonts();
+ int n = T1_GetNoFonts();
int i;
for (i = 0; i < n && strcmp(fileName, T1_GetFontFileName(i)); i++) ;