BasKet is a desktop organization tool. It uses baskets /
drawers ("baskets") to organize objects, such as text, URLs, images, sounds or other documents. Objects in a basket can be edited, copied, moved, dragged, etc PR: 56603 Submitted by: Markus Brueffer <brueffer@phoenix-systems.de>
This commit is contained in:
parent
342c774626
commit
b69470380b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=90165
@ -4,6 +4,7 @@
|
||||
SUBDIR += abacus
|
||||
SUBDIR += aspostit
|
||||
SUBDIR += babytrans
|
||||
SUBDIR += basket
|
||||
SUBDIR += bigyear
|
||||
SUBDIR += cal
|
||||
SUBDIR += cbb
|
||||
|
26
deskutils/basket/Makefile
Normal file
26
deskutils/basket/Makefile
Normal file
@ -0,0 +1,26 @@
|
||||
# New ports collection makefile for: basket
|
||||
# Date created: Mon Sep 8 19:32:42 CEST 2003
|
||||
# Whom: Markus Brueffer <brueffer@phoenix-systems.de>
|
||||
#
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= basket
|
||||
PORTVERSION= 0.3
|
||||
CATEGORIES= deskutils kde
|
||||
MASTER_SITES= http://www.sebastien.laout.tuxfamily.org/basket/
|
||||
|
||||
MAINTAINER= brueffer@phoenix-systems.de
|
||||
COMMENT= Desktop organization tool
|
||||
|
||||
USE_KDELIBS_VER= 3
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_REINPLACE= yes
|
||||
|
||||
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's/-O2//g; s/-lpthread/${PTHREAD_LIBS}/g' \
|
||||
${WRKSRC}/${CONFIGURE_SCRIPT}
|
||||
|
||||
.include <bsd.port.mk>
|
1
deskutils/basket/distinfo
Normal file
1
deskutils/basket/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (basket-0.3.tar.gz) = 2a72ade0ba1a16c7e7d26a15cbc0cef6
|
19
deskutils/basket/files/patch-configaction.cpp
Normal file
19
deskutils/basket/files/patch-configaction.cpp
Normal file
@ -0,0 +1,19 @@
|
||||
--- basket/configaction.cpp.orig Mon Sep 8 19:22:28 2003
|
||||
+++ basket/configaction.cpp Mon Sep 8 19:22:55 2003
|
||||
@@ -38,16 +38,6 @@
|
||||
{
|
||||
}
|
||||
|
||||
-int ConfigAction::action()
|
||||
-{
|
||||
- return m_action;
|
||||
-}
|
||||
-
|
||||
-QString ConfigAction::runCommand()
|
||||
-{
|
||||
- return m_runCommand;
|
||||
-}
|
||||
-
|
||||
void ConfigAction::setAction(int action)
|
||||
{
|
||||
m_action = action;
|
13
deskutils/basket/files/patch-configaction.h
Normal file
13
deskutils/basket/files/patch-configaction.h
Normal file
@ -0,0 +1,13 @@
|
||||
--- basket/configaction.h.orig Mon Sep 8 19:21:02 2003
|
||||
+++ basket/configaction.h Mon Sep 8 19:22:16 2003
|
||||
@@ -35,8 +35,8 @@
|
||||
public:
|
||||
ConfigAction(int action = 0, QString runCommand = "");
|
||||
~ConfigAction();
|
||||
- inline int action();
|
||||
- inline QString runCommand();
|
||||
+ inline int action() { return m_action; };
|
||||
+ inline QString runCommand() { return m_runCommand; };
|
||||
inline void setAction(int action);
|
||||
inline void setRunCommand(QString runCommand);
|
||||
private:
|
6
deskutils/basket/pkg-descr
Normal file
6
deskutils/basket/pkg-descr
Normal file
@ -0,0 +1,6 @@
|
||||
BasKet is a desktop organization tool. It uses baskets / drawers ("baskets")
|
||||
to organize objects, such as text, URLs, images, sounds or other documents.
|
||||
Objects in a basket can be edited, copied, moved, dragged, etc.
|
||||
|
||||
Author: Sebastien Laout <sebastien.laout@tuxfamily.org>
|
||||
WWW: http://www.sebastien.laout.tuxfamily.org/basket
|
12
deskutils/basket/pkg-plist
Normal file
12
deskutils/basket/pkg-plist
Normal file
@ -0,0 +1,12 @@
|
||||
bin/basket
|
||||
share/applnk/Applications/basket.desktop
|
||||
share/icons/locolor/16x16/apps/basket.png
|
||||
share/icons/locolor/32x32/apps/basket.png
|
||||
@unexec rmdir %D/share/icons/locolor/32x32/apps 2>/dev/null || true
|
||||
@unexec rmdir %D/share/icons/locolor/32x32 2>/dev/null || true
|
||||
@unexec rmdir %D/share/icons/locolor/16x16/apps 2>/dev/null || true
|
||||
@unexec rmdir %D/share/icons/locolor/16x16 2>/dev/null || true
|
||||
@unexec rmdir %D/share/icons/locolor 2>/dev/null || true
|
||||
@unexec rmdir %D/share/icons 2>/dev/null || true
|
||||
@unexec rmdir %D/share/applnk/Applications 2>/dev/null || true
|
||||
@unexec rmdir %D/share/applnk 2>/dev/null || true
|
Loading…
Reference in New Issue
Block a user